Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Webcamera werkt niet meer.  (gelezen 4630 keer)

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Webcamera werkt niet meer.
« Gepost op: 2009/05/02, 16:02:41 »
Na een verse Ubuntu9.04 installatie werkt m'n 'Logitech QuickCam Pro 4000'  webcam niet meer.     ???

Als ik Camorama Webcam Viewer start, krijg ik

Could not connect to video device (/dev/video0)
Please check connection.


De camera is een USB webcam. De verbinding is het in ieder geval niet.
Het werkte op deze pc (DELL Optiplex GX270) in 8.10 wel goed.    :D

Ook het programma Ekiga, waar ik deze webcam heb gebruikt, crasht voortdurend (niet in 8.10)

Op een andere pc (MSI)  met Ubuntu9.04 werkt de webcam en Ekiga wel.

Wat kan ik nog doen om te checken ?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #1 Gepost op: 2009/05/02, 19:33:42 »
Welke driver had je in 8.10? Heb je deze nu ook geïnstalleerd? Wat geeft lsusb in de terminal?
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #2 Gepost op: 2009/05/02, 22:24:49 »
Welke driver had je in 8.10? Heb je deze nu ook geïnstalleerd? Wat geeft lsusb in de terminal?


Helemaal geen driver geinstalleerd in 8.10.

Ik plugde de camera in een usb poort en die deed het meteen.

henkoegema@DELL:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 05fe:1010 Chic Technology Corp. Optical Wireless
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
henkoegema@DELL:~$

Als ik 'Cheese Webcam Booth' opstart, zie ik dat het ledje op de webcam even aan gaat, direkt daarna weer uit en dan crasht ook dit programma.   :(
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline eXtreem

  • Lid
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #3 Gepost op: 2009/05/03, 01:02:34 »
Doe eens een keer:

ls -l /dev/video*
Zie je dan de file video0 ook staan? En zoniet, zie je dan andere files die met video beginnen?
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #4 Gepost op: 2009/05/03, 11:51:10 »
Doe eens een keer:

ls -l /dev/video*
Zie je dan de file video0 ook staan? En zoniet, zie je dan andere files die met video beginnen?

henkoegema@DELL:~$ ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 2009-05-03 11:01 /dev/video0
henkoegema@DELL:~$
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline eXtreem

  • Lid
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #5 Gepost op: 2009/05/03, 12:25:15 »
henkoegema@DELL:~$ ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 2009-05-03 11:01 /dev/video0
henkoegema@DELL:~$

De opgevraagde file is dus wel aanwezig.

Krijg je als je camorama vanuit de terminal start nog meer info over de fout?
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #6 Gepost op: 2009/05/03, 12:38:16 »
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #7 Gepost op: 2009/05/03, 13:05:43 »
Misschien heb je hier wat aan http://linux.softpedia.com/get/Multimedia/Graphics/PWCConfig-13621.shtml

henkoegema@DELL:~/pwc-config$ ls -l
total 328
-rw-rw-r-- 1 henkoegema henkoegema    142 2003-01-31 23:17 acconfig.h
-rw-rw-r-- 1 henkoegema henkoegema  48054 2003-01-31 23:18 aclocal.m4
-rw-rw-r-- 1 henkoegema henkoegema     38 2003-02-02 08:11 AUTHORS
-rw-rw-r-- 1 henkoegema henkoegema    203 2003-02-02 08:10 ChangeLog
-rw-rw-r-- 1 henkoegema henkoegema   4506 2003-01-31 23:18 config.h.in
-rw-r--r-- 1 henkoegema henkoegema   1640 2009-05-03 12:59 config.log
-rwxr-xr-x 1 henkoegema henkoegema 213057 2003-02-02 08:42 configure
-rw-r--r-- 1 henkoegema henkoegema    785 2003-02-02 07:56 configure.in
lrwxrwxrwx 1 henkoegema henkoegema     31 2009-05-03 12:57 COPYING -> /usr/share/automake-1.6/COPYING
lrwxrwxrwx 1 henkoegema henkoegema     31 2009-05-03 12:57 depcomp -> /usr/share/automake-1.6/depcomp
lrwxrwxrwx 1 henkoegema henkoegema     31 2009-05-03 12:57 INSTALL -> /usr/share/automake-1.6/INSTALL
lrwxrwxrwx 1 henkoegema henkoegema     34 2009-05-03 12:57 install-sh -> /usr/share/automake-1.6/install-sh
-rw-r--r-- 1 henkoegema henkoegema  14373 2003-02-02 08:00 Makefile.in
lrwxrwxrwx 1 henkoegema henkoegema     31 2009-05-03 12:57 missing -> /usr/share/automake-1.6/missing
lrwxrwxrwx 1 henkoegema henkoegema     37 2009-05-03 12:57 mkinstalldirs -> /usr/share/automake-1.6/mkinstalldirs
-rw-rw-r-- 1 henkoegema henkoegema     64 2003-02-02 08:12 NEWS
drwxrwxr-x 2 henkoegema henkoegema   4096 2003-02-02 08:02 po
-rw-rw-r-- 1 henkoegema henkoegema   1846 2003-02-04 01:28 README
drwxrwxr-x 3 henkoegema henkoegema   4096 2003-02-02 08:27 src
-rw-r--r-- 1 henkoegema henkoegema     65 2003-02-02 08:11 TODO


henkoegema@DELL:~/pwc-config$ ./configure
configure: error: cannot find install-sh or install.sh in . ./.. ./../..    <---------------------- :o
henkoegema@DELL:~/pwc-config$
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #8 Gepost op: 2009/05/03, 13:08:36 »
henkoegema@DELL:~$ ls -l /dev/video*
crw-rw----+ 1 root video 81, 0 2009-05-03 11:01 /dev/video0
henkoegema@DELL:~$

De opgevraagde file is dus wel aanwezig.

Krijg je als je camorama vanuit de terminal start nog meer info over de fout?

Nee, het enige is:

Could not connect to video device (/dev/video0)
Please check connection.

Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #9 Gepost op: 2009/05/03, 13:21:33 »
Ik kreeg een foutmelding dat gtk+-2.0 niet was geinstalleerd, dit nog geprobeerd maar ook hier kreeg ik een foutmelding. Ik kan je helaas niet vertellen hoe je dit oplost.
Wel alvast een link naar logitec voor Linux drivers http://www.quickcamteam.net/software/linux/drivers  en een link hoe je met Easycam(2) een driver kan installeren. https://help.ubuntu.com/community/Webcam#Driver%20installation misschien heb je hier wat aan.
« Laatst bewerkt op: 2009/05/03, 15:28:07 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #10 Gepost op: 2009/05/03, 17:58:41 »
Ik kreeg een foutmelding dat gtk+-2.0 niet was geinstalleerd, dit nog geprobeerd maar ook hier kreeg ik een foutmelding. Ik kan je helaas niet vertellen hoe je dit oplost.
Wel alvast een link naar logitec voor Linux drivers http://www.quickcamteam.net/software/linux/drivers  en een link hoe je met Easycam(2) een driver kan installeren. https://help.ubuntu.com/community/Webcam#Driver%20installation misschien heb je hier wat aan.

In ieder geval bedankt voor de moeite.   ;)

Vond op een van je links dit:

In some cases you (VLC, mplayer, amongst others) will need to know the video and audio device files for your webcam. Before you plug in your webcam, try the following two command at a console:
ls /dev/video*
ls /dev/audio*
Make a note of the devices appearing. Now plug in your webcam, allow the system a few seconds to register the device, and run the two commands again. The new appearances should belong to your webcam (for instance, /dev/video0 and /dev/audio2).



henkoegema@DELL:~$ ls /dev/video*   <-----------hier heb ik GEEN webcam aangekoppeld
/dev/video0       <-------------------------------------wat is dit ?
henkoegema@DELL:~$

henkoegema@DELL:~$ ls /dev/video*  <------------hier heb ik WEL een webcam aangekoppeld
/dev/video0  /dev/video1    <-------------------------is de webcam nou video0 of video1 
henkoegema@DELL:~$
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #11 Gepost op: 2009/05/03, 18:09:01 »
Heb je een tv-kaart o.i.d.? Ik heb namelijk een tv kaart en een webcam, de tvkaart is dev/video0 en mijn webcam dev/video1. Om camorama op te starten gebruik ik dit commando
camorama -d /dev/video1 Dit commando kan je in een starter zetten.
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #12 Gepost op: 2009/05/03, 18:33:08 »
Heb je een tv-kaart o.i.d.? Ik heb namelijk een tv kaart en een webcam, de tvkaart is dev/video0 en mijn webcam dev/video1. Om camorama op te starten gebruik ik dit commando
camorama -d /dev/video1 Dit commando kan je in een starter zetten.

Ik heb geen tv-kaart o.i.d.  (maar wat wel ?)

henkoegema@DELL:~$ lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)

henkoegema@DELL:~$ lsusb
Bus 001 Device 007: ID 04a9:10a2 Canon, Inc. iP4200
Bus 001 Device 005: ID 054c:0243 Sony Corp. MicroVault Flash Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 006: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 05fe:1010 Chic Technology Corp. Optical Wireless
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
henkoegema@DELL:~$

Maar toch heb je me al een (heel) stuk verder geholpen, want......
camorama -d /dev/video1  laat WEL een (uitstekend) beeld zien.     =D

Moet ik nog zien uit te vissen wat /dev/video0 is.......en dan verder zoeken hoe ik Ekiga weer aan de praat krijg.
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #13 Gepost op: 2009/05/03, 20:45:08 »
Wat is dit Chic Technology Corp. Optical Wireless?
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #14 Gepost op: 2009/05/03, 21:18:09 »
Wat is dit Chic Technology Corp. Optical Wireless?

Ja, dat vroeg ik me ook al af.     ???
(Eerlijk gezegd geen idee wat het is.)
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #15 Gepost op: 2009/05/03, 21:26:09 »
Is het misschien iets van een Infra Rood ontvanger? Sommige PC's zijn hier al standaard van voorzien
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #16 Gepost op: 2009/05/03, 21:34:13 »
Heeft Camorama geen config file waar ik /dev/video1 als default kan zetten ?

Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #17 Gepost op: 2009/05/03, 22:40:46 »
Systeem>Voorkeuren>Hoofdmenu>Grafisch>Camorama selecteren>Eigenschappen>Bij opdracht regel invullen>camorama -d /dev/video1 nu hoef je het niet meer in een terminal in te typen. Dit is zoals ik het doe, ik zou niet weten waar een config file is voor camorama.
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #18 Gepost op: 2009/05/03, 23:00:42 »
Is het misschien iets van een Infra Rood ontvanger? Sommige PC's zijn hier al standaard van voorzien

Het is de draadloze muis en toetsenbord.   :D

Heb nu de draadloze muis en toetsenbord ontkoppeld om even verder te testen.

henkoegema@DELL:~$ lsusb
Bus 001 Device 004: ID 04a9:10a2 Canon, Inc. iP4200    <--------- Printer
Bus 001 Device 002: ID 054c:0243 Sony Corp. MicroVault Flash Drive   <--------USB Stick
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000   <-------Webcam
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
henkoegema@DELL:~$


Bus 002 Device 002: ID 05fe:1010 Chic Technology Corp. Optical Wireless    <-------is nu weg

henkoegema@DELL:~$ ls /dev/video*
/dev/video0  /dev/video1     <--------heb nog steeds  video0 en video1(dit blijft de webcam)
henkoegema@DELL:~$
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #19 Gepost op: 2009/05/03, 23:02:45 »
Systeem>Voorkeuren>Hoofdmenu>Grafisch>Camorama selecteren>Eigenschappen>Bij opdracht regel invullen>camorama -d /dev/video1 nu hoef je het niet meer in een terminal in te typen. Dit is zoals ik het doe, ik zou niet weten waar een config file is voor camorama.


Ja, dit werkt inderdaad.     :D
Maar zolang de webcam /dev/video1 blijft kan ik Ekiga niet opstarten.    :o
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #20 Gepost op: 2009/05/03, 23:48:14 »
Het commando is alleen bedoelt om bij opstart Camorama duidelijk te maken welke video bron deze moet gebruiken. En je webcam dev/video1 omzetten naar dev/video0 zou ik niet weten.
Mijn tv-kaart(pci) wordt altijd als video0 gezien bij een installatie. Ik denk dat je hardware matig in de weer moet om dit om te zetten. Je video0 apparaat alleen uitpluggen is niet genoeg, je zal ook de driver(s) moeten verwijderen. Dan weer opstarten, drivers installeren, kijken of het functioneert. Vervolgens je andere apparatuur aansluiten, drivers installeren, kijken of alles functioneert. Althans dit is mijn idee, misschien kan het eenvoudiger, weet iemand dit?
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #21 Gepost op: 2009/05/03, 23:51:02 »
.............. mijn webcam /dev/video1..........

Kun jij Ekiga dan wel starten ??  (Omdat jouw webcam ook op /dev/video1 staat)
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #22 Gepost op: 2009/05/04, 13:47:26 »
Ja ik kan Ekiga gewoon starten, althans gisteren wilde het niet lukken, vandaag wel. Ik heb nl. v4l veranderd naar v4l2.
« Laatst bewerkt op: 2009/05/04, 13:54:56 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline henkoegema

  • Lid
    • PA2HO
  • Steunpunt: Nee
Re: Webcamera werkt niet meer.
« Reactie #23 Gepost op: 2009/05/04, 14:35:56 »
.................. Ik heb nl. v4l veranderd naar v4l2.

Hoe doe je dat ?
Miscere utile dulci. (Ter leering ende vermaeck)
http://www.henk.oegema.com
Registered linux user 520520.  In gebruik: Ubuntu 18.04.  Radio Amateur callsign: PA2HO Interesses: Raspberry Pi & Arduino

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcamera werkt niet meer.
« Reactie #24 Gepost op: 2009/05/04, 17:24:22 »
Tijdens de configuratie bij video kan je dit opgeven, keuze uit picture,v4l en v4l2.
Naderhand kan ook nog, in Ekiga>Bewerken>Voorkeuren>Apparaten>Videoapparaten>Videoplugin
In der Beschränkung zeigt sich der Meister.