Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: cifs en mounten van een WD Mybook  (gelezen 1351 keer)

Offline René Luijckx

  • Lid
  • Steunpunt: Nee
cifs en mounten van een WD Mybook
« Gepost op: 2009/05/01, 14:56:58 »
Mijn Fstab ziet er als volgt uit:


# /etc/fstab: static file system information.

#

# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    defaults        0       0

# /dev/hdc10

UUID=861233da-ce16-4e57-a70a-5179557cf4b0 /               reiserfs notail          0       1

# /dev/hdc1

UUID=60A4-325A  /windows        vfat    defaults,utf8,umask=007,gid=46 0       1

# /dev/hdc9

UUID=f5741b61-0a07-4c71-92f2-bcd72ea818fa none            swap    sw              0       0

//192.168.16.253/PUBLIC   /media/dikkeberta/public   cifs   auto,user   0   0

/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0

/dev/hdb        /media/cdrom1   udf,iso9660 user,noauto,exec 0       0

/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0

//192.168.16.253/EIGEN      /media/dikkeberta/eigen /sbin/cifs,username=gebruikersnaam,password=raracombinatie   rw,auto,user   0   0



PUBLIC en EIGEN zijn mappen op een WD Mybook met als IP-adres 192,168,16,253
Tot PUBLIC heeft iedereen toegang.
EIGEN is alleen toegankelijk voor gebruikersnaam.

Bij opstart of als root mount -a wordt PUBLIC netjes gemount.
Voor EIGEN krijg ik de melding:

root@linux:/home/rene# mount -a

mount: onbekende bestandssysteemsoort 'password=raracombinatie'



Als ik in de laatste regel van fstab /sbin/ weghaal, dan gebeurt het volgende:

root@linux:/home/rene# mount -a

Password:

mount error 13 = Permission denied

Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

Bij Password: vul ik dan raracombinatie in.



Maak ik van de laatste regel:
//192.168.16.253/EIGEN   /media/dikkeberta/eigen   /sbin/mount.cifs,username=gebruikersnaam,password=raracombinatie   rw,auto,user   0   0


dan krijg ik weer:
root@linux:/home/rene# mount -a

mount: onbekende bestandssysteemsoort 'password=libbar'


Wie kan mij helpen de juiste syntax/ opdracht te vinden?

Bij voorbaat dank,

René.


Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: cifs en mounten van een WD Mybook
« Reactie #1 Gepost op: 2009/05/01, 21:14:16 »
Een regel in /etc/fstab heeft 6 parameters.

Verpaalts de komma:

//192.168.16.253/EIGEN      /media/dikkeberta/eigen /sbin/cifs,username=gebruikersnaam,password=raracombinatie   rw,auto,user   0   0
zodat username en password bij de opties, de 4e parameter hoort

//192.168.16.253/EIGEN      /media/dikkeberta/eigen /sbin/cifs username=gebruikersnaam,password=raracombinatie,rw,auto,user   0   0
Je kan overwegen een credentials file te gebruiken zodat de raracombinatie NIET door iedereen te lezen is (standaard kan iedereen /etc/fstab lezen). Zie http://wiki.ubuntu-nl.org/community/Fstab
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline René Luijckx

  • Lid
  • Steunpunt: Nee
opgelost
« Reactie #2 Gepost op: 2009/05/01, 22:04:53 »
Hoi Cees,

de regel is nu geworden:

//192.168.16.253/EIGEN   /media/dikkeberta/eigen   cifs username=gebruiker,password=rarecombinatie,rw,auto,user   0   0

Het veiligheidsrisico is mij bekend, maar ik wilde eerst contact kunnen leggen alvorens de volgende uitdaging aan te gaan.

Een derde uitdaging heeft zich al aangekondigd:
Op mijn siesteem ben ik niet dezelfde gebruiker als op de Mybook. Het Linus siesteem op de Mybook wil een gebruiker van tenminste 5 posities. Op mijn siesteem heb ik maar 5 posities voor mijn gebruikersnaam.

Dank voor je hulp.

Rene.

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: cifs en mounten van een WD Mybook
« Reactie #3 Gepost op: 2009/05/01, 22:32:49 »
Mijn Fstab ziet er als volgt uit:


Ik heb ook zo'n ding.
Leuk projectje voor je:
Waarom maak je er geen NFS server van? Werkt perfect.
Het ding draait gewoon een Linux OS.
Dit is mijn fstab, althans een stukje......

inaninck@renault:~$ cat /etc/fstab
# NFS mount of WD MyBook
192.168.123.120:/shares/internal/PUBLIC /MyBook nfs rw,auto,nolock,user,rsize=32768,timeo=14,wsize=32768,intr 0 0
#

inaninck@renault:~$ mount
192.168.123.120:/shares/internal/PUBLIC on /MyBook type nfs (rw,user=root,noexec,nosuid,nodev,nolock,rsize=32768,timeo=14,wsize=32768,intr,addr=192.168.123.120)

inaninck@renault:~$ alias | grep myboo
alias mybook='ssh -l ivonaninck mybook'

inaninck@renault:~$ mybook
ivonaninck@mybook's password:
[ivonaninck@MyBookWorld ~]$

[ivonaninck@MyBookWorld ~]$ uname -a
Linux MyBookWorld 2.6.17.14 #1 PREEMPT Mon Mar 26 12:36:33 BST 2007 armv5tejl GNU/Linux

http://gathering.tweakers.net/forum/list_messages/1250645
http://mybookworld.wikidot.com/hacks-and-howto
http://martin.hinner.info/mybook/

There are only 10 types of people in the world; those who understand binary and those who don't.

Offline René Luijckx

  • Lid
  • Steunpunt: Nee
Re: cifs en mounten van een WD Mybook
« Reactie #4 Gepost op: 2009/05/05, 12:22:40 »
Hoi Ivo,

Bedankt voor de info.
Ik krijg echter na een tijd een melding: "internal error" op de nfs verbinding.
Heb ik soms niet alle benodigde pakketten geïnstalleerd?
Weet jij welke pakketten geïnstalleerd moeten zijn voor NFS ?

Alvast bedankt,

René.

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: cifs en mounten van een WD Mybook
« Reactie #5 Gepost op: 2009/05/05, 22:17:16 »
Op de WD World Book moet je de handleiding volgne die ik je stuurde.
Ik kan me niet herinneren dat ik zelf op mijn PC iets extras voor NFS heb geinstalleerd.
Maar in ieder geval staat het pakket nfs-common erop.

Je zou even in /etc/init.d kunnen kijken of je daar het script nfs-common hebt staan.
Zo ja:
sudo ./nfs-common start

Zo nee, het package installeren.

Op je PC moet in ieder geval
daemon    4281     1  0 Apr28 ?        00:00:00 /sbin/portmap
statd     4301     1  0 Apr28 ?        00:00:00 /sbin/rpc.statd
draaien.

There are only 10 types of people in the world; those who understand binary and those who don't.