Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Standaard engine mysql wijzigen naar InnoDB ipv MyISAM  (gelezen 1630 keer)

Offline Menno_

  • Lid
  • Steunpunt: Nee
De standaard engine voor mysql is myisam. Ik wil echter dat de default-engine=Innodb. Normaal geef je bij de aanmaak van tabellen de parameter engine=innodb; mee achter je list met kolommen, maar in het geval van software die ik nu gebruik gaat dat niet en moet je parameter weg kunnen laten. In de huidige configuratie wordt er dan echetr een myisam engine aan de tabel toegewezen.
Volgens mijn collega kan hij in de config van zijn mysql op een sufbak gewoon de property engine=innodb opgeven, maar op mijn server lukt dat niet in /etc/mysql/my.cnf (na herstarten van mysqld is de standaardtabelengine nog steeds myisam). Weet iemand van jullie waar ik deze parameter kan wijzigen?

mvg, Menno
« Laatst bewerkt op: 2009/04/24, 13:47:49 door Menno_ »
6x Ubuntu 10.04 server op VM-Ware // Ubuntu 8.04 server op Dell SC1425

Offline Michael Anckaert

  • Lid
    • http://www.sinax.be
  • Steunpunt: Nee
Re: Standaard engine mysql wijzigen naar InnoDB ipv MyISAM
« Reactie #1 Gepost op: 2009/04/23, 15:20:22 »
Uit de mysql documentation:
setting the default-storage-engine or default-table-type option in the my.cnf
www.sinax.be
Open Source Integrators, consulting and custom development

Offline Menno_

  • Lid
  • Steunpunt: Nee
Re: Standaard engine mysql wijzigen naar InnoDB ipv MyISAM
« Reactie #2 Gepost op: 2009/04/24, 13:23:35 »
Hoi Michael,

dank voor je input, maar dat had ik ook gelezen en geprobeerd, maar dat werkte niet. Het lukte alleen maar met de commandline:
sudo mysqld stopsudo mysqls --default-storage-engine=InnoDBen vervolgens de console te sluiten, maar bij de volgende herstart van mysql is de engine weer MyISAM.

Desondanks heb ik het probleem opgelost  :-[ het blijkt namelijk dat ik de setting in de verkeerde sectie heb neergezet en dan werkt het ook niet  :rolleyes:. Ik heb nu het my.cnf bestand ongewijzigd (tov installatieversie) gelaten en in de directory /etc/mysql/conf.d een nieuw bestand "storage_engine.cnf" aangemaakt met daarin:
#commentaar
[mysqld]
default-storage-engine=InnoDB
#EOF
zodat bij een update van my.cnf de setting niet verloren gaat en dan werkt het prima. My.cnf verwijst namelijk standaard naar de directory conf.d en alle bestanden die daarin staan met .cnf als extensie worden bij het opstarten van mysql uitgevoerd/meegenomen.

mvg, Menno
« Laatst bewerkt op: 2009/04/24, 13:47:17 door Menno_ »
6x Ubuntu 10.04 server op VM-Ware // Ubuntu 8.04 server op Dell SC1425