Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Server en router instellen  (gelezen 9072 keer)

Offline evarie

  • Lid
  • Steunpunt: Nee
Server en router instellen
« Gepost op: 2009/04/22, 22:13:35 »
Wil je alsjeblieft even de tijd er voor nemen als je weet hoe je de storing interrupt 5 kan verhelpen?
Ik heb mijn best gedaan om alles zo volledig mogelijk in te vullen.
Daarom is deze post misschien langer dan je gewend bent.
Ook heb ik op internet gezocht met google, en
ook met de zoekfunctie van de website ubuntu.
Maar helaas ik kan niets vinden waar ik iets aan heb.

Voor mijn server wil ik graag weten hoe je de instellingen moet veranderen.
Ik weet hoe dat moet, maar ik heb dus een storing; zie onderwerp.
Eerst was deze op dhcp ingesteld tijdens het installeren van ubuntu server.
Dat heb ik veranderd naar de instellingen voor een vast ip adre in
/etc/network/interfaces;
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.255.255.*

# The eth0 3com network interface
auto eth0
iface eth0 inet static
   address 193.*.*.*
   netmask 255.255.255.*
   gateway 0.0.0.0
                   
Ook de nameservers heb ik aangepast in /etc/resolv.conf
De instellingen heb ik na gelezen in de ubuntu server documentatie op
http://help.ubuntu.com/8.04/

De instellingen zijn nu goed ingesteld....denk ik.
Alleen ik kan niet vinden waar de Fully Qualified Domain Name wordt op geslagen.
Dat wil ik graag weten om het te kunnen veranderen in verband met storingen.

De modem heeft vier vaste ip adressen. Daar staat een windows computer op
waarmee ik met putty kan inloggen op de server, en dat lukt. Maar als ik vanaf het internet
met putty wil inloggen op de server. Gebeurt er niets. De verbinding komt niet tot stand.
Ook de website 'it works' komt niet te voorschijn.

Wat is het probleem?
En welke informatie hebben we nodig om het echte probleem te vinden, zodat
ik een juiste oplossing kan toepassen?

Ifconfig geeft geen errors behalve de interrupt melding;
eth0      link encap:Ethernet HWaddr *
             inet addr: *  Bcast: * Mask: *
             inet 6 *
             up
             RX packets: *     errors:0
             TX packets: *     errors:0
             Collissions:0 txqueuelen:1000
             RX bytes:              TX: bytes
             Interrupt:5 Base address:0x4c00

Nu is dus de vraag waar op internet een lijst staat, zodat je kan lezen wat
interrupt:5 Base addres: 0x4c00 betekend?

De belangrijste vraag is waarom ik wel met de windows computer kan inloggen, en
waarom de server vanaf het internet niet berijkbaar is?
Zou het aan kpn offie dsl liggen? Of ligt het aan de server vanwege een storing?
Er kan wel degelijk een storing op de server zitten, want mysqld is gefaald ( gerepareerd na herinstalleren ) om op te starten tijdens het booten meerdere malen.

Graag jouw wijze antwoord.....dank je wel !
« Laatst bewerkt op: 2009/04/25, 01:06:38 door evarie »

Online Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #1 Gepost op: 2009/04/23, 04:20:30 »
Voor mijn server wil ik graag weten hoe je de instellingen moet veranderen.
Ik weet hoe dat moet, maar ik heb dus een storing; zie onderwerp.
Eerst was deze op dhcp ingesteld tijdens het installeren van ubuntu server.
Dat heb ik veranderd naar de instellingen voor een vast ip adre in
/etc/network/interfaces;
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.255.255.*
Hier zou ik de laatste 2 regels weghalen. Die zijn niet nodig.

Citaat
# The eth0 3com network interface
auto eth0
iface eth0 inet static
address 193.*.*.*
netmask 255.255.255.*
gateway 0.0.0.0
Wat is het adres wat je opgeeft? Een ip-adres dat met 193 begint lijkt me een foutje. Meestal is dat 192.168.X.Y
De gateway moet je ook invullen. Hier moet het adres van de router/modem komen te staan.

Citaat
Ook de nameservers heb ik aangepast in /etc/resolv.conf
De instellingen heb ik na gelezen in de ubuntu server documentatie op
http://help.ubuntu.com/8.04/

De instellingen zijn nu goed ingesteld....denk ik.
Alleen ik kan niet vinden waar de Fully Qualified Domain Name wordt op geslagen.
Dat wil ik graag weten om het te kunnen veranderen in verband met storingen.
Die staat in /etc/hostname
Let op dat je dan ook /etc/hosts aan moet passen (De 1e 2 regels)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #2 Gepost op: 2009/04/23, 10:39:13 »
Citaat
Eerst was deze op dhcp ingesteld tijdens het installeren van ubuntu server.
Dat heb ik veranderd naar de instellingen voor een vast ip adre in
/etc/network/interfaces;

Mja wat Johan al zegt...
Je hebt hier een IP adres ingevuld wat waarschijnlijk niet op jouw netwerk voorkomt.
En dit (address 193.*.*.*) met die sterretjes hoef je niet te doen, dat is je LAN IP adres en die is verder niet interesant, je verward dit blijkbaar met je IP adres die je van je provider gekregen hebt?

Vervolgens is idd geen gateway ingevuld dus je server weet bij god niet waar hij naar toe moet.

Citaat
De modem heeft vier vaste ip adressen. Daar staat een windows computer op
waarmee ik met putty kan inloggen op de server, en dat lukt. Maar als ik vanaf het internet
met putty wil inloggen op de server. Gebeurt er niets. De verbinding komt niet tot stand.
Ook de website 'it works' komt niet te voorschijn.
Om van buitenaf op je server te komen in de www folder zal je poort 80 moeten openzetten in je modem/router.

Om met putty van buitenaf op je server te komen zal je poort 22 moeten openzetten in je modem/router .
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #3 Gepost op: 2009/04/23, 16:05:33 »
Bedankt voor het antwoord.

Voor bescherming van mijn gegevens heb ik de ip adressen afgeschermd met een ster.
Dus de ip adressen heb ik overgenomen van de lijst die we van onze provider kregen.
Het ip adres begint dus wel met 193 omdat dit statische ip adressen zijn.
Ook de gateway heeft een adres dat ik liever niet kenbaar maak.
Dus vandaar dat ik er of sterren of nullen heb ingevuld.
Deze modem maakt geen eigen netwerk met 192.168.0.0 ipadressen.
Het zou ook kunnen dat het niet werkt omdat ik de broadcast niet kan invullen.

Maar ik kan nu weer een stapje verder komen door host en hostname aan te passen in de server.

Als ik vanaf het internet commando's invoer;
ssh en dan het ip adres van de  server
dan krijg ik terug;
no route to host
maar als ik ssh 193.x.y.z met poort 2222 dan krijg ik terug;
name or service not know

Hopelijk geeft dat extra info voor het vinden van het probleem.

Uiteindelijk is het de bedoeling dat de server vanaf het internet berijkbaar wordt.
« Laatst bewerkt op: 2009/04/23, 18:26:03 door evarie »

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #4 Gepost op: 2009/04/23, 18:52:36 »
Hmz kan van je verhaal niet echt chocolade maken.... ?

Dus ff voor mijn beeldvorming:
Bij welke provider zit je ?
Welk merk modem gebruik je ?
Hoeveel computers heb je thuis aan het werk ?
Hoeveel IP adressen heb je van je provider gekregen?

En waarom ga je naar poort 2222 ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #5 Gepost op: 2009/04/23, 19:03:43 »
Hmz kan van je verhaal niet echt chocolade maken.... ?

Dus ff voor mijn beeldvorming:
Bij welke provider zit je ?
Welk merk modem gebruik je ?
Hoeveel computers heb je thuis aan het werk ?
Hoeveel IP adressen heb je van je provider gekregen?

En waarom ga je naar poort 2222 ??


provider met domeinnaam  kpn-officedsl.nl  het is kpn voor de zakelijke markt.
modem siemens speedstream 5450; zakelijk adsl pstn. Met 4 vaste ip adressen.
Aan deze siemens modem zitten twee computer; een windows xp pro en een ubuntu server 8.04.2
Aan de andere kant van het internet heb ik een experia box van kpn voor particulieren.
En dat is wel een router met thuisnetwerk 192.168.x.y
Andere kennissen hebben mijn url-koppeling ontvangen maar zien geen verbinding met de lamp server.

Ik deed ssh oproepen met poort 2222 om te kijken wat voor melding ik terug krijg.
Zodoende kan je dus lezen wat de status is van de verbinding.

Als ik commandeer ;
sudo nano /etc/hostname
Dan staat daar de computernaam. Dat zorgt er dan voor dat je dan gebruiker@computernaam:~$ te zien krijgt.
Maar....over hostname gesproken, is dat fully q. domainname?
Of is dat de computer naam?

In mijn bestand staat, en is het goed ingevuld?;
$ sudo nano /etc/hosts

127.0.0.1       localhost
127.0.1.1       computernaam

#The following lines are desirable for IPv6 capable hosts
::1                ip6-localhost ip6-loopback
fe00::0          ip6-localnet
ff00::0           ip6-mcastprefix
ff00::1           ip6-allnodes
ff00::2           ip6-allrouters
ff00::3           ip6-allhost

#--end--hosts


« Laatst bewerkt op: 2009/04/23, 19:39:20 door evarie »

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #6 Gepost op: 2009/04/23, 19:12:58 »
Mja in dat geval zit je er dus naast dat dit <modem>?  wat in wezen een modem-router is de IP adressen 1 op 1 doorzet.

Volgens deze gebruiksaanwijzing:
http://zakelijk.kpn.com/web/file?uuid=db2fcda2-c1c4-4be8-86b6-3b36b967a210&owner=bffb4411-db1d-4b2c-bfd9-d996d32dc72b

Werkt het toch iets anders zoals ik al vreesde.
Ik denk toch dat je met deze gebruiksaanwijzing in de hand de boel ff anders moet instellen....

En bovenal, voor iedere functie zal je een poort moeten openzetten in dit ding.
Doe je dat niet heeft men van buitenaf geen verbinding met een pc of server.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #7 Gepost op: 2009/04/23, 19:42:43 »
Bedankt, dan ga ik dat doorlezen! Ik ben al begonnen met het lezen van de gebruiksaanwijzing van deze siemens router.
Even inloggen op de router en zal het dan werken?

Ja het werkt. Want ik heb de firewall van de router uitgezet.

Dit probleem is opgelost ! Allemaal bedankt !

Een interrupt is geen foutmelding maar een of ander adres voor hardware.
« Laatst bewerkt op: 2009/04/23, 22:40:52 door evarie »

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #8 Gepost op: 2009/04/23, 22:45:33 »
Probleem opgelost !

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: eth0 interrupt:5 Base addres
« Reactie #9 Gepost op: 2009/04/24, 01:23:31 »
Citaat
Ja het werkt. Want ik heb de firewall van de router uitgezet.

Dit is min of meer het domste wat je kan doen.
Je hele LAN staat nu open naar de buitenwereld, en mocht er een script-kiddy voorbij komen geef ik je server nog maar 24 uur.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Verder gaan met instellen en installeren van de server
« Reactie #10 Gepost op: 2009/04/24, 23:46:35 »
Oke, de firewall is weer aan.

Vanavond heb ik joomla geinstalleerd op mijn server.
Maar als ik een url opgeef met een bestandsnaam, dan
vraagt de browser of ik het wil opslaan.
Terwijl ik de pagina's wil laten weer geven.
Hoe kan ik dat oplossen?
En wat moet de chowner zijn voor mappen en bestanden in  /var/www ?

Weer bedankt.
« Laatst bewerkt op: 2009/04/25, 01:03:05 door evarie »

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #11 Gepost op: 2009/04/25, 01:11:33 »
Wanneer je vanuit je eigen LAN netwerk met een PC naar de server gaat en in de www map wilt kijken zal je deze fout krijgen omdat je niet via een DNS server werkt.

Oplossing is heel simpel.
In alle HOSTS files van die computers het IP adres van die server zetten met de naam van die website.

bijv.
192.168.1.101 www.mijnwebsite.nl
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #12 Gepost op: 2009/04/25, 02:55:45 »
Inderdaad, ik ging op het eigen LAN netwerk met windows naar de server website.

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #13 Gepost op: 2009/04/26, 10:41:09 »
Mijn /etc/hosts ;

127.0.0.1 localhost
127.0.1.1 hostnaam

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
192.168.1.2 gateway
192.168.1.79 localhost


En dat heeft niet geholpen?
« Laatst bewerkt op: 2009/04/27, 13:02:29 door evarie »

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #14 Gepost op: 2009/04/26, 20:35:03 »
Ik zie nergens iets staan met www.mijnwebsite.nl
of hoe je die ook genoemd hebt ?
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #15 Gepost op: 2009/04/27, 12:57:15 »
Ik had dit er ingzet; 192.168.1.79 localhost

Maar ik heb nog geen rechten om een fully q. domainname te gebruiken. Dus ik moet een hostnaam instellen.

En dat heb ik nu op deze manier gedaan.
nog een keer dan;

Mijn /etc/hosts ;

#hostnaam is vervangen met "hostnaam".
127.0.0.1 localhost
127.0.1.1 hostnaam

193.x.y.z hostnaam

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
« Laatst bewerkt op: 2009/04/27, 13:01:57 door evarie »

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #16 Gepost op: 2009/04/27, 13:00:57 »
De extensie phtml is php3. Dus er is een instelling dat er voor zorgt dat het gezien wordt als php3 en dus phtml. Maar het moet php5 zijn in mijn instellingen.

Iemand anders op het forum heeft het lamp pakket op nieuw geinstalleerd en toen deed zijn php parser het wel weer.

Dit probleem moet toch op te lossen zijn zonder opnieuw installeren?
Er zit denk ik een fout ergens in de update's van de update lijsten.
Dit probleem heb ik op twee ubuntu compters.
Dus het is geen toevallig iets.
« Laatst bewerkt op: 2009/04/27, 22:10:42 door evarie »

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #17 Gepost op: 2009/04/28, 23:39:04 »
In middels heb ik wel site's gevonden met het zelfde probleem. Maar daar staat geen duidelijk voorbeeld bij.
Zo dus ook in deze mailing;
http://mail-archives.apache.org/mod_mbox/httpd-users/

Maar ik weet niet of ze daar iets van zeggen als je dit probleem voorlegt.
Je mag namelijk geen FAQ vragen stellen.

Eigenlijk snap ik niet waarom de apache website nog niet in het nederlands is?
Iedereen gebruikt het. Dus waar om geen vertaling?
Zijn nederlanders daar niet zo actief in?

Maar goed. Graag wil ik dus het probleem oplossen zodat mijn server je niet meer vertelt dat een php bestand een phtml bestand is en dat je die moet downloaden en opslaan. Nee ik wil dat mijn server ook zijn php bestanden parst. En dat doet mijn server niet.
Wat en in welk bestand moet ik een aanpassing doen?
Graag antwoord, bedankt !

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #18 Gepost op: 2009/04/29, 00:52:36 »
Allereerst ?
Is wel alles geinstalleerd ?

Check nog ff met deze regel of dit er allemaal inzit.
apt-get install libapache2-mod-php4 libapache2-mod-perl2 php4 php4-cli php4-common php4-curl php4-dev php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt curl libwww-perl imagemagick
Wat misschien een klein probleem kan zijn is dat dit een oude install regel is die ik gebruikte dus het kan zijn dat je misschien php4 moet veranderen naar php5 ??
Geen idee namelijk wat jij gebruikt.

WBT dat verkeerd weegeven ?
Je zou in de config kunnen kijken of het hier goed staat.

Vuistregels om te veranderen zijn:

Bewerk /etc/apache2/apache2.conf en verander
DirectoryIndex index.html index.cgi index.pl index.php index.xhtmlnaar
DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.pl index.xhtml
Bewerk /etc/mime.types en zet een hekje voor de volgende regels:
#application/x-httpd-php                                phtml pht php
#application/x-httpd-php-source                 phps
#application/x-httpd-php3                       php3
#application/x-httpd-php3-preprocessed          php3p
#application/x-httpd-php4                       php4

Bewerk /etc/apache2/mods-enabled/php4.conf en zet een hekje voor de volgende regels:
<IfModule mod_php4.c>
#  AddType application/x-httpd-php .php .phtml .php3
#  AddType application/x-httpd-php-source .phps
</IfModule>

Bewerk /etc/apache2/ports.conf en voeg toe luisteren op poort 443:
Listen 80
Listen 443

Nou nog wat Apache modules aanzetten zoals (SSL,  rewrite and suexec):
Met de volgende opdrachten:
a2enmod ssl
a2enmod rewrite
a2enmod suexec
a2enmod include

Nu Apache herstarten:
/etc/init.d/apache2 restart

En nu maar kijken of het werkt...
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #19 Gepost op: 2009/05/02, 19:03:32 »
Voor mijn lamp server kies ik altijd de standaard installatie. En die is natuurlijk met commando sudo tasksel of via de synaptic software pakketten.
En de derde optie is met de ubuntu server cd. Het maakt eigenlijk niet uit voor deze drie keuzes. Want bij deze drie keuzes krijg ik altijd de download en save opdracht van de lamp server, na het aanvragen van een php webpagina. Zo blijkt dus dat een lamp server altijd geconfigureerd moet worden. En dus is een lamp server niet voor de gewone gebruikers. Dus ga ik opzoek naar een apache2 tutorial en een goed nederlandstalig boek.
Tenminste als jij lezer geen goede tips meer weet.....
Dus laat een kopie van je tip hier op dit topic, en mijn dank is groot.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #20 Gepost op: 2009/05/02, 21:06:05 »
Citaat
En dus is een lamp server niet voor de gewone gebruikers.
Klopt een server is geen speelgoed maar serieus gedoe.!

Citaat
Dus ga ik opzoek naar een apache2 tutorial en een goed nederlandstalig boek.

Denk dat je zowiezo eens een boel moet gaan lezen, want je postje zegt me zoveel dat je er niet zo heel veel kaas van gegeten hebt ?

Zonder Apache geen server en dus kan je geen PHP website zien.

Je weet wat LAMP betekent ?
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #21 Gepost op: 2009/05/03, 21:18:51 »
Wat een LAMP (Lekker Anders Maar Prima) server is?
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #22 Gepost op: 2009/05/05, 00:26:31 »
Zo laag is mijn niveau gelukkig niet. Linux is juist leuker met een apache mysql en php server.

Op dit moment ben ik bezig om de storing te verhelpen zodat apache geen download venster meer geeft, en de phtml / php bestanden wel parst.
Graag wil ik dus deze pagina leren begrijpen, een beetje hulp waar ik moet beginnen zou wel fijn zijn.
http://wiki.apache.org/httpd/PHPDownload

Welke bestanden moet ik dan hebben?
Kheb wat info gevonden, ik zet het meteen erbij;

Debian, Ubuntu (Apache 2):

ServerRoot                  ::      /etc/apache2
DocumentRoot            ::      /var/www
Apache Config Files     ::      /etc/apache2/apache2.conf
                                    ::      /etc/apache2/ports.conf
Default VHost Config   ::      /etc/apache2/sites-available/default, /etc/apache2/sites-enabled/000-default
Module Locations        ::      /etc/apache2/mods-available, /etc/apache2/mods-enabled
ErrorLog                      ::      /var/log/apache2/error.log
AccessLog                   ::      /var/log/apache2/access.log
cgi-bin                         ::      /usr/lib/cgi-bin
binaries (apachectl)    ::      /usr/sbin
start/stop                    ::      /etc/init.d/apache2 (start|stop|restart|reload|force-reload|start-htcacheclean|stop-htcacheclean)

Notes:

   1.      The Debian/Ubuntu layout is fully documented in /usr/share/doc/apache2/README.Debian.gz
   2.      Debian/Ubuntu use symlinks to enable vhosts and modules. Configuration files are created in their respective sites-available and mods-available directories. To activate vhosts and modules, symlinks are created in the respective sites-enabled and mods-enabled directories to the config files in either sites-available and mods-available. Debian provides scripts to handle this process called 'a2ensite' and 'a2enmod' which enables vhosts and modules.
   3.      The default DocumentRoot is specified in the default vhost config file, /etc/apache2/sites-available/default
« Laatst bewerkt op: 2009/05/05, 00:51:39 door evarie »

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #23 Gepost op: 2009/05/05, 01:45:41 »
Toen ik dit toevoegde deed mijn lamp het en parste wel de php;
Zie: /etc/apache2/sites-available/default;

      allow from localhost
                Allow from 127.0.0.0


   <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from localhost
                Allow from 127.0.0.0
   </Directory>


En van dit bestand moeten de hekjes weg;
Zie: /etc/apache2/mods-enabled/php5.conf

<IfModule mod_php5.c>
  AddType application/x-httpd-php .php .phtml .php3
  AddType application/x-httpd-php-source .phps
</IfModule>


« Laatst bewerkt op: 2009/05/16, 22:36:57 door evarie »

Offline evarie

  • Lid
  • Steunpunt: Nee
Re: Server en router instellen
« Reactie #24 Gepost op: 2009/05/17, 14:21:00 »
Mysql instellen dat lukt nu wel, en de server instellen is ook gelukt. Nu wil ik 'php my admin' installeren. Ik heb de bestanden uitgepakt en op de server gezet in localhost/server/phpadmin/
Ten eerste dacht ik dat het komt door de rechten en eigenaren, die heb ik aangepast met chown en chmod. Maar dat wilt niet helpen.
Dus dit is de melding voor de map /var/www/server/phpadmin/;

Warning: require_once(./libraries/common.inc.php) [function.require-once]: failed to open stream: Permission denied in /var/www/server/phpadmin/index.php on line 34
Fatal error: require_once() [function.require]: Failed opening required './libraries/common.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/server/phpadmin/index.php on line 34

En voor /var/www/weblog/b2evoluiton heb ik de rechten op 777 gezet met commando sudo chmod -R b2evolution
Nu zijn alle bestanden en mappen van deze weblog ingesteld op rechten 777
Dat kan ik ook doen bij phpmyadmin, maar dat lijkt me niet zo veilig. Dus welke chmod en chown commando moet ik dan gebruiken om het goed te doen?

Phpadmin heb ik geinstalleerd, alleen nu moet ik nog weten welke rechten deze bestanden mogen hebben?
« Laatst bewerkt op: 2009/05/17, 23:44:46 door evarie »