Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: PonyProg2000 werkend krijgen  (gelezen 1913 keer)

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
PonyProg2000 werkend krijgen
« Gepost op: 2009/04/21, 16:11:07 »
Hallo allemaal,

Ik wil graag ponyprog aan de gang krijgen, en dan bedoel ik 2.07c. Ik heb nu 2.06c, maar ik mis toch wat functionaliteit. 2.06 heb ik werkend gekregen door de executable te downloaden en alle dingen waar 'ie van afhankelijk is, en dat met een hele hoop sudo mv in de juiste mappen geduwd. Het runt nu als ik ponyporg2000 in een terminal gooi, dus dat is goed. Ik wil echter 2.07c, die ondersteunt net wat meer chips, waaronder de attiny2313 die ik nodig heb. Op mijn windowsPC werkt de windowsversie van Ponyprog gewoon goed, maar de hele tijd files overzetten vind ik maar niks. Ponyprog in mijn virtuele windowsmachine draaien gaat niet, virtualbox doet niet aan parallelle poorten, en mijn AVR programmer zit op de parallelle poort.

Voor wie onbekend is met ponyprog: mijn probleem is vooral hoe ik de source gecompiled krijg.

De source is hier te vinden:
http://www.lancos.com/ppwin95.html (naar beneden scrollen)

Ik heb het gedownload en geunzipped, het staat in /home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c (en submappen) Spaties in de naam heb ik dus al op gelet ("belangrijke_programmas" heette eerst "Belangrijke programma's", en die appastrof gooide roet in het eten)

Het werkt alleen nog steeds niet.

Er zitten instalatieinstructies bij, die zeggen het volgende:

<zie INSTALL, word anders een beetje lang>

die folder /v staat dus in de folder /PonyProg2000-2.07c (voor het hele pad: zie boven)

Ik heb de gevraagde file ge-editted, maar make geeft nog steeds errors.
Mijn file is de andere bijlage.

make geeft de volgende errors:
(compleete stuk van mijn terminalvenster:)
luke@luke-desktop:~/Opslag/belangrijke_programmas/PonyProg2000-2.07c$ make
cd v; make vlib
make[1]: Map '/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v' wordt binnengegaan
cd srcx ; make
make[2]: Map '/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v/srcx' wordt binnengegaan
g++-3.4 -c -fpermissive -Wno-deprecated -I/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v/includex -I/usr/X11R6/include  -O2 -DAthena -o /home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v/objx/vapp.o vapp.cxx
make[2]: g++-3.4: Opdracht niet gevonden
make[2]: *** [/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v/objx/vapp.o] Fout 127
make[2]: Map '/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v/srcx' wordt verlaten
make[1]: *** [srcx] Fout 2
make[1]: Map '/home/luke/Opslag/belangrijke_programmas/PonyProg2000-2.07c/v' wordt verlaten
make: *** [vlib] Fout 2
luke@luke-desktop:~/Opslag/belangrijke_programmas/PonyProg2000-2.07c$

Sudo make zegt hetzelfde...

Wat doe ik fout?

Ander vraagje (misschien ook voor een ander topic) PonyProg kan ook IIC EEPROMs programeren. Maar niet de 24AA1024. Wel de eerste paar bytes ervan, niet het hele ding. Zou het mogelijk zijn nu ik toch aan het compilen ga, support voor dat EEPROM toe te voegen? Door bijvoorbeeld e24xx-1.cpp (EDIT: en waarschijnlijk nog wat andere files ook) aan te passen tot meer banks en meer bytes? Zodat ik het hele EEPROM kan programmeren?
« Laatst bewerkt op: 2009/04/21, 16:15:04 door Lucky_Luke »

Offline G. Schrijvers

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #1 Gepost op: 2009/04/21, 16:31:13 »
Hallo,

zo te zien heb je g++ niet geïnstalleerd
make[2]: g++-3.4: Opdracht niet gevondeng++ wordt gebruikt om code in c++ te compileren.
Om g++ te installeren kan je het volgende in de terminal ingeven :
sudo apt-get install g++Dit zal g++ installeren.

mvg
Grtz GGS1988

Laptop: Packard Bell: Easynote MX 65 100    :   Debian Edge (32-bit) (Test-server)
Laptop: Dell XPS 1530                               :   Ubuntu 8.10 (64-bit)
Desktop: AMD 6000, HD3870, 4GB DDR2        :   Ubuntu 8.04 (64-bit)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #2 Gepost op: 2009/04/21, 16:31:43 »
Het compileerscript is gewoon slecht. het probeert g++-3.4 uit te voeren, dat erg verouderd is en niet bestaat op je computer. Doe even het volgende:

sudo ln -s /usr/bin/g++ /usr/bin/g++-3.4

Daarmee maak je een link genaamd g++-3.4 naar g++. probeer het daarna nog eens.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #3 Gepost op: 2009/04/21, 16:32:24 »
Hallo,

zo te zien heb je g++ niet geïnstalleerd
make[2]: g++-3.4: Opdracht niet gevondeng++ wordt gebruikt om code in c++ te compileren.
Om g++ te installeren kan je het volgende in de terminal ingeven :
sudo apt-get install g++Dit zal g++ installeren.

mvg
Incorrect, zijn terminaloutput is het levende bewijs dat make op zijn computer staat ;)

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #4 Gepost op: 2009/04/21, 17:22:59 »
sudo ln -s /usr/bin/g++ /usr/bin/g++-3.4 gedaan, en daarna zegt mijn terminal als ik make doe het volgende:

<uhm... ik maak er wel een tekstfile van, anders krijg ik een error dat mijn bericht langer is dan 20.000 karakters...>

 :o

Misschien handig om te weten: Ik draai 8.04

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #5 Gepost op: 2009/04/21, 17:41:16 »
Ik kan niet veel zeggen over PonyProg enzo (ken het niet enzo), maar de nieuwste Virtualbox van de website doet wel aan parallele poorten.

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #6 Gepost op: 2009/04/22, 11:58:50 »
Ik had inderdaad nog een ouder (1.6.5) versie van virtualbox. 'k heb nu de nieuwe versie 2.0. Werkt prima, ik zie alleen nergens iets om mijn parallele poort te configureren... Dus Vistaus, heb je een linkje? Enige wat ik kan vinden is dit: http://vbox.innotek.de/pipermail/vbox-dev/2007-July/000252.html (en een forumtopic waarin een heleboel mensen om parport support vragen).

EDIT: moet ik gewoon opvolgen wat er in dat linkje staat?
« Laatst bewerkt op: 2009/04/23, 19:47:23 door Lucky_Luke »

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #7 Gepost op: 2009/04/24, 19:49:34 »
topickick en vraag:

topickick: Moet ik de instructies van dat linkje volgen?

Vraag: Hoe? Want erg uitgebreid is het niet...

stap 1 was patch Vbox met "patch -Np0 -i vbox-parallel.patch" Moet ik dat gewoon in een terminal gooien of wat?
stap 2 was build vbox. Gewoon "build vbox" in een terminal gooien of ingewikkelder?
stap 3 was een lijstje commando's die als root in een terminal gegooit moeten worden. Ok, daar kom ik nog wel uit. sudo.
stap 4, moet ik die ook gewoon in een terminal gooien?
stap 5: guest starten. Gaat lukken
stap 6: de parallele poort handmatig configureren in windows. Welk windows? (dat in mijn guest? Op mijn host draait natuurlijk Ubuntu)
stap 7, 8 en 9 zijn meer  "test" neem ik aan?

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #8 Gepost op: 2009/04/27, 12:27:38 »
IK kom bij de eerste stap al in de problemen:

luke@luke-desktop:~/Bureaublad$ patch -Np0 -i vbox-parallel.patch
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: include/VBox/pdm.h
|===================================================================
|--- include/VBox/pdm.h (Revision 3615)
|+++ include/VBox/pdm.h (Arbeitskopie)
--------------------------
File to patch:

Wil iemand me helpen? Heeft iemand misschien een andere oplossing?

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #9 Gepost op: 2009/05/08, 21:31:01 »
Is wine gebruiken geen optie, ik heb net even geprobeerd hem te installeren en het lijkt te werken. (overigens heb ik op deze PC geen parallelle poort en ik werk ook met PIC's en niet met AVR's)

Maar ik zal even naar het compilen van source kijken. Maar als dit fout gaat is het vaak een kwestie van de goede parameters aan de make geven en de goede libs geïnstalleerd hebben.


(ik zou het ook wel fijn vinden als ik AVR's zou kunnen proggen, dat is wel handig voor de projecten in de elektor)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #10 Gepost op: 2009/05/08, 21:35:00 »
Ik zou gewoon stoppen met het compileren van dit programma. Het make-script is duidelijk verrot.

Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #11 Gepost op: 2009/05/09, 11:27:31 »
Ik heb het ook nog even op circuitsonline.net gevraagd, nog geen 5 minuten nadat ik dat gepost had kwam ik zelf al een oplossing tegen, namelijk: ik zat in de config van avrdude te kijken hoe lastig het zou zijn mijn programmer toe te voegen (niet zo heel lastig), en hij bleek er al in te staan (pony-stk200). Dus ik kan nu avrs proggen met avrdude.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #12 Gepost op: 2009/05/09, 14:24:37 »
Ik heb een uur besteed aan het compileren van PonyProg, maar het is me niet gelukt. Het programma is dermate oud, dat de compiler allemaal foutmeldingen geeft over syntaxfouten en missende headers. Helaas, dit programma is te oud om nog te compileren.

Offline rja

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #13 Gepost op: 2009/05/09, 15:15:56 »
Kun je niet beter Vmware gebruiken voor je virtualisatie van Windows XP, die ondersteund al heel lang LPT poorten.


Offline Lucky_Luke

  • Lid
  • Steunpunt: Nee
Re: PonyProg2000 werkend krijgen
« Reactie #14 Gepost op: 2009/05/09, 15:46:04 »
Ik heb een uur besteed aan het compileren van PonyProg, maar het is me niet gelukt. Het programma is dermate oud, dat de compiler allemaal foutmeldingen geeft over syntaxfouten en missende headers. Helaas, dit programma is te oud om nog te compileren.
Jammer, maar helaas. Ik zal het ook wel redden met avrdude denk ik. Wel heel erg bedankt voor de moeite!

Over VMware: Daar heb ik al eens mee lopen knoeien, virtualbox kreeg ik sneller aan de gang en werkt gewoon prima.