Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] sneltoetsen worden niet onthouden  (gelezen 1686 keer)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
[OPGELOST] sneltoetsen worden niet onthouden
« Gepost op: 2009/04/21, 15:33:48 »
Kameraden,

Inmiddels heb ik al mijn speciale toetsen aan de praat. De hieronder volgende reacties kun je dus negeren.

Toetsenbord = Logitech Media Elite
of  Logitech Cordless Desktop LX 300

Ik heb grotendeels deze how-to gevolgd:
http://www.linuxinfusion.com/configuring-logitech-media-keyboard-elite-linux

* Stap 1 ongewijzigd uitvoeren.

* Stap 2 heb ik aangepast.
- Als je een .Xmodmap in je homemap maakt, plak dan alleen onderstaande erin:
keycode 240 = XF86Go
keycode 140 = XF86ZoomOut
keycode 213 = XF86ZoomIn
keycode 230 = XF86Favorites
keycode 178 = XF86WWW
keycode 162 = XF86AudioPlay
keycode 164 = XF86AudioStop
keycode 237 = XF86AudioMedia
keycode 176 = XF86AudioRaiseVolume
keycode 174 = XF86AudioLowerVolume
keycode 160 = XF86AudioMute
keycode 144 = XF86AudioPrev
keycode 153 = XF86AudioNext
keycode 236 = XF86Mail
keycode 199 = XF86Messenger
keycode 161 = XF86Calculator
keycode 223 = XF86Sleep
- Tevens een wijziging in onderstaande opdracht:
Citaat
Next edit your .xinitrc or .xsession file and insert xmodmap ~/.Xmodmap & towards the top of the file.
Dit kun je gevoeglijk overslaan. Helemaal niets doen.

* Stap 3 is voor Openbox.
- In Gnome kan dat grafisch, via Systeem / Voorkeuren / Sneltoetsen.
- Of via Toepassingen / Systeemgereedschappen / Configuratie-editor
        - - Apps / Metacity / global_keybindings

Mocht er iets niet lukken, kijk dan eens in dit draadje:
http://forum.ubuntu-nl.org/software-en-configuratie/logitech-toetsenbord-f-keys-toewijzen/

groeten,

Steven
« Laatst bewerkt op: 2009/09/29, 10:45:13 door Steven Klein Haneveld »

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: sneltoetsen worden niet onthouden
« Reactie #1 Gepost op: 2009/04/24, 15:48:49 »
Het is niet zo netjes, maar voor deze keer toch maar.....

*schop*

groet,
steven

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: sneltoetsen worden niet onthouden
« Reactie #2 Gepost op: 2009/09/23, 18:46:26 »
Onvoorstelbaar, maar.....

Na al die tijd is het me deze week eindelijk gelukt mijn multimedia-toetsen aan de praat te krijgen en te houden.

Ik heb een Logitech Media Elite Keyboard.
Via onderstaande how-to is het me gelukt:

http://www.linuxinfusion.com/configuring-logitech-media-keyboard-elite-linux

Voor hen die dezelfde worsteling ondergaan  ;-)

Groetend,

Steven

Offline Robertos

  • Lid
  • Steunpunt: Nee
Re: sneltoetsen worden niet onthouden
« Reactie #3 Gepost op: 2009/09/26, 03:16:35 »
Zou ik mogen vragen of je op bepaalde punten bent afgeweken van de handleiding?
Ik heb namelijk een Logitech Cordless Desktop LX300 en ik ben hier ook nog steeds mee aan het worstelen (*klik*).
De functietoetsen onder F1 t/m F12 en de "Messenger" knop krijg ik niet aan de gang.

Citaat
2. Setting up your multimedia keys.
To set up your multimedia keys, you will need to edit a line in your xorg.conf file as root.
Look for the InputDevice section of the file and update the XkbModel line so it looks exactly like the following:
Option "XkbModel" "logiclx300"
Met alle goede wil van de wereld kan ik geen InputDevice section vinden in xorg.conf?

Citaat
Next edit your .xinitrc or .xsession file and insert xmodmap ~/.Xmodmap & towards the top of the file.
Ook deze files kan ik helaas niet vinden...

Citaat
3. Configure Openbox to use your media keys.
The final step is configuring Openbox to use your newly configured media keys. This can be done by editing your ~/.config/openbox/rc.xml file and adding the following. This is my personal configuration so please change the applications to your preference.
.config/openbox/rc.xml blijkt ook onvindbaar te zijn.

Blijkbaar doe ik toch iets verkeerd, of moet er op bepaalde punten worden afgeweken van de handleiding aangezien deze al meer dan drie jaar oud is. Ik gebruik trouwens Ubuntu 9.04. Zou jij (of iemand anders) mij op weg kunnen helpen?

Bij voorbaat dank.

Robert
« Laatst bewerkt op: 2009/09/26, 03:19:52 door Robertos »

Offline track

  • Lid
  • Steunpunt: Nee
Re: sneltoetsen worden niet onthouden
« Reactie #4 Gepost op: 2009/09/26, 18:52:04 »
Robertos:
Jij hebt de Uby 9.04, daar zit een andere hardwareherkenning in dan bij de 8.04 .
Echt een ander verhaal dus.
Ik zal op jouw draad er even op ingaan hoe je het wél kunt overnemen naar 9.04 !

track

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: sneltoetsen worden niet onthouden
« Reactie #5 Gepost op: 2009/09/26, 18:52:37 »
Robertos,

Ja, ik ben een klein beetje afgeweken van die how-to.

Dat stuk van iets toevoegen aan .xsession of xinitrc kun je vergeten - dat hoeft tegenwoordig niet meer. Bij mij zorgde het zelfs voor fouten bij het inloggen.
In xorg.conf moet toch echt een input device staan. Post hem anders eens (liefst tussen code tags). Kan ik eens kijken.

Openbox - de how-to gaat over de sneltoetsen in "openbox". Jij (en ik) gebruiken Gnome (met metacity). Wij doen dat gewoon grafisch, onder Systeem, voorkeuren, sneltoetsen.

Ik zie in jouw draadje, dat je je ook afvraagt waarom die sneltoetsen niet "onthouden" worden.
Dit lijkt vooral te maken te hebben met de aanwezigheid van dat Xmodmap-bestandje.
En je F-toetsen worden in de eerste stap geregeld.
Ik moet er wel bij zeggen, dat bij jouw toetsenbord die keycodes misschien iets anders zijn, dus ik weet niet of stap 1 in die how-to helemaal klopt bij jou.

Laat me weten hoe het gaat. Bij mij werkt het nu goed, hoewel ik die F-toetsen even nog niet gebruik (heb ze niet nodig nu), dus dat verhaal heb ik nog niet uitgebreid getest.

EDIT
Track was me voor,
maar zijn voorstel is inderdaad verstandiger.
Ik zal eventueel ook daarheen gaan.