Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [How-to] Ubuntu op Medion MD97470  (gelezen 894 keer)

stefandebacker

  • Gast
[How-to] Ubuntu op Medion MD97470
« Gepost op: 2009/04/18, 17:02:11 »
Ik heb vorige week een nieuwe laptop Medion MD97470 model 7610 Notebook PC gekocht (http://www.medion.com/ms/aldi/md97470/be_nl/flash.html)

Deze is uiteraard standaard voorzien van Vista, maar om toch wat productief te werken heb ik toch Ubuntu nodig.

De installatie liep echter niet zo vlot. Om andere mensen mijn leed te besparen zal ik trachten hier een omschrijving te geven van wat ik gedaan heb om de zaak toch min of meer draaiend te krijgen.

1. Installatie van Ubuntu 8.10
Eerst en vooral moet je natuurlijk opstarten van de ubuntu ceedee. Ik koos ervoor om Vista naast mijn ubuntu te draaien. Dus de harde schijf werd ingedeeld in 160Gbyte voor de Vista (NTFS), 100 GB (ext3) voor ubuntu en de rest (30GB) voor de recovery die standaard door Medion voorzien was.

Out of the box en na de installatie van de updates (apt-get update, apt-get upgrade) moet je wel nog even de Nvidea driver die aangeboden wordt installeren om het scherm volledig tot zijn recht te laten komen.

Probleem was: geen geluid, geen webcam en geen wireless.

2. Installatie wireless
De wireless werkt dus niet. Je moet dus eerst via een kabeltje op het internet zien te raken. Met een router is dit dus niet moeilijk: enkel het kabeltje met je router verbinden, en surfen maar.
Dankzij deze link: http://www.csnotes.net/blog/home/how-to-install-the-ralink-wireless-driver-for-medion-akoya-using-ubuntu/ ben ik erin geslaagd om de wireless ook draaiende te krijgen.

Wel eerst even build-essential installeren (apt-get install build-essential)

- De driver kan je hier downloaden: http://www.ralinktech.com/ralink/Home/Support/Linux.html
- Even de driver uitpakken: tar -xvjf 2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2
- nano 2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/config.mk

Daar pas je volgende zaken aan:
# Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y
# Support Native WpaSupplicant for Network Manager
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

- open een terminal als root
cd 2008_0918_RT2860_Linux_STA_v1.8.0.0/
sudo su
make && make install
modprobe rt2860sta
echo rt2860sta >> /etc/modules

3. Installatie geluid

Het geluid begon pas echt muziek te maken toen ik deze link volgde: http://forum.ubuntu-nl.org/index.php?action=printpage;topic=35896.0
- Open een terminal als root
- nano /etc/modprobe.d/alsa-base
helemaal onderaan voeg je volgende regel toe: options snd-hda-intel model=medion probe_mask=1
sla het bestand weer op
- rmmod snd-hda-intel
- modprobe snd-hda-intel model=medion probe_mask=1
- Herstart de pc. Het geluid zou moeten werken.

Het geluid werkt nu wel, maar enkel via de boxen. De micro en de hoofdtelefoon geven nog steeds geen teken van leven.

Om de micro min of meer werkend te krijgen moet je hetvolgende doen:

- installeer de GNOME ALSA Mixer
- start deze op (applications, geluid en video), zet de schuif bij capture omhoog en vink Rec aan.

Om de zaak te testen kan je Audacity installeren. Skype werkt alleen goed als bij Options, Sound Devices volgende instellingen gebruikt:
- Sound In: HDA Intel (hw:Intel,0)
- Sound Out: HDA Intel (hw:Intel,0)
- Ringing: Default device (default)


4. De webcam
De oplossing voor de webcam vond ik op: http://www.qbik.ch/usb/devices/showdev.php?id=4320
- je moet dus surfen naar: https://sourceforge.net/project/showfiles.php?group_id=229562
- download daar het ql860 package
- even uitpakken
- cd nvgl
- en natuurlijk installeren (./install)
- installeer eventueel camorama om je webcam te bekijken.


Dit is het voorlopig, hopelijk is er iemand iets mee.

Groetjes


« Laatst bewerkt op: 2009/04/18, 18:07:38 door stefandebacker »