Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] nVidia driver werkt niet  (gelezen 1565 keer)

Offline frodo007

  • Lid
  • Steunpunt: Nee
[OPGELOST] nVidia driver werkt niet
« Gepost op: 2009/04/17, 09:50:46 »
Hallo,

als ubuntu new-bie heb ik een probleem met de driver voor de grafische kaart. Ik heb een onboard nVidia kaart. Deze (via lspci)
VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
Als ik echter de nVidia drivers installeer (System->Admin->Hardware Drivers) krijg ik na een restart een zwart scherm. Vervolgens moet ik weer restarten en met recovery->xfix heb ik weer beeld, maar dan zijn m'n drivers weer weg. Zo draai ik 'n kringetje  :(

Hetzelfde probleem had ik in 8.04, 8.10 (en 8.10-64) en nu ook in 9.04.

Wat doe ik fout?
« Laatst bewerkt op: 2009/04/22, 21:09:03 door frodo007 »

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #1 Gepost op: 2009/04/17, 11:21:45 »
welkom,
probeer het eens met: envyng-gtk
http://sites.google.com/site/computertip/directdoen

GrJ

Offline frodo007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #2 Gepost op: 2009/04/17, 11:30:13 »
hei joop905,

envy heb ik geprobeerd. Die staat nu bij App->systemtools->EnvyNG.
Deze geeft een 3tal nVidia drivers die compatible moeten zijn. Als ik er een van kies, maakt niet uit welke, krijg ik nog steeds hetzelde problem: na een restart krijg ik een zwart scherm en moet ik via xfix de boel resetten.

Nog andere opties ?

PS:  dit site heb ik doorlopen

Offline track

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #3 Gepost op: 2009/04/17, 13:13:52 »
Hoi Frodo,

welkom op het forum !
(had ik je niet laatst nog in de Gauw gezien ?)

Volgens mij is het bij jou ook het probleem dat hij de PCI-sleutel niet vindt en dus maar de "VESA" pakt.
Een parallele draad vind je hier: http://forum.ubuntu-nl.org/hardware-en-drivers/dubieuze-grafische-kaart-verschijnselen/30/

Daar was de PCI-tabel het knelpunt.  Misschien is ook bij jou een sudo update-pciids (in de terminal) al de oplossing.
(en herstarten uiteraard)

Vriendelijke groet,

track

Offline frodo007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #4 Gepost op: 2009/04/17, 15:22:19 »
Hei track,

deze oplossing hielp niet.
Nu heb ik de nouveau driver geïnstalleerd, en dat werkt zover. Nu heb ik in ieder geval een werkbare resolutie  :D
http://manpages.ubuntu.com/manpages/jaunty/man4/nouveau.4.html

Dus kan ik nu de nVidia 180 driver en x server settings verwijderen?

groet

frodo007

Offline track

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #5 Gepost op: 2009/04/17, 16:38:47 »
Dergelijke dingen zou ik liever niet zo maar verwijderen.
Bovendien heb je de nvidia-driver voor 3d nodig.

En ik blijf stellen dat er iets mis is als de videokaart in de  sudo lspci niet goed verschijnt.
Wil je het resultaat nog een keer (letterlijk en volledig) hier posten ?  Misschien valt er iets te zien.

track

Offline frodo007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #6 Gepost op: 2009/04/17, 16:57:54 »
Hei track,

hier de inhoudt van sudo lspci :

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OH

Nog een vraagje: omdat de video driver werkt, wordt ook de monitor automatisch herkend. Echter de verkeerde.
Waar kan ik dat aanpassen?

Bedankt allemaal voor de snelle reacties  :)

froto007

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #7 Gepost op: 2009/04/17, 17:03:28 »
Dergelijke dingen zou ik liever niet zo maar verwijderen.
Bovendien heb je de nvidia-driver voor 3d nodig.

En ik blijf stellen dat er iets mis is als de videokaart in de  sudo lspci niet goed verschijnt.
Wil je het resultaat nog een keer (letterlijk en volledig) hier posten ?  Misschien valt er iets te zien.

track
Nouveau levert 3d, hoor.

Offline track

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #8 Gepost op: 2009/04/17, 17:22:38 »
00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
Hij wordt dus wél herkend.
Hier ligt het probleem dus niet.

Je moet nu waarschijnlijk de driver handmatig in de  /etc/X11/xorg.conf  invoeren.  Dus met  gksu gedit  /etc/X11/xorg.conf .
Verder kun je gewoon deze draad volgen:  https://answers.launchpad.net/ubuntu/+question/55916
en de wijzigingen rechtstreeks naar jouw "xorg.conf" overnemen:
Citaat
Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
 
   EndSubSection

track

p.s.: op de link boven stond maar "2d", dat heb ik gewoon geloofd ...

Offline frodo007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #9 Gepost op: 2009/04/17, 17:38:27 »
Hei track,

dit ga ik morgen nog es proberen. Maar volgens mij heb ik dit al een aantal keren geprobeerd. Zo snel als d'r Driver "nvidia" in staat, krijg ik een zwart scherm bij het opstarten  :(
Mijn xorg.conf:

Section "Device"
   Identifier   "Device0"
    Driver "nouveau"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Device0"
EndSection


Ik heb dus de vorige keer alleen bij de driver "nvidia" vervangen door "nouveau", en toen werkte het!
Zit er nog iets anders scheef?

Groet

frodo007

Offline track

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #10 Gepost op: 2009/04/17, 17:46:08 »
Als het goed werkt valt er niets meer te zeuren.

Bij de nieuwere versies van Uby gebeurt het herkennen van de video enz allemaal automatisch.
Als het werkt is het goed (en dan zou ik er ook niet verder aan raken), anders kun je nog steeds de handmatige manier erover heen doen.
Dus de passende wijzigingen in de "xorg.conf" invoeren, dan wél telkens achter de  [    Identifier   "Configured Monitor"] .
(-> https://help.ubuntu.com/community/XORGHardy )

track

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #11 Gepost op: 2009/04/17, 20:13:39 »
Als het goed werkt valt er niets meer te zeuren.

Bij de nieuwere versies van Uby gebeurt het herkennen van de video enz allemaal automatisch.
Als het werkt is het goed (en dan zou ik er ook niet verder aan raken), anders kun je nog steeds de handmatige manier erover heen doen.
Dus de passende wijzigingen in de "xorg.conf" invoeren, dan wél telkens achter de  [    Identifier   "Configured Monitor"] .
(-> https://help.ubuntu.com/community/XORGHardy )

track

Wees wel voorzichtig met het editen van xorg.conf, want je kan gemakkelijk dingen om zeep helpen ermee.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #12 Gepost op: 2009/04/18, 01:22:13 »
+1
Maak altijd eerst een kopie voordat je gaat lopen veranderen:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf-backup

wil je de back-up terug zetten ??
sudo cp /etc/X11/xorg.conf-backup /etc/X11/xorg.conf

Grj.

Offline frodo007

  • Lid
  • Steunpunt: Nee
Re: nVidia driver werkt niet
« Reactie #13 Gepost op: 2009/04/22, 21:08:24 »
na een aantal avonden verschillende nVidia drivers geprobeerd en 10-tallen xorg.conf varianten gemaakt:

bij mij blijft het zo: zolang d'r geen "nvidia" in de device sectie staat, gaat het goed. Dus Vesa of nouveau werkt.

Dus vooralsnog is het zo voor mij opgelost  :D

Allemaal bedankt voor de input