Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Netwerk instellingen  (gelezen 2354 keer)

Offline rene4all

  • Lid
  • Steunpunt: Nee
Netwerk instellingen
« Gepost op: 2009/04/16, 11:11:02 »
Forumleden

Graag wil ik mijn ubuntu pc van een vast ipadres voorzien.
Maar als ik deze wil instellen via rechtse muisknop op de knipperende computers, verbindingen, auto eth0, bewerken, ipv4 instellingen, toevoegen, gegevens invullen.
Maar na een reboot staat de dhcp weer op automatisch en alle instellingen zijn weer weg.
Wie kan mij vertellen hoe ik een vast ipadres ingesteld krijg op mijn ubuntu pc's ?
 

Bvd Rene

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #1 Gepost op: 2009/04/16, 12:19:17 »
Heb je bij "Methode" "handmatig" opgegeven?
Post eens de output van

cat /etc/network/interfaces
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline rene4all

  • Lid
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #2 Gepost op: 2009/04/16, 12:21:52 »
Handmatig heb ik ingesteld.




« Laatst bewerkt op: 2009/04/16, 12:54:21 door rene4all »

Offline rene4all

  • Lid
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #3 Gepost op: 2009/04/16, 12:51:26 »
Heb je bij "Methode" "handmatig" opgegeven?
Post eens de output van

cat /etc/network/interfaces

rene@rene:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #4 Gepost op: 2009/04/16, 15:19:52 »
Blijkbaar gaat het om een gekende bug in de Gnome network manager die in Ubuntu 8.10 zit. Een oplossing is deze (via de terminal wel, maar met grafisch texteditor):

sudo gedit /etc/network/interfaces
Voeg onderaan de file het volgende toe:
auto eth0
iface eth0 inet static
address 192.168.0.100
netmask 255.255.255.0
gateway 192.168.0.1

Uiteraard wel de juiste IP gegevens invullen voor je eigen situatie en de file opslaan en sluiten.

Dan moeten we nog aangeven welke DNS servers je wil gebruiken.
sudo gedit /etc/resolv.conf
Voeg hier de juiste DNS servers toe:
nameserver 195.130.130.3
nameserver 195.130.131.3

Deze uiteraard ook weer aanpassen naar je eigen situatie.

Sla het bestand op en geef het volgende in in de terminal (je kan ook gewoon rebooten):
sudo /etc/init.d/networking restart
Dat zou het moeten zijn!

° Bezoek mijn blog Digital (in)Sanity °

Offline rene4all

  • Lid
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #5 Gepost op: 2009/04/16, 19:21:35 »
Hallo Darkstar

Allereerst bedankt voor je infNa je info verwerkt te hebben is er het volgende gebeurt.
Na de reboot had ik geen verbinding meer bij de het venster waar het macadres is ingevuld stond niets dus ik dacht mijn netwerkkaart wordt niet meer gezien.
En er stond ook geen eth0 meer bij .
Dus heb ik de gegevens die ik ingevuld had weer eruit gekieperd en raar maar waar ik krijg nu tot miijn verbazing een kabelverbinding1
en eth0 maar het leuke aan alles is dat het volgens mij nu wel werkt want mijn ingevoerde ipadres blijft wel staan.
Ik zal nog eens een keer booten of het mooi blijft staan.
Het lijkt mij niet de oplossing zoals het hoort maar het werkt wel.

Even gereboot maar de pc start op met de auto eth0 en niet met kabelverbinding 1
Dus op een of andere manier is het nog niet helemaal goed.

Gr Rene
« Laatst bewerkt op: 2009/04/16, 19:29:58 door rene4all »

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #6 Gepost op: 2009/04/17, 13:35:24 »
Gisteren heb ik nog ergens een gelijkaardige oplossing gevonden voor dit probleem nl. een nieuwe connectie maken in de network manager (dus niet auto eth0 gebruiken), en daar alle nodige gegevens invullen zoals bv. je MAC adres, etc. Volgens mij heb je dus nu al zo'n 'extra' verbinding nl. kabelverbinding1. Als je nu bij Auto eth0 het vinkje 'automatisch verbinden' uitvinkt, en dat bij kabelverbinding1 aanvinkt zou het volgens mij moeten lukken.
Een andere oplossing is om de Gnome network manager te verwijderen, zodat deze bug niet meer voor komt en het dan dus op de handmatige manier te doen zoals ik in mijn vorige post heb uitgelegd.
Misschien nog makkelijker is te upgraden naar 9.04 volgende week, voor zo ver ik weet zit die bug er niet meer in.

° Bezoek mijn blog Digital (in)Sanity °

Offline rene4all

  • Lid
  • Steunpunt: Nee
Re: Netwerk instellingen
« Reactie #7 Gepost op: 2009/04/18, 17:41:42 »
Heb alles ingesteld en alles werkt.
Ik denk dat ik volgende week maar doe upgraden
In iedergeval bedankt voor je info

Gr. Rene