Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Fout bij opstarten server HELP waar is mijn data  (gelezen 872 keer)

Offline jayel

  • Lid
  • Steunpunt: Nee
Fout bij opstarten server HELP waar is mijn data
« Gepost op: 2009/04/14, 14:52:49 »
hello,

Ik krijg mijn ubuntu server niet meer opgestart, hier gaat het over een server waar ik 4 schijven van 500 GB in heb en die in RAID 0 staan. Die server makt iedere nacht een backup (dat dacht ik toch). Maar nu krijg ik dit te zien bij opstarten server.
Apr 14 14:36:12 backup2T kernel: [    1.462847] md: raid0 personality registered for level 0
Apr 14 14:36:12 backup2T kernel: [    2.522713] ata1: PATA max UDMA/100 cmd 0x00011018 ctl 0x00011026 bmdma 0x00011000 irq 16
Apr 14 14:36:12 backup2T kernel: [    2.694655] ata2: SATA max UDMA/133 cmd 0x00012148 ctl 0x0001217e bmdma 0x00012110 irq 19
Apr 14 14:36:12 backup2T kernel: [    2.694677] ata3: SATA max UDMA/133 cmd 0x00012140 ctl 0x0001217a bmdma 0x00012118 irq 19
Apr 14 14:36:12 backup2T kernel: [    3.749089] ata4: SATA max UDMA/133 cmd 0x00012138 ctl 0x00012176 bmdma 0x000120f0 irq 19
Apr 14 14:36:12 backup2T kernel: [    3.749108] ata5: SATA max UDMA/133 cmd 0x00012130 ctl 0x00012172 bmdma 0x000120f8 irq 19
Apr 14 14:36:12 backup2T kernel: [    4.556873] md: md0 stopped.
Apr 14 14:36:12 backup2T kernel: [    4.668589] md: bind<sdb1>
Apr 14 14:36:12 backup2T kernel: [    4.691812] md: md0 stopped.
Apr 14 14:36:12 backup2T kernel: [    4.691818] md: unbind<sdb1>
Apr 14 14:36:12 backup2T kernel: [    4.691823] md: export_rdev(sdb1)
Apr 14 14:36:12 backup2T kernel: [    4.708916] md: bind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    4.709046] md: bind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    4.709189] md: bind<sda4>
Apr 14 14:36:12 backup2T kernel: [    4.802859] md: array md0 already has disks!
Apr 14 14:36:12 backup2T kernel: [    7.505494] md: md0 stopped.
Apr 14 14:36:12 backup2T kernel: [    7.505503] md: unbind<sda4>
Apr 14 14:36:12 backup2T kernel: [    7.505510] md: export_rdev(sda4)
Apr 14 14:36:12 backup2T kernel: [    7.505526] md: unbind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    7.505531] md: export_rdev(sdd1)
Apr 14 14:36:12 backup2T kernel: [    7.505566] md: unbind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    7.505570] md: export_rdev(sdc1)
Apr 14 14:36:12 backup2T kernel: [    7.690359] md: bind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    7.694383] md: bind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    7.703586] md: bind<sda4>
Apr 14 14:36:12 backup2T kernel: [    7.849015] md: md0 stopped.
Apr 14 14:36:12 backup2T kernel: [    7.849022] md: unbind<sda4>
Apr 14 14:36:12 backup2T kernel: [    7.849029] md: export_rdev(sda4)
Apr 14 14:36:12 backup2T kernel: [    7.849036] md: unbind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    7.849040] md: export_rdev(sdd1)
Apr 14 14:36:12 backup2T kernel: [    7.849055] md: unbind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    7.849059] md: export_rdev(sdc1)
Apr 14 14:36:12 backup2T kernel: [    7.863298] md: bind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    7.863416] md: bind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    7.863856] md: bind<sda4>
Apr 14 14:36:12 backup2T kernel: [    9.583463] md: md0 stopped.
Apr 14 14:36:12 backup2T kernel: [    9.583473] md: unbind<sda4>
Apr 14 14:36:12 backup2T kernel: [    9.583480] md: export_rdev(sda4)
Apr 14 14:36:12 backup2T kernel: [    9.583528] md: unbind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    9.583533] md: export_rdev(sdd1)
Apr 14 14:36:12 backup2T kernel: [    9.583567] md: unbind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    9.583572] md: export_rdev(sdc1)
Apr 14 14:36:12 backup2T kernel: [    9.656205] md: bind<sdc1>
Apr 14 14:36:12 backup2T kernel: [    9.656347] md: bind<sdd1>
Apr 14 14:36:12 backup2T kernel: [    9.656468] md: bind<sda4>
Apr 14 14:36:17 backup2T mdadm: DeviceDisappeared event detected on md device /dev/md0

Ik kan niet meer op mijn home partitei

help

John
« Laatst bewerkt op: 2009/04/14, 14:59:33 door jayel »

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #1 Gepost op: 2009/04/14, 16:20:37 »
Je array is blijkbaar gestopt en heeft de schijven er uit gegooid...

Maareuh... RAID0? Je beseft toch dat als er één schijf kapot gaat je dus ook ALLE data kwijt bent hè?
Best eens de man pages van mdadm doorzoeken: http://www.linuxmanpages.com/man8/mdadm.8.php
Probeer eventueel eens via mdadm --assembleOp die manier gaat mdadm kijken welke raid-devices er bestaan.

° Bezoek mijn blog Digital (in)Sanity °

Offline jayel

  • Lid
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #2 Gepost op: 2009/04/15, 10:24:08 »
Ja, RAID0, ik wilde het ook anders zien maar 2 jaar geleden waren er og geen schijven  van 1 TB, dus moest ik van mijn baas 4 x 500GB in RAUD 0 zetten om zovel mogelijk opslag te hebben voor camerabeelden.

Dit gezegd zijnde krijg ik dit als error :
root@backup2T:/var/log# mdadm --assemble --scan
mdadm: /dev/md0 assembled from 3 drives - not enough to start the array.

het lijk erop dat er een drive tekort in zit ???

nog een log /var/dmesg:
[    1.878434] Copyright (c) 1999-2006 Intel Corporation.
[    1.878479] ACPI: PCI Interrupt 0000:00:19.0[A] -> GSI 20 (level, low) -> IRQ 20
[    1.878491] PCI: Setting latency timer of device 0000:00:19.0 to 64
[    1.884975] ieee1394: Initialized config rom entry `ip1394'
[    1.889753] SCSI subsystem initialized
[    1.889820] usbcore: registered new interface driver usbfs
[    1.889837] usbcore: registered new interface driver hub
[    1.894985] libata version 2.20 loaded.
[    1.903066] usbcore: registered new device driver usb
[    1.903858] USB Universal Host Controller Interface driver v3.0
[    1.920609] e1000: 0000:00:19.0: e1000_probe: (PCI Express:2.5Gb/s:Width x1) 00:19:d1:b1:c9:51
[    2.042093] e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
[    2.042125] ata_piix 0000:00:1f.2: version 2.10ac1
[    2.042131] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
[    2.042152] ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 19 (level, low) -> IRQ 19
[    2.042169] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[    2.042211] ata1: SATA max UDMA/133 cmd 0x00012148 ctl 0x0001217e bmdma 0x00012110 irq 19
[    2.042232] ata2: SATA max UDMA/133 cmd 0x00012140 ctl 0x0001217a bmdma 0x00012118 irq 19
[    2.042243] scsi0 : ata_piix
[    2.482877] ata1.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    2.482882] ata1.00: ATA-7: ST3500630AS, 3.AAK, max UDMA/133
[    2.482885] ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    2.482888] ata1.01: ATAPI, max UDMA/33
[    2.549489] ata1.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    2.549493] ata1.00: configured for UDMA/133
[    2.773168] ata1.01: configured for UDMA/33
[    2.773174] scsi1 : ata_piix
[    2.999653] ata2.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    2.999656] ata2.00: ATA-7: ST3500630AS, 3.AAK, max UDMA/133
[    2.999659] ata2.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    3.074595] ata2.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    3.074600] ata2.00: configured for UDMA/133
[    3.074686] scsi 0:0:0:0: Direct-Access     ATA      ST3500630AS      3.AA PQ: 0 ANSI: 5
[    3.075830] scsi 0:0:1:0: CD-ROM            TSSTcorp DVD-ROM SH-D163B SB00 PQ: 0 ANSI: 5
[    3.075987] scsi 1:0:0:0: Direct-Access     ATA      ST3500630AS      3.AA PQ: 0 ANSI: 5
[    3.076092] ata_piix 0000:00:1f.5: MAP [ P0 P2 P1 P3 ]
[    3.076107] ACPI: PCI Interrupt 0000:00:1f.5[A] -> GSI 19 (level, low) -> IRQ 19
[    3.076119] PCI: Setting latency timer of device 0000:00:1f.5 to 64
[    3.076139] ata3: SATA max UDMA/133 cmd 0x00012138 ctl 0x00012176 bmdma 0x000120f0 irq 19
[    3.076157] ata4: SATA max UDMA/133 cmd 0x00012130 ctl 0x00012172 bmdma 0x000120f8 irq 19
[    3.076162] scsi2 : ata_piix
[    3.297744] ata3.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    3.297749] ata3.00: ATA-7: ST3500630AS, 3.AAK, max UDMA/133
[    3.297751] ata3.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    3.372680] ata3.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    3.372685] ata3.00: configured for UDMA/133
[    3.372689] scsi3 : ata_piix
[    3.601405] ata4.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    3.601409] ata4.00: ATA-7: ST3500630AS, 3.AAK, max UDMA/133
[    3.601412] ata4.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 0/32)
[    3.676347] ata4.00: ata_hpa_resize 1: sectors = 976773168, hpa_sectors = 976773168
[    3.676351] ata4.00: configured for UDMA/133
[    3.676419] scsi 2:0:0:0: Direct-Access     ATA      ST3500630AS      3.AA PQ: 0 ANSI: 5
[    3.676571] scsi 3:0:0:0: Direct-Access     ATA      ST3500630AS      3.AA PQ: 0 ANSI: 5
[    3.676694] ACPI: PCI Interrupt 0000:06:03.0[A] -> GSI 19 (level, low) -> IRQ 19
[    3.726838] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19]  MMIO=[90004000-900047ff]  Max Packet=[2048]  IR/IT contexts=[4/8]
[    3.728578] ACPI: PCI Interrupt 0000:00:1a.0[A] -> GSI 16 (level, low) -> IRQ 17
[    3.728587] PCI: Setting latency timer of device 0000:00:1a.0 to 64
[    3.728591] uhci_hcd 0000:00:1a.0: UHCI Host Controller
[    3.728675] uhci_hcd 0000:00:1a.0: new USB bus registered, assigned bus number 1
[    3.728699] uhci_hcd 0000:00:1a.0: irq 17, io base 0x000020a0
[    3.728785] usb usb1: configuration #1 chosen from 1 choice
[    3.728808] hub 1-0:1.0: USB hub found
[    3.728813] hub 1-0:1.0: 2 ports detected
[    3.837077] ACPI: PCI Interrupt 0000:00:1a.1[B] -> GSI 21 (level, low) -> IRQ 21
[    3.837084] PCI: Setting latency timer of device 0000:00:1a.1 to 64
[    3.837088] uhci_hcd 0000:00:1a.1: UHCI Host Controller
[    3.837108] uhci_hcd 0000:00:1a.1: new USB bus registered, assigned bus number 2
[    3.837131] uhci_hcd 0000:00:1a.1: irq 21, io base 0x00002080
[    3.837208] usb usb2: configuration #1 chosen from 1 choice
[    3.837232] hub 2-0:1.0: USB hub found
[    3.837237] hub 2-0:1.0: 2 ports detected
[    3.947503] ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 23 (level, low) -> IRQ 22
[    3.947510] PCI: Setting latency timer of device 0000:00:1d.0 to 64
[    3.947514] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[    3.947532] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 3
[    3.947556] uhci_hcd 0000:00:1d.0: irq 22, io base 0x00002060
[    3.947634] usb usb3: configuration #1 chosen from 1 choice
[    3.947656] hub 3-0:1.0: USB hub found
[    3.947661] hub 3-0:1.0: 2 ports detected
[    4.057902] ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 19
[    4.057909] PCI: Setting latency timer of device 0000:00:1d.1 to 64
[    4.057912] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[    4.057931] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 4
[    4.057952] uhci_hcd 0000:00:1d.1: irq 19, io base 0x00002040
[    4.058030] usb usb4: configuration #1 chosen from 1 choice
[    4.058052] hub 4-0:1.0: USB hub found
[    4.058057] hub 4-0:1.0: 2 ports detected
[    4.168307] ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 18
[    4.168314] PCI: Setting latency timer of device 0000:00:1d.2 to 64
[    4.168317] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[    4.168336] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 5
[    4.168360] uhci_hcd 0000:00:1d.2: irq 18, io base 0x00002020
[    4.168438] usb usb5: configuration #1 chosen from 1 choice
[    4.168459] hub 5-0:1.0: USB hub found
[    4.168464] hub 5-0:1.0: 2 ports detected
[    4.278726] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17 (level, low) -> IRQ 16
[    4.278731] ACPI: PCI Interrupt 0000:00:1a.7[C] -> GSI 18 (level, low) -> IRQ 18
[    4.278743] PCI: Setting latency timer of device 0000:00:1a.7 to 64
[    4.278746] PCI: Setting latency timer of device 0000:02:00.0 to 64
[    4.278748] ehci_hcd 0000:00:1a.7: EHCI Host Controller
[    4.278772] ehci_hcd 0000:00:1a.7: new USB bus registered, assigned bus number 6
[    4.278797] ehci_hcd 0000:00:1a.7: debug port 1
[    4.278803] PCI: cache line size of 32 is not supported by device 0000:00:1a.7
[    4.278807] ehci_hcd 0000:00:1a.7: irq 18, io mem 0x90326400
[    4.282698] ehci_hcd 0000:00:1a.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[    4.282754] usb usb6: configuration #1 chosen from 1 choice
[    4.282775] hub 6-0:1.0: USB hub found
[    4.282779] hub 6-0:1.0: 4 ports detected
[    4.282808] ata5: PATA max UDMA/100 cmd 0x00011018 ctl 0x00011026 bmdma 0x00011000 irq 16
[    4.282820] scsi4 : pata_marvell
[    4.282861] BAR5:00:00 01:7F 02:22 03:CA 04:00 05:00 06:00 07:00 08:00 09:00 0A:00 0B:00 0C:01 0D:00 0E:00 0F:00
[    4.460764] ATA: abnormal status 0x8 on port 0x0001101f
[    4.460814] ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 23 (level, low) -> IRQ 22
[    4.460822] PCI: Setting latency timer of device 0000:00:1d.7 to 64
[    4.460825] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[    4.460844] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 7
[    4.460867] ehci_hcd 0000:00:1d.7: debug port 1
[    4.460872] PCI: cache line size of 32 is not supported by device 0000:00:1d.7
[    4.460876] ehci_hcd 0000:00:1d.7: irq 22, io mem 0x90326000
[    4.464758] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[    4.464813] usb usb7: configuration #1 chosen from 1 choice
[    4.464833] hub 7-0:1.0: USB hub found
[    4.464838] hub 7-0:1.0: 6 ports detected
[    4.575495] SCSI device sda: 976773168 512-byte hdwr sectors (500108 MB)
[    4.575505] sda: Write Protect is off
[    4.575507] sda: Mode Sense: 00 3a 00 00
[    4.575519] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.575555] SCSI device sda: 976773168 512-byte hdwr sectors (500108 MB)
[    4.575563] sda: Write Protect is off
[    4.575565] sda: Mode Sense: 00 3a 00 00
[    4.575577] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.575579]  sda: sda1 sda2 sda3 sda4
[    4.605550] sd 0:0:0:0: Attached scsi disk sda
[    4.606084] SCSI device sdb: 976773168 512-byte hdwr sectors (500108 MB)
[    4.606093] sdb: Write Protect is off
[    4.606095] sdb: Mode Sense: 00 3a 00 00
[    4.606108] SCSI device sdb: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.606143] SCSI device sdb: 976773168 512-byte hdwr sectors (500108 MB)
[    4.606151] sdb: Write Protect is off
[    4.606152] sdb: Mode Sense: 00 3a 00 00
[    4.606164] SCSI device sdb: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.606166]  sdb:sr0: scsi3-mmc drive: 4x/48x cd/rw xa/form2 cdda tray
[    4.618841] Uniform CD-ROM driver Revision: 3.20
[    4.618874] sr 0:0:1:0: Attached scsi CD-ROM sr0
[    4.622226]  sdb1
[    4.622261] sd 1:0:0:0: Attached scsi disk sdb
[    4.622544] SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
[    4.622553] sdc: Write Protect is off
[    4.622555] sdc: Mode Sense: 00 3a 00 00
[    4.622567] SCSI device sdc: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.622596] SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
[    4.622604] sdc: Write Protect is off
[    4.622606] sdc: Mode Sense: 00 3a 00 00
[    4.622617] SCSI device sdc: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.622620]  sdc: sdc1
[    4.636524] sd 2:0:0:0: Attached scsi disk sdc
[    4.636567] SCSI device sdd: 976773168 512-byte hdwr sectors (500108 MB)
[    4.636577] sdd: Write Protect is off
[    4.636579] sdd: Mode Sense: 00 3a 00 00
[    4.636593] SCSI device sdd: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.636626] SCSI device sdd: 976773168 512-byte hdwr sectors (500108 MB)
[    4.636635] sdd: Write Protect is off
[    4.636637] sdd: Mode Sense: 00 3a 00 00
[    4.636651] SCSI device sdd: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.636653]  sdd: sdd1
[    4.657077] sd 3:0:0:0: Attached scsi disk sdd
[    4.664262] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    4.664280] sr 0:0:1:0: Attached scsi generic sg1 type 5
[    4.664299] sd 1:0:0:0: Attached scsi generic sg2 type 0
[    4.664316] sd 2:0:0:0: Attached scsi generic sg3 type 0
[    4.664333] sd 3:0:0:0: Attached scsi generic sg4 type 0
[    4.776473] md: md0 stopped.
[    4.836728] md: bind<sdd1>
[    4.836854] md: bind<sdc1>
[    4.873015] md: array md0 already has disks!
[    4.907971] md: array md0 already has disks!
[    4.921490] md: array md0 already has disks!
[    4.924376] md: array md0 already has disks!
[    4.927123] md: array md0 already has disks!
[    4.929926] md: array md0 already has disks!
[    4.932689] md: array md0 already has disks!
[    4.935228] md: array md0 already has disks!
[    4.937770] md: array md0 already has disks!
[    4.940299] md: array md0 already has disks!
[    4.942838] md: array md0 already has disks!
[    4.950751] md: array md0 already has disks!
[    4.959993] Attempting manual resume
[    4.959996] swsusp: Resume From Partition 8:2
[    4.959997] PM: Checking swsusp image.
[    4.960111] PM: Resume from disk failed.
[    4.981749] kjournald starting.  Commit interval 5 seconds
[    4.981756] EXT3-fs: mounted filesystem with ordered data mode.
[    4.982283] md: array md0 already has disks!
[    5.052484] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[0090270001e98a99]
[    5.079816] md: array md0 already has disks!
[    6.609390] e1000: eth0: e1000_request_irq: Unable to allocate MSI interrupt Error: -22
[    6.621779] e1000: eth0: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
[    7.251133] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    7.268787] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    7.321608] Linux agpgart interface v0.102 (c) Dave Jones
[    7.379110] iTCO_vendor_support: vendor-support=0
[    7.439182] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.01 (11-Nov-2006)
[    7.439243] iTCO_wdt: Found a ICH8DO TCO device (Version=2, TCOBASE=0x0460)
[    7.439271] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[    7.456904] agpgart: Detected an Intel 965Q Chipset.
[    7.457850] agpgart: Unknown page table size, assuming 512KB
[    7.457854] agpgart: Detected 7676K stolen memory.
[    7.470437] agpgart: AGP aperture is 256M @ 0x80000000
[    7.691608] md: md0 stopped.
[    7.691616] md: unbind<sdc1>
[    7.691622] md: export_rdev(sdc1)
[    7.691681] md: unbind<sdd1>
[    7.691684] md: export_rdev(sdd1)
[    7.718066] NET: Registered protocol family 10
[    7.718140] lo: Disabled Privacy Extensions
[    7.895969] input: PC Speaker as /class/input/input2
[    7.909308] md: bind<sdc1>
[    7.913571] md: bind<sdd1>
[    7.913690] md: bind<sda4>
[    7.942079] parport: PnPBIOS parport detected.
[    7.942154] parport0: PC-style at 0x378 (0x778), irq 7, using FIFO [PCSPP,TRISTATE,COMPAT,ECP]
[    7.958007] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 23
[    7.958024] PCI: Setting latency timer of device 0000:00:1b.0 to 64
[    8.095005] md: md0 stopped.
[    8.095013] md: unbind<sda4>
[    8.095019] md: export_rdev(sda4)
[    8.095027] md: unbind<sdd1>
[    8.095031] md: export_rdev(sdd1)
[    8.095046] md: unbind<sdc1>
[    8.095049] md: export_rdev(sdc1)
[    8.126765] md: bind<sdc1>
[    8.126905] md: bind<sdd1>
[    8.127024] md: bind<sda4>
[    9.293141] lp0: using parport0 (interrupt-driven).
[    9.427374] Adding 1461904k swap on /dev/disk/by-uuid/52ddc541-6912-4753-906d-ee68dcbb877b.  Priority:-1 extents:1 across:1461904k
[    9.518209] EXT3 FS on sda3, internal journal
[    9.629881] md: md0 stopped.
[    9.629889] md: unbind<sda4>
[    9.629897] md: export_rdev(sda4)
[    9.629942] md: unbind<sdd1>
[    9.629946] md: export_rdev(sdd1)
[    9.629956] md: unbind<sdc1>
[    9.629960] md: export_rdev(sdc1)
[    9.711003] md: bind<sdc1>
[    9.711120] md: bind<sdd1>
[    9.711264] md: bind<sda4>
[   18.681657] eth0: no IPv6 routers present
[   55.201157] kjournald starting.  Commit interval 5 seconds
[   55.201359] EXT3 FS on sda1, internal journal
[   55.201373] EXT3-fs: mounted filesystem with ordered data mode.


Daar hou ik dus van, hier kan je van leren (alhoewel mijn baas niet gelukkig is).

Wat is hier het probleem?

mvg
John

Offline jayel

  • Lid
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #3 Gepost op: 2009/04/15, 10:51:27 »
Dit vind in ook raar !!

root@backup2T:/etc/init.d# cat /proc/mdstat
Personalities : [raid0]
md0 : inactive sda4[0](S) sdd1[3](S) sdc1[2](S)
      1453432384 blocks

unused devices: <none>


schijf sdb1 ontbreekt en de andere staan op Spare (S)

???

mvg
John

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #4 Gepost op: 2009/04/15, 18:24:17 »
sdb zal gemarkeerd staan als 'failed' en dus uit de array gegooid zijn... Omdat het een RAID0 is kan de array met slecht 3 van de 4 schijven dus uiteraard niet terug gestart worden...

° Bezoek mijn blog Digital (in)Sanity °

Offline jayel

  • Lid
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #5 Gepost op: 2009/04/16, 07:57:21 »
ok,

maar kan iki die terug in de array steken ?

of kan ik ergns weten waarom die uit de array is gesmeten?

mvg
John

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #6 Gepost op: 2009/04/16, 15:08:05 »
Een disk die failed kan je niet zomaar er terug in gooien, vooral omdat er ook een reden is waarom die disk failde!
Je kan dit eens proberen om wat meer info te krijgen:
mdadm --detail /dev/md0

De kans dat je nog data zal terugkrijgen is echt wel klein dus ik hoop dat je een goede backup hebt.
Ik kan je misschien ook wel aanraden om een keer dit probleem voor te leggen in het "Non-windows OS" gedeelte van het forum op Tweakers.net. Daar zitten een aantal mensen die wat meer praktijkervaring hebben met dit soort gevallen, misschien dat je daar wat wijzer uit wordt.

° Bezoek mijn blog Digital (in)Sanity °

Offline jayel

  • Lid
  • Steunpunt: Nee
Re: Fout bij opstarten server HELP waar is mijn data
« Reactie #7 Gepost op: 2009/04/16, 15:11:57 »
ok bedankt Darkstar

Hier de output :
root@backup2T:~# mdadm --detail /dev/md0
mdadm: md device /dev/md0 does not appear to be active.


Ik neus even rond in tweakers.net

John