Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Skype start niet op  (gelezen 4002 keer)

Offline avanca

  • Lid
  • Steunpunt: Nee
[opgelost] Skype start niet op
« Gepost op: 2009/04/12, 15:56:30 »
Hallo,
Skype en ook nog andere programma's starten niet en krijg ik de volgende foutmelding:


avc@avc-desktop:~$ skype
/usr/bin/skype.real: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
avc@avc-desktop:~$

Ik heb reeds un- en install gedaan maar de fout blijft.
Heeft er iemand een idee hoe ik dit kan oplossen?

Mvg
Avanca
« Laatst bewerkt op: 2009/04/12, 18:57:53 door avanca »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Skype start niet op
« Reactie #1 Gepost op: 2009/04/12, 16:00:08 »
Wat vreemd. Er zit een compileerfout in libQtNetwork. Sinds wanneer heb je dit? En bij welke programma's?
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/340252

Offline eXtreem

  • Lid
  • Steunpunt: Nee
Re: Skype start niet op
« Reactie #2 Gepost op: 2009/04/12, 16:23:30 »
Heb je skype vanuit de repositories geïnstalleerd? Zoja, dan zou je nog een keer kunnen kiezen voor een volledige verwijdering van skype vanuit synaptic. Hierbij worden ook de persoonlijke instellingen van het programma verwijderd en aangezien skype niet zo erg veel persoonlijke instellingen heeft, lijkt me dit niet zo'n probleem.
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline vrijevogel

  • Lid
  • Steunpunt: Nee
Re: Skype start niet op
« Reactie #3 Gepost op: 2009/04/12, 18:11:22 »
Ik heb volgende oplossing gevonden op een franstalige website :

sudo apt-get remove skype
sudo apt-get install skype-static

Hoe heb je Skype geïnstalleerd? Ik heb bvb. Skype geïnstalleerd via de website van Skype zelf (.deb bestand downloaden,
aanklikken in je map waarin je gedownload hebt, pakket wordt automatisch en probleemloos geïnstalleerd. Ik gebruik
Skype regelmatig (Ubuntu8.10).

Offline eXtreem

  • Lid
  • Steunpunt: Nee
Re: Skype start niet op
« Reactie #4 Gepost op: 2009/04/12, 18:40:33 »
Het enige wat ik heb gedaan na de installatie is de bekende "direct doen" handleiding gevolgd. Hierna alleen maar sudo apt-get install skype gedaan en het werkt.

Wat ik bij de info in synaptic zie staan als verschil tussen de static en de normale versie is dat deze zijn eigen Qt libraries heeft en dus niet afhankelijk is van die op het systeem zelf.

Zoals je al zegt hebben ook andere programma's op jouw systeem last van het zelfde probleem. Het lijkt er dus op dat er een probleem is met de Qt4 libraries op je systeem. Bij mij staan in Synaptic 2 pakketten aangevinkt m.b.t. Qt4:

python-qt4
python-qt4-common

Heb jij deze ook aangevinkt staan of heb je juist meer qt4 zaken geïnstalleerd staan? Je zou ze eventueel een keer kunnen markeren voor herinstallatie.

Edit:
qt4-qtconfig is niet nodig... deze weg gehaald
« Laatst bewerkt op: 2009/04/12, 18:52:47 door eXtreem »
http://ubuntu.zurf.nl    (password ubuntu)
:wq

Offline avanca

  • Lid
  • Steunpunt: Nee
Re: Skype start niet op
« Reactie #5 Gepost op: 2009/04/12, 18:54:41 »
Probleem is opgelost!!!

Na het volgen van de link die Cumulus007 doorgaf heb ik gevonden dat de libqt* niet hoefden te staan in de map /usr/local/lib/libqt*
Na deze te hebben verwijderd was het probleem opgelost.
Het was skype niet alleen maar nog een heel pak programma"s die in conflict kwamen met de dubbele libqt's

Iedereen bedankt voor de info en het meedenken.
Mvg
Avanca