Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: VLC 0.8.6i installeren.  (gelezen 2629 keer)

Offline FrodoW

  • Lid
  • Steunpunt: Nee
VLC 0.8.6i installeren.
« Gepost op: 2009/04/09, 14:56:19 »
Beste forumleden,

Ik zou graag VLC op mijn server willen installeren maar dan een wat oudere versie dan de standaard nu. Is er ergens een bron voor Apt-Get om oudere versies van VLC, bijvoorkeur 0.8.6i, te kunnen selecteren?

Groet,
FrodoW

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #1 Gepost op: 2009/04/09, 15:07:56 »
Hoi Frodo,

misschien kom je hiermee al verder:  http://packages.ubuntu.com/nl/hardy/vlc
Je kunt de .deb daar rechtstreeks ophalen, en er zijn ook verdere links.

Vriendelijke groet,

track

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #2 Gepost op: 2009/04/09, 16:16:43 »
Hoi track,

Ik heb het blok:

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

aan /etc/apt/sources.list togevoegd en apt-get update uitgevoerd.

Aptitude geeft wel een aantal addins voor VLC 0.8.6 maar nog niet het pakket zelf.

FrodoW

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #3 Gepost op: 2009/04/09, 16:23:04 »
Heb je Hardy (=8.04) geïnstalleerd dan ?
Anders zou ik een Hardy-bron nooit aan de bronnenlijst toevoegen, want het gehele systeem komt dan in de war.
(bovendie hoeft "security" niet, want het staat ook al in "multiverse")

Je kunt het pakket rechtstreeks downloaden (link op de genoemde site beneden) en dan per  sudo dpkg  installeren.

track

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #4 Gepost op: 2009/04/09, 17:15:13 »
@track

Jouw suggestie uitgeprobeerd. Krijg echter een fout melding:

(Database inlezen ... 38618 bestanden en mappen geïnstalleerd.)
Uitpakken van vlc (uit vlc_0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2_i386.deb) ...
dpkg: fout bij afhandelen van vlc_0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2_i386.deb (--install):
 poging tot overschrijven van `/usr/share/pixmaps/vlc.png', wat ook in pakket vlc-data zit
dpkg-deb: subproces paste werd gedood door signaal (Broken pipe)
Fouten gevonden tijdens behandelen van:
 vlc_0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2_i386.deb

Heb voor alle zekerheid /usr/share/pixmaps/vlc.png vewijderd, dpkg -i vlc_0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2_i386.deb blijft echter deze fout geven!

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #5 Gepost op: 2009/04/09, 20:22:12 »
Waarom moet je eigenlijk precies de  VLC 0.8.6i hebben eigenlijk ?
Is er iets mis met de versie  0.9.4 (intrepid) of  0.9.8a (jaunty) ?

Want die staan gewoon in de repositories.  Dus zou ik eerst hen proberen te gebruiken.

track

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #6 Gepost op: 2009/04/10, 00:45:51 »

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #7 Gepost op: 2009/04/10, 00:50:23 »
En ?? 
Wat moeten wij met een "nightly build 0.8.6" van augustus 2008    ???
wanneer de versies 0.9.x  al regulair in de repositories staan ?

track

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #8 Gepost op: 2009/04/10, 08:56:32 »
Ik heb een versie tot 0.8.6i nodig omdat dat dat de versie is die goed werkt met m'n satelietontvanger (Dreambox).
De huidige versie heb ik uiteraard al gebrobeerd!

FrodoW

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #9 Gepost op: 2009/04/10, 09:03:09 »
Ik heb een versie tot 0.8.6i nodig omdat dat dat de versie is die goed werkt met m'n satelietontvanger (Dreambox).
De huidige versie heb ik uiteraard al gebrobeerd!

FrodoW
bij mij werkt de versie  0.9.4 goed op een dreambox 7000
(met Gbox met ccc weet ik niet.)

GrJ.

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #10 Gepost op: 2009/04/10, 13:07:27 »
Ik heb een DM7020.
Inderdaad werkt 0.9.4 goed met PLI Jade 2. Helaas werkt het niet met M4RTiN's re-stream tool.
De tool was voor mij de reden om mijn NSL2 te vervangen door een server.

FrodoW

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #11 Gepost op: 2009/04/10, 17:36:20 »
Nou, dan is er nog een truc "diep uit de kast" - en op eigen risico.

1. Je installeert het "gewone" Pakket  VLC 0.9.4 .
2. Je haalt de binairen vanuit het pakket  VLC 0.8.6i  en vervangt daarmee de binairen vanuit de  VLC 0.9.4
   (in  /usr/lib/vlc ) -> dat is hier een hele aantal, maar misschien lukt het.
   Eerst de oude hernoemen naar *.bak en de nieuwe gewoon inkopiëren uiteraard.

Je moet duidelijk weten dat dit helemaal het pakketbeheer voorbij is (dus ben je zelf voor alles verantwoordelijk)
maar op die manier heb ik b.v. makkelijk in de Uby 7.10 de nieuwste Flash-player ingeënt.

En misschien is het ook een goed idee om eerst te kijken waar het knelpunt met de M4RTiN's re-stream tool ligt.
Die dus in de terminal oproepen en de foutmeldingen analyseren.
Misschien moet je niet alle binairen vervangen, of het is maar een probleem van de configuratie !

track

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #12 Gepost op: 2009/04/10, 17:37:43 »
mooi speelgoed,
gebruik de dreambox 7000 met Gemini v4.6, CS met Gbox, webserver (Apache mine)
en ook een NSL2

GrJ

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #13 Gepost op: 2009/04/10, 17:52:19 »
Ik heb een versie tot 0.8.6i nodig omdat dat dat de versie is die goed werkt met m'n satelietontvanger (Dreambox).
De huidige versie heb ik uiteraard al gebrobeerd!

FrodoW

http://download.videolan.org/pub/videolan/vlc/0.8.6i/
betreft tar bestand
In general, the following steps are used to install a tarball:

       1. For a GZipped tarball: tar –zxvf filename.tar.gz (or filename.tgz)
       2. For a BZipped tarball: tar jzvf filename.tar.bz (or filename.tbz)
       3. ./configure
       4. make
       5. (as root) make install

Gestopt als aktief Forumlid 17/10/2011

Offline track

  • Lid
  • Steunpunt: Nee
Re: VLC 0.8.6i installeren.
« Reactie #14 Gepost op: 2009/04/10, 18:06:15 »
En is dat ook definitief geschikt voor 64 bit ?

Want als je met "make install" iets installeert (met geweld dus, niet alleen het pakketbeheer voorbij !)  kun je
het systeem echt in de soep sturen.
Je moet precies weten wat je doet, want je moet het pakket eerst nog goed configureren. (en dat kan best mis gaan)
En weet je überhaupt wat je daarna zou moeten opruimen of verwijderen als het mis gaat ?

track