Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Dubieuze grafische kaart verschijnselen  (gelezen 7313 keer)

Offline daigu

  • Lid
  • Steunpunt: Nee
[OPGELOST] Dubieuze grafische kaart verschijnselen
« Gepost op: 2009/04/08, 00:25:12 »
Dankzij de uitstekende hulp op het installatie forum schrijf ik deze post nu vanaf een geslaagde 8.04-2 desktop amd64 installatie.

Ik ben de stappen van http://sites.google.com/site/computertip/directdoen aan het volgen, maar bij stap 4 "Controleer of alle hardware goed werkt en installeer eventueel stuurprogramma's (drivers)" loop ik vast.

Sowieso, hoe controleer je of alles goed werkt? Met "Hardware Testing"? De resolutie staat goed ingesteld, maar bij de video test (SMPTE 100% color bars) krijg ik niks te zien. Met glxgears krijg ik draaiende tandwielen en 6238 frames in 5.0 seconds = 1247.376 FPS. Onder System->Administration->Hardware Drivers krijg ik de melding: No proprietary drivers are in use on this system. En EnvyNG geeft een exception: "EnvyNG ERROR: Envy does not recognize your card as compatible with any version of the driver. This might happen because either your card is not supported by the driver or Envy's hardware detection failed. You can try the manual installation at your risk." Tenslotte krijg ik de melding "desktop effects could not be enabled" als ik de visuele effecten aan wil zetten (ze stonden default uit).

Mijn grafische kaart is een Asus EAH4350 SILENT/DI/512MD2.

daigu@Satori:~$ lspci | grep VGA
02:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 954f

Bij het opstarten krijg ik een lelijke groene streepjesbalk aan de bovenkant van het scherm te zien. Lijkt een beetje op een crash in CGA.

Maar alles lijkt wel gewoon te werken.

Het is me overigens niet gelukt om Flash 10 te installeren, maar ik neem aan dat dat een afzonderlijk probleem is. Er waren overigens nog wel meer onderdelen van het computertip/directdoen stappenplan die niet werkten.

Enig idee of dit uberhaupt een probleem is, en zo ja, hoe ik het op kan lossen?
« Laatst bewerkt op: 2009/04/13, 19:17:06 door daigu »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #1 Gepost op: 2009/04/08, 01:41:07 »
Bij Linux wordt de hardware minder per fabrikant dan per chipsets gezien. 
Dus zit in jouw blik volgens mij een  "Radeon HD 4350" . 
Kun je best zelf testen met de toverspreuk  lshw -html > ijzerwaren.html .
En voor die kaart staat er iets op het Engelse forum:  http://ubuntuforums.org/showthread.php?t=985774

Die groene strepjesbalk wijst inderdaad erop dat toch iets met de driver niet helemaal goed staat.
(de grafiek wordt niet helemaal goed aangestuurd)
Bij de Flash 10 denk ik dat je misschien nog de een of andere softwarebron (-> [systeem] - beheer) moet aanvinken.
Dan zal het lukken.

track

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #2 Gepost op: 2009/04/08, 20:13:11 »
En via de terminal:
gksudo displayconfig-gtkkan je ook eens op je kaart zoeken of op de driver. Voor ATI zijn er drie: 'ati' 'radeon' en dan nog één die wat meer naar onderen staat maar ben de naam vergeten. Even zoeken en lezen in de lijst.
Je kan elke keuze eens uittesten met de 'test' knop.
En dan kan je de instellingen opslaan via de floppy-icon rechtsboven.
Ter info: gksudo displayconfig-gtk werkt enkel in 8.04.... dus als je ooit 8.10 of 9.04 en/of een nieuwere versie installeerd werkt dit dus niet meer)
Succes!

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #3 Gepost op: 2009/04/08, 23:40:28 »
Zie de bijlage voor de uitvoer van lshw.

displayconfig-gtk geeft bij Graphics Card: "Graphics card (VESA driver (generic))" en "Driver: None"

Bij ASUS staan zes modellen in de lijst, maar die zeggen me nog niet veel. Misschien wel na het lezen van de post op het Engelse forum.

Oh, volgens lshw heb ik ATI en geen ASUS. Volgens de paklijst van de leverancier was het ASUS. Hmm, dat slaat zeker op het ATI vs NVidia gebeuren... afijn, ik ga de Engelse oplossing eens uitproberen.

Alvast heel erg bedankt.

Update: Via displayconfig-gtk was het resultaat vier keer niks.
« Laatst bewerkt op: 2009/04/09, 00:11:41 door daigu »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #4 Gepost op: 2009/04/09, 00:20:32 »
Tsja, wegens gebrek aan een passende driver pakt hij voor het eerst de VESA standaard-driver. (en het video-hokje is grijs)
Of hij kon de kaart niet identificeren.  (dus leveren de "ijzerwaren" op dit moment ook niets bruikbaars op)

Bij de benaming moet je een beetje oppassen.  Bij Win.. gaat het per merk van de kaart, bij Linux van de chips op de kaart.
Citaat van: mijzelf boven
Bij Linux wordt de hardware minder per fabrikant dan per chipsets gezien.
Dus had ik jouw kaart (per google) als  Radeon HD 4350 geïdentificeerd. (-> http://de.wikipedia.org/wiki/ATI-Radeon-HD-4000-Serie )

Het best ga je nu met dit trefwoord even in synaptic zoeken.

track

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #5 Gepost op: 2009/04/09, 18:26:55 »
Zie de bijlage voor de uitvoer van lshw.

displayconfig-gtk geeft bij Graphics Card: "Graphics card (VESA driver (generic))" en "Driver: None"

Bij ASUS staan zes modellen in de lijst, maar die zeggen me nog niet veel. Misschien wel na het lezen van de post op het Engelse forum.

Oh, volgens lshw heb ik ATI en geen ASUS. Volgens de paklijst van de leverancier was het ASUS. Hmm, dat slaat zeker op het ATI vs NVidia gebeuren... afijn, ik ga de Engelse oplossing eens uitproberen.

Alvast heel erg bedankt.
De kaarten van ASUS kunnen dus van ATI zijn , Ik heb een ASUS A9250 maar is dus een ATI kaart. Mijn driver is door Jaunty zelf geconfigureerd. Kan geen andere driver  installeren, werkt dan niet. Je hebt ook ASUS kaarten die NVidia zijn.

Update: Via displayconfig-gtk was het resultaat vier keer niks.
Dus de 'ati' driver of 'radeon' kiezen werkt niet?


Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #6 Gepost op: 2009/04/09, 20:54:27 »
Per ongeluk op OK geklikt i.p.v. test en nu is mijn systeem iets meer fubar dan voorheen. Zit nu in low-res. Sowieso erg dubieus dat ik niet terug kan naar de oude situatie. De optie "No driver" staat niet in de lijst, en geeft geen lingo. Ik snap dat displayconfig-gtk scherm ook niet. Je kunt zoeken op driver of op model, maar als ik zoek op manufacturer "ATI" en model "Radeon" dan krijg ik de ati - ATI Mach8, Mach32, Mach64, ... driver. Idem voor Radeon (fglrx) en Radeon 8500. Radeon (fbdev) geeft me de Linux FrameBuffer, en bij Radeon (vesa) krijg ik de vesa - Generic VESA-compliant driver.

Synaptic had overigens niks voor me m.b.t. de Radeon 4350. Heb gezocht op Radeon en gekeken of er ergens iets van 4350 of 4000 serie stond. Zag niks staan maar heb wellicht iets over het hoofd gezien.

Blijkbaar had ik beter een andere grafische kaart moeten kopen.
Ik zal de Engelse oplossing eens proberen. Ik kan neem ik aan altijd Ubuntu opnieuw installeren als het verkeerd gaat. Weer eens wat anders dan eieren zoeken.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #7 Gepost op: 2009/04/09, 21:30:49 »
Een "zonder driver"- versie bestaat uiteraard niet, want je moet de kaart op enige manier aanspreken toch.
Voor die "minimaal"- functie wordt dus feitelijk de "vesa" driver gebruikt, want de VESA-standaard  kunnen uiteindelijk alle kaarten aan.

En volgens http://manpages.ubuntu.com/manpages/jaunty/man4/radeon.4.html  zou je eigenlijk met de driver "radeon" aan de slag kunnen.
(google levert wél ook een heleboel berichten met problemen op)

track

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #8 Gepost op: 2009/04/09, 23:19:49 »
Ik heb [1] http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide en [2] https://help.ubuntu.com/community/RadeonHD geprobeerd, en daarna weer braaf Ubuntu opnieuw geinstalleerd aangezien de oplossingen niet werkten.

[3] http://www.x.org/wiki/radeonhd heb ik nog niet geprobeerd, maar ziet er erg technisch uit...

De "zonder driver" mag dan wel niet bestaan, maar zonder driver heb ik in ieder geval wel mijn normale resolutie. Met dat VESA spul zit ik vast in low res 800x600.

Op de manpages link heb ik geen Radeon 4350 gevonden.

Bij Windows ging het ook niet altijd goed, maar daar was de installatie (en het verwijderen) van een driver voor een grafische kaart wel vele malen eenvoudiger. Ubuntu valt me wat het tweak-gehalte betreft behoorlijk tegen; tenminste ik heb altijd begrepen dat het juist het hele idee achter Ubuntu was om alles gebruiksvriendelijker te maken.

Dus nu kan ik of allerlei tweaks proberen, met "zonder driver" verder gaan, een andere grafische kaart kopen, of Vista installeren. Die laatste twee opties zie ik niet zo zitten, en voor de eerste optie ben ik nu te moe.

EnvyNG gaf trouwens foutmeldingen over i386.

Misschien eens op de website van ASUS of ATI kijken wat ze daar aan het doen zijn.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #9 Gepost op: 2009/04/09, 23:52:08 »
Jouw links [2] en [3] zijn volgens mij een dwaalweg, want ze zijn voor andere chips dan jij hebt. (kan volgens mij niet lukken)
Je hebt nu een beetje pech dat je precies met een iets moeilijke viedo-kaart zit.  Dat is jammer, en iets moeilijker dan gewoon.
(en gemiddeld bij Uby)

Maar even terug bij mijn link:
1. Volgens de Wiki zit in jouw kaart een "RV710" chip.
2. Volgens de manpage werkt de driver "radeon" ook met de "RV710" chip,
    en zelfs de "Radeon HD 4350" wordt er vermeld. (in de twee na laatste regel in de lijst)

Dus stel ik voor dat je in het pakketbeheer synaptic met het trefwoord "radeon" zoekt en daar precies die driver installeert.
edit: ik zie net dat de driver standaard al geïnstalleerd is. Je moet dus met  gksu gedit  /etc/X11/xorg.conf  (in de terminal)
de configuratie bewerken en alleen de volgende regel wijzigen:  |         Driver          "vesa"    veranderen naar:
Section "Device"
        Identifier      "(naam van de kaart)" # <- deze regel moet je niet veranderen !
        Driver          "radeon"
        BusID           "PCI:1:0:0"     # <- kan bij jou ook anders zijn, niet veranderen !
EndSection
en opslaan uiteraard.  De wijziging wordt pas na 1x uitloggen en inloggen effectief.

Er is een (Duitse) handleiding (Ubuntu Wiki) die dit precies beschrijft:  http://wiki.ubuntuusers.de/Grafikkarten/ATI/radeon
(als je problemen met het Duits hebt zullen wij je ook daarbij verder helpen uiteraard)
Je moet dus in het bestand  /etc/xorg.conf  uiteindelijk precies die driver hebben staan.
En zouden er nog problemen zijn, je kunt met "opties" nog een heleboel instellen. ("verdere mogelijkheden")
Dus even geduld, en het is wél te doen.

Vriendelijke groet,

track
« Laatst bewerkt op: 2009/04/10, 00:26:13 door track »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #10 Gepost op: 2009/04/10, 00:20:44 »
Even een aanvulling hierop. Je moet wel met root-rechten werken, dus ofwel via Alt+F2 en dan intikken: gksudo nautilus
Ofwel via de terminal:
sudo gedit /etc/X11/xorg.conf(X11 moet wel met hoofdletter geschreven worden)
Dan veranderen en opslaan.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #11 Gepost op: 2009/04/10, 00:27:02 »
Maak altijd eerst een kopie voordat je gaat lopen veranderen:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf-backup

wil je de back-up terug zetten ??
sudo cp /etc/X11/xorg.conf-backup /etc/X11/xorg.conf


GrJ.

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #12 Gepost op: 2009/04/10, 13:52:08 »
Nieuwe ronde, nieuwe kansen. Hieronder mijn xorg.conf. Na toevoegen van Driver "radeon" (en opnieuw opstarten) kom ik weer in low-res, maar eerst krijg ik een aantal keer een melding over "anac(h)ronistic cron anacron" te zien. Dat is me overigens al eerder voorgekomen bij pogingen om een driver te installeren.

Wat de Manpage betreft zie ik inderdaad mijn 4350 staan... maar alleen op de Jaunty pagina. Ik heb zelf Hardy (8.04-2 desktop amd64). En in de lijst voor Hardy staat geen 4350 (of RV710). Maar goed, als er een driver is voor 9.04, kan ik die dan niet gebruiken in 8.04?

Afijn, in xorg.conf staat Identifier op "Configured Video Device". Ik had hier gehoopt op Radeon 4350 of zoiets.

Ik heb het gevoel dat de 64bit versie op een aantal punten afwijkt, aangezien ik bijvoorbeeld ook al geen Flash 10 kan vinden, en bij VLM geen audio output. En NumLock gaat al automatisch aan. Ook heb ik geen "Restricted Drivers Manager" maar in plaats daarvan "Hardware Drivers". Deze zaken staan beschreven op http://sites.google.com/site/computertip/directdoen

Vandaag ook weer een nieuw probleem: toetsenbord en muis reageren niet. Opnieuw opstarten en ze doen het weer. En toen weer niet direkt na een restart, en toen weer wel. Tja, goede vrijdag...




# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "altgr-intl"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #13 Gepost op: 2009/04/10, 14:15:06 »
EnvyNG herkent mijn kaart niet, en de handmatige installatie van een driver brengt mijn systeem weer terug in de VESA compliant low-res fubar staat. Gelukkig werkt de "Uninstall the ATI driver" optie daarna wel goed.

Veel keuze heb ik bij Envy niet. Alleen de 8-6 versie wordt aangeboden.

In Synaptic heb ik geen xserver-xorg-driver-ati kunnen vinden.

Bij Software Sources heb ik onder Ubuntu Software alles aangevinkt behalve "Source code".
Bij Third Party software staat alleen een vinkje bij "http://archive.canonical.com/ubuntu hardy partner"
Mis ik hier nog een bron?



Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #14 Gepost op: 2009/04/10, 17:21:47 »
Bij de nieuwere Uby's heb je dit soort automatische toestanden met "configured .." iets.
Dat is normaal handig (omdat het gewoon werkt) maar je moet een beetje wennen om daarmee rekening te houden
(en ik zit nog met de "oude stijl").

Goed, dus probeer om in de  Section "Monitor"  onder de  "Configured Monitor" de driver in te voegen:
Section "Monitor"
   Identifier   "Configured Monitor"
   Driver       "radeon"
EndSection
Dit moet eigenlijk lukken.

Wat de 64bit betreft waren er in het verleden vaker knelpunten met de compatibiliteit, maar de "64biters" op het forum
zeggen nu steeds dat dat het probleem niet meer was ...

track

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #15 Gepost op: 2009/04/10, 18:59:25 »
Driver "radeon" in de Monitor sectie geeft me allerlei wazige foutmeldingen bij het opstarten. Ik krijg zelfs een prompt op een gegeven moment, en daarna kom ik weer terug in de alom geliefde low-res mode.

Een aantal installaties geleden heb ik een driver van de ATI website afgehaald.
http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.38&lang=English

Dat leek allemaal te werken, totdat ik de Visual Effects op Normal wilde instellen. Ik kreeg een tekst over het ontbreken van een 3D accelerator of iets dergelijks en of ik die wilde hebben. Ik dacht waarom niet. Paar keer replace gekozen... en toen kwam ik weer in low-res. Het verwijderen van de ATI driver lukte vervolgens niet, en de een of andere sadist heeft de beheerschermen van ATI zo ingesteld dat ze niet kleiner gemaakt kunnen worden. Met als resultaat dat je de knoppen "Ok", "Cancel", e.d. niet kunt zien. Sowieso kreeg ik weer foutmelding over vcmd of iets dergelijks. Heb het trauma alweer verdrongen. Ik ga nog een laatste keer de ATI driver proberen.

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #16 Gepost op: 2009/04/10, 19:26:35 »
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_cat92-inst.pdf is niet helemaal up-to-date en/of correct, denk ik.
Voor "Generate Distribution Specific Driver Package" moet ik --listpkg en daarna -buildpkg doen met Ubuntu/hardy.
De Installer zet dan een paar bestanden op disk:

fglrx-modaliases_8.593-0ubuntu1_amd64.deb
fglrx-amdcccle_8.593-0ubuntu1_amd64.deb
libamdxvba1_8.593-0ubuntu1_amd64.deb
fglrx-installer_8.593-0ubuntu1_amd64.changes
xorg-driver-fglrx_8.593-0ubuntu1_amd64.deb
fglrx-kernel-source_8.593-0ubuntu1_amd64.deb
xorg-driver-fglrx-dev_8.593-0ubuntu1_amd64.deb

Maar /usr/bin/aticonfig was blijkbaar teveel moeite want dat is nergens te vinden.

M.a.w. "Generate Distribution Specific Driver Package" werkt niet... tenzij ik nog iets met die .deb bestanden moet doen, maar dat staat niet in de handleiding vermeld.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #17 Gepost op: 2009/04/10, 19:36:49 »
Jij probeert nu het driverprobleem op de win..-achtige manier op te lossen (met de driver-CD van de fabrikant enz.).
Dat zal bij Linux niet lukken.  Het werkt gewoon anders.

Als je gewoon die 1 regel in de /etc/X11/xorg.conf  bijvoegd en opslaat zoals,ik boven heb beschreven  (verder niets)
wat gebeurt er als je uitlogt en weer inlogt ?

Bij Linux moet je echt van een blokkenmodel uitgaan waar iedere blok goed ingepast wordt en dan heb je het.
Niet die automatische toestanden met allerlei CDs zoals bij Win.. . Even echt omschakelen dus.

track

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #18 Gepost op: 2009/04/10, 20:39:56 »
Met de Driver "radeon" regel krijg ik de melding dat "Ubuntu is running in low-graphics mode. Your screen and graphics card could not be detected correctly. To use higher resolutions, visual effects or multiple screens, you have to configure the display yourself."

Mijn monitor is een Neovo (M19), en de Neovo staat niet in de lijst van monitors.
Resolutie kan niet hoger dan 800x600 ingesteld worden.

De nieuwe xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "vesa"
   Busid      "PCI:2:0:0"
   Driver      "vesa"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Plug 'n' Play"
   Modelname   "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Configured Video Device"
   Monitor      "Configured Monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   640   480
      Modes      "640x480@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
EndSection
Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection
Section "ServerFlags"
EndSection

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #19 Gepost op: 2009/04/10, 21:49:44 »
Hallo

Ondanks dat jouw monitor er niet tussen staat, kan je prima
met displayconfig-gtk even bij; algemeen een andere lcd pakken, met wel de
juiste resolutie. Dit staat nog los van je driver kwestie trouwens. Ook de vesa driver
moet daar op lopen, probeer dat eerst eens. Als die resolutie dan werkt, even een backup
maken van je /etc/X11/xorg.conf en dan weer gaan experimenteren met alleen de driver.

Groeten Gerrit


-- = >  simplify if you can   -- = >

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #20 Gepost op: 2009/04/10, 22:36:14 »
Wat de resolutie op dit moment beperkt zijn de getallen in jouw xorg.conf .
Hoe is die eigenlijk ontstaan ?  Heeft dat de "herstelmodus" zelf aangemaakt ?

In ieder geval kun je nu handmatig enkele dingen veranderen en recht zetten.
1. In de  Section "Monitor"  moet je in ieder geval die "modline" verwijderen:
    "modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync"
    (anderes blijft hij denken dat jouw monitor geen hogere resolutie aan kan)
   Je kunt misschien zetten:      Option      "DPMS"
    (dan zal hij de modus per DPMS ophalen, eigenlijk de beste oplossing)

2. In de  Section "Screen"  heb je ook zoiets zitten:
     SubSection "Display"
        Depth   24
        Virtual   640   480
        Modes      "640x480@60"
     EndSubSection

     Dat zou je best vervangen door: SubSection "Display"
Depth 1
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
Dit gehele blok laat alle zinvolle modes toe (trouwens gejat uit mijn eigen xorg.conf , ik heb ook een 19" LCD met 1280x1024).

Nu zou ik inderdaad even pauseren, opslaan en testen (uit- + inloggen dus), precies zoals mrGee al zei.

En als dat lukt heb je al een betere uitgangspunt. Dus opslaan (-> xorg.conf.19" of zoiets) en nu
de      Driver      "vesa"  vervangen door     Driver      "radeon" .

Hopelijk lukt dat, want anders moeten wij een andere truc verzinnen.

track

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #21 Gepost op: 2009/04/11, 11:04:45 »
Ik heb het vernaggelde xorg.conf bestand aangepast. Dit bestand is overigens tot stand gekomen door eerst Driver="radeon" in het Monitor gedeelte in te vullen, log out/log in, low-graphics mode foutmelding, configure (en dan kom ik in dat gtkconfig scherm).

Met de wijzigingen van Track (zonder Driver="radeon") startte mijn systeem in high-res op. Daarna Driver="radeon" geprobeerd, en kwam weer in low-graphics mode. Oude xorg.conf terug gezet met wijzigingen van Track. Bleef in low-res, maar nu kon ik wel met gtkconfig een hoge resolutie scherm uitkiezen. Ik zal zo weer eens Driver="radeon" invullen.

Het werkt nu, maar het voelt wel wat stroperig aan. En bij Hardware Testing mislukt de video test (resolutie staat nu wel goed, ook de frequentie). Visual Effects kan ik niet op Normal zetten (Desktop effects could not be enabled).


Mijn nieuwe xorg.conf



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "vesa"
   Busid      "PCI:2:0:0"
   Driver      "vesa"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Vendorname   "Plug 'n' Play"
   Modelname   "Plug 'n' Play"
   Option      "DPMS"
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Configured Video Device"
   Monitor      "Configured Monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   1
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   4
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   8
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   15
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   16
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   24
      Modes      "1280x1024"   "1280x800"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
EndSection
Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection
Section "ServerFlags"
EndSection

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #22 Gepost op: 2009/04/11, 11:08:30 »
Section "Device"
   Identifier   "Configured Video Device"
   Boardname   "vesa"
   Busid      "PCI:2:0:0"
   Driver      "radeon"
   Screen   0
EndSection

Werkt ook. Maar met dezelfde resultaten; Hardware Test mislukt, en geen Visual Effects.

Offline track

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #23 Gepost op: 2009/04/11, 12:05:59 »
Dat wijs allemaal erop dat de driver het niet "zo maar" met jouw chipset klaarspeelt.

Op het Duitse forum heb een interessant bericht gevonden:
http://forum.ubuntuusers.de/topic/fglrx:-h.264-hardware-acceleration-mit-radeon/#post-1842737

Zij gebruiken daar standaard de "fglrx" driver ( staat in de "multiverse" repo -> http://packages.ubuntu.com/nl/hardy/xorg-driver-fglrx )
en blijkbaar met succes. Dan wél met een heleboel opties, maar die kun je van die link plukken.

Zij zijn er blijkbaar zelfs in geslaagd om H.264 (HiRes video dus) te draaien door de nieuwste versie van die driiver zelf te compileren.
Maar dat is iets "voor gevorderden", dus echt een twede (of derde) stap.

track

Offline daigu

  • Lid
  • Steunpunt: Nee
Re: Dubieuze grafische kaart verschijnselen
« Reactie #24 Gepost op: 2009/04/11, 12:17:54 »
Mijn Duits is niet zo geweldig, maar als ik het goed begrijp heeft Xstyler op de ATI website naar drivers gezocht (en niet gevonden?), en er wordt software rendering gebruikt waardoor de graphics nogal brak zijn (dat was ook mijn probleem met een BeOS installatie tig jaar terug).

Moet ik nu xorg-driver-fglrx en fglrx-kernel-source installeren en daarna de volgende commando's uitvoeren:

sudo dkms add -m fglrx -v 8.573
sudo dkms build -m fglrx -v 8.573
sudo dkms install -m fglrx -v 8.573

En wel of niet de Catalyst driver van ATI installeren? Dat is me op zich al eens gelukt (niet de Hardy specifieke build, maar wel de algemene driver). Met de Hardy build kreeg ik enkel een aantal .deb bestanden op mijn systeem...