Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] NFS usb disk  (gelezen 1013 keer)

Offline Hij

  • Lid
  • Steunpunt: Nee
[OPGELOST] NFS usb disk
« Gepost op: 2009/04/02, 14:27:31 »
Ik heb een tijdje tevreden NFS gebruikt tussen twee ubuntu pc's
Hier een topic waar ik met vragen zat: topic

Nu had ik ook mijn 500GB disk gemount. Ik had deze regel bij fstab gezet;
192.168.1.10:/media/disk /mnt/500GBDisk/ nfs timeo=14,intr 0 0
Nu ik gebruik maak van Ubuntu 64bit 9.04 beta werkt dit niet meer. Terwijl de mount van het home mapje wel werkt dat heb ik met deze regel toegevoegd
192.168.1.10:/home/tamara /mnt/VasteComputer/ nfs timeo=14,intr 0 0Wat doe ik fout?
Of ligt het dat dit een beta versie is?

BTW adobe heeft een pre-release van flash 64 bit voor linux. Tot nu toe werkt die perfect! link
« Laatst bewerkt op: 2009/04/02, 15:35:04 door Hij »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #1 Gepost op: 2009/04/02, 14:36:52 »
Bestaat deze map wel? /mnt/500GBDisk
Krijg je een foutmelding te zien als je probeert te mounten met sudo mount -av ?

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #2 Gepost op: 2009/04/02, 14:47:09 »
Bestaat deze map wel? /mnt/500GBDisk
Krijg je een foutmelding te zien als je probeert te mounten met sudo mount -av ?
Hoi Johan van Dijk, volgens mij heb je mij al vaker geholpen! Thanks hiervoor!
Ja het mapje 500GBDisk bestaat in /mnt/ (ook zo met hoofdletters geschreven)

sudo mount -av geeft het volgende;
tamara@laptop:~$ sudo mount -av
mount: proc already mounted on /proc
mount: UUID=de303d3d-746a-4bf7-a3f7-a68ad3644d8c already mounted on /home
mount: 192.168.1.10:/home/tamara already mounted on /mnt/VasteComputer/
mount.nfs: timeout set for Thu Apr  2 14:46:01 2009
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
Dit blijft zo, de terminal springt niet meer terug op; tamara@laptop:~$

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #3 Gepost op: 2009/04/02, 14:50:06 »
Even op control-c drukken om dat te stoppen ;)

Daarna:
sudo mount -v /mnt/500GBDisk

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #4 Gepost op: 2009/04/02, 14:54:45 »
Even op control-c drukken om dat te stoppen ;)
Weer wat geleert  =D

Daarna:
sudo mount -v /mnt/500GBDisk

sudo mount -v /mnt/500GBDisk geeft;
tamara@laptop:~$ sudo mount -v /mnt/500GBDisk
mount: can't find /mnt/500GBDisk in /etc/fstab or /etc/mtab

Meteen even mijn fstab;
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=985d0151-4496-43a7-8bc5-966b3e9a8484 /               ext4    relatime,errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=de303d3d-746a-4bf7-a3f7-a68ad3644d8c /home           ext4    relatime        0       2
# swap was on /dev/sda6 during installation
UUID=e0b675e1-e6c1-45a8-b77b-4dc3e471fd93 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
192.168.1.10:/home/tamara /mnt/VasteComputer/ nfs timeo=14,intr 0 0

192.168.1.10:/media/disk /mnt/500GBDisk/ nfs timeo=14,intr 0 0

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #5 Gepost op: 2009/04/02, 14:58:30 »
Vreemd hoor, hij zegt dat die map niet in fstab staat, maar ik zie hem er toch echt staan...
Kan je het fstab bestand aanpassen?
/mnt/500GBDisk/ veranderen in /mnt/500GBDisk
de / op het eind weghalen.

Daarna nog een keer proberen te mounten:
sudo mount -v /mnt/500GBDisk

Kan je ook het resultaat van het commando mount hier neerzetten?

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #6 Gepost op: 2009/04/02, 15:06:34 »
Vreemd hoor, hij zegt dat die map niet in fstab staat, maar ik zie hem er toch echt staan...
Kan je het fstab bestand aanpassen?
/mnt/500GBDisk/ veranderen in /mnt/500GBDisk
de / op het eind weghalen.
het "/" weg gehaald. Mijn fstab ziet nu zo uit:
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=985d0151-4496-43a7-8bc5-966b3e9a8484 /               ext4    relatime,errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=de303d3d-746a-4bf7-a3f7-a68ad3644d8c /home           ext4    relatime        0       2
# swap was on /dev/sda6 during installation
UUID=e0b675e1-e6c1-45a8-b77b-4dc3e471fd93 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
192.168.1.10:/home/tamara /mnt/VasteComputer/ nfs timeo=14,intr 0 0

192.168.1.10:/media/disk /mnt/500GBDisk nfs timeo=14,intr 0 0

Daarna nog een keer proberen te mounten:
sudo mount -v /mnt/500GBDisk

Kan je ook het resultaat van het commando mount hier neerzetten?

sudo mount -v /mnt/500GBDisk geeft;
tamara@laptop:~$ sudo mount -v /mnt/500GBDisk
mount.nfs: timeout set for Thu Apr  2 15:07:27 2009
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: text-based options: 'timeo=14,intr,addr=192.168.1.10'
mount.nfs: mount(2): Stale NFS file handle
^C
tamara@laptop:~$

mount geeft;
tamara@laptop:~$ mount
/dev/sda5 on / type ext4 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=755)
/dev/sda7 on /home type ext4 (rw,relatime)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/tamara/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=tamara)
192.168.1.10:/home/tamara on /mnt/VasteComputer type nfs (rw,timeo=14,intr,addr=192.168.1.10)
tamara@laptop:~$

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #7 Gepost op: 2009/04/02, 15:30:45 »
Heb je het probleem nog steeds als je reboot?

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: NFS usb disk
« Reactie #8 Gepost op: 2009/04/02, 15:34:43 »
Heb je het probleem nog steeds als je reboot?
Het werkt!!!!  =D
Na een reboot doet die het!
Alweer heel erg bedankt voor je hulp!