Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Geen geluid in Konservation  (gelezen 3542 keer)

Offline satshow

  • Lid
  • Steunpunt: Nee
[Opgelost] Geen geluid in Konservation
« Gepost op: 2009/03/29, 20:01:44 »
Het geluid werkt niet in konversation, heb ingesteld dat ik een geluidje hoor als iemand me roept. Ik hoor alleen niks als iemand me roept.
Ik kan wel gewoon een cd beluisteren of zo.
Iemand een idee hoe op te lossen?
Ik had dit onder 8,10 en onder 9.04 nog steeds.
Indien dit topic verkeerd staat graag verplaatsen.
« Laatst bewerkt op: 2009/04/03, 21:16:53 door Vistaus »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #1 Gepost op: 2009/03/29, 20:05:07 »
Konversation voor KDE 3 neem ik aan? Dan moet je arts installeren, die zorgt voor de KDE 3-geluiden.

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #2 Gepost op: 2009/03/29, 20:09:17 »
Ja klopt, even zoeken waar ik dat kan vinden.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #3 Gepost op: 2009/03/29, 20:10:48 »
Gewoon in Synaptic/Adept ;)

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #4 Gepost op: 2009/03/29, 20:19:25 »
Ik vind niks als ik zoek onder arts
Wat is de precieze zoeknaam?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #5 Gepost op: 2009/03/29, 20:22:18 »
arts

Tja, op 9.04 zitten geen KDE 3-pakketten meer, maar dan zou Konversation ook weg moeten zijn. Zeer vreemd... In ieder geval draai ik hier de KDE 4-versie van Konversation, draait heerlijk, maar ik zou het niet aanraden aan jou (de manier van installeren).

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #6 Gepost op: 2009/03/29, 20:24:20 »
Ik vind dit de engiste chatclient onder ubuntu waar ik tevreden over ben. Dan zal ik eens gaan zoeken naar een andere

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #7 Gepost op: 2009/03/29, 20:30:39 »
Konversation vind ik ook de beste :)

Als je toch de KDE 4 versie wil proberen:

In een Terminal:

svn checkout http://websvn.kde.org/branches/work/konvi-kde4/
cd konvi-kde4
mkdir build
cd build
cmake ..
make
sudo make install

Je moet wel build-essential, cmake, phonon en gettext geïnstalleerd hebben.

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #8 Gepost op: 2009/03/29, 21:35:18 »
De onderste programmas heb ik allemaal geinstalleerd

Moet ik de rest gewoon plakken in een terminal?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #9 Gepost op: 2009/03/29, 21:35:47 »
Ja :) Maar wel 1 voor 1 hè, niet direct dat hele stukje ;)

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #10 Gepost op: 2009/03/29, 21:48:26 »
Bij de eerste regel krijg ik dit
fred@ubuntu:~$ svn checkout http://websvn.kde.org/branches/work/konvi-kde4/
svn: Repository moved permanently to '/branches/work/konvi-kde4/'; please relocate

Hoe moet ik hiermee verder?
 

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #11 Gepost op: 2009/03/29, 21:57:00 »
Oeps, verkeerd commando, mijn excuses.

Dit is de juiste:

svn checkout svn://anonsvn.kde.org/home/kde/branches/work/konvi-kde4

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #12 Gepost op: 2009/03/29, 22:21:56 »
Bij de regel cmake ..  krijg ik volgende foutmelding

fred@ubuntu:~/konvi-kde4/build$ cmake ..
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:84 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /home/fred/.kde/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
  CMakeLists.txt:10 (find_package)


-- Configuring incomplete, errors occurred!

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #13 Gepost op: 2009/03/30, 17:21:40 »
Dat is vreemd, daar had ik geen last van bij het installeren. Probeer eens sudo cmake ..

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #14 Gepost op: 2009/03/30, 17:59:31 »
Ik heb gelijk dit commando uitgevoerd, ben niet opnieuw begonnen
Nu krijg ik onderstaande melding

CMake Error: The source directory "/home" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #15 Gepost op: 2009/03/30, 18:04:05 »
Je moet natuurlijk nog wel even cd'en naar de broncodemap. van Koversation. Overigens, je mist kdelibs5-dev volgens mij.

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #16 Gepost op: 2009/03/30, 18:15:01 »
Die miste ik inderdaad deze heb ik geinstalleerd kdelibs5-dev

Daarna krijg ik onderstaand probleem

fred@ubuntu:~/konvi-kde4/build$ cmake ..
-- Found Qt-Version 4.5.0 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1053 (file):
  file Internal CMake error when trying to open file:
  /home/fred/konvi-kde4/build/CMakeTmp/check_qt_visibility.cpp for writing.
Call Stack (most recent call first):
  /usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
  CMakeLists.txt:10 (find_package)


-- Phonon Version: 4.3.0
-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake-2.6/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
  Could NOT find KdepimLibs (missing: KdepimLibs_CONFIG)
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKdepimLibs.cmake:73 (find_package_handle_standard_args)
  CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred!
fred@ubuntu:~/konvi-kde4/build$ sudo cmake ..
-- Found Qt-Version 4.5.0 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Phonon Version: 4.3.0
-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake-2.6/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
  Could NOT find KdepimLibs (missing: KdepimLibs_CONFIG)
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKdepimLibs.cmake:73 (find_package_handle_standard_args)
  CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred!

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #17 Gepost op: 2009/03/31, 17:14:53 »
Nogmaals: probeer het eens met sudo cmake ..

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #18 Gepost op: 2009/03/31, 22:13:36 »
Dan krijg ik dit

fred@ubuntu:~/konvi-kde4/build$ sudo cmake ..
[sudo] password for fred:
-- Found Qt-Version 4.5.0 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Phonon Version: 4.3.0
-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake-2.6/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
  Could NOT find KdepimLibs (missing: KdepimLibs_CONFIG)
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKdepimLibs.cmake:73 (find_package_handle_standard_args)
  CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred!

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #19 Gepost op: 2009/04/01, 15:00:56 »
Installeer kdepim-dev, kdepimlibs5 en kdepimlibs5-dev en daarna weer sudo cmake ..

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #20 Gepost op: 2009/04/02, 10:56:16 »
Dat is gelukt, daarna druk ik op make

fred@ubuntu:~/konvi-kde4/build$ sudo cmake ..
[sudo] password for fred:
-- Found Qt-Version 4.5.0 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Phonon Version: 4.3.0
-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found KdepimLibs: /usr/lib/KdepimLibs-4.2.2/cmake/KdepimLibsConfig.cmake
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ libXss
+ libx11
+ X11 Xutil.h header
Congratulations! All external packages have been found.
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /home/fred/konvi-kde4/build
fred@ubuntu:~/konvi-kde4/build$ make
Scanning dependencies of target konversation_automoc
CMake Error: Cannot open file for write: /home/fred/konvi-kde4/build/src/CMakeFiles/konversation_automoc.dir/depend.make.tmp
CMake Error: : System Error: Permission denied
make[2]: *** [src/CMakeFiles/konversation_automoc.dir/depend] Fout 2
make[1]: *** [src/CMakeFiles/konversation_automoc.dir/all] Fout 2
make: *** [all] Fout 2

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #21 Gepost op: 2009/04/02, 11:25:45 »
Probeer eens sudo make

Offline satshow

  • Lid
  • Steunpunt: Nee
Re: Geen geluid in konservation
« Reactie #22 Gepost op: 2009/04/03, 10:43:34 »
Het is nu wel gelukt, het ziet er een heel stuk anders uit dan voorheen.
Bedankt voor de hulp.

Overigens werkt het geluid wel als ik in het beheer klik op het geluidje wat ik ingesteld heb.  Alleen niet tijdens het chatten. Is er misschien nog ergens een instelling die ik over het hoofd zie.

Het is een kwestie van onder instellingen en dan bij meldingen instellingen het geluid in te stellen welke je wilt hebben.
« Laatst bewerkt op: 2009/04/03, 11:13:07 door satshow »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Opgelost:Geen geluid in konservation
« Reactie #23 Gepost op: 2009/04/03, 17:22:23 »
Mooi dat het gelukt is :) Veel plezier nog met je Konversation voor KDE 4 en welkom bij de klup :)

Offline Typhoner

  • Lid
    • http://typhoner.blogspot.com/
  • Steunpunt: Nee
Re: [Opgelost] Geen geluid in Konservation
« Reactie #24 Gepost op: 2009/04/07, 16:23:04 »
je moet zeker nog kdelibs5-dev hebben.

Maar ik zou het je niet aanraden. Konversation4 zit in een porting-branch, dus eigenlijk alleen mensen die mee helpen programmeren zouden het moeten gebruiken, bugreports worden voorlopig geweigerd. Hij bestaat officieel niet eens! Er zijn ook geen vertalingen beschikbaar.... En apt vindt het niet leuk.  ^-^