Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Audio afspelen  (gelezen 3545 keer)

harmjansen2005

  • Gast
Audio afspelen
« Gepost op: 2005/12/19, 23:15:37 »
Hallo lezers,

"Mijn" Ubuntu begint steeds beter te draaien. Ik moet zeggen dat, als je er een beetje "in" komt, je de mogelijkheden van Ubuntu steeds meer gaat waarderen. Met name Synaptic is een welkome steun in de rug.
Niettemin kom je toch steeds weer voor nieuwe verrassingen te staan. K3b en Totem werken, Audacity blijft klagen dat er een fout is bij het initialiseren van de audio i/o laag, zodat je geen audio kunt opnemen of afspelen. Wat je dan wel kunt...?
Als ik in K3b of Totem een cd afspeel, stokt de muziek exact elke twee seconden even, een soort hik. In Windows doet mijn Soundblaster MP3 plus het probleemloos. Heeft iemand een idee hoe ik die hik kan verwijderen. Dan kan ik gaan genieten van mijn net geinstalleerde Harman Kardon soundsticks.

O ja, nog iets: ik heb op mijn laptop (Aldi) een toetsenbord met een Nederlandse indeling. Maar ik kan die uit de lijst kiezen zo vaak ik wil, Ubuntu blijft hardnekkig de Amerikaanse indeling gebruiken. Op Internet zag ik dat er meer mensen met dit probleem zitten, maar een goede oplossing heb ik niet kunnen vinden.

Harm Jansen

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Audio afspelen
« Reactie #1 Gepost op: 2005/12/20, 11:46:50 »
Toetsenbord instellingen vind je in System -> Preferences -> Keyboard. Haal er eens alles uit behalve uw instelling?

Voor het afspelen zal het iets zijn met uw geluidskaart. Misschien wel een driver probleem, zoek eens uw type en merk op en zie of je linux drivers beschikbaar zijn, en probeer ook eens ALSA.

Sys -> Pref -> Multimedia...

harmjansen2005

  • Gast
Audio afspelen
« Reactie #2 Gepost op: 2005/12/20, 22:53:57 »
Hallo Zappa,

Met het schaamrood op de kaken moet ik bekennen dat ik inmiddels helemaal geen geluid meer uit mijn Soundblaster MP3+ krijg... Ik heb zitten knoeien met Systeem - Voorkeuren - Multimediasystemen selecteren. Ook het opnieuw installeren van Gstreamer helpt niet. Kun je me helpen het geluid terug te krijgen?

Ik krijg nog steeds niet de Nederlandse toetsenbordindeling, hoewel ik die als enige nog in de lijst (Systeem - Voorkeuren - Toetsenbord) heb.

Linux valt me nog niet echt mee; het is wel heel anders dan het vertrouwde Windows.

Groet, Harm

BobvanOijen

  • Gast
Audio afspelen
« Reactie #3 Gepost op: 2005/12/21, 14:27:29 »
Je kan op je gnome-balk door rechter klikken een icoon toevoegen, voor een toestenbordwissllaar.
rechterklik op balk boven in -> + Toevoegen aan paneel -> (kopje) gereedschappen -> Toetsenbordwisselaar -> Toevoegen
Ik gebruik deze om te wisselen tussen US-International en Dvorak indeling.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Audio afspelen
« Reactie #4 Gepost op: 2005/12/21, 17:37:21 »
Geluid is nog altijd een baby-tje in linux wat heel veel vooruit geholpen moet worden. In die multimedia selector moet de default sink op ESD staan en de default source op OSS

Lai

  • Gast
Audio afspelen
« Reactie #5 Gepost op: 2005/12/24, 10:34:15 »
Dat geluid probleem heb ik ook, ik dacht dat het aan mijn antieke cd-rom speler lag. Ik merk wel dat als ubuntu opstart het deuntje prima eruit komt, heb je al geprobeerd muziek van je hardeschijf af te spelen? Misschien heeft ubuntu problemen met het verwerken van cd audio vanaf verwijderbare schijf.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Audio afspelen
« Reactie #6 Gepost op: 2005/12/24, 12:05:37 »
Wat het ook kan zijn, indien het begingeluid er wel doorkomt, is dat de 'deamon' voor systeemgeluiden een exclusieve lock zet op het gebruik van uw geluidskaart. Je kan die grafisch uitztten in Sys -> sound, het eerste vinkje dat je tegenkomt uitvinken :)

Lai

  • Gast
Audio afspelen
« Reactie #7 Gepost op: 2005/12/24, 13:19:18 »
hmmm... als ik dat afvink heb ik helemaal geen geluid meer

harmjansen2005

  • Gast
Audio afspelen
« Reactie #8 Gepost op: 2006/01/05, 20:54:36 »
Citaat van: Lai
Dat geluid probleem heb ik ook, ik dacht dat het aan mijn antieke cd-rom speler lag. Ik merk wel dat als ubuntu opstart het deuntje prima eruit komt, heb je al geprobeerd muziek van je hardeschijf af te spelen? Misschien heeft ubuntu problemen met het verwerken van cd audio vanaf verwijderbare schijf.
Lai, ik had het probleem van stotterend geluid, als ik bijv. een cd afspeelde. Ik heb je tip opgevolgd en een mp3-tje op het bureaublad gezet. Dat wordt perfect afgespeeld. Jouw conclusie zal dus wel waar zijn. Maarre... heb je ook een suggestie voor een oplossing? Een beetje lastig om steeds eerst een cd naar de harde schijf te kopieren, voordat je die goed kunt afspelen...

Groet, Harm

harmjansen2005

  • Gast
Audio afspelen
« Reactie #9 Gepost op: 2006/01/05, 21:00:46 »
Bob,

Al weer een poosje geleden schreef je op mijn vraag over een verkeerde toetsenbordindeling het onderstaande:

Je kan op je gnome-balk door rechter klikken een icoon toevoegen, voor een toestenbordwissllaar.
rechterklik op balk boven in -> + Toevoegen aan paneel -> (kopje) gereedschappen -> Toetsenbordwisselaar -> Toevoegen
Ik gebruik deze om te wisselen tussen US-International en Dvorak indeling.

Ik heb gedaan wat  je schreef. Bovenaan op de Gnome-balk staat nu Nld en op de plattegrond van het toetsenbord staat precies de indeling die ik heb. Maar zodra ik iets intyp, gedraagt het toetsenbord zich als een VS-Internationaal bord. Daar werk ik op mijn werk mee, maar thuis zoek ik me wezenloos in mijn geheugen waar wat ook al weer zit.
Ik ben dus nog niks verder. Kan iemand helpen?

Groet, Harm

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Audio afspelen
« Reactie #10 Gepost op: 2006/01/05, 21:09:20 »
Toetsenbordindeling kun je ook in /etc/X11/xorg.conf aangeven, dan houden alle applicaties zich eraan. DMA aanzetten wil wel eens helpen tegen stotterende CD's.

Slecht nieuws: je moet er nog een configuratiebestand voor bewerken met een onmogelijk syntax
Goed nieuws: vanaf dapper gaat dit automatisch ;)

Als je even meldt hoe je cd station heet /dev/hdc of iets dergelijks, help ik je wel met het DMA gebeuren.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Audio afspelen
« Reactie #11 Gepost op: 2006/04/19, 21:52:38 »
Ik heb een klein probleempje:

In Breezy verscheen er steeds een muzieknootje wanneer ik met mijn muis boven een mp3 file ging staan en kon ik luisteren naar een voorstukje van dat liedje zonder daar op te moeten klikken.
In Dapper verschijnt dat muzieknootje ook maar ik hoor niets meer, wanneer ik dubbelklik speelt het nummer gewoon af. (Net zo voor .ogg- of mp4- muziekbestanden)

Dat vond ik wel een handige functie die ik graag terug wil.
Moet ik daar ergens een instelling voor aanpassen?

In de map open waar de muziekbestanden zich in bevinden heb ik in Edit -> Preferences -> Preview bij Sound Files reeds de optie verzet van Local files only naar Always ... Zonder resultaat ...  :(
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Audio afspelen
« Reactie #12 Gepost op: 2006/04/21, 11:35:49 »
apt-get install mpg321 ogg123

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Audio afspelen
« Reactie #13 Gepost op: 2006/04/22, 11:43:23 »
@Dennis thx het is gelukt maat.
Ik kan nu de mp3 in preview (of is 't prehear?) beluisteren. Alleen met .ogg bestanden blijf ik met hetzelfde probleem zitten
Als ik sudo apt-get install ogg123 doe krijg ik dit:
Citaat
bb@ubuntu:~$ sudo apt-get install ogg123
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
Pakket ogg123 is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket ogg123 heeft geen installeerbare kandidaat
bb@ubuntu:~$
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Audio afspelen
« Reactie #14 Gepost op: 2006/04/22, 12:00:43 »
Tja, nieuwe repositories vinden die het wel hebben :)
Ken je dit reeds?
http://www.ubuntulinux.nl/source-o-matic
En anders een debje of zo :D

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Audio afspelen
« Reactie #15 Gepost op: 2006/04/22, 17:44:02 »
ogg123 is geen eigen pakket en ik ben suf :) Het zit in vorbis-tools (je kunt ook zelf met apt-file zoeken ;))

Gast

  • Gast
Audio afspelen
« Reactie #16 Gepost op: 2006/04/26, 14:52:52 »
Beetje late reactie, maar het probleem met audacity heeft nog niemand op gereageerd, dus bij deze.

Audacity klaagt over zijn i/o als er een ander programma gebruik maakt van het geluidssysteem. Als je dat programma stopt (bijvoorbeeld rhythmbox) en audacity opnieuw opstart zal alles werken.

In elk geval, bij mij werkt het zo, dapper i386...