Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (opgelost) mounten van nieuwe hd  (gelezen 2870 keer)

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
(opgelost) mounten van nieuwe hd
« Gepost op: 2009/03/26, 20:46:18 »
Goede morgen,

Heb oude HD eruitgegooid en een nieuwe geplaatst.
De oude schijf heeft die altijd gezien .
De nieuwe hd ziet deze niet

Met de gparted zie ik de nieuwe hd.
Met sudo fdisk -l in terminal zie ik ze ook.
Maar niet in nautilus

Hoe kan ik deze hd koppelen of mounten ( is Interne sata hd  )

Groetjes joske
« Laatst bewerkt op: 2009/03/28, 21:57:21 door joske vermeule »
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

timmy

  • Gast
Re: mounten van nieuwe hd
« Reactie #1 Gepost op: 2009/03/26, 20:58:40 »
Probeer eens het volgende in je terminal:sudo mount /dev/sdb1 /media/nieuwehd(Dit zijn maar voorbeelden, kijk zelf even naar de goede partities en koppelpunt)

Offline track

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #2 Gepost op: 2009/03/26, 21:08:57 »
Hoi Joske,

is dat een geheel nieuwe schijf zonder iets erop ?
Dan zal er eigenlijk niets op staan toch ?  Dus ook geen bestandsysteem of wat dan ook.

Dus moet je eerst een partitie aanmaken en formatteren.  (Een taak voor gparted dus)

En daarna kun je een koppelpunt aanmaken (of ook het oude weer gebruiken).
En eventuĂ«el de /etc/fstab  aanpassen. (de nieuwe UUID van de nieuwe partitie in plaats van de oude UUID)

Vriendelijke groet,

track

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #3 Gepost op: 2009/03/26, 21:20:09 »

sudo mount /dev/sdb1 /media/nieuwehd
fuse: failed to access mountpoint /media/nieuwehd: Bestand of map bestaat niet

sudo mount /dev/sdb1 /media/nieuwvolume
fuse: failed to access mountpoint /media/nieuwvolume: Bestand of map bestaat niet

sudo mount /dev/sdb1 /media/NieuwVolume
fuse: failed to access mountpoint /media/NieuwVolume: Bestand of map bestaat niet

Er staan al bestanden op in ntfs maar normaal mag dit geen probleem geven
De vorige schijf had dit ook

groetjes joske
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #4 Gepost op: 2009/03/26, 21:24:22 »
Je ziet aan de foutmelding dat het koppelpunt niet bestaat. Maak dus eerst een lege directory /media/nieuwehd en voer daarna het eerste commando dat je probeerde terug uit. Als er geen output is, is hij gemount. Indien wel, dan is er ook iets anders aan de hand (kan al raden wat) en dan post je best eens de output hier.

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #5 Gepost op: 2009/03/26, 21:34:11 »
Sorry ben nog een leek en weet nog niet hoe je dit doet in ubuntu.
Een lege directory maken  /media/nieuwehd

Zou je mij hiervoor het juiste comando geven

groetjes joske
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #6 Gepost op: 2009/03/26, 21:44:52 »
Je kan dit ook grafisch doen met bestandsbeheer. Als je echter een koppelpunt onder /media wil maken, dan moet je beheerdersrechten hebben. Start derhalve nautilus op met beheerdersrechten. Dit moet altijd met een commando gebeuren:

gksudo nautilus

Klik op "bestandssysteem" in het linker paneel: dit brengt je in de bovenste directory, symbool: / Zoek daar Media, dubbel-klik om erin te gaan. Bestand - Nieuwe map, geef de naam "nieuwehd".

Maak die map tot de jouwe als gebruiker: rechts-klik, Eigenschappen, tab "Rechten", en verander de eigenaar van root naar je login naam.

Hetzelfde via de terminal:
sudo mkdir /media/nieuwehd
sudo chown $USER:$USER /media/nieuwehd

Daarna kun je het mount commando eens opnieuw proberen.

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: mounten van nieuwe hd
« Reactie #7 Gepost op: 2009/03/26, 21:59:57 »
Bedankt vanadium ,
Met zo een lesgever moet dit perfect lukken willen of niet
Dit geeft de mensen de moed om ubuntu onder de knie te krijgen

Groetjes joske
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #8 Gepost op: 2009/03/26, 23:03:37 »
Goede morgen

kan niet ontkoppelen ,

Unmount:/media/nieuwehd staat niet in fstab ( en u bent niet root)
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #9 Gepost op: 2009/03/26, 23:12:35 »
Wel opgelost. Als je om te koppelen root moet zijn, dan is het logisch dat je ook om te ontkoppelen root moet zijn (dus: sudo ...)

Je kan ervoor zorgen dat je als gebruiker de schijf kunt aan/afkoppelen door de schijf in /etc/fstab op te nemen met de "users" optie. Tweede voordeel van /etc/fstab is dat het commando eenvoudiger wordt ("sudo mount /dev/sdb1" of "sudo mount /media/nieuwehd" volstaat: het mount commando vogelt de rest automatisch uit aan de hand van de info die reeds in /etc/fstab staat.

Normaal zou je die schijf toch ook ergens in nautilus moeten zien, waar hij dan gekoppeld wordt op het ogenblik dat je hem aanklikt. De /etc/fstab technologie is immers niet meer de meest moderne manier om met de schijven om te gaan. Dit wordt enkel nog gebruikt voor interne schijven die bij opstart automatisch gemount moeten zijn.

Offline track

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #10 Gepost op: 2009/03/26, 23:25:01 »
De schijf handmatig weer ontkoppelen kun je zowel met umount /media/nieuweschijf  als met sudo umount /dev/sdb1 (rechten !)

Een automatische mount is makkelijk te bereiken door een desbetreffende regel in de /etc/fstab  bij te voegen.
De achtergrond staat in de handleiding  http://wiki.ubuntu-nl.org/community/Fstab 

1. Je zult dus best met gksu nautilus  (let op: met root-rechten !) eerst een kopie van  /etc/fstab  maken (als backup).
2. Jouw partitie is  /dev/sdb1 ,  het mountpunt  /media/nieuwehd  en het bestandsysteem  ntfs ?
    Dan moet je de volgende regel aan het eind van /etc/fstab  bijvoegen (met gksu gedit /etc/fstab ):
/dev/sdb1  /media/nieuwehd  ntfs-3g  rw,exec,auto,users   0   1Nu zal hij zowel bij  sudo mount -a  als bij het opstarten automatisch mounten (en met een rechterklik ook zonder sudo)

Vriendelijke groet,

track

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #11 Gepost op: 2009/03/27, 05:24:51 »
Met gparted de schijf formateren.(dit is alleen bij een lege schijf).
pysdm installeren.
Met "gksudo pysdm" De hd met een map koppelen.
Dit is de grafische manier.
(het is mogelijk dat je de rechten van de files moet veranderen naar jezelf).
« Laatst bewerkt op: 2009/03/27, 15:39:04 door jan11000 »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #12 Gepost op: 2009/03/27, 11:25:09 »
Citaat van: jan11000
Met gparted de schijf formatteren.
???

waarom wil je dat formateren er nog bij?

Citaat van: track
De schijf handmatig weer ontkoppelen kun je zowel met umount /media/nieuweschijf  als met sudo umount /dev/sdb1 (rechten !)
Volgens mij heb je in beide varianten van het commando beheerdersrechten nodig.

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #13 Gepost op: 2009/03/27, 23:28:54 »
Goede Morgen
Deze regel heb ik gedaan in etc/fstab
/dev/sdb1  /media/nieuwehd  ntfs-3g  rw,exec,auto,users   0   1

Hij ziet deze nieuwehd nog niet in nautilus.
In terminal kan ik hem nog met sudo mounten , zodat deze zichtbaar is.

unmounten in terminal :
sudo unmount /dev/sdb1 /media/nieuwehd :
sudo: unmount: command not found

Als ik klik op icoon voor te unmounten krijg ik : zie bijlage


[verwijderd door de beheerder]
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline track

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #14 Gepost op: 2009/03/27, 23:36:05 »
Er zijn enkele foutjes ingeslopen.
1. Het is niet  unmount  maar  umount .
2. De bijlage vertoont iets met "regel in fstab ongeldig".  Volgens mij ook een tikfout.
  -> zou je de schijf nog een keer handmatig mounten en dan het resultaat van het commando  mount  posten ?

Dan zullen wij het gauw oplossen.

track

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #15 Gepost op: 2009/03/28, 15:53:40 »
Ik denk dat het regeltje zo moet zijn:

/dev/sdb1  /media/nieuwehd  ntfs  rw,exec,auto,user   0   1

Dus geen 3g erbij en user in het enkelvoud.

Van de 1 op het einde ben ik ook niet zeker, maar dat is iets met prioriteiten, kan wel juist zijn.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #16 Gepost op: 2009/03/28, 15:58:06 »
Beter eens je /etc/fstab volledig hier posten:

cat /etc/fstab

en om de fout in /etc/fstab nog eens goed te zien:

sudo mount -a

Offline track

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #17 Gepost op: 2009/03/28, 16:14:36 »
/dev/sdb1  /media/nieuwehd  ntfs  rw,exec,auto,user   0   1

Dus geen 3g erbij en user in het enkelvoud.

Even twee opmerkingen erbij: 
ntfs-3g is het nieuwe systeem, en het wordt feitelijk vandaag alleen gebruikt.
  (-> zie ook voorbeelden op  http://wiki.ubuntu-nl.org/community/Fstab )
Er is een verschil tussen user en users ten opzichte van de rechten. users is de vrijgevigere variant.
  (-> zie de uitleg bij de parameters in  http://linux.die.net/man/8/mount )

Mijn voorstel was dus niet willekeurig, maar doelmatig gekozen om zo min mogelijk problemen te veroorzaken.

track

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #18 Gepost op: 2009/03/28, 16:28:30 »
Mij lijkt ook niets fout met die opties. Wat ntfs/ntfs-3g betreft: sedert Hardy is ntfs synoniem met ntfs-3g.

cat /etc/fstab
sudo mount -a
Commando's en uitvoer hier posten, en dan hebben we alle informatie.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #19 Gepost op: 2009/03/28, 20:31:58 »
@track

Dank voor de verwijzingen.
'k Ben er ook niet intensief mee bezig...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #20 Gepost op: 2009/03/28, 21:05:48 »
Goede morgen

@track :
Het ingeslopen foutje van unmount is rechtgezet
Ik kan nu mounten en umounten in terminal met sudo.
Kan ik deze automatisch laten laten mounten bij opstart en umounten bij afsluiten ?

Groetjes joske

PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #21 Gepost op: 2009/03/28, 21:11:20 »
@ vanadium
Dit is de uitkomst van de 2 commando's

-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=28d44b3f-3f85-45c2-85ea-a28690a63a7e /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda6
UUID=3b64e1f8-0c7c-4d21-a700-9cfce7573b92 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0/dev/sdb1  /media/nieuwehd  ntfs-3g  rw,exec,auto,users   0   1


desktop:~$ sudo mount -a
[mntent]: regel 9 in /etc/fstab is ongeldig

Groetjes joske
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig

Offline track

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #22 Gepost op: 2009/03/28, 21:21:08 »
In jouw /etc/fstab  staat de regel voor de schijf /dev/sdb1 in een regel met de vorige !!
Dat begrijpt hij dus niet.

Voeg in de /etc/fstab  gewoon de ontbrekende [enter]s bij:
Citaat
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0[enter]
/dev/sdb1  /media/nieuwehd  ntfs-3g  rw,exec,auto,users   0   1[enter]
Dan zijn allen gelukkig.

track
« Laatst bewerkt op: 2009/03/28, 21:35:52 door track »

Offline joske vermeule

  • Lid
  • Steunpunt: Nee
Re: (net niet opgelost) mounten van nieuwe hd
« Reactie #23 Gepost op: 2009/03/28, 21:56:53 »
@ track:
Bedankt voor de goede hulp , nu zal ik wel opletten waar ik een regel neerzet
groetjes Joske
PB Imedia X9911
2.4 Ghz Intel Core Quad Q6600
2 x 1024 Ram / HD 320 gig / HD 1.5 TB
Hardy Heron 8.04 / Thunderbird /Firefox/skype/Amsn/VLC/Amaroc
Nvidia Gforce 8300GS (128 Mb)
Vista voorlopig nog op HD 500 gig