Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: SD kaart wordt niet meer gemount  (gelezen 1640 keer)

Offline Hij

  • Lid
  • Steunpunt: Nee
SD kaart wordt niet meer gemount
« Gepost op: 2009/03/15, 23:37:45 »
Mijn sd kaartje wordt niet meer gemount in ubuntu.
Ik heb zo'n ingebouwde kaartlezer en die werkt niet meer, terwijl die het wel gedaan heeft. Ook heb ik een aparte via USB kaart lezer, die werkt ook niet.
Het enige dat ik veranderd heb de laatste tijd aan de pc is een NFS verbinding tussen twee ubuntu pc's.
Waar moet ik gaan zoeken om dit probleem op te lossen? Heb al geprobeerd via google, maar weet niet goed waar ik op moet zoeken...
Hier het topic over mijn NFS verbinding; topic misschien dat het hier mee te maken heeft?
Alvast bedankt

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: SD kaart wordt niet meer gemount
« Reactie #1 Gepost op: 2009/03/15, 23:47:56 »
Bij mij werkt het mounten ook niet meer, ik geloof dat dat vanaf 8.10 pas zo is. Maar ik blijf dit draadje even volgen :)
Op de chat te vinden als debiantux

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #2 Gepost op: 2009/03/15, 23:49:57 »
Bij mij werkt het mounten ook niet meer, ik geloof dat dat vanaf 8.10 pas zo is. Maar ik blijf dit draadje even volgen :)
Ik heb Ubuntu Hardy op beide pc's staan, is lekker makkelijk zo'n LTS versie  =D
Maar hopen voor ons beide dat het opgelost wordt  ;)

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #3 Gepost op: 2009/03/16, 00:05:51 »
Nu nog meer zoeken op internet (zonder een oplossing te vinden) post ik maar hier mijn bevindingen:

Als ik de sd kaart in de lezer stop krijg ik de volgende melding bij "lsusb";
tamara@laptop:~$ lsusb
Bus 002 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000

Het werkt zelfs niet als ik de foto camera via het kabeltje aansluit (wat nog aardig zoek werk was, het kabeltje heb ik volgens mij nog nooit gebruikt)  :)
"lsusb" geeft het volgende aan dan;
tamara@laptop:~$ lsusb
Bus 002 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 002: ID 04da:2372 Panasonic (Matsushita) Lumix DMC-FZ10 Camera
Bus 003 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #4 Gepost op: 2009/03/16, 19:42:55 »
Hallo

Dat kaartje wordt wel gezien in andere systemen? En ook in de camera; gewoon foto's
te zien?  En als laatste; in windows geweest en netjes daar afgemount (groene pijl icoontje) ?

Om te zien of de schijf überhaupt wordt gezien (buiten het evt. automount probleem om)
schijf in je kaartlezer (bij twijfel herhalen met die andere kaartlezer)
ga in de terminal en tik in
sudo fdisk -l
als het goed is moet daar je kaartje opduiken.

Zoniet, dan horen we het wel, gaan we bijv. mbv. photorec /testdisk kijken of er wat anders
aan de hand kan zijn.

Groeten Gerrit






-- = >  simplify if you can   -- = >

Offline Hij

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #5 Gepost op: 2009/03/18, 00:57:22 »
Dat kaartje wordt wel gezien in andere systemen? En ook in de camera; gewoon foto's
te zien?  En als laatste; in windows geweest en netjes daar afgemount (groene pijl icoontje) ?
In de camera doet het SD kaartje het gewoon. En windows wat is dat?  ;) Ik heb wel nog windows op mijn computer, maar gebruik het eigenlijk nooit... heb ook geen zin om dit in windows te gaan doen. Als ik dat test zal ik er wel achter komen of het inderdaad niet aan de hardware ligt. Ik weet trouwens helemaal niet of de cardreader wel werkt in windos, nooit gebruikt. Meteen na aanschaf van de laptop Ubuntu erop gezet. Ik zal morgen eens proberen in windows (ben nu teveel aan het doen op ubuntu om ff naar windows te gaan :))
Ik heb het kaartje nooit gemount in windows.

Om te zien of de schijf überhaupt wordt gezien (buiten het evt. automount probleem om)
schijf in je kaartlezer (bij twijfel herhalen met die andere kaartlezer)
ga in de terminal en tik in
sudo fdisk -l
als het goed is moet daar je kaartje opduiken.
Kaart erin gestopt en sudo fdisk -l in de terminal getikt, resultaat;
tamara@laptop:~$ sudo fdisk -l
[sudo] password for tamara:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x18000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          14      112423+  de  Dell Utility
/dev/sda2              15        1320    10485760    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3   *        1320        3505    17550781+   7  HPFS/NTFS
Partition 3 does not end on cylinder boundary.
/dev/sda4            3506        9729    49994280    5  Extended
/dev/sda5            3506        4376     6996276   83  Linux
/dev/sda6            4377        4625     2000061   82  Linux swap / Solaris
/dev/sda7            4626        9729    40997848+  83  Linux

Zoniet, dan horen we het wel, gaan we bijv. mbv. photorec /testdisk kijken of er wat anders
aan de hand kan zijn.

Groeten Gerrit
Gerrit bedankt voor het meedenken en je hulp!







Offline track

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #6 Gepost op: 2009/03/18, 01:45:04 »
Vanuit jouw  lsusb  blijkt het zo te zijn dat hij de kaartlezer helemaal niet ziet.
De camera is er wél, als je ze inprikt. 
Bij mijn kaartlezers is het zodanig dat zij in de lsusb altijd verschijnen, of er nu een kaart in zit of niet.
Zowel de interne als de externe (zodra ik hem inprik).

Vandaar gaat mijn verdenking eerder naar losse kabels (bij de interne). 

En bij de externe, als je hem inprikt verschijnt hij op de lsusb toch ?
Knippert het lichtje bij de externe eigenlijk als je de kaart inprikt ?

track

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #7 Gepost op: 2009/03/18, 09:51:48 »
Ja track; inderdaad, heb ik overheen gelezen; je interne cardreader moet zich ten allen
tijde laten zien. En ook als je externe cardreader inplugt moet lsusb hem laten zien.
Zou wel heel toevallig wezen dat ze nu allebei defect zijn, maar ook dat soort
onwaarschijnlijke dingen zie ik in mijn werk ook voorbijkomen.

Alvorens nu je laptop te gaan demonteren; start even op met een live linux ubuntu
en kijk daar ook even, met lsusb naar de status van zowel de interne als de externe
cardreader (losstaande nog van je sd kaartje) en hang evt. ten overvloede die externe
aan een andere computer ergens.

Groeten Gerrit


 
-- = >  simplify if you can   -- = >

Offline track

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #8 Gepost op: 2009/03/18, 12:11:21 »
Idd is een hardware-fout niet de enige mogelijkheid.

Het zou al "voldoende" zijn als het HAL- / USB- systeem enkele regels kwijt is die de omgang met dit soort toestellen beschrijven.
Maar dan heb je soms iets aan de aanpak van  http://forum.ubuntu-nl.org/hardware-en-drivers/automount-van-apparaten-geeft-problemen/ .

Als er niets met de hardware mis is zou die "analyse-tocht" een volgende aanpak zijn.

track
« Laatst bewerkt op: 2009/03/18, 12:13:58 door track »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: SD kaart wordt niet meer gemount
« Reactie #9 Gepost op: 2009/03/18, 15:56:29 »
Citaat
Het zou al "voldoende" zijn als het HAL- / USB- systeem enkele regels kwijt is die de omgang met dit soort toestellen beschrijven.
Denk ik niet. Dan nog zou hij in fdisk -l moeten verschijnen.