Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: video driver probleem  (gelezen 2150 keer)

Wesseltje

  • Gast
video driver probleem
« Gepost op: 2009/03/15, 18:34:29 »
Hallo mensen,

Ik had andere drivers geinstalleerd zodat ik de game Saurbraten kon spelen, alles zag er goed uit, maar mijn systeem werd traag. (ik weet niet waarom, doet er ook niet toe)
Dus ik installeer de standaard drivers weer, tijdens het installeren loopt ubuntu vast..... tijdje laten staan maar deed helemaal niks meer.

Ubuntu opnieuw proberen op te starten: voor het inlogscherm krijg ik een melding: ubuntu is running in low graphics mode.
Ik moet op oke drukken maar ik kan nieteens de muis bewegen, enter werkt ook niet.

Ik heb een Nvidia kaart.
Hoe moet ik verder?

Alvast bedankt.

edit:

Na wat hulp werken de video drivers, de muis en het toetsenbord werken nog niet.

edit2:

Heb hem op kunnen starten in low graphics mode, het ligt echt aan de video drivers.
« Laatst bewerkt op: 2009/03/15, 20:41:04 door Wesseltje »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Nvidia video drivers weg
« Reactie #1 Gepost op: 2009/03/15, 19:05:37 »
Start op in de recovery mode (optie in de opstartlader), en kies voor de root shell prompt. Type vervolgens:

apt-get remove --purge nvidia-glx-<druk hier op de tab-toets>

Offline track

  • Lid
  • Steunpunt: Nee
Re: Nvidia video drivers weg
« Reactie #2 Gepost op: 2009/03/15, 19:15:06 »
Hoi Wesseltje,

welke "andere drivers" zij dat geweest trouwens ? 
Want als dat het synaptic pakketbeheer vorbij was kunnen verschillende dingen grondig mis gaan.
En het is zeker een goed idee om even na te gaan wat er toen gebeurd is.

track

Wesseltje

  • Gast
Re: Nvidia video drivers weg
« Reactie #3 Gepost op: 2009/03/15, 19:17:20 »
Door cumulus007 kan ik nu bij mijn inlogscherm komen, bedankt! maaaarrr: muis en toetsenbord werken niet.

Ik heb het niet via synaptic pakketbeheer gedaan, gewoon via hardware en drivers. Het liep vast en heb mijn pc toen gereset.

Offline track

  • Lid
  • Steunpunt: Nee
Re: muis en toetsenbord doen het niet
« Reactie #4 Gepost op: 2009/03/15, 20:26:54 »
Het lijkt erop dat je de Xwindows een beetje overhoop hebt gegooid.

Wat gebeurt als je op het inlogscherm een [ctrl][alt][F1] doet ?   
Kom je dan op een zuivere commandolijn ?  En kun je daar inloggen ?   (terug kan via [ctrl][F7])

Als dat lukt is de boosdoener inderdaad de Xorg-configuratie.

track


p.s.: welke zwemerige driver heb je toen geïnstaaleerd eigenlijk ?

Wesseltje

  • Gast
Re: muis en toetsenbord doen het niet
« Reactie #5 Gepost op: 2009/03/15, 20:40:22 »
De normale nvidia driver, heb niks van internet af gehaald.

Ik heb hem op kunnen starten in low graphics mode, dus het probleem ligt echt bij de drivers.

als ik een driver wil installeren krijg ik dit:

SystemError: E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.

Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #6 Gepost op: 2009/03/15, 20:43:59 »
Een stap terug dus:  lukt het om op console 1 (dat is het verhaal met [ctrl][alt][F1]) in te loggen ?
(en uitloggen met logout)

Zo ja kunnen wij misschien een oude Xorg-configuratie terug halen.

track

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #7 Gepost op: 2009/03/15, 20:59:32 »
Ja dat lukt! :)

Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #8 Gepost op: 2009/03/15, 21:37:05 »
Dus is de xorg.conf de eerste verdachte.
Als je nu in de veilige modus opstart ("recovery mode") en daarna de "root command line" kiest,
wat levert een  ls -ls xorg*  op ?   Kun je dat even noteren (datum en namen zijn voldoende) ?

Dat is de lijst van de backups van de  xorg.conf .

En als wij hiervan een goede kunnen terughalen hebben wij het.

track

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #9 Gepost op: 2009/03/15, 21:44:59 »
Command not found ???

Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #10 Gepost op: 2009/03/15, 22:04:30 »
Heb je op de de "root command line" precies dit ingevoerd ?  :ls -ls /etc/X11/xorg*(sorry, ik was het pad vergeten)

En dan zegt hij "command not found" ??

track

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #11 Gepost op: 2009/03/15, 22:30:30 »
1165 mar 15 20:27 /etc/X11/xorg.conf
1037   "      2 19:58               "                (datum enz)
1194   "    15 18:39               "                   "
1037   "     "   19:06               "                   "
1065   "     "   19:07              "                   "
1065   "     "   20:26              "                    "
922     "     "   21:42              "                   .failsafe

Ik ga nu mijn bed in, morgen ga ik weer verder

Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #12 Gepost op: 2009/03/15, 22:46:35 »
Welterusten !

De volgende poging zal zijn:
1. de  xorg.conf  hernoemen  naar  xorg.conf.x
2. eerst proberen om de  xorg.conf.failsafe  in te zetten. (kopiëren)  Dus weer op de "root command line": cd  /etc/X11
mv  xorg.conf  xorg.conf.x
cp  xorg.conf.failsafe  xorg.conf
en dan gewoon met  reboot  herbooten.  (en kijken of het iets oplevert)

Zo ja, prima.  Zo niet, de volgende poging met het oudste backup dat er is  (weer "root command line")cp  -f  xorg.conf.200903021958*  xorg.confen  reboot .  (lukt het nu?)

Zou ook dit mis gaan wordt he misschien moeilijker.  Dan zou ik handmatig de inhoud van de  xorg.conf  gaan bekijken.  (met nano)

track

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #13 Gepost op: 2009/03/15, 22:52:21 »
Ik heb ook ongeveer een keer zo'n probleem gehad met mijn nVidia 8800GTX kaart. Herstarten in recovery mode en kiezen voor 'xfix' verhielp bij mij het probleem. Daarna kun je inloggen en de 'goede' drivers opnieuw installeren
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #14 Gepost op: 2009/03/15, 22:56:30 »
Ik kan nu gewoon normaal opstarten na het uitvoeren van de eerste commands van track, maar de foutmelding blijft komen als ik de goede drivers wil installeren: SystemError: E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.


Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #15 Gepost op: 2009/03/15, 23:05:44 »
Als je eers jouw systeem weer binnenkomt heb je tenminste een situatie waar je beter verder kunt zoeken.

Dus mogen verder nagaan waar die kreet vandaan komt en hoe wij er verder kunnen.

track

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #16 Gepost op: 2009/03/16, 09:04:10 »
Ik kon het systeem al in, alleen nu onder normale mode, dus niet meer onder low graphic mode.
Ik  heb die tweede command uitgevoerd, maar dan krijg ik: no such file or directory.


Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #17 Gepost op: 2009/03/16, 11:55:44 »
Dat is niet erg.  Want ook het tweede commando was maar een poging om weer het systeem binnen te komen.
Maar dat is nu gelukt.
Nu moeten wij het knelpunt vinden waarom hij van  "Encountered a section with no Package" zeurt.

Dat is dus het antwoord wanneer je probeert de Nvidia "hardware driver" te installeren.  Juist ?

Wat vind je als je met het bestandsbeheer nautilus in de map  /var/lib/dpkg/  het bestand  status  opzoekt ?
Hoe groot is die, en is er ook een  status.old  ?

track

Wesseltje

  • Gast
Re: video driver probleem
« Reactie #18 Gepost op: 2009/03/16, 20:47:23 »
Heel veel applicaties werken niet meer, alleen maar errors krijg ik.
Ik installeer ubuntu opnieuw zodat ik weer normaal kan werken!

Offline track

  • Lid
  • Steunpunt: Nee
Re: video driver probleem
« Reactie #19 Gepost op: 2009/03/16, 21:17:40 »
Mijn voorstel was om even naar die  /var/lib/dpkg/status  en  /var/lib/dpkg/status.old  te kijken.
Zij allebei ±evengroot in de orde van  1..2 MB  ?   
Als b.v. /var/lib/dpkg/status  zou ontbreken (of beschadigd zijn) kun je de status.old misschien terug zetten.

Dat was de hint vanuit de foutmelding. 
Als er geen belangrijke data op de schijf staat is een nieuwe installatie wél misschien de snellere oplossing ...

track