Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: SMB shares openen niet in het domain  (gelezen 679 keer)

Starfish

  • Gast
SMB shares openen niet in het domain
« Gepost op: 2009/03/13, 17:16:09 »
hoi iedereen,

Ik heb een samba fileserver opgezet (Ubuntu 8.04) en de bedoeling is dat Active Directory users (W2K3 R2) de shares kunnen benaderen.
Ik heb de tutorial gebruikt vanop https://help.ubuntu.com/community/SettingUpSamba#Active%20Directory%20Integrated%20File%20Server

Settings:
domain name: DORA
full domain: DORA.INFO
domain admin account: kirsti
backup user account: raymond
share name: common
primary domain controller: GW2K3DC1
file server name: GUB804FS
primary subnet: 192.168.0.0/24

Probleem: Stap 19 kan ik niet uitvoeren
setfacl -R -m group: "DORA+domain admins" :rwx /share
setfacl -R -m group: "DORA+domain users" :rwx /share/common
setfacl -R -m user: "DORA+raymond" :rwx /share
setfacl -R -m user: "DORA+raymond" :rwx /share/common

FOUTMELDING in Ubuntu: setfacl: option -m incomplete

In windows krijg ik ook een foutmelding

\\Gub804FS\common is not accessible. You might not have permission to use this network resource.

Kan iemand me helpen met deze fout? Het zou me alvast helpen om voor mijn eindproject meer linux in het overwegend Windows netwerk te steken.

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: SMB shares openen niet in het domain
« Reactie #1 Gepost op: 2009/03/14, 17:31:03 »
Tiens, ik ken dat probleem precies van ergens  =D

Even op zoek gegaan naar die 'setfacl' en als syntax krijg ik het volgende te zien:
Granting an additional user read access
              setfacl -m u:lisa:r file

De syntax die je gebruikt lijkt dus te kloppen, maar volgens mij moet je hier heel goed opletten met het gebruik van spaties. Ik zie bv. dat je  voor en na "DORA+domain admins" nog een spatie zet (na de 'group:' en voor de ':rwx') en ik denk dat de syntax van setfacl dit niet toe laat. Misschien toch maar eens proberen.  ;)

Dat je vanuit Windows die foutmelding krijgt lijkt me normaal zolang de file-permissies niet juist zijn gezet via setfacl

° Bezoek mijn blog Digital (in)Sanity °