Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Videobeelden niet vloeiend  (gelezen 3722 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
Videobeelden niet vloeiend
« Gepost op: 2009/03/04, 20:40:00 »
Op allebei mijn Ubuntu systemen (laptop en desktop) ervaar ik geen optimaal videobeeld bij het bekijken van (HD)-films van zowel DVD als harddisk. Met name bij snelle beelden of een pan (horizontale camerabeweging) vertoont het videobeeld regelmatig storende horizontale strepen. Alsof er iets van de beeldpixels blijft hangen. Het maakt daarbij niet uit welke mediaspeler ik gebruik (favoriet is VLC). Op beide systemen heeft ook XP gedraaid en daar was het beeld altijd vloeiend. Terwijl je zou zeggen dat linux lichter is en meer power overhoudt voor video-afhandeling...

Nou heb ik natuurlijk al eens wat gegoogled; exact hetzelfde probleem is wel eens vaker gerapporteerd. Het enige advies dat ik ben tegengekomen is om eens 'n andere uitvoermodus te kiezen in VLC (X11 of XVideo i.p.v. standaard of GL). Dat heb ik gedaan, maar het levert geen verbetering op.

Destop: AMD Athlon 64 X2 6000, 4GB, Radeon X1200 - Ubuntu 8.04 64bits
Laptop: Intel Celeron 520 @ 1.6Ghz, 1GB, Intel Mobile 945 - Ubuntu 8.10 32bits
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #1 Gepost op: 2009/03/04, 22:53:41 »
Probeer de desktop effecten eens af te zetten.
systeem > voorkeuren > uiterlijk > effecten > geen.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #2 Gepost op: 2009/03/04, 22:54:52 »
Probeer de desktop effecten eens af te zetten.
systeem > voorkeuren > uiterlijk > effecten > geen.
Staan al uit... Op de desktop met de Radeon werkt sowieso alleen 'geen'.
« Laatst bewerkt op: 2009/03/04, 22:57:54 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #3 Gepost op: 2009/03/04, 22:58:09 »
Persoonlijk gebruik ik liefst: mplayer met de front-end smplayer.
VLC vind ik zelf over het algemeen minder beeld geven.


Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #4 Gepost op: 2009/03/04, 23:23:34 »
Persoonlijk gebruik ik liefst: mplayer met de front-end smplayer.
VLC vind ik zelf over het algemeen minder beeld geven.
Getest: De beeldkwaliteit van (s)mplayer is identiek aan dat van VLC.
Op precies dezelfde momenten in de film ontstaan er 'strepen'...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #5 Gepost op: 2009/03/04, 23:25:50 »
bijna vergeten
systeem > beheer > hardware driver moet je daar geen aanzetten voor je ati setup?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Videobeelden niet vloeiend
« Reactie #6 Gepost op: 2009/03/04, 23:39:53 »
10o, kan je een schermafdruk van het beeld met de strepen maken? En ik neem aan dat je alle codecs etc. hebt geïnstalleerd?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #7 Gepost op: 2009/03/04, 23:52:18 »
10o, kan je een schermafdruk van het beeld met de strepen maken? En ik neem aan dat je alle codecs etc. hebt geïnstalleerd?
Met vriendelijke groet,
Gijs
De codecs zijn volgens mij netjes geïnstalleerd a.d.h.v. Pjotr's lijstje.
Ik zal eens kijken of het lukt een schermafdruk te maken. De 'strepen' zijn nl. redelijk subtiel doch storend aanwezig.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #8 Gepost op: 2009/03/04, 23:55:03 »
bijna vergeten
systeem > beheer > hardware driver moet je daar geen aanzetten voor je ati setup?
Met het aanvinken van deze driver heb ik slechte ervaringen. Met EnvyNG heb ik op mijn desktop met 8.04 64bits alles lekker stabiel draaiende gekregen incl. dual-screen e.d.
« Laatst bewerkt op: 2009/03/05, 00:19:33 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #9 Gepost op: 2009/03/05, 00:18:56 »
10o, kan je een schermafdruk van het beeld met de strepen maken?
Het lukt niet om de strepen te 'vangen' met een snapshot. Daarin zijn ze niet meer zichtbaar. Alleen bij snel bewegend beeld is de storing zichtbaar...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Videobeelden niet vloeiend
« Reactie #10 Gepost op: 2009/03/05, 00:48:38 »
Het is niet een laag/hoog frequent storing. Ik had het een keer dat ik strepen op mijn monitor had als mijn vrouw de wasmachine aanzette, bleek een "rotte" condensator te zijn. Ook bijv. speaker boxen naast de monitor die een storend magnetisch veld opwekken.
Dit soort dingen dus, heb je iets nieuws in huis of juist heel ouds? Of iets in de computer? Het is maar een idee, aangezien je alle benodigde multimedia hebt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #11 Gepost op: 2009/03/05, 01:13:05 »
Het is niet een laag/hoog frequent storing. Ik had het een keer dat ik strepen op mijn monitor had als mijn vrouw de wasmachine aanzette, bleek een "rotte" condensator te zijn. Ook bijv. speaker boxen naast de monitor die een storend magnetisch veld opwekken.
Dit soort dingen dus, heb je iets nieuws in huis of juist heel ouds? Of iets in de computer? Het is maar een idee, aangezien je alle benodigde multimedia hebt.
Met vriendelijke groet,
Gijs
Hi Gijs, dat zou zeker een effect kunnen hebben, maar als er een dergelijke interference zou zijn, zou hij dan niet de hele tijd of op willekeurige momenten moeten storen?
Nu is het specifiek bij snel veranderende beelden. Zo weet ik inmiddels precies waar in een film ik kan testen.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Videobeelden niet vloeiend
« Reactie #12 Gepost op: 2009/03/05, 13:49:57 »
Hi Gijs, dat zou zeker een effect kunnen hebben, maar als er een dergelijke interference zou zijn, zou hij dan niet de hele tijd of op willekeurige momenten moeten storen?
Nu is het specifiek bij snel veranderende beelden. Zo weet ik inmiddels precies waar in een film ik kan testen.
Hangt een beetje af van het frequentie gebied van de storing en of LF is of HF.
Het is helemaal niet gezegd dat het zo'n storing is, het was maar een idee. Als je alle andere apparaten uit hebt staan, heb je de storing dan nog? Kan je monitor of grafische kaart wel de snelle beeld wisseling aan? En verder kan je een dvd testen op een andere PC/Laptop met Ubuntu, heb je dan ook die strepen?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #13 Gepost op: 2009/03/05, 15:17:34 »
Hi Gijs, dat zou zeker een effect kunnen hebben, maar als er een dergelijke interference zou zijn, zou hij dan niet de hele tijd of op willekeurige momenten moeten storen?
Nu is het specifiek bij snel veranderende beelden. Zo weet ik inmiddels precies waar in een film ik kan testen.
Hangt een beetje af van het frequentie gebied van de storing en of LF is of HF.
Het is helemaal niet gezegd dat het zo'n storing is, het was maar een idee. Als je alle andere apparaten uit hebt staan, heb je de storing dan nog? Kan je monitor of grafische kaart wel de snelle beeld wisseling aan? En verder kan je een dvd testen op een andere PC/Laptop met Ubuntu, heb je dan ook die strepen?
Met vriendelijke groet,
Gijs
Gijs, wederom dank voor het meedenken!
Ik vermoed dat de op het moederbord geïntegreerde grafische engines niet krachtig genoeg zijn (zie eerder bericht voor specs). Op mijn laptop (waarmee ik de meeste films kijk) is het erger dan op de desktop. Ook als de laptop op de tv is aangesloten, is het resultaat hetzelfde. Aan de desktop hangt een Samsung 20" met een responstijd van 2ms. Lijkt me sterk dat 't 'm in de monitor zit. Ik ken op dit moment niemand in mijn buurt met een losse/krachtigere grafische kaart om te testen of het dan beter is...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Videobeelden niet vloeiend
« Reactie #14 Gepost op: 2009/03/05, 16:01:27 »
Kijk eens op de steunpunten kaart misschien woont er iemand in de buurt waar je het kan testen. http://kaart.ubuntu-nl.org/

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline 2ndchance

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #15 Gepost op: 2009/03/05, 19:53:30 »

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Videobeelden niet vloeiend
« Reactie #16 Gepost op: 2009/03/05, 20:38:51 »
t klinkt als t zelfde probleem als in dit topic: http://forum.ubuntu-nl.org/hardware-en-drivers/performance-video-kwaliteit-verbeteren/?PHPSESSID=3b1e3cbf1e2208b9b7c5cc5b6582b70a
misschien heb je er iets aan!!!
Het lijkt er inderdaad op dat er sprake is van enige 'tearing' (http://nl.wikipedia.org/wiki/Tearing). Het gaat in bovengenoemde post om een nVidia-kaart en niet om een Intel Mobile. De oplossing zou moeten liggen in verticale synchronisatie (v-sync)...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Videobeelden niet vloeiend
« Reactie #17 Gepost op: 2009/03/05, 23:00:30 »
t klinkt als t zelfde probleem als in dit topic: http://forum.ubuntu-nl.org/hardware-en-drivers/performance-video-kwaliteit-verbeteren/?PHPSESSID=3b1e3cbf1e2208b9b7c5cc5b6582b70a
misschien heb je er iets aan!!!
Het lijkt er inderdaad op dat er sprake is van enige 'tearing' (http://nl.wikipedia.org/wiki/Tearing). Het gaat in bovengenoemde post om een nVidia-kaart en niet om een Intel Mobile. De oplossing zou moeten liggen in verticale synchronisatie (v-sync)...
Dit zou je handmatig aan moeten brengen in je xorg.conf, de vsync en hsync deze gegevens zijn terug te vinden in de handleiding van je monitor. Wat is trouwens de vernieuwing frequentie, staat onder voorkeuren>Schermresolutie.Valt misschien ook nog wat aan te passen.

Met vriendelijke groet,

Gijs
« Laatst bewerkt op: 2009/03/05, 23:07:52 door Gijsbert »
In der Beschränkung zeigt sich der Meister.