Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Fujitsu Scaleo-J geeft onacceptabele grafische kwaliteit in Ubuntu 8.04.2  (gelezen 4552 keer)

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
De PC:
Fujitsu Scaleo J (Intel Celeron 3.06 Ghz, met 480 Mb Intern geheugen)
met geintegreerde ATI Radeon Xpress 200 series als grafische kaart, alles slechts anderhalf jaar oud.

Dual boot gemaakt met Ubuntu 8.04.2 en reeds geinstalleerde WinXP. Beeldscherm is een Sony SDM s51(LCD).
De live versie leek op deze PC mooi te werken, dus installatie direct gestart....

Direct na installatie al een slecht leesbaar scherm.
Aanpassen beeldscherminstellingen bleek niet mogelijk: resolutie liet zich niet aanpassen en beeldverhoudingen niet goed
Aanbevolen instellingen voor LCD aangepast (weergave lettertype). De centrering van  het scherm wijkt ook af van de oorspronkelijk instelling. Het scherm werd aanvankelijk ook niet herkend; later handmatig wel.

Vervolgens de aanbevolen driver geinstalleerd en dan....: weer een wit scherm met alleen een muiscursor.
Opnieuw opgestart in de recovery modus en geprobeerd de grafische Ubuntu krachten te herstellen....helaas geen succes want terug bij af.
Na zoeken op dit forum compiz op laagste stand gezet en de eerder ingestelde driver weggehaald.
Nu weer (lage resolutie) beeld en eerst maar even alle updates binnengehaald. Nog maar eens de grafische driver geprobeerd: weer wit scherm.

De Fujitsu Scaleo J heeft een geintegreerde grafische kaart (ATI Radeon Xpress 200) en daar zit het dus op vast vrees ik.

De suggesties van Pjotr (http://sites.google.com/site/computertip/geenbeeld ) helemaal uitgeprobeerd: daarna nu alleen lage resolutie mogelijk 800x600. Wel kon ik toen handmatig het beeldscherm installeren.
Vervolgens ATI Radeon Xorg drivers erbij geinstalleerd (Xorg fglrx en Xorg driver voor Ati Radeon Xpress 200....maar ook deze beide geven alleen een resolutie 800x600. Als ik bij het opstarten van Ubuntu het configuratiescherm krijg dat aangeeft alleen in lage resolutie te willen werken, kan ik vervolgens wel een hogere resolutie aangeven van het beeldscherm aangeven. Als ik dat test krijg ik allerlei kleurvlakken en strepen waar niets mee te doen is en komt hij vanzelf weer in de 800x600 resolutie terug.

Wat is wijs?
Heb er al heel veel tijd ingestoken en wil nu eindelijk een passende oplossing, mits beschikbaar.
Diverse forums afgestruind en niets bruikbaars gevonden dat ik al niet had gedaan (o.a. : https://answers.launchpad.net/ubuntu/+question/12823) En ook daar las ik al dat die ATI Radeon Xorg driver niet altijd goed werkt.
Een andere grafische kaart bijsteken, zo las ik op Internet levert conflicten op met de interne grafisch kaart.
Bij de eerste installatie werd een generieke vesa driver gekozen en die werkt merwaardigerwijs wel in hogere resolutie, maar geeft een vertekend beeld (hoogte/breedte verhouding klopt niet) en bijstewllen kan ik die resolutie dus niet.

VRAAG: Heeft iemand een praktische oplossing en hoe krijg ik met deze scaleo J toch een acceptabele resolutie? 
« Laatst bewerkt op: 2009/03/01, 18:22:23 door Peterbeter »
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline heir4c

  • Lid
  • Steunpunt: Nee
En het commando: gksudo displayconfig-gtk  Daar kan je normaal gezien drie drivers selekteren, de 'ati', de 'radeon' en de 'r128'
Of via Toepassingen>Overige>Schermen en weergave. (Staat die er niet, dan even naar Systeem>Voorkeuren>Hoofdmenu>Overige gaan en daar Schermen en Weergave aanvinken.)

Als je scherm kleiner is en meer naar rechtsstaat dan moet je je refresh verminderen. Bijvoorbeeld van 72 naar 70
Dit kan je ook via Systeem>Voorkeuren>Schermresolutie.

Als er in 'Hardware Drivers' geen drivers staan aangegeven dan geen andere installeren. Heb dat ook met mijn Ati kaart geprobeerd om de fglrx te installeren maar dat ging niet.


Offline jan11000

  • Lid
  • Steunpunt: Nee
Witte scherm is door compiz. Zoek maar eens op blacklisted of white screen.

Zo kun je compiz uitzetten: (dan krijg je je witte scherm niet meer.)
Stop Compiz-Fusion From Loading Automatically

This guide will show you how to stop Compiz-Fusion from loading automatically on startup in Hardy Heron and how to setup a shortcut for launching Compiz when you want.

Step 1: Run gconf-edit
Start Run Application by pressing Alt+F2

Screenshot-Run Application

Enter gconf-editor into the box, hit enter


Step 2: Set Metacity as your default start up window manager
Once in gconf-editor navigate to desktop>gnome>applications>window_manager

Screenshot-Configuration Editor - window_manager

under current and default replace each instance of:
/usr/bin/compiz with /usr/bin/metacity
it should like this when you're done:

Screenshot-Configuration Editor - window_manager-1



Step 3: Create a shortcut for starting Compiz-Fusion
right click the Applications Places System Menu
select the Edit Menu option

Screenshot-Main Menu

pick a location for your shortcut and select New Item box

Screenshot-Launcher Properties
Type: Application
Name: Compiz
Command: compiz --replace
COmment compiz window manager

Offline heir4c

  • Lid
  • Steunpunt: Nee
Zet gewoon de visuele effekten uit. (Systeem>Voorkeuren>Uiterlijk>(Laatste tabblad)Visuele effekten.

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Dank voor jullie suggesties, maar dat helpt me helaas nog niet verder.
Zoals hierboven te lezen had ik de voorkeuren voor visuele effecten had ik al uitgezet. Dat witte scherm (zie mijn eerste post) was ik dus ook al kwijt en daar zit ook het probleem niet in denk ik.
Probleem is volgens mij dat de driver niet goed werkt. Hij gooit zich na heropstarten er ook vaak weer uit.
Dan moet ik alles (scherm en driver weer opnieuw aanzetten.

Als driver gebruik ik nu de vesa generic driver met max resolutie 800x600.
De (ATI Radeon) Xorg driver fglrx is via synaptic geinstalleerd.
Maar die pikt hij blijkbaar niet.....
Lastig, allemaal en ik weet nu geen weg verder.
De logica ontgaat me ook hoe dit moet worden opgelost...
« Laatst bewerkt op: 2009/03/01, 23:39:16 door Peterbeter »
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline heir4c

  • Lid
  • Steunpunt: Nee
De fglrx werkt voor mijn Ati ook niet. En de andere drivers die ik aangeef?

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Als ik schermen en weergave aanklik loopt het aktiviteit´molentje´ een tijdje, maar laat vervolgens helemaal niks zien.
Voorts in de monitor word ik ook niet wijzer.
Helaas zeg die info zegt MIJ niet veel, misschien jou wel ?

-desktop:~$ gksudo displayconfig-gtk
  File "/usr/bin/displayconfig-gtk", line 75, in <module>
    app = DisplayConfig(options)
  File "/usr/lib/python2.5/site-packages/displayconfiggtk/DisplayConfig.py", line 189, in __init__
    debug_scan_pci_filename=self.options.pcitable)
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 394, in __init__
    self._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 404, in _finalizeInit
    gfxcard._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 1123, in _finalizeInit
    screen._finalizeInit()
  File "/var/lib/python-support/python2.5/displayconfigabstraction.py", line 1588, in _finalizeInit
    (cw,ch,x,x) = self.x_live_screen.getSize()
  File "/var/lib/python-support/python2.5/xf86misc.py", line 77, in getSize
    return self.sizes[self.currentsizeid]
IndexError: list index out of range
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline heir4c

  • Lid
  • Steunpunt: Nee
Raar, want dit moet werken in 8.04 dat commando, er moet ergens iets mis zijn met het pakket.
Misschien eens herinstalleren via Synaptic. Kijken naar: displayconfig-gtk

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
Hallo.

Dit probleem komt mij zeer bekend voor ook ik heb een Scaleo J met dezefde grafische kaart.

Met de standaard installatie van Kubuntu 8.04 werkt alles redelijk maar als ik drivers ga installeren voor deze kaart dan loopt alles mis.
Bij sommige drivers die ik installeer met EnvyNG lijkt alles goed te werken ook 3D enz.

Maar als dat gelukt is kan ik mijn systeem niet meer afsluiten de machine blijft dan met een zwart scherm staan tot dat ik bijv CTRL ALT Del geeft dan sluit de machine af.

Ik ben al ruim 1 jaar met dit probleem bezig en heb nog geen doeltreffende oplossing kunnen vinden.


Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Hallo.

Dit probleem komt mij zeer bekend voor ook ik heb een Scaleo J met dezefde grafische kaart.

Met de standaard installatie van Kubuntu 8.04 werkt alles redelijk maar als ik drivers ga installeren voor deze kaart dan loopt alles mis.
Bij sommige drivers die ik installeer met EnvyNG lijkt alles goed te werken ook 3D enz.

Maar als dat gelukt is kan ik mijn systeem niet meer afsluiten de machine blijft dan met een zwart scherm staan tot dat ik bijv CTRL ALT Del geeft dan sluit de machine af.

Ik ben al ruim 1 jaar met dit probleem bezig en heb nog geen doeltreffende oplossing kunnen vinden.


Johan ,ik had je eerder al een persoonlijk bericht gestuurd maar mogelijk heb je dat niet gezien. Ik had via dit forum al ontdekt dat jij dezelfde PC had met gelijkaardige problemen, meen ik. Welnu: wil je hier misschien het resultaat laten zien van jouw: displayconfig-gtk
Die van mij staat hierboven en daar kan ik niks mee.
Die EnvyNG hoe installeer ik die? via synaptic?
« Laatst bewerkt op: 2009/03/04, 21:25:42 door Peterbeter »
¨ik respecteer u zoals ik ben¨
Herman Brood

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
Re: Fujitsu Scaleo-J geeft onacceptabele grafische kwaliteit in Ubuntu 8.04.2
« Reactie #10 Gepost op: 2009/03/04, 18:30:26 »
Hoi.

Ik heb displayconfig-gtk niet geinstalleerd want ik maak gebruik van Kubuntu en die gaat anders om met de grafische kaart.

Ik maak gebruik van de standaard instelling van KDE en dan is er goed mee te werken, alleen bij het afsluiten zie ik geen grafisch scherm en heel veel fout meldingen over de resolutie enz.

EnvyNG zit gewoon in Adept dat is de tegenhanger van Synaptic.

Offline Peterbeter

  • Lid
  • Steunpunt: Nee
Re: Fujitsu Scaleo-J geeft onacceptabele grafische kwaliteit in Ubuntu 8.04.2
« Reactie #11 Gepost op: 2009/03/05, 12:59:27 »
Ik zie dat je het ook via synaptic kun binnenhalen. Zal dat ook eens proberen.
Jij werkt met KDE, ik werk met Gnome. Kijken of het hier nu wel lukt.
Jammer dat dit probleem in Ubuntu nog steeds niet is opgelost.
¨ik respecteer u zoals ik ben¨
Herman Brood