Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!  (gelezen 3007 keer)

Azalin

  • Gast
Mochten er meer mensen het volgende hebben:
Bij dmesg zie je steeds "hda-intel: Invalid position buffer, using LPIB read method instead."
Je hebt wel geluid maar als je in je alsamixer kijkt dan zie je alleen master en pcm staan wat uitvoer betreft. Ofschoon het een surround 6 kanaals audio output zou moeten hebben, heb je dus alleen maar stereo.
Als je audio op de voorkant van je PC hebt, dan werkt deze niet. Je krijgt er geen geluid uit terwijl je boxen wel geluid geven omdat die in de achterkant zitten.

Nou, dan denk ik dat ik d

Offline Kakysan

  • Lid
    • Het computermannetje
  • Steunpunt: Nee
ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #1 Gepost op: 2006/10/10, 09:43:08 »
Dit is erg handig info hoor !

Ik heb het regeltje toegevoegd en kan inderdaad veel meer instellen. Jammer dat ik alleen mijn subwoofer niet kan instellen. Maar het is een hele verbetering qua geluid !

Gr Karel,
Ik gebruik Linux Ubuntu 12.04 Unity & Windows 8.1

Mijn overstap weblogs zijn: http://overstappen2ubuntu.wordpress.com & http://overstappen2linuxmint.wordpress.com

Azalin

  • Gast
ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #2 Gepost op: 2006/10/12, 00:31:01 »
Bij mij is LFE = Subwoofer (as far as I know) en die heb ik hier in mijn mix paneel staan. Als het goed is dan zou die er bij jou ook bij moeten staan, alleen heb ik geen surround aangesloten :) dus ik zou even proberen als ik jou was.

In elk geval mooi dat je er iets aan had... ik heb er me echt rot naar gezocht en dacht, plaats het hier dan hoeft er minder hard gezocht te worden door mensen die eenzelfde probleem hadden als ik.

Azalin

  • Gast
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #3 Gepost op: 2009/05/11, 11:51:35 »
Ik zag dat in mijn eerste post de oplossing van dit probleem is verdwenen. Daarom toch even de post aanvullen. Het blijkt namelijk ook in de laatste versie van Ubuntu nodig je alsa-base aan te passen. De volgende regel toevoegen aan /etc/modprobe.d/alsa-base (voor 9.04 is de naam van alsa-base in modprobe.d veranderd, op een later tijd stip zal ik dat hier erbij plaatsen):

options snd-hda-intel model=3stack position_fix=1

Dit lost dus het probleem op voor mensen die een onboard hd audio chip hebben en alleen maar stereo uit hun systeem krijgen. De bovengenoemde regel zorgt er voor dat er enkele foutmeldingen in de logboeken verdwijnt plus dat je ineens meer kanalen tot je beschikbaar hebt. Officieel zou je er 6 moeten hebben meen ik.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #4 Gepost op: 2009/05/11, 11:56:09 »
Hallo

Mooi dat je nog even hier op terug gekomen bent, zou je misschien nog een kleine
aanvulling willen geven? Omdat de chipset die in je Asus zit, waarschijnlijk in veel meer
machines zit.
Zou je in de terminal even een ;
aplay -l
willen doen en de bewuste alc.....    chipset hier willen posten.

ik spaar die dingen nl.  ;)

Bijvoorbaat dank

Groeten Gerrit
-- = >  simplify if you can   -- = >

Azalin

  • Gast
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #5 Gepost op: 2009/05/11, 12:00:37 »
OP de Asus website heb ik even snel de specificaties van mijn MOBO opgezocht en daar zag ik het volgende bij audio staan:

ADI AD1986A SoundMAX 6-kanaals High-Definition Audio CODEC
Jack Sensing en Enumeratie
S/PDIF-out interface

Zodra ik vanavond thuis ben zal ik even aplay -l voor je in een terminal timmeren en de uitkomst hier plakken.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #6 Gepost op: 2009/05/11, 12:04:06 »
Das lekker snel :D, ik verwacht bij je alc output trouwens iets geheel anders te zien.

Alvast bedankt.
-- = >  simplify if you can   -- = >

Azalin

  • Gast
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #7 Gepost op: 2009/05/12, 21:45:20 »
aplay -l gaf dit:

Citaat
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: VT82xx [HDA VIA VT82xx], apparaat 0: AD198x Analog [AD198x Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: VT82xx [HDA VIA VT82xx], apparaat 1: AD198x Digital [AD198x Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: default [EasyCall Speakerphone         ], apparaat 0: USB Audio [USB Audio]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #8 Gepost op: 2009/05/12, 21:53:36 »
Bedankt, ik had trouwens verwacht een andere codec te zien,
omdat de laatste tijd veel alc chipsetjes opduiken icm.
met hda intel, goed dat ik deze ook even zie.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Azalin

  • Gast
Re: ASUS A8V-X en VIA HD Audio Controller (onboard) probleem opgelost!
« Reactie #9 Gepost op: 2009/05/12, 22:29:53 »
Mijn mobo is al weer een tijdje oud. Vandaar denk ik :)