Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Fout "403 Forbidden" op http://localserver:631/admin  (gelezen 3144 keer)

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Dag lui,

Na Cups geinstalleerd en geconfigureerd te hebben krijg ik de fout 403 Forbidden als ik in de browser http://localserver:631/admin oproep.
Onderzoek op internet geeft aan dat het iets met de shadow-groep te maken moet hebben. Kom hier als Linux newbie echter niet uit. Dus graag jullie suggesties en opmerkingen.

Groet,
FrodoW
« Laatst bewerkt op: 2009/02/25, 19:43:11 door FrodoW »

Offline Dennisgroot

  • Lid
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #1 Gepost op: 2009/02/23, 19:37:14 »
localserver moet localhost zijn dus
http://localhost:631/admin

Als je vanaf een andere computer in de cups wilt van je server
verander je localhost in het ip adres

edit:
Hoe bedoel je cups geinstalleer en geconfigureerd.
Bij mij doet hij het meteen (hij is meegeleverd).
Ook op een andere pc is die te bereiken.

Zeg even welke stappen je genomen hebt misschien is daar wat fout mee gegaan?
« Laatst bewerkt op: 2009/02/23, 19:39:58 door Dennisgroot »

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #2 Gepost op: 2009/02/23, 21:51:02 »
Als je het ip-adres van de cups computer wilt weten kan je met de rechtermuis op het netwerk icoon klikken en dan voor "verbindigsinformatie" kiezen.

De 403 Forbidden error kreeg ik ook, als ik vanaf een ANDERE computer probeerde cups op te roepen.

Dit was eenvoudig op te lossen door op de computer met cups de admin pagina op te roepen en dan een vinkje te plaatsen bij "Allow remote administration".
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #3 Gepost op: 2009/02/23, 23:56:26 »
Hallo,

Ik heb een verse installatie van Ubuntu server 8.10 genomen, inclusief cups, op een aparte server.

De in de Ubuntu Server Guide genoemde opdracht '/etc/init.d/cupsys restart' werkt niet (command not found) ook niet als de opdracht als sudo uitvoer. 'http://server_ip:631/' geeft aan dat de pagina niet kan worden gevonden.

Met nano in /etc/cups/cupsd.conf 'Listen localhost:631' vervangen door 'Listen server_ip:631'. Reboot uitgevoerd omdat '/etc/init.d/cupsys restart' niet werkt. 'http://server_ip:631/' geeft nu `403 Forbidden`

Tot zover, graag jullie reacties.
FrodoW
« Laatst bewerkt op: 2009/02/24, 00:28:22 door FrodoW »

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #4 Gepost op: 2009/02/24, 20:40:57 »
@ testcees, geldt waarschijnlijk voor een Ubuntu-PC, op een server weet ik niet hoe de admin pagina op te vragen

@ Dennisgroot, zie de hieraan voorafgaande post. Nog vragen of suggesties?

Offline Dennisgroot

  • Lid
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #5 Gepost op: 2009/02/24, 21:32:06 »
/etc/init.d/cupsys restart
klopt want het is volgens mij /etc/init.d/cups (tip met tab krijg je degene die nog kunnen)

Daarnaast op de cupsserver doet hij het daar wel dus localhost:631 op de computer waar cups opdraait.

Daarnaast lijk me wat je hebt veranderd niet zo handig dan kan straks de computer die in verbinding staat met de printer deze niet meer aansturen

Zo ziet mijn cupsd.conf eruit misschien heb je er wat aan
LogLevel warning
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Enable printer sharing and shared printers.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseAddress @LOCAL
DefaultAuthType Basic
<Location />
  # Allow shared printing and remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin>
  # Allow remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow all
</Location>
<Policy default>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #6 Gepost op: 2009/02/24, 23:39:18 »
Hallo,

Ik heb een verse installatie van Ubuntu server 8.10 genomen, inclusief cups, op een aparte server.

De in de Ubuntu Server Guide genoemde opdracht '/etc/init.d/cupsys restart' werkt niet (command not found) ook niet als de opdracht als sudo uitvoer. 'http://server_ip:631/' geeft aan dat de pagina niet kan worden gevonden.

Met nano in /etc/cups/cupsd.conf 'Listen localhost:631' vervangen door 'Listen server_ip:631'. Reboot uitgevoerd omdat '/etc/init.d/cupsys restart' niet werkt. 'http://server_ip:631/' geeft nu `403 Forbidden`

Tot zover, graag jullie reacties.
FrodoW

Klopt ook dat je die error krijgt. Je hebt Cups op een aparte server gezet, maar die luistert op dit moment nog niet naar andere computers. Op zich is dat makkelijk op te lossen, maar vergt wel een paar aanpassingen aan de configuratie van cups.
Op de server:
sudo nano /etc/cups/cupsd.conf

Dan zie je een hele hoop tekst. Nu zijn er een paar wijzigingen nodig:

# Only listen for connections from the local machine.
#Listen localhost:631
Listen /var/run/cups/cups.sock
Listen server_ip

Bij server_ip natuurlijk het ip-adres van je server invoeren.

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic
DefaultEncryption IfRequested

Staat als het goed is al goed. Hoef je dus niets aan te veranderen.

Restrict access to the server...
<Location />
  Order allow,deny
Allow localhost
Allow ip_adres
</Location>

Bij ip_adres kun je de hele ip-pool van je netwerk invullen. Ik heb dat simpelweg zo gedaan:
192.168.1.*

Zo laat hij alles toe dat tot je netwerk hoort. Elke computer die begint met 192.168.1 kan dan dus verbinding met cups maken. Wil je het wat beter beveiligen, voer hier dan alleen het ip-adres in van de computer waarmee je cups wilt gebruiken.

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
Allow From 192.168.1.*
</Location>

Idem, 192.168.1.* is het ip-adres van je netwerk.

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Basic
  Require user @SYSTEM
  Order allow,deny
  Allow localhost
  Allow 192.168.1.*
</Location>

Idem.

De rest zou voor zover ik kan nagaan al goed moeten staan. Druk nu op Ctrl+o (= opslaan) en Ctrl+x. Herstart cupsys. Met sudo /etc/init.d/cupsys restart

O, en vergeet in geen geval om er 'sudo' voor te zetten, anders werkt het herstarten niet! Als dit commando niet werkt, dan heb je Cups gewoon nog niet geïnstalleerd. In dat geval:
sudo tasksel --> kies voor printerserver installeren en volg de aanwijzingen.

Succes ermee!!
« Laatst bewerkt op: 2009/02/24, 23:41:08 door crashit »
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #7 Gepost op: 2009/02/25, 19:42:06 »
@crashit
Dank dit was de help die ik nodig had, het werkt nu ik kan het adm.menu op de pc starten.
Btw sudo /etc/init.d/cupsys restart werkt niet. Ik heb de server ge-reboot om cups opnieuw te starten. Dat werkt wel, dus Cups is wel geinstaleerd!?!?

Offline crashit

  • Lid
    • Tekstbureau Anderverhaal
  • Steunpunt: Nee
Re: [OPGELOST] Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #8 Gepost op: 2009/02/26, 15:10:31 »
Wat betreft het herstarten van cups, als je de raad van Dennisgroot opvolgt, moet ie het denk ik wel doen.

Dus sudo /etc/init.d/cups restart

In 8.10 hebben ze zo te zien dat commando aangepast, want in 8.04.2 (dat op mijn server draait) doet cupsys het wel.
"If engineers built buildings the way Microsoft builds operating systems the first woodpecker to come along would bring civilization to its knees."

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Fout "403 Forbidden" op http://localserver:631/admin
« Reactie #9 Gepost op: 2009/03/02, 20:05:03 »
Okay, ben er nu helemaal uit.
Bedankt allen voor jullie reacties!

FrodoW