Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet  (gelezen 1963 keer)

hansieb112

  • Gast
Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Gepost op: 2009/02/23, 12:38:05 »
Hallo iedereen,

Mijn zusje gebruikt graag haar webcam voor Amsn. Nu heb ik een nieuwe pc voor haar gemaakt en hier ubuntu 8.10 op gezet.
Op haar oude pc stond ubuntu 8.04 waar de webcam perfect op werkte.

Nu probeer ik de webcam op ubuntu 8.10 aan de praat de krijgen, maar ik krijg het niet voor elkaar.

Hij ziet het usb apparaat wel, maar ik krijg er geen beeld uit.

Citaat
jolinde@jolinde-desktop:~$ lsusb
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 046d:c513 Logitech, Inc. MX3000 Cordless Desktop Receiver
Bus 004 Device 003: ID 093a:2460 Pixart Imaging, Inc. Q-TEC WEBCAM 100
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
jolinde@jolinde-desktop:~$

Ik heb al even gegoogled en er zijn mensen die ook problemen hiermee hebben.
Zie: https://bugs.launchpad.net/ubuntu/intrepid/+source/linux/+bug/267522

Op ubuntu 8.04 staat ook een andere driver,  dan in unbuntu 8.10

Ubuntu 8.10
Als ik op amsn de webcam probeer te configureren staat er:
Kies apparaat -> V4l2  Cif single chip
Kies kanaal -> Pac207

Ubuntu 8.04
Als ik op amsn de webcam probeer te configureren staat er:
Kies apparaat -> V4l2  Cif single chip
Kies kanaal -> Pac207bca

Wie weet de oplossing voor dit probleem.

Alvast bedankt.

Hans

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Reactie #1 Gepost op: 2009/02/23, 13:17:23 »
Ik heb deze link voor je https://help.ubuntu.com/community/Webcam#Driver%20installation misschien kan je er iets mee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

hansieb112

  • Gast
Re: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Reactie #2 Gepost op: 2009/02/24, 15:08:57 »
Bedankt voor de link.

Ik heb geprobeerd om met easycam de drivers te installeren, maar deze failt jammer genoeg.

make[2]: *** [/usr/share/EasyCam2/drivers/gspca/gspca_core.o] Fout 1
make[1]: *** [_module_/usr/share/EasyCam2/drivers/gspca] Fout 2
make[1]: Map '/usr/src/linux-headers-2.6.27-11-generic' wordt verlaten
make: *** [default] Fout 2

Maar ik heb nu wel beeld met Cheese, hier werkt de webcam prima mee.   Cheese geeft aan bij voorkeuren:

Camera: Cif single chip (/dev/video0)
Resolutie: 352 x 288

Ook geeft het programmatje camera monitor aan:  Camera is on   Video device:/dev/video0

Alleen moet ik nu nog beeld krijgen bij Amsn. Deze geeft bij instellingen een zwart scherm   ???
Tevens nog geprobeerd om met kopete messenger beeld uit de camera te krijgen, deze geeft een zwart beeld met grijze balken erin.

Als ik in terminal v4l-info dev/video0 probeer krijg ik als output:

jolinde@jolinde-desktop:~$ v4l-info /dev/video0

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
driver                  : "pac207"
card                    : "CIF Single Chip     "
bus_info                : "0000:00:1d.3"
version                 : 2.2.0
capabilities            : 0x5000001 [VIDEO_CAPTURE,READWRITE,STREAMING]

standards

inputs
    VIDIOC_ENUMINPUT(0)
index                   : 0
name                    : "pac207"
type                    : CAMERA
audioset                : 0
tuner                   : 0
std                     : 0x0 []
status                  : 0x0 []

video capture
    VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
index                   : 0
type                    : VIDEO_CAPTURE
flags                   : 1
description             : "P207"
pixelformat             : 0x37303250 [P207]
    VIDIOC_G_FMT(VIDEO_CAPTURE)
type                    : VIDEO_CAPTURE
fmt.pix.width           : 176
fmt.pix.height          : 144
fmt.pix.pixelformat     : 0x37303250 [P207]
fmt.pix.field           : NONE
fmt.pix.bytesperline    : 176
fmt.pix.sizeimage       : 25632
fmt.pix.colorspace      : SRGB
fmt.pix.priv            : 1

controls
    VIDIOC_QUERYCTRL(BASE+0)
id                      : 9963776
type                    : INTEGER
name                    : "Brightness"
minimum                 : 0
maximum                 : 255
step                    : 1
default_value           : 4
flags                   : 0

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
name                    : "CIF Single Chip     "
type                    : 0x1 [CAPTURE]
channels                : 1
audios                  : 0
maxwidth                : 352
maxheight               : 288
minwidth                : 48
minheight               : 32

channels
    VIDIOCGCHAN(0)
channel                 : 0
name                    : "pac207"
tuners                  : 0
flags                   : 0x0 []
type                    : CAMERA
norm                    : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
brightness              : 52171
hue                     : 0
colour                  : 0
contrast                : 0
whiteness               : 0
depth                   : 8
palette                 : unknown

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
    VIDIOCGWIN
x                       : 0
y                       : 0
width                   : 176
height                  : 144
chromakey               : 0
flags                   : 0

Heb jammer genoeg nog niks bruikbaars van google kunnen vinden :(


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Reactie #3 Gepost op: 2009/02/24, 18:09:42 »
Easycam2 kan je zo installeren http://forum.ubuntu-fr.org/viewtopic.php?id=16670 is wel in het frans, echter wat je in de terminal moet ingeven staat in aparte blokjes met code erboven. Op deze manier voeg je bronnen toe en kan je de deb installeren. Wees gerust met mijn uitermate beperkte kennis van de Franse taal is dit mij ook gelukt. :)

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

hansieb112

  • Gast
Re: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Reactie #4 Gepost op: 2009/02/24, 20:23:34 »
Easycam2 kan je zo installeren http://forum.ubuntu-fr.org/viewtopic.php?id=16670 is wel in het frans, echter wat je in de terminal moet ingeven staat in aparte blokjes met code erboven. Op deze manier voeg je bronnen toe en kan je de deb installeren. Wees gerust met mijn uitermate beperkte kennis van de Franse taal is dit mij ook gelukt. :)

Met vriendelijke groet,

Gijs

Geinstalleerd is die al, maar hij geeft dus een foutmelding  ??? Ook als je het programma standalone via  Hulpmiddelen -> Easycam2 opstart kan je drivers installeren.  Hij gaat dan even bezig en daarna kan je op toepassen drukken, dit heeft geen effect :(

Als ik het volgende command invoer in de terminal dan start die Easycam2 op. Dan kan je de driver installeren, maar komt die met een foutmelding

jolinde@jolinde-desktop:~$ gksudo 'python /usr/share/EasyCam2/core.py --gtk'
GO !
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
linux-headers-2.6.27-11-generic is reeds de nieuwste versie.
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  libpopt-dev gstreamer-tools automake1.7 libjinglep2p0.3-dev debhelper
  intltool-debian libglib2.0-dev check m4 po-debconf
  libgstreamer-plugins-base0.10-dev autoconf libjinglexmllite0.3-dev cdbs
  libmail-sendmail-perl intltool gettext fdupes autotools-dev libssl-dev
  zlib1g-dev libxml2-dev libjinglexmpp0.3-dev libexpat1-dev html2text
  libgstreamer0.10-dev libgsm1-dev libsys-hostname-long-perl
  libjinglebase0.3-dev
U kunt deze verwijderen via 'apt-get autoremove'.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.

 REMOVE the old module if present
ERROR: Module gspca does not exist in /proc/modules
/2.6.27-11-generic/build/include/linux/config.h': Bestand bestaat al

 CLEAN gspca source tree
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
.gspca.o.cmd  *.o *.ko *.mod.* .[a-z]* core *.i \
*.symvers *.err

 COMPILE gspca Please Wait ....!!

 INSTALL gspca in the kernel binary tree
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: kan status van `gspca.ko' niet opvragen: Bestand of map bestaat niet
make: *** [install] Fout 1

 LOAD gspca in memory
FATAL: Module gspca not found.

 PRINT COMPILATION MESSAGES if ERRORS look kgspca.err
make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/share/EasyCam2/drivers/gspca CC=cc modules
make[1]: Map '/usr/src/linux-headers-2.6.27-11-generic' wordt binnengegaan
  CC [M]  /usr/share/EasyCam2/drivers/gspca/gspca_core.o
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:54:27: error: asm/semaphore.h: Bestand of map bestaat niet
/usr/share/EasyCam2/drivers/gspca/gspca_core.c: In functie ‘spca5xx_ioctl’:
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2464: fout: impliciete declaratie van functie ‘video_usercopy’
/usr/share/EasyCam2/drivers/gspca/gspca_core.c: Op bovenste niveau:
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2610: fout: unknown field ‘owner’ specified in initializer
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2610: let op: initialization from incompatible pointer type
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2612: fout: unknown field ‘type’ specified in initializer
/usr/share/EasyCam2/drivers/gspca/gspca_core.c: In functie ‘spca50x_create_sysfs’:
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2770: fout: impliciete declaratie van functie ‘video_device_create_file’
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:2781: fout: impliciete declaratie van functie ‘video_device_remove_file’
/usr/share/EasyCam2/drivers/gspca/gspca_core.c: In functie ‘spca5xx_probe’:
/usr/share/EasyCam2/drivers/gspca/gspca_core.c:4310: fout: incompatible types in assignment
make[2]: *** [/usr/share/EasyCam2/drivers/gspca/gspca_core.o] Fout 1
make[1]: *** [_module_/usr/share/EasyCam2/drivers/gspca] Fout 2
make[1]: Map '/usr/src/linux-headers-2.6.27-11-generic' wordt verlaten
make: *** [default] Fout 2

« Laatst bewerkt op: 2009/02/24, 20:25:05 door hansieb112 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Q-tec webcam 100 installeren op ubuntu 8.10 werkt niet
« Reactie #5 Gepost op: 2009/02/24, 21:28:57 »
Ik heb zelf dit pakket geinstalleerd en verder niet gspca-source, zit in Synaptic. Kijk eerst of het hiermee lukt en anders op de oude manier. Download gspcaV2 hier http://blognux.free.fr/?p=171
Hier staat ook de installatie beschreven.
Lukt het hiermee ook niet misschien op de oude manier. Download hier of ergens anders de driver http://linux.softpedia.com/downloadTag/GSPCA
Dan dit uitvoeren:
1)Rechts klik op het bestand, kies hier uitpakken.
Navigeer met de terminal naar de map van gspca.
Geef in de terminal het commando make
Hierna in de terminal sudo make install
2) Installeer in Synaptic nautilus-open-terminal
Rechts klik op het bestand, kies hier uitpakken
Navigeer met nautilus naar de map, klik nu op de werkbalk van nautilus op Bestand en klik op In Terminal venster openen.
Geef in de terminal het commando make
Hierna in de terminal sudo make install
Deze tweede manier is nu iets meer werk, naderhand heb je er alleen plezier van
Probeer het na installatie nogmaals met Easycam2.
Ik hoop dat je er iets aan hebt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.