Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wake on LAN  (gelezen 1570 keer)

Offline JiK

  • Lid
  • Steunpunt: Nee
Wake on LAN
« Gepost op: 2009/02/17, 10:34:46 »
Sinds kort heb ik een muziek server gemaakt van een oude pc die amper meer gebruikt werd. Nu heb ik bijna alles voor elkaar wat ik met de server wil, alleen èèn ding krijg ik maar niet voor elkaar. Dat is wake on lan, ik heb zoals op verschillende sites gezegd word in de BIOS van de pc deze mogelijkheid aangezet, maar het wil nog steeds niet.

Weet iemand hoe ik dit moet doen?

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #1 Gepost op: 2009/02/17, 10:36:12 »
Hallo JiK, wat werkt er niet precies niet? Welk Wake On LAN commando gebruik je?

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #2 Gepost op: 2009/02/17, 22:01:39 »
Hier een goede howto op het engelse forum
http://ubuntuforums.org/showthread.php?t=234588

Hiermee heb k zelf WOL aan ge gang gekregen
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #3 Gepost op: 2009/02/17, 22:42:34 »
In Ubuntu 8.10 (Intrepid) heb ik het zo opgelost:

Installeer het pakket ethtool

Maak een opstartscript aan:
sudo nano /etc/init.d/wakeonlanconfig
Zet hier het volgende in:
#!/bin/sh
### BEGIN INIT INFO
# Provides: wakeonlanconfig
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 1
# Short-Description: Set up Wake On Lan
### END INIT INFO
 
ETHTOOL="/usr/sbin/ethtool"
DEV="eth0"
case "$1" in
start)
    echo -n "Setting $DEV to wakeonlan..."
    $ETHTOOL -s $DEV wol g;
    echo " done.";;
stop)
    ;;
esac
 
exit 0
(Verander DEV="eth0" in DEV="eth1", afhankelijk van je systeem)

Maak het bestand uitvoerbaar:
sudo chmod a+x /etc/init.d/wakeonlanconfig

Zorg dat het script uitgevoerd wordt bij het opstarten:
sudo update-rc.d -f /etc/init.d/wakeonlanconfig defaults

Pas het afsluitscript aan, zodat de netwerkkaart niet uitgezet wordt:
sudo nano /etc/init.d/halt
Verander bovenaan "NETDOWN=yes" in "NETDOWN=no"

Voer het opstartscript handmatig uit, zodat WOL aangezet wordt:
sudo /etc/init.d/wakeonlanconfig

Zet nu je computer uit en probeer vanaf een andere computer om hem weer aan te zetten.

Heeft je computer een Nforce chipset (Nvidia moederbord), dan moet je het MAC adres in het WOL-netwerkpakketje omdraaien: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/288053

Offline JiK

  • Lid
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #4 Gepost op: 2009/02/18, 08:44:09 »
Bedankt voor de reactie, zal zo kijken of dit werkt!

Offline JiK

  • Lid
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #5 Gepost op: 2009/02/18, 11:07:24 »
@ Johan

ik heb alles gedaan wat je hierboven uitgelegd hebt, maar ik krijg het niet voor elkaar om hem vanaf m'n macbook op te starten... moet ik nog andere instellingen wijzigen?

ik zie nu trouwens wel in mijn finder de computer terwijl die uit staat, dus de netwerkkaart is inidergeval nog aan....

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #6 Gepost op: 2009/02/18, 11:10:05 »
Welk commando gebruik je op je Macbook voor Wake On Lan?

Offline JiK

  • Lid
  • Steunpunt: Nee
Re: Wake on LAN
« Reactie #7 Gepost op: 2009/02/18, 11:19:07 »
ik gebruik het programma WakeOnLan.app

die scant je netwerk en ziet alle aangesloten apparaten, en kan je op wake of op shut down klikken...