Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Installeren van Ebox  (gelezen 3427 keer)

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Installeren van Ebox
« Gepost op: 2009/02/14, 19:18:06 »
Dag lui,

Ik ben nieuw hier en probeer een server te installeren.
De off. server documentatie verwijst naar Ebox en omdat m'n Unix ervaring oud en verroest is (ruim 13 jaar oud) lijkt dit interessant.
De installatie van Ebox geeft echte als fout
" De volgende pakketten hebben niet-voldane vereisten:
  ebox: Vereisten: libapache-authcookie-perl maar het is niet installeerbaar
E: Niet-werkende pakketten:"

Geen idee wat ik hiermee moet/kan!
Graag jullie suggesties

Groet
FrodoW

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #1 Gepost op: 2009/02/14, 22:00:33 »
Welkom,
libapache-authcookie-perl  staat in Synaptic pakketbeheer

Systeem - Beheer - Synaptic pakketbeheer

zoekterm: libapache-authcookie-perl
aan vink druk op knop Toepassen

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #2 Gepost op: 2009/02/15, 09:57:17 »
@ Joop905
Bedankt voor je reactie, maar ...
Ik ben op een server versie aan het prutsen, ik denk dat jouw aanwijzingen op de grafische userinterface slaan.

@allen
Iemenad die me kan helpen met commandline instructies?

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #3 Gepost op: 2009/02/15, 10:01:20 »

sudo apt-get install libapache-authcookie-perl

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #4 Gepost op: 2009/02/15, 10:04:44 »
@joop905
Nogmaals dank, ga het proberen

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #5 Gepost op: 2009/02/15, 10:09:08 »
Helaas foutmelding:

"Pakket libapache-authcookie-perl is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket libapache-authcookie-perl heeft geen installeerbare kandidaat"



Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #6 Gepost op: 2009/02/15, 10:18:18 »
Dan is het pakket gewoon kapot. Google eens op "ebox ubuntu" ?

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #7 Gepost op: 2009/02/15, 10:52:17 »
@Cumulus007
Okay, dat was de hint (zal i.h.v.v. zelf eerste meer moeten zoeken (lees googelen).
Er is blijkbaar nog geen correcte versie voor ubuntu 8.10
« Laatst bewerkt op: 2009/02/15, 11:17:18 door FrodoW »

Offline track

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #8 Gepost op: 2009/02/15, 20:46:56 »
Hoi Frodow,

het klopt dat volgens http://packages.ubuntu.com/hardy/libapache-authcookie-perl die libapache-authcookie-perl er voor intrepid niet is.

De reden hiervoor vind je in de discussie op https://bugs.launchpad.net/ubuntu/+source/ebox/+bug/255368 . Er zijn ook verschillende pogingen om het probleem op te lossen.

Vriendelijke groet,

track

publiek

  • Gast
Re: Installeren van Ebox
« Reactie #9 Gepost op: 2009/02/16, 13:55:04 »
Hoi.

Aan:
sudo nano /etc/apt/sources.list
Volgende lijn toevoegen:
deb http://ppa.launchpad.net/ebox-unstable/ubuntu intrepid main
Vervolgens om eBox en alle modules te installeren:
sudo apt-get install "^ebox-.*"
« Laatst bewerkt op: 2009/02/16, 13:57:48 door publiek »

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #10 Gepost op: 2009/02/16, 19:09:38 »
@publiek
Resulteerd in:

Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.

Aangezien u slechts een enkele opdracht gegeven hebt is het zeer
waarschijnlijk dat het pakket gewoon niet installeerbaar is. U kunt dan
best een foutrapport indienen voor dit pakket.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
  ebox-ca: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
           Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-dhcp: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
             Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-dns: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
  ebox-firewall: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                 Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-network: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-ntp: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
            Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-objects: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-openvpn: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-printers: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                 Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-samba: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
              Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-services: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                 Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-squid: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
              Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
  ebox-usersandgroups: Vereisten: ebox (>= 0.11.99) maar het zal niet geïnstalleerd worden
                       Vereisten: ebox (< 0.12) maar het zal niet geïnstalleerd worden
E: Niet-werkende pakketten:

Offline Tralapo

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #11 Gepost op: 2009/02/16, 19:51:51 »
Heb net zelf Ebox geinstalleerd, doe het volgende:

sudo nano /etc/apt/sources.listVoeg in dat bestand de volgende 2 regels toe:
deb http://ppa.launchpad.net/ebox/ubuntu intrepid main
deb-src http://ppa.launchpad.net/ebox/ubuntu intrepid main

Opslaan (Ctrl+O), afsluiten (Ctrl+X) en vervolgens:
sudo apt-get install ebox
En hij installeert perfect.
Alleen kan ik er verder niet veel mee  :| Kan niks beheren of wat dan ook..
Ja, de computer uitschakelen en rebooten wil wel, maar voor de rest zie ik nergens iets staan of wat dan ook..
En Webmin wordt ik al helemaal niet wijs uit ;)
« Laatst bewerkt op: 2009/02/16, 19:55:15 door Tralapo »

publiek

  • Gast
Re: Installeren van Ebox
« Reactie #12 Gepost op: 2009/02/17, 01:08:21 »
@FrodoW:

Nog wel een punt van aandacht: 8.10 Intrepid & eBox is nog onstabiel.
Op 8.04 Hardy draait eBox stable.

Bestaande installatie (8.04 Hardy):
deb http://ppa.launchpad.net/ebox/ubuntu hardy main$ sudo apt-get update
$ sudo apt-get install "^ebox-.*"

Of

Ubuntu 8.04 Hardy + eBox in een pakket (stable):
http://ebox-platform.com/download/latest
Downloaden .iso, branden en installeren


Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #13 Gepost op: 2009/02/17, 21:58:08 »
@publiek
Ik ga het met 8.04 proberen.

@allen
Bedankt voor jullie reacties!

Offline karlhungus

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #14 Gepost op: 2009/02/18, 13:21:35 »
Heb laast een aantal van deze pakketten bekeken en daaruit kwam voor mij toch wel naar  voren dat je helemaal niks hebt aan ebox.
Heb ebox  zelf in tien minuten geinstalleerd, een uur de resources van mn server op laten eten, en vervolgens ben ik 3 uur bezig geweest om alles weer weg te halen. geen succes. en op mijn oude deskpro 500mhz 512mb al helemaal niet. webmin doet het wat dat betreft een stuk beter.
Wat ik zelf alleen tegen dit soort systemen heb is dat je weinig overzicht houdt over wat er allemaal gebeurd in je server. er kunnen van die vervelende foutjes insluipen die je hele server overhoop gooien. Zeker Ebox die plaatst zoveel extra gegevens in configuratie files. weinig zicht op hoe,wat, waar, waarom en hoe haal ik het weer weg wat mij betreft.

Je kan beter eerst zorgen dat je een beetje inzicht hebt in de opbouw van een linux systeem voordat je gaat beginnen aan dit soort tools heb ik altijd geleerd.

Offline FrodoW

  • Lid
  • Steunpunt: Nee
Re: Installeren van Ebox
« Reactie #15 Gepost op: 2009/02/23, 08:15:04 »
@karlhungus

Bedankt voor je waarschuwing, zal hem ter harte nemen.
Ben trouwens weer terug op 8.10 en laat Ebox voor wat het is!

Groet,
FrodoW