Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: fstab, auto mount harddisks  (gelezen 3090 keer)

pbecks

  • Gast
fstab, auto mount harddisks
« Gepost op: 2009/02/11, 14:57:01 »
Hallo,

Ik probeer mijn fstab zo aan te passen dat mijn harddisks automatisch gemount worden.

even wat gegevens: (fdisk -l)

Disk /dev/sda: 20.0 GB, 20020396032 bytes
255 heads, 63 sectors/track, 2434 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x90909090

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2327    18691596   83  Linux
/dev/sda2            2328        2434      859477+   5  Extended
/dev/sda5            2328        2434      859446   82  Linux swap / Solaris

Disk /dev/sdb: 40.9 GB, 40982151168 bytes
255 heads, 63 sectors/track, 4982 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0005e70f

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1        4982    40017883+  83  Linux

Disk /dev/sdc: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00024801

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1        9729    78148161   83  Linux

Disk /dev/sdd: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000dcfc1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1               1        9964    80035798+  83  Linux

Ik heb nu deze hd's met de hand gemount maar dat moet dus voortaan via fstab!

Hoe?

Onderstaand het scriptje waarmee ik "met de hand" mount.
******************************
mkdir /mnt/40GB
mkdir /mnt/80GB1
mkdir /mnt/80GB2
mount /dev/sdb1 /mnt/40GB
mount /dev/sdc1 /mnt/80GB1
mount /dev/sdd1 /mnt/80GB2
*****************************

?

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: fstab, auto mount harddisks
« Reactie #1 Gepost op: 2009/02/11, 15:10:49 »
Dit lijntje toevoegen aan /etc/fstab zou moeten werken. voor de eerste hd, voor de andere is het gelijkaardig.
/dev/sdb1 /mnt/40GB               ext3    defaults 0       2
Voor de uitgebreide uitleg in het nederlands kijk even naar volgende wiki.
http://wiki.ubuntu-nl.org/fstab
« Laatst bewerkt op: 2009/02/11, 15:12:29 door siegi »

pbecks

  • Gast
Re: fstab, auto mount harddisks
« Reactie #2 Gepost op: 2009/02/11, 15:14:34 »
Ik heb de fstab aangepast en krijg nu dit! (mount -a)

patrick@ubuntu:~$ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mount: wrong fs type, bad option, bad superblock on /dev/sdd1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


???????

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: fstab, auto mount harddisks
« Reactie #3 Gepost op: 2009/02/11, 15:16:14 »
Hangt er natuurlijk vanaf welk filesystem je gebruikt, normaal gezien is dit standaard ext3 tenzij je iets anders gekozen hebt.
Probeer eens ext2 inplaats van ext3

pbecks

  • Gast
Re: fstab, auto mount harddisks
« Reactie #4 Gepost op: 2009/02/11, 15:16:29 »
Mijn fstab ziet er nu zo uit:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=a6305338-5b92-4757-b2fb-fe35ba609601 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=0e1e0510-1158-49ef-950e-55cb6f33aa36 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/sdb1 /mnt/40GB               ext3    defaults 0       1
/dev/sdc1 /mnt/80GB1               ext3    defaults 0       1
/dev/sdd1 /mnt/80GB2               ext3    defaults 0       1

pbecks

  • Gast
Re: fstab, auto mount harddisks
« Reactie #5 Gepost op: 2009/02/11, 15:16:59 »
Ik heb de hd's geformeteerd met gparted (ext 3)

?

pbecks

  • Gast
Re: fstab, auto mount harddisks
« Reactie #6 Gepost op: 2009/02/11, 15:19:45 »
Toch ext2!!!!


Nog bedankt!

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: fstab, auto mount harddisks
« Reactie #7 Gepost op: 2009/02/11, 15:27:51 »
mooi :)

Offline pablotanguero

  • Lid
  • Steunpunt: Nee
Re: fstab, auto mount harddisks
« Reactie #8 Gepost op: 2012/03/25, 12:42:11 »
Ik heb ook een Dual boot computer met 2 harddisks. Op een draai ik Linux Ubuntu 11.10 en windows 7 en de op de andere draai ik Ubuntu 10.04. Ik kan sinds kort niet via bestandsbeheer [nautilus] niet van de ene ubuntu versie op de andere komen. Dit is niet altijd zo geweest en waarom en hoe dit is gekomen is mij niet bekent. Ik dacht de op losing gevonden te hebben op https://sites.google.com/site/computertip/faq#TOC-Hoe-koppel-ik-een-partitie-permanen . Ik heb alle stappen uitgevoerd en het viel mij op dat de laatste stap "Nu kunt u nog even de rechten op de partitie goedzetten via de terminal:
sudo chmod -R 777 /media/ubuntu 11.10" een fout melde n.l; partitie niet gevonden ???. Ik had deze isu al weer losgelaten :rolleyes:, maar bij de eerst volgende herstart had ik een probleem de desbetreffende Ubuntu versie (dit was ubuntu 10.04) loopt vast nog voor het aanmeldscherm :'(
Waarschijnlijk kan ik met met live cd sessie nog wel het fstab bestand herstellen maar het eerst genoemde probleem [hoe kom ik op het bestandsysteem van de andere ubuntu versie, dus ook van ubuntu 11.10 na 10.04] is daar mee niet opgelost!!!

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: fstab, auto mount harddisks
« Reactie #9 Gepost op: 2012/03/25, 16:25:34 »
Met gksudo pysdm of storage device manager kun je dit grafisch doen, wel eerst installeren.
(en van je goed partities afblijven).
« Laatst bewerkt op: 2012/03/25, 18:48:40 door jan11000 »