Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Zoveelste dualboot probleem  (gelezen 1355 keer)

unXpected

  • Gast
[OPGELOST] Zoveelste dualboot probleem
« Gepost op: 2009/02/10, 16:54:12 »
Goedemiddag!

Om eerst even voor te stellen. Ik heb een tijdje geleden Intrepid Ibex op 'n oude laptop geïnstalleerd met het doel: Eens kijken wat dat linux nou is. Allemaal prima! Dus ik heb besloten om het ook maar op mijn nieuwe laptop te zetten, MAAR wel als dualboot. Aangezien ik toch nog een aantal programma's in Windows draai.
Een aantal documentjes en installatie tutorials later dacht ik wel klaar te zijn om eindelijk de dual boot op m'n laptop te installeren. Deze laptop (Acer Aspire 5920G) had op dit moment Vista. Op zich geen probleem voor een dual boot dus. Dus zo ook maar begonnen.

Na de Iso van de live cd op een cdtje gebrand te hebben kon ik aan de slag. Zo gezegd zo gedaan. Op dat moment zag mijn schijf er als volgt uit:
C: was Vista partitie van ongeveer 60 gig.
D: was programma's en data partitie van +/- 90 gig.
Mijn idee was dus om ubuntu op de D partitie te zetten. Aangezien ik daar nog zeker 35 gig vrij had dus moest het geen probleem zijn om op deze schijf een extra linux partitie te maken. Dus, gedaan wat er in de tutorials gezegd word. En uiteindelijk linux op een partitie op D geinstalleerd. Ik start opnieuw op...Geen grub, en direct door na vista. Hmm...Na een aantal topics hier op t forum gelezen te hebben en een aantal dingen geprobeerd maar helaas mocht niks baten.
Uiteindelijk maar t besluit genomen (nogal radicaal misschien, maar dat zat er toch al een tijdje aan te komen), om XP te installeren. Na een aantal probleempjes daarmee (schijf van AHCI naar IDE moeten zetten in bios), helemaal goed gegaan. Dus toen stond XP op men laptop. Dus nog maar een keer dualboot proberen te maken.
Nou dit heb ik nu al zo'n 4 of 5 keer gedaan (ken ondertussen de hele installatie van buiten  XD). Om jullie even "in de loop" te houden een samenvatting van m'n schijf op dit moment:

fdisk -l
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x33af1021

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1889    15173361    7  HPFS/NTFS
/dev/sda2            1890       10814    71690062+   7  HPFS/NTFS
/dev/sda3           10815       19457    69424897+   7  HPFS/NTFS

Op t moment is t dus als volgt: XP op sda1 en 2 lege partities sda2 en 3. Deze zijn onder windows DATA en PROGRAMMA genoemd. Allebei rond de 70 gig groot.
Wat ik dus tot nu toe geprobeerd heb is het volgende. Als eerste Linux op sda2 te zetten. Via de schijfindeler in de install gezegd dat 20 gig voor Ubuntu 8.10 moest zijn en de rest zou sda2 blijven. Wat mij logisch zou lijken is dat ie Ubuntu op t begin zet. Maar hij zet m dus op t einde. Install gedaan en na install blijft ie hangen in een zwart scherm met volgende meldingen:

Ik heb m een half uur daarin laten hangen maar deed niks. Het liggende streepje knippert en je kan typen. Op een gegeven moment maar 1x op de uitknop gedrukt. Krijg de volgende melding: * Stopping GNOME Display Manager...



 Daarna het ubuntu uitlog balkje en als laatste wordt de CD eruit gegooid en moet je op enter drukken (zoals ubuntu dus normaal afsluit). Daarna schakelt de laptop uit en kan ik m weer aanzetten. Doe ik dit dan start de laptop op en begint op een gegeven moment gewoon windows XP weer te laden. Oftewel ik krijg geen enkele bootloader (grub) of wat dan ook. Dit is dus t probleem waarmee ik zit.
Ik heb ondertussen al een aantal dingen gedaan waaronder de Windows partitie 35 gig maken en dan ubuntu op /dev/sda1 installaren (naast windows dus). Zelfde probleem.
ubuntu op /dev/sda3 installeren...Guess what. Zelfde probleem.

Zelf even een beetje lopen nadenken en eens gekeken onder het geavanceerd knopje in de samenvatting vlak voordat installatie begint (waar je kan instellen waar je grub wil hebben). Toen ik dat opende stond er een vinkje voor opstartlader inschakelen en daarna kan je selecteren op welk apparaat je m wil hebben. Standaard stond ie op (hd0) en ik heb dus al een aantal installaties gedaan waarmee ik hier ook gespeeld heb (samenvatting hieronder van de keuzes) de opstartlader installeren op /dev/sda1 bijvoorbeeld (daar staat windows op). Helaas werkte dit ook geen van allen.

Grub: appartaat voor opstartlader-installatie:
(hd0)
/dev/sda
/dev/sda1          Windows XP Professional
/dev/sda2
/dev/sda5
/dev/sda3

Dus tot zover de conclusie gekomen dat het eventueel hieraan kan liggen. Of misschien het zwarte scherm na de installatie waar ik het eerder over gehad heb.

OF iets anders wat een stomme fout van mezelf is maar kan me niet voorstellen dat dit de reden is. Maar voor de volledigheid zal ik dit toch even vertellen. Toen Vista op m'n laptop stond, stond men harde schijf in de bios in AHCI. Toen ik XP wou installeren vond ie geen harde schijf. Na wat zoeken op google vond ik dat het hielp als je je schijf in IDE mode zette, of als je je XP cd met extra drivers slipstreamde. Nou ben ik dus voor de eerste optie gegaan aangezien ik men xp cd al gebrand had. Wat blijkt nu uiteindelijk (wist ik van te voren niet) maar als ik de schijf in de bios weer op AHCI zet start windows niet op. Hij laadt en na een paar seconden krijg je een mooie BSOD... Dus dat werkt niet en ik moet de schijf dus in IDE Mode laten staan.

Volgens mij heb ik nu alles gezegd wat ik wou zeggen. En begin ondertussen een beetje gefrustreerd te raken dat t niet lukt. T leek allemaal zo makkelijk en uiteindelijk is t me nog niet gelukt. Uit t verhaal komt waarschijnlijk wel naar voren dat ik niet de handigste ben met Linux. Daarom mijn hulproep aan jullie of jullie hier misschien wijs uit kunnen worden. Ik heb al een hele hoop topics hier op t forum doorgelopen maar helaas hebben de meest voor de hand liggende oplossingen niet geholpen.

Alvast bedankt dat jullie sowieso de moeite genomen hebben om dit hele verhaal door te lezen  :-X. Maar t zou helemaal super zijn  als iemand hier een oplossing voor zou weten!
Peter
« Laatst bewerkt op: 2009/02/10, 23:50:22 door unXpected »

Offline mcgyver

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #1 Gepost op: 2009/02/10, 17:27:37 »
Welke videokaart huist in je pc.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #2 Gepost op: 2009/02/10, 17:29:47 »
Wanneer je geen grafische omgeving krijgt, is dat vrijwel altijd de schuld van de videokaartdriver. Dus, welke videokaart heb je?

unXpected

  • Gast
Re: Zoveelste dualboot probleem
« Reactie #3 Gepost op: 2009/02/10, 17:48:27 »
Tis een Geforce 8600m GT...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #4 Gepost op: 2009/02/10, 18:45:48 »
Tis een Geforce 8600m GT...
Deze kaart word ondersteund, dus dat is geen probleem.
Je kan eventueel de alternate 8.04 LTS versie installeren:
http://nl.releases.ubuntu.com/releases/
http://nl.releases.ubuntu.com/releases/8.04.2/

En maak die twee partities eventueel volledige vrije ruimte van en dan installeren, dan kan je een bepaald aantal GB kiezen voor ubuntu en de rest kan je dan nog formateren naar nfts of wat dan ook.

unXpected

  • Gast
Re: Zoveelste dualboot probleem
« Reactie #5 Gepost op: 2009/02/10, 19:57:20 »
Hmm maar ens proberen met 8.04 dan. Maar jullie denken dus dat t probleem aan 8.10 ligt? Nouja we zullen zien!

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #6 Gepost op: 2009/02/10, 20:06:22 »
OF iets anders wat een stomme fout van mezelf is maar kan me niet voorstellen dat dit de reden is. Maar voor de volledigheid zal ik dit toch even vertellen. Toen Vista op m'n laptop stond, stond men harde schijf in de bios in AHCI. Toen ik XP wou installeren vond ie geen harde schijf. Na wat zoeken op google vond ik dat het hielp als je je schijf in IDE mode zette, of als je je XP cd met extra drivers slipstreamde. Nou ben ik dus voor de eerste optie gegaan aangezien ik men xp cd al gebrand had. Wat blijkt nu uiteindelijk (wist ik van te voren niet) maar als ik de schijf in de bios weer op AHCI zet start windows niet op. Hij laadt en na een paar seconden krijg je een mooie BSOD... Dus dat werkt niet en ik moet de schijf dus in IDE Mode laten staan.

Peter

Windows XP kan wel degelijk goed met SATA schijven overweg als je service pack 2 installeert. verder doen wat heir4c zegt, lijkt me  O0

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #7 Gepost op: 2009/02/10, 20:19:03 »
Gebruik de Alternate Installation CD eens, deze gebruikt geen grafische omgeving voor het installeren.
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

unXpected

  • Gast
Re: Zoveelste dualboot probleem
« Reactie #8 Gepost op: 2009/02/10, 20:39:01 »
Windows XP kan wel degelijk goed met SATA schijven overweg als je service pack 2 installeert.
Hmm naja op een of andere manier kreeg ik t niet aan de praat tijdens de installatie en nu wil die niet opstarten als ik ACHI selecteer in bios. Maargoed dit is geen windows forum;). Dus als ik dat ooit nog ens willen veranderen dan vraag ik dat wel ergens anders. T was meer als eventuele toevoeging, omdat het misschien effect kon hebben op de ubuntu install.

Ben nu net 8.04 op een schijfje weg aant branden. Mocht dit niet lukken (pff! :P) dan probeer ik de alternate install wel. Jullie hebben het wel over de grafische omgeving, maar ik heb al een aantal keer vanaf de Live-CD ubuntu 8.10 op die acer opgestart en dat was geen enkel probleem...Maargoed dat zal wel wat anders zijn ;)! We zien wel wat er gebeurd.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #9 Gepost op: 2009/02/10, 21:46:39 »
Jullie hebben het wel over de grafische omgeving, maar ik heb al een aantal keer vanaf de Live-CD ubuntu 8.10 op die acer opgestart en dat was geen enkel probleem...Maargoed dat zal wel wat anders zijn ;)! We zien wel wat er gebeurd.
Dat is niet hetzelfde, de Livecd gebruikt de vesa driver als ik me niet bedrieg, is een algemene driver die een grafische omgeving bied met mindere mogelijkheden maar nog kwalitatief.  De alternate heeft een tekst gebaseerde install, een beetje zoals bij windows. (Blauwe achtergrond met witte kaders met de tekst in, enz...

unXpected

  • Gast
Re: Zoveelste dualboot probleem
« Reactie #10 Gepost op: 2009/02/10, 22:18:45 »
Okee 8.04 is allemaal gelukt. Heb nu ook grub en kan nu gewoon kiezen tussen linux en xp. En dat dus gedaan met de live cd van 8.04. Heb dus niet de alternate cd gebruikt. Zal ik nu nog update naar 8.10?
Ik ben nog een redelijk nieuwe gebruiker dus ik weet niet hoe de verschillen tussen 8.04 en 8.10 zijn. Dus als die verwaarloosbaar zijn ga ik ook de moeite (en de kans dat t weer mislukt) niet nemen. Mocht er nou wel een groot voordeel zijn dan overweeg ik t eventueel. Wat is jullie opinie hierover?

Offline woteb

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #11 Gepost op: 2009/02/10, 22:24:40 »
Daarover zullen de meningen verdeeld zijn. Zelf heb ik met de Ubuntuversies van oktober altijd last, terwijl de versie van april geen problemen hebben. Op andere systemen is het omgekeerd. Maar als jouw Hardy goed werkt, waarom veranderen? Hardy (8.04.2 LTS) wordt sowieso drie jaar ondersteund, en Intrepid (de 8.10) maar de helft. wanneer Intrepid na anderhalf jaar wordt stopgezet, kun je met Hardy nog een jaartje extra doorwerken.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #12 Gepost op: 2009/02/10, 22:25:10 »
Nee, nee, Ik raad u persoonlijk af van een upgrade te doen naar 8.10. Er zullen wel zaken van de 8.04 blijven staan, maar er zullen ook zaken van de 8.10 erbij komen die toch conflikt kunnen veroorzaken zoals je eerst met de 8.10 gehad hebt. De 8.04 is tenslotte de LTS (Long Term Support) en je krijgt 3 jaar ondersteuning. Met 8.10  krijg je maar 1,5 jaar ondersteuning. Als alles goed werkt blijf je het best bij de 8.04. De tussentijdse versies zoals 8.10 werken met andere/nieuwere kernels van Linux en dat zijn versies die men maakt om verder te kunnen bouwen en dan weer een LTS te kunnen maken zodat men weer een stabiele versie heeft om de 2 jaar. Waar je dan weer 3 jaar ondersteuning voor krijgt.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Zoveelste dualboot probleem
« Reactie #13 Gepost op: 2009/02/10, 22:28:36 »
Doe regelmatig wel eens een backup van foto's, documenten enz... op een externe schijf, als er ooit iets misgaat, en je eens een herinstall moet doen, red je zo al je belangrijke bestanden. Ook je /home/username kan je backuppen en de verborgen bestanden van .mozilla enz...

unXpected

  • Gast
Re: Zoveelste dualboot probleem
« Reactie #14 Gepost op: 2009/02/10, 23:50:07 »
Primaprima! Allemaal duidelijk en probleem opgelost! Bedankt