Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] wit scherm na aanmelden in ubuntu 8.04.2  (gelezen 1164 keer)

Offline winkbuul

  • Lid
  • Steunpunt: Nee
[OPGELOST] wit scherm na aanmelden in ubuntu 8.04.2
« Gepost op: 2009/02/04, 00:35:49 »
Na kernel update  2.6.24-23 krijg ik na het aanmelden een wit scherm. Als ik een sessie in Gnome-veilige modus start treedt dit probleem niet op. Tijdens de update is een nieuwe menu.lst aangemaakt waarbij de root-verwijzing is gewijzigd in (hd0,5). Dit heb ik hersteld - en voor de toekomst hopelijk voorkomen door in de default kernel options de default grub root device te wijzigen in groot=(hd0,6)

Heeft iemand een verklaring of misschien zelfs een oplossing of is hier sprake van een (nieuwe) bug? Ik vermoed van wel want zie topic http://forum.ubuntu-nl.org/index.php/topic,34842.0.html en bugreport 302966 (betreft weliswaar kernelupdate 2.6.24.22)
« Laatst bewerkt op: 2009/02/07, 00:42:52 door winkbuul »

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
Re: wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #1 Gepost op: 2009/02/04, 02:41:00 »
Ik heb er geen last van, heb dan ook aangegeven dat Ubuntu van de GRUB af moest blijven, toen hij vroeg wat hij met menu.lst moest doen. Ik heb deze namelijk ge-edit zodat Windows XP de standaard is, en dat wilde ik even zo houden zodat mijn pa er nog "probleemloos" op kan als mijn weekend-pc voor hem als reservist zou moeten dienen (de zijne is 7 dus je weet waar nooit). Ik koos dus voor "gebruik huidige" en heb dat akkefietje dus niet.
Hoe het zit met mijn 8.10 installatie op mijn studentenkamer-pc weet ik even niet meer ('t is erg laat op dit moment), als het goed is heb ik die vraag daar ook tijdens een update gehad en heb ik (ditmaal zonder speciale reden) dezelfde keuze gemaakt.

maar ik kan me voorstellen dat dat een "gevaarlijk" punt was voor mensen die niet bekend zijn met menu.lst (wat het is etc.)

Offline winkbuul

  • Lid
  • Steunpunt: Nee
Re: wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #2 Gepost op: 2009/02/05, 22:13:16 »
...inmiddels heeft zich nog een ´wijziging´ geopenbaard: mijn ntsf-partities (WindowsXP) die in de vorige versie probleemloos waren te benaderen via lokaties, zijn nog steeds zichtbaar maar niet te ´mounten´. In plaats daarvan krijg ik de foutmelding ´kan volume niet aankoppelen´. Na enig zoekwerk op diverse ubuntufora lijkt de oplossing te liggen in een aanpassing in fstab. Dat ga ik eerst maar 's proberen...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #3 Gepost op: 2009/02/05, 22:22:59 »
Tijdens de update is een nieuwe menu.lst aangemaakt waarbij de root-verwijzing is gewijzigd in (hd0,5). Dit heb ik hersteld - en voor de toekomst hopelijk voorkomen door in de default kernel options de default grub root device te wijzigen in groot=(hd0,6)
Als er (hd0,5) staat dan staat ubuntu op sda6, let daarmee op voor je dat veranderd, Want als jij dat in: root/(hd0,6) dan betekend dat dat ubuntu op sda7 staat.
Tik eens in de terminal:
sudo fdisk -lEn post hier de uitkomst.

Offline winkbuul

  • Lid
  • Steunpunt: Nee
Re: wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #4 Gepost op: 2009/02/06, 23:00:59 »
...daar heb ik al rekening mee gehouden, heir4c! Ik heb drie (2) Ubuntu-partities ext3 en een swap-partitie: /dev/sda6 is de /home partitie, /dev/sda7 de / partitie (root) en /dev/sda8 de swap - ik weet het een ongebruikelijke volgorde ;)

Thanks anyway

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #5 Gepost op: 2009/02/06, 23:08:22 »
graag gedaan, en ja ongebruikelijk  :)
en misschien eens windows terug opstarten en nog eens goed afsluiten misschien daardoor dat die partities niet kunnen mounten. (?)

Offline winkbuul

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #6 Gepost op: 2009/02/07, 00:53:03 »
...alvorens tot drastischer maatregelen over te gaan, heb ik de PC opnieuw gestart in Windows...geen probleem. Daarna opnieuw gestart in Ubuntu en zie:... de NTFS-partities zijn weer zonder problemen te benaderen via "Lokaties". Wat mij opvalt: rond het tijdstip van de reboot is het bestand mtab gewijzigd; helaas heb ik de oude versie niet gesaved, maar mi zijn de volgende twee regels toegevoegd:

/dev/sda5 /media/Data fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sda1 /media/Programs fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] wit scherm na aanmelden in ubuntu 8.04.2
« Reactie #7 Gepost op: 2009/02/07, 01:57:36 »
Blij te horen dat het opgelost is. En thx voor het posten ervan.