Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] geen geluid HP dv7-1199ed (64bits Ubuntu, Intel Corporation ...)  (gelezen 6397 keer)

Offline canti

  • Lid
  • Steunpunt: Nee
Beste mede-ubunters,

Ik weet dat er meerdere malen een topic hierover zijn verschenen, maar de daarin aangedragen oplossingen werken niet. Vandaar dit nieuw topic.

Het gaat om hp dv7-1199ed met 64bits processor. Het loopt op 64bits Ubuntu 8.10, werkt heerlijk soepel. Alleen is er dus geen geluid :(. Het geluid werkt wel onder Vista, dus het ligt niet aan hardware op zich. Laptop heeft een Intel Corporation 82801I ICH9 Family HD Audio Controller (rev03), met als codex Generic 10de IO 6. De methode van Pjotr mbt deze Intel Corporation card (zie punt 7 van http://sites.google.com/site/computertip/geengeluid) biedt geen soelaas, evenals punt 6 voor hda intel kaarten. Het werkt ook niet als ik in dat punt 6 het woord "auto" vervang door "hp" of door "hp-m4" zoals sommige sites suggereren. Ook het laatste redmiddel, het installeren van OSS, helpt niet.

Het zou heel fijn als Ubuntu geluid kan geven. Anders is het een zonde van geluidskaarten en speakers van de nieuwe laptop... Hopelijk kan iemand mij helpen.

canti
« Laatst bewerkt op: 2009/03/16, 20:34:43 door canti »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Hallo canti, zou je de uitkomst kunnen posten van lspci | grep -i audio en cat /proc/asound/* 2>/dev/null in een terminal? Kopiëren en plakken gaat met resp. shift+ctrl+c en shift+ctrl+v in een terminal.

Offline canti

  • Lid
  • Steunpunt: Nee
Ik zit momenteel op mijn werk (jawel, ik kijk ook op het werk af en toe op het Ubuntu-forum, wie doet dat nou niet?). Vanavond kan ik hier de uitkomst posten als ik thuis ben. Ben benieuwd wat je ervan zegt.

Tot vanavond!

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
 ^-^
Is goed, ik wacht het af. Werkze!

Offline canti

  • Lid
  • Steunpunt: Nee
Hier ben ik weer. grep-commando geeft: 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

En cat-commando:
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdf300000 irq 2294
  2:        : timer
  3:        : sequencer
  4: [ 0- 1]: digital audio playback
  5: [ 0- 0]: digital audio playback
  6: [ 0- 0]: digital audio capture
  7: [ 0]   : control
 0 snd_hda_intel
00-01: STAC92xx Digital : STAC92xx Digital : playback 1
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 2
G0: system timer : 4000.000us (10000000 ticks)
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
P0-0-3: PCM capture 0-0-3 : SLAVE
P0-1-0: PCM playback 0-1-0 : SLAVE
Advanced Linux Sound Architecture Driver Version 1.0.17.

Heb je daar wat aan?

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Jup. Je hebt exact dezelfde geluidschipconfiguratie als mijn notebook (een HP DV7-1070). Ik heb wel geluid onder 8.10 64-bits na het toevoegen van options snd-hda-intel enable_msi=1 in /etc/modprobe.d/alsa-base.

Offline canti

  • Lid
  • Steunpunt: Nee
Dat had ik al gedaan, aan de hand van de befaamde computertip van Pjotr (zie mijn eerste bericht). Er is helaas nog geen geluid. Vast een kleinigheid ergens, maar waar?

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Kun je de inhoud van je /etc/modprobe.d/alsa-base bestand posten?

Offline canti

  • Lid
  • Steunpunt: Nee
Ik ben weer op mijn werk. Vanavond post ik het hier. Alvast bedankt voor je geduld!

canti

Offline canti

  • Lid
  • Steunpunt: Nee
Hierbij output van /etc/modprobe.d/alsa-base:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel enable_msi=1

Hopelijk zie je daar een afwijking in.

Groetjes,
canti

Offline canti

  • Lid
  • Steunpunt: Nee
Kan iemand misschien me helpen? Ik heb output van /etc/modprobe.d/alsa-base geplaatst. Ziet iemand hier een of andere afwijking waardoor ik geen geluid heb? Sinds de aankoop van mijn laptop een week geleden heb ik nog geen geluid, het wordt onderhand wat saai... Alle hulp is welkom!

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Hallo canti, dan wordt het schuifjes checken, het zou moeten werken namelijk.
Kun je screenshots plaatsen van System - Preferences - Sound (Sound Preferences) en van alsamixergui -c0 (opstarten via terminal)?

KingKong65

  • Gast
Beste Canti

Ik ben een Ubuntu-nieuweling en heb zelf problemen gehad met het geluid.

Bij volgende topic vond ik de oplossing:

http://forum.nedlinux.nl/viewtopic.php?id=26893

Het antwoord van Arjan...


Als je 2 geluidskaarten hebt, bijvoorbeeld 1 onboard en 1 pci kaartje, dan kan het zijn dat ubuntu de verkeerde kiest, waardoor je niets hoort.

Als dit misschien het probleem is kan je dat als volgt oplossen:

type in de console:

sudo asoundconf list

Dan krijg je een lijstje met de geluidskaarten die gevonden worden:

(Bijv:)

Names of available sound cards:
Live
V8237

Dan stel je er een in als default met het volgende commando (hier stel je dus de Live kaart in als voorbeeld)

sudo asoundconf set-default-card Live


Ik heb de 2 getest en bij één ervan had ik geluk, kon ik op you tube etc. weer clipkes bekijken met geluid.
Wel Mozilla afsluiten en opnieuw openen na de verandering.

Hopelijk heb je hier iets aan.
Succes.

mvg
KingKong




Offline canti

  • Lid
  • Steunpunt: Nee
Hierbij de gevraagde screenshots.

KingKong65, volgens sudo asoundconf list heb ik één geluidskaart, en wel Intel. Maar toch bedankt, jouw insteek wordt niettemin zeer gewaardeerd!

canti
« Laatst bewerkt op: 2009/02/07, 16:33:06 door canti »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Bedankt canti, maar graag nog even een screenshot posten van System - Preferences - Sound (Sound Preferences) of gnome-sound-properties in een terminal.
Ik zie niks vreemds, ja je digital mic staat voluit, die zou ik wat lager of helemaal uitzetten.

Offline canti

  • Lid
  • Steunpunt: Nee
Hierbij screenshot van gnome-sound-properties

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Van autodetectie afhalen en alles op ALSA zetten. Mixer apparaat moet op HDA Intel staan.

Offline canti

  • Lid
  • Steunpunt: Nee
Noppes, zelfs na een herstart. Vreemd. Onder windows was er wel geluid, dus het ligt niet aan geluidskaart, vermoed ik. Ik weet ook niet waarom er bij Autostatic wel geluid is en bij mij niet, ondanks dezelfde geluidskaart. Zucht... Maar we gaan de moed niet verliezen en gaan door tot we een oplossing hebben gevonden! Weet iemand wellicht wel een mogelijke oplossing?

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
En als je het met een live CD probeert van 8.04 of 8.10?

Offline canti

  • Lid
  • Steunpunt: Nee
Vanaf Live -CD Ubuntu 8.10 is er wel geluid bij het testen van systeem - voorkeur - geluid. Opmerkelijk genoeg wel. Vanaf geïnstalleerde versie van dezelfde Ubuntu 8.10 dus niet. Wat is het verschil? Zit daar niet de oorzaak?

AutoStatic, overigens sorry als je zolang moest wachten op mijn reactie, ik moest tijd verdelen tussen mijn zoontje van anderhalf maand, mijn vrouw, computer, werk, studie. Zucht... Als je geduld hebt, dank je wel!

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Hé canti, je hoeft je niet te verontschuldigen hoor!
Maar het geluid werkt met een live CD dus wel. Dus is het toch een instelling ergens kennelijk. Als je een nieuwe user aanmaakt, had je dat al geprobeerd, heeft die wel geluid? En aangezien in de /etc/modprobe.d/alsa-base van de live CD geen options enable_msi=1 staat zou je die weer uit kunnen commenten (# ervoor).

Offline canti

  • Lid
  • Steunpunt: Nee
Op aanwijzingen van AutoStatic heb ik new user toegevoegd met als resultaat: geen geluid. Bij het testen van geluid in systeem - voorkeuren - geluid komt wel een foutmelding die hier als bijlage is weergegeven. Op de andere aanwijzing door in de hoofdgebruiker de regel options enable_msi=1 uit te schakelen: dat geeft in systeem - voorkeuren - geluid ook dezelfde foutmelding. Ik kon deze foutmelding in beide gevallen overigens niet gemakkelijk uitzetten door op de sluit-knop te drukken, dat moest via systeemmonitor gebeuren. Het weer in gebruik stellen van de regel options enable_msi=1 levert geen foutmelding meer op. De regel is dus wel noodzakelijk. Maar nog geen geluid dus, noch in de huidige hoofdgebruiker, noch in de toegevoegde gebruiker.

Vreemd dat het in live-cd wel werkt... Hopelijk brengt mijn bevindingen op jouw nieuwste aanwijzingen je wel verder. Ben benieuwd.

canti

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Als het met de Live CD wel werkt zou ik weer met de Live CD starten en de geluidsinstellingen nagaan en eventueel screenshots maken of opschrijven (van alsamixergui en gnome-sound-properties). Daar moet het gewoon aan liggen.
En als je bijv. aplay /usr/share/sounds/login.wav in een terminal doet, wat gebeurt er dan?

Offline canti

  • Lid
  • Steunpunt: Nee
Hoi Autostatic,

Ik heb de instellingen in live-cd overgenomen in de huidige instellingen. Helaas zonder resultaat. In live-cd was de bekende regel options enable_msi=1 niet nodig en de geluidstest in gnome sounds properties verliep vlekkeloos en met geluid. Een andere afwijking t.o.v. huidige sessie is dat device binnen gnome sounds properties een andere apparaat geselecteerd was: capture: ALSA PCM on front 0 (STA92xx etc.) in plaats van HDA Intel in de huidige sessie.  Dat zijn dus de twee verschillen.

Overigens, jouw suggesties om aplay te gebruiken levert geen soelaas op, en tot mijn verrassing ook niet op live-cd. Als ik in de huidige sessie dit wil doen met weglating van de options enable_msi=1 regel, dan levert dat de volgende foutmelding op:

aplay /usr/share/sounds/card_shuffle.wav
Playing WAVE '/usr/share/sounds/card_shuffle.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
ALSA lib pcm_pulse.c:625:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

aplay: set_params:1015: Unable to install hw params:
ACCESS:  RW_INTERLEAVED
FORMAT:  S16_LE
SUBFORMAT:  STD
SAMPLE_BITS: 16
FRAME_BITS: 32
CHANNELS: 2
RATE: 44100
PERIOD_TIME: 125000
PERIOD_SIZE: (5512 5513)
PERIOD_BYTES: 22050
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 22050
BUFFER_BYTES: 88200
TICK_TIME: [0 0]

Zucht... Ik weet niet waarom in live-cd de options regel niet nodig was en in de huidige sessie wel, zelfs met de instellingen die van de live-cd zijn overgenomen. Heel gek allemaal... Ik ben blij dat er ubuntero's zijn die veel geduld hebben! Uiteindelijk komen we er samen uit! Het moet gewoon lukken!

canti

Offline canti

  • Lid
  • Steunpunt: Nee
Niemand? Te lastig probleem? Kan ik misschien naar een steunpunt in de buurt gaan met mijn laptop? Of is dat niet de bedoeling? Ik woon in ieder geval in Delft.

canti