Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Installatie wil niet werken op raid1 met windows  (gelezen 1685 keer)

spookeend

  • Gast
Installatie wil niet werken op raid1 met windows
« Gepost op: 2009/02/03, 09:47:26 »
Goedendag.

Nadat mijn oude pc dusdanig vervuild was, is windows eraf gegaan, en ben ik met linux varianten aan de slag gegaan. Na het een en ander geprobeerd te hebben, is het bij Ubuntu gebleven. Een kleine maand mee gewerkt (nieuwe pc was besteld) en op 1 programma na wat ik veel gebruikte onder windows, werkte alles beter, sneller en lekkerder dan onder windows. Even ter verduidelijking, Windows stond dus niet meer op die pc.

Omdat ik een aantal maal gedoe heb gehad met HDD's die stukgingen, heb ik bij mijn nieuwe pc gekozen voor een RAID1 configuratie. Zodat bij hardware problemen er in ieder geval geen data verloren zou zijn. Dit omdat ik nogal wat werk en hobby met de pc. Omdat ik voor flash bewerking geen alternatief kon vinden onder ubuntu, heb ik op mijn nieuwe pc weer windows XP laten plaatsen. Echter, ik heb op mijn oude pc een manier gevonden om toch een flash programma te laten draaien, namelijk met Wine.

Nu wilde ik de ubuntu naast windows laten draaien, maar hoe ik ook installeer, na installatie kan ik niet bij Ubuntu komen. Er wordt een dual boot scherm getoond, maar ik krijg dan een dos scherm, waar ik opdrachten in kan geven, maar starten doet ubuntu niet. Als ik Ubuntu van de cd opstart, dan werkt alles wel, maar dan draait het om het raid systeem heen. Dus, ik kan dan gewoon bij beide schijven komen, zonder dat de raid gebruikt wordt zeg maar.

Mijn computer vaardigheden beperken zich voornamelijk tot het gebruik van programma's en ik kom er nu eigenlijk niet verder mee zo.
Ik heb het NL en Engelstalig forum doorgespit, maar kom er eigenlijk niet uit hoe ik dit nu eens kan laten werken zoals ik wil. Ik heb er geen bezwaar tegen om op den duur Windows helemaal kwijt te raken, maar voor nu, zou ik een dual boot wel prettig vinden.

Groeten Spookeend

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Installatie wil niet werken op raid1 met windows
« Reactie #1 Gepost op: 2009/02/03, 11:26:41 »
Softwarematige RAID schijnt sowieso niet veel rendement op te leveren. Noch qua snelheid, noch qua bescherming tegen gegevensverlies. Overweeg eens om RAID uit te schakelen in het BIOS?

Voor het voorkómen van gegevensverlies kun je beter een externe USB harde schijf gebruiken, en daar wekelijks je gegevens op kopiëren. Dat is de veiligste oplossing.

Offline ruujan

  • Lid
  • Steunpunt: Nee
Re: Installatie wil niet werken op raid1 met windows
« Reactie #2 Gepost op: 2009/02/03, 12:44:51 »
Software RAID wordt afgehandeld door het OS op een voor elk OS specifieke manier. Een RAID onder Windows is dus voor Linux gewoon twee disks. Omgekeerd kan ook Windows niks met een Linux Raid.
Hardwarematige RAID wordt door de controller (hardware) gedaan. Het OS dat er op gezet wordt heeft dan helemaal geen weet van het feit dat er twee of meer schijven zijn. Hij ziet er maar één. Voor dit soort controllers heb je dan meestal een speciaal stuk software nodig om de Raid te beheren. Bij Compaq servers heet dat bijvoorbeeld ACU.

Hardware RAID is dan ook een stuk prijziger, want behalve een extra schijf heb je ook een speciale controller nodig.

Er zijn echter ook mengvormen van die twee. Je hebt dan een controller die in samenwerking met een speciale driver de Raidfunctionaliteit verzorgt. Ook hierbij zul je waarschijnlijk problemen hebben als je verschillende OS'sen gebruikt. Ik vermoed dat jouw Raid ook op deze manier is uitgevoerd. Hardware is duur  en XP ondersteunt volgens mij alleen software raid als je de registry hackt.


spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #3 Gepost op: 2009/02/03, 12:48:53 »
Ik heb al een 1 TB WD Extern. Omdat ik het dus niet zelf heb ingesteld, niet voldoende kennis van, wat gebeurt er met mijn systeem en data als ik de raid uitschakel in de BIOS. Ik weet hoe ik er kan komen enz, maar wat zijn de consequenties?

Ik heb al eerder een HDD kapot gehad met dit systeem, en dat is netjes in de garantie vervangen, maar ik heb nu wel soms dat de pc erg traag is omdat de data gecontroleerd wordt, of er op beide schijven hetzelfde staat ed.

Van wat ik begrepen heb, heb ik inderdaad de variant hard en software. Er zit een raid controller op het moederboard. En een programma, intel raid storage console die mij verteld wat wanneer gebeurt enz.

Gaat nu het verhaal nog op van de raid uitzetten in de Bios?

Ik heb dus 2 keer een TB hdd, die wordt gezien als 1, en ook nog ergens is verdeeld in 2. Ik zie dus 2 hdd's, beide zeg 500 gb, maar dan wel verdeeld over 2 schijven van 1TB

Excuses voor mijn leek uitleg, ik hoop dat er wat van te maken valt.

kleine update :

Nog eens even aan het checken geweest, en de installer van Ubuntu ziet wel de raid config. Als ik de live demo draai niet.
Installeren gaat goed, ik kan de partitie kiezen die ik wil, dus, na de raid. De installer ziet 2 schijven, C en D, en de grootte van deze schijven klopt met de windows partities die ik dus al heb onder windows.

Als ik dan installeer op de C of D schijf, gaat alles goed, en komt de install ook op de gekozen partitie. Na het voltooien van de install, begint de install van grub. Volgens mij gaat het daar mis. Ik kan dan niet ubuntu opstarten, wel kiezen, maar krijg dan het eerder genoemde dos scherm met invoer opties. Echter, niets lijkt een actie uit te voeren. De meldingen varieren.

Als ik dan windows start, vind ik de ubuntu folder op de schijf die ik geselecteerd heb voor de install. Ik kan m echter ook niet verwijderen met de un-install functie. Alleen door de folder te verwijderen en het register aan te passen vedwijnt het dual boot scherm.
« Laatst bewerkt op: 2009/02/03, 18:13:43 door spookeend »

spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #4 Gepost op: 2009/02/04, 20:11:22 »
Alle data op de schijven maar veiliggesteld, en de raid eens uitgezet.
Resultaat, geen HD meer te vinden in de pc. Dus, kan ook niet opstarten. Raid weer aangezet, reboot, en alsof er nooit iets gebeurt is start de pc gewoon weer op.

Hoe gaat een en ander als je Ubuntu dan IN windows installeerd? Ik heb het geprobeerd, maar loop tegen dezelfde problemen aan met (volgens mij) grub daarna. De pc kan Ubuntu niet opstarten, blijft vastzitten in het dos scherm.

Groeten Spookeend

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: Installatie wil niet werken op raid1 met windows
« Reactie #5 Gepost op: 2009/02/04, 20:18:25 »
spookeend

misschien kan je wat met de info die onderstaande link geeft:

Creating A Dual-Boot System On RAID10 (Ubuntu/Windows)
Gestopt als aktief Forumlid 17/10/2011

spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #6 Gepost op: 2009/02/04, 21:27:20 »
Dat ziet er, uhm, uitdagend uit, voor mij dan.

Maar goed, worth a try, denk ik dan maar, kan hooguit misgaan, toch?

Bedankt

spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #7 Gepost op: 2009/10/27, 22:48:06 »
Ok, lang geleden, maar toch weer verder.

Ik kom er zelf niet uit, dus maar hulp ingeroepen van een steunpunt. Zaterdag AS is D-Day voor de huidige pc.

Het zou een Dual-Boot moeten worden, beetje vanwege gamen, gameconsole zit er ff niet in, en, toch windows omdat onze zoon (net 5) ook al pc les krijgt op school, en toch zo nu en dan een discje meekrijgt met gekkigheid. Plus het feit dat ik nu nog niet meteen wil beginnen met hem leren om te gaan met 2 verschillende besturings-systemen........

Ik hoop zo dat ik nu eens lekker kan surfen, websites kan beheren, bouwen etc zonder dat windows exploren eruit knalt..............

Greatnix Spookeend

spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #8 Gepost op: 2009/11/01, 00:31:41 »
Hier steunpunt vpr op de account spookeend,

met de alternate cd geinstalleerd omdat de desktop geen raid schijven herkende.
na install herstart, en 2 harde schijven (.11 kernell) (moet ook 2 hd;s zijn, raid 1, 2 parties)
Update naar kernell .16

Herstart, geen raid, 4 parties, (2 keer op 2 schijven, normaal raid, 1 x 2 schijven)
Herstart, geen raid, geen schijven.
Startup manger geinstaleerd, 4 schijven.
Start up terug naar kernell .11, 3 schijven. Feitelijk niet mogelijk, maar wel alleen dat zichtbaar.
Start up manager terug naar .16, gedeinstalled, reboot

geen raid en geen HD's (alleen linux partie)

Na zoeken de volgende link gevonden
De gedachte is dat het iets kleins en simpels moet zijn, maar wat precies? Iemand?

Groeten stp VPR.......



Spookeend wacht ook op antwoord, voorlopig blij met de dual boot, want dat werkt nu nog gewoon.

Groeten Spookeend

Offline ertai

  • Lid
    • programming
    • http://www.ertai.nl
  • Steunpunt: Nee
Re: Installatie wil niet werken op raid1 met windows
« Reactie #9 Gepost op: 2009/11/01, 00:58:20 »
je zegt dat hij nu dualboot is.. maar je eindigd je lijstje met alleen linux-partitie. Hoe bedoel je dat? Je kan alleen /dev/sda1 zien?
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #10 Gepost op: 2009/11/01, 10:40:22 »
Goedenmorgen......

PC opgestart, meteen maar in windows om te zien wat er aan antwoorden was.
Nou ja, toch maar een restart naar Ubuntu, en, geloof het of niet, ik werk nu in de raid...... Alles zichtbaar en werkbaar zoals het zou moeten zijn.
Ik ga nu even wat kloten, opslaan op de schijven, en straks in windows even zien of dat het ook echt is opgeslagen.

Mocht dit niet zo zijn, dan gaat onder windows de storage maneger meteen aan de slag, omdat er dan op de ene raid schijf wel, en op de andere niet nieuwe data geplaatst is, dus dan weet ik of het echt werkt..........

Groeten Spookeend (Under Ubuntu)
« Laatst bewerkt op: 2009/11/01, 10:43:24 door spookeend »

Offline chris.

  • Lid
    • http://www.linuxmintusers.be
  • Steunpunt: Nee
Re: Installatie wil niet werken op raid1 met windows
« Reactie #11 Gepost op: 2009/11/01, 10:44:35 »
je zou bijna denken dat het een citroën is met dit vage gedrag =D


spookeend

  • Gast
Re: Installatie wil niet werken op raid1 met windows
« Reactie #12 Gepost op: 2009/11/01, 10:53:20 »
Goed, ik kan dus onder Ubuntu alles zien, ik kan alleen de home folder en mijn externe HD benaderen

Wil ik naar 1 van de Windows raid schijven, dan zie ik ze dus wel, maar ik heb geen toegang. Vraagt om wachtwoord, en dan gewoon, cannot mount volume, tot ziens, fijne dag nog..........

Heeft iets te doen met System policy, maar wat?

En bijna een Citroen, helemaal waar, alleen is de mijne vaak met ijzerdraad en ducktape wel thuis te krijgen..........

# Edit :

Ok, na nog eens rebooten, geen schijven meer te zien in Ubuntu, alleen de Home schijf (partie) waarop Ubuntu staat. Dit is zo in beide kernells....
Windows starten, afsluiten, wel raid te zien in Ubuntu (beide kernells) maar niet benaderbaar. Ubuntu als eerste opstarten, geen schijven van de windows raid te zien in Ubuntu.

Dus, kort, als ik windows eerst opstart, dan reboot naar Ubuntu, dan is het allemaal zichtbaar, maar niet werkbaar.
Begin ik in Ubuntu als eerste, dan is er niets zichtbaar.
« Laatst bewerkt op: 2009/11/01, 12:02:00 door spookeend »