Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hoe username+password verplicht te stellen in postfix SMTP?  (gelezen 2938 keer)

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Hoe username+password verplicht te stellen in postfix SMTP?
« Gepost op: 2009/01/30, 16:36:20 »
Ik heb thuis een server draaien met postfix, dovecot (imap) en squirrelmail, geinstalleerd met behulp van deze tutorial: https://help.ubuntu.com/community/MailServer
Alles werkt prima, ik kan mail versturen en ontvangen.
Nu is het zo dat ik voor mail ontvangen een username en password moet ingeven in mijn mailclient, maar voor versturen niet. Dat lijkt me nogal onveilig! Voor de veiligheid heb ik poort 25 maar even dichtgegooid op mijn router.
Hoe kan ik er voor zorgen dat voor het versturen van mail via mijn server om een wachtwoord en username gevraagd wordt? Het liefst gewoon de UNIX-credentials, want die worden ook gebruik om mail te lezen.
Ik hoop dat ik het zo duidelijk genoeg omschreven heb.
Alkvast bedankt voor de reacties!

Offline sniper_david

  • Lid
    • http://www.computer-team.info
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #1 Gepost op: 2009/01/30, 16:41:55 »
Hoi,

Als ik me niet vergis kunnen alleen de users die in de postfix database vermeld staan mails verzenden.
Of je nu gebruik maakt van sql of ascii-files, speeld daarbij geen rol.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #2 Gepost op: 2009/01/30, 16:52:15 »
Dank voor je reactie.

Hoe krijg ik dit voor elkaar? Ik heb al zitten zoeken, maar een duidelijke howto of tutuorial kan ik niet direct vinden...
Alvast bedankt!
« Laatst bewerkt op: 2009/01/30, 18:22:23 door w.d »

Offline sniper_david

  • Lid
    • http://www.computer-team.info
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #3 Gepost op: 2009/01/30, 19:12:42 »
De tuts zijn inderdaad wat slecht beschreven en niet heel duidelijk.
Maar ik denk dat men het extra ingewikkeld wil houden, zodat niet iedereen een eigen mail-server gaat beginnen.

Je kan zonder problemen de tuts gebruien voor debian-etch.

Hieronder enkle links die ik gebruikte voor mijn postfix configuratie

http://workaround.org/articles/ispmail-etch/
https://help.ubuntu.com/community/PostfixVirtualMailBoxClamSmtpHowto    <--- vooral deze hier

Bijkomende Dovecot,spamassassin,pyrazor

Ikzelf maak niet gebruik van een sql-databank.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #4 Gepost op: 2009/01/30, 19:49:55 »
Bedankt voor deze tutorials!
Jammer dat er niet een korte howto bestaat, tenminste, ik heb hem nog niet gevonden.
Mijn huidige mailserver werkt prima, en voldoet aan mijn eigen gebruiksgemak. Het zou mooi zijn als ik door enkele simpele handelingen uitgaande mail zou kunnen authenticeren.
Ik ga het eens doorneuzen, en ik hou me aanbevolen voor andere interessante tips en tutorials.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #5 Gepost op: 2009/01/30, 21:06:18 »
Ik denk dat je in deze howto alles vind wat je hartje begeert:
http://www.hetlab.tk/artikelen/StratoMailserver
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #6 Gepost op: 2009/01/30, 22:45:26 »
Ik kom er helaas niet uit. Nu slapen, morgen weer verder klooien! ;-)

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #7 Gepost op: 2009/01/30, 23:05:28 »
Ik vond deze heel hulpvol:

http://flurdy.com/docs/postfix/

Groeten John.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #8 Gepost op: 2009/01/31, 14:10:24 »
Ik ben nu deze tutorial aan het volgen: https://help.ubuntu.com/community/PostfixCompleteVirtualMailSystemHowto
Bij het stukje over PostfixAdmin loop ik vast. Ik heb het geinstalleerd, de setup verloopt goed, en dan wil ik inloggen. Maar met welke username en password?
postfix@localhost?
postfixadmin@localhost?
En welk wachtwoord? Mijn postfix-wachtwoord of mijn root wachtwoord?
Ik kom er niet uit!
Alvast bedankt voor de tips!

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #9 Gepost op: 2009/01/31, 20:47:15 »
Ik heb geen ervaring met postfixadmin, maar ik zou denken met je username@domein.nl oid.
Je kunt ook proberen met phpmyadmin rechtstreeks in de database users etc. toe te voegen.
Werkt ook en net zo snel.

Succes.

John.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #10 Gepost op: 2009/02/04, 14:51:11 »
Ik heb inmiddels 5 verschillende tutorials geprobeerd, maar niet een werkte zoals ik het wil.
Helaas, ik heb de moed opgegeven! Dan maar zonder mailserver...

Allen bedankt voor het meedenken!

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #11 Gepost op: 2009/02/05, 21:34:13 »
Niet zo snel opgeven!!
Wel een zeer raadzame tip, volg slechts 1 turtorial, en volg bij iedere stap je syslog.
Er staat veel informatie in die je kan helpen je fouten op te sporen.
Vaak liggen de fouten in permissies, of dat je net een file op een andere plek hebt staan.
pHpmyadmin is een mooie tool als je tenminste een postfix mailserver opzet met virtuele gebruikers.
Volg deze maar eens:
http://workaround.org/articles/ispmail-sarge/
Neem ook de tijd om de configuratie ook voor jouw goed te tweaken/aanpassen.
Het opzetten van een beetje veilige mailserver heeft wel een paar uurtjes nodig.

Succes!

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #12 Gepost op: 2009/02/06, 13:57:54 »
Dank Johnno40, voor je bemoedigende woorden. Ik ga het dit weekend weer een keer proberen en rapporteer hier hoe het er voor staat!
Groet,

W.D

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #13 Gepost op: 2009/02/06, 22:40:16 »
Zo wil ik het zien.
Succes!!
Mocht je tegen problemen aanlopen dan post ze maar, kunnen we altijd zien of er nog hulp geboden kan worden.
Probeer ook een tweede shell sessie te openen en met het commando tail -f /var/log/syslog kun je gelijk zien of er iets niet lekker loopt.

Postfixadmin heb je niet echt nodig, je kunt via phpmyadmin ook users en domeinen toevoegen met een beetje oefenen lukt dat makkelijk!

Mocht je het helemaal makkelijk willen hebben:
http://www.tummy.com/Products/vpostmaster/autoinstall.html

Ik heb alleen totaal geen ervaring in de veiligheid in het systeem, ik vind het zelf onder controle hebben van mijn eigen mailservertje zelf leuker.

Succes  :D

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #14 Gepost op: 2009/02/08, 14:15:25 »
Helaas werkt het nog steeds niet zoals ik het graag zou willen. Ik heb alle stappen van de tutorial (http://workaround.org/articles/ispmail-sarge/) doorlopen, maar mijn smtp-client (Thunderbird) geeft 'relay acces denied'. Ook via mijn iPhone werkt verzenden via mail.mijndomein.nl niet. Verzenden zonder gebruikersnaam en wachtwoord werkt wel. En dat wilde ik juist niet!
Ik wil graag dat je een gebruikersnaam en wachtwoord nodig hebt om via mail.mijndomein.nl te kunnen versturen!
Heeft iemand een idee wat ik verkeerd doe?
« Laatst bewerkt op: 2009/02/08, 14:36:23 door w.d »

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #15 Gepost op: 2009/02/08, 17:59:27 »
Het lijkt erop alsof je mysql database niet helemaal lekker lekker werkt.
Kun je een uitdraai maken van je /etc/postfix/main.cf en master.cf ?
(Laat wel aub je mailnaam en zo weg, voor het geval dat...)
Het feit dat je via aparte username en de testen wel kunt verzenden en via mysql niet geeft aan dat daar een probleem zit.
 
Kijk verder even direct in je syslog als je wat probeert en zet die er ook bij.

Verder FF onderzoeken of je provider "toevallig" poortje 25 niet blokkeert.
Dan lukt het versturen over het interne netwerk wel, maar voor mail buiten het netwerk werkt het dan niet.
Lukt het je bijvoorbeeld om een mail te sturen naar je eigennaam@provider.nl oid te versturen?

Johnno.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #16 Gepost op: 2009/02/09, 08:30:41 »
Ik zit nu op mijn werk en kan helaas niet inloggen op mijn server (ssh verkeer wordt hier geblokkeerd).
Ik kan in ieder geval van buiten mijn eigen netwerk mailen en mail ontvangen. Ik kan vanaf mijn werk inloggen op squirrelmail, en mail versturen en ontvangen. Met de imap-client op mijn iPhone kan ik vanaf mijn werk mail ontvangen. Versturen via mijn eigen smtp (op adres mail.mijndomein.nl) kan alleen als ik geen gebruikersnaam en wachtwoord opgeef. Een soort open relay dus, en ik vrees dat mijn provider dat niet leuk vindt!

Ik heb inmiddels in PHPMyAdmin meerdere testgebruikers aangemaakt, en ze werken allemaal.

Volgens mij wordt het aanmelden bij de smtp-server in dit (http://workaround.org/articles/ispmail-sarge/#authsmtp) gedeelte van de tutorial geregeld, of heb ik het mis? Ik heb die stappen exact gevolgd, en ik ben geen foutmeldingen tegen gekomen, ook niet in syslog.

Poort 25 wordt niet geblokkeerd, want ik kan vanaf buiten dus wel verzenden via mijn smtp, alleen zonder gebruikersnaam en
wachtwoord.

main.cf:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mijndomein.nl
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_atuh_enable = yes
broken_sasl_atuh_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key

master.cf:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#submission inet n       -       -       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
-o smtp_fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
retry     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}

Bedankt voor de hulp!
« Laatst bewerkt op: 2009/02/09, 16:42:33 door w.d »

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #17 Gepost op: 2009/02/09, 21:54:40 »
Eens even kijken:
master.cf:
alias_maps = hash:/etc/postfix/aliases
alias_destination = hash:/etc/postfix/aliases
mydestination = (leeglaten!!!)
relayhost = (eventueel je mailhost van je provider)
mynetworks = 127.0.0.0/8 192.168.1.0/24 (afhankelijk van je netwerk, IP-6 adressen kun je weglaten)

Probeer:
#virtual_transport = maildrop
virtual_transport = virtual

virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf (DEZE ONTBRAK !!!!)
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail

Main.cf

Maildrop kan soms problemen geven, maak je gebruik van de ingebouwde virtual transport werkt helaas de sorteerfunctie van maildrop niet, maar de rest verloopt prima.
Wil je het toch gebruiken probeer dan:

maildrop  unix  -       n       n       -       -       pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${user}@${nexthop} ${extension} ${recipient} ${user} ${nexthop}

Ben benieuwd.....

Succes..


Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #18 Gepost op: 2009/02/10, 17:53:50 »
Ik heb de aanpassingen die je voorgesteld hebt gemaakt, maar ik kan nog steeds mail versturen zonder gebruikersnaam en wachtwoord.
Helaas!
Ik ga denk ik ook op het engelstalige forum maar eens een bericht posten, kijken of daar iemand de oplossing weet.
Bedankt voor je hulp, Johnno, en mocht je nog iets weten dan houd ik me aanbevolen!
« Laatst bewerkt op: 2009/02/10, 20:22:43 door w.d »

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #19 Gepost op: 2009/02/10, 20:44:22 »
Hoi W.D.

Hoe heb je dit getest?
Wat komt er rond die tijd in je syslog te staan  ???

Een ander forum kan je ook verder helpen, geen probleem, maar probeer eerst de oorzaak te vinden.
Heel veel trial and error en vooral goed je syslog kijken.
Vaak helpt het te "googlen" op de zin die je dan krijgt in je syslog om de juiste oplossing te vinden.

Succes verder!

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #20 Gepost op: 2009/02/11, 07:55:13 »
Ik heb een nieuwe thread aangemaakt op het internationale ubuntu forum:
http://ubuntuforums.org/showthread.php?p=6714808

Ben benieuwd of er reacties komen.

johnno40

  • Gast
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #21 Gepost op: 2009/02/14, 14:07:54 »
Hoi W.D.

Ik zie dat je op het internationale forum ook niet heel veel verder komt.

Wat ik zie:
ontbreekt: virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf

Verder ben ik benieuwd op welke manier je dan de mail zonder zender verstuurd?!?
Heb je wel na de aanpassingen /etc/init.d/postfix reload gedaan, anders blijf je het met de oude configuratie proberen!

Verder is het wijs om als je verstuurd hebt even de regels uit je syslog (met betrekking tot je testmail) hier te plakken, dan kan ik even meekijken of ik zo wat zie.

Groeten,

Johnno.

Offline w.d

  • Lid
    • WTR-DK
  • Steunpunt: Nee
Re: Hoe username+password verplicht te stellen in postfix SMTP?
« Reactie #22 Gepost op: 2009/02/17, 11:33:29 »
Hoi,

Ben een paar dagen plat geweest ivm griep, hoop vanavond weer verder te kunnen knutselen!