Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: foutmelding glxgears  (gelezen 3802 keer)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Gepost op: 2006/09/24, 17:53:12 »
ik krijg een rare foutmelding als ik glxgears intyp in de terminal..
namelijk deze:

darell@bora:~$ glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
wat betekent dit?

mn videokaart heeft ie wel gewoon gevonden:

Section "Device"
        Identifier  "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Driver      "fglrx"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
        BusID       "PCI:1:0:0"
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #1 Gepost op: 2006/09/24, 18:02:26 »
En wat zegt het commando glxinfo|grep direct en fglrxinfo ?
En het commando cat /etc/X11/xorg.conf|grep Module -A 20
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #2 Gepost op: 2006/09/24, 18:14:25 »
glxinfo|grep direct:

darell@bora:~$ glxinfo|grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
fglrxinfo:

darell@bora:~$ fglrxinfo
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual!
cat /etc/X11/xorg.conf|grep Module -A 20:

Section "Module"
        Load  "bitmap"
        Load  "ddc"
        Load  "dri"
        Load  "extmod"
        Load  "freetype"
        Load  "int10"
        Load  "type1"
        Load  "vbe"
EndSection

Section "InputDevice"
        Identifier  "Generic Keyboard"
        Driver      "kbd"
        Option      "CoreKeyboard"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc11"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #3 Gepost op: 2006/09/24, 18:21:56 »
1. heb je de ati fglrx drivers ge
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #4 Gepost op: 2006/09/24, 18:36:34 »
apt-cache policy xorg-driver-fglrx geeft:

darell@bora:~$ apt-cache policy xorg-driver-fglrx
xorg-driver-fglrx:
  Installed: 7.0.0-8.25.18+2.6.15.11-5
  Candidate: 7.0.0-8.25.18+2.6.15.11-5
  Version table:
 *** 7.0.0-8.25.18+2.6.15.11-5 0
        500 http://security.ubuntu.com dapper-security/restricted Packages
        100 /var/lib/dpkg/status
     7.0.0-8.25.18+2.6.15.11-1 0
        500 http://nl.archive.ubuntu.com dapper/restricted Packages
ik heb de xorg.conf aangepast zoals je zei maar de foutmelding blijft.
Open Source = Freedom = Power !!

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #5 Gepost op: 2006/09/24, 18:46:00 »
glxinfo geeft trouwens dit:

darell@bora:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
enig idee wat dit kan zijn en hoe ik het kan oplossen?
Open Source = Freedom = Power !!

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #6 Gepost op: 2006/09/24, 19:40:13 »
het is opgelost!
het was eigenlijk heel dom, ik startte steeds de verkeerde kernel op omdat ik wat aan mn GRUB had gekloot.
Nu werkt alles weer perfect! en geuss what Compiz + XGL doet het ook weer helemaal :D echt cool!
Open Source = Freedom = Power !!

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #7 Gepost op: 2006/09/24, 21:43:41 »
k*t! nadat ik sudo dpkg-reconfigure xserver-xorg heb gedaan geeft ie weer precies dezelfde foutmelding!:( ik heb toen de fglrx drivers nog eens opnieuw geinstalleerd maar dat helpt niks :( ook Compiz doet het nu niet meer :(:(
wat is hier het probleem? ik heb gewoon de standaard instellingen gekozen die die vanzelf pakt bij xserver-xorg
help!
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #8 Gepost op: 2006/09/24, 21:52:14 »
kies bij Driver bij het uitvoeren van sudo dpkg-reconfigure xserver-xorg voor fglrx -- heb je dat gedaan ? kan zijn dat de standaardwaarde anders was (ik gok op radeon of ati)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #9 Gepost op: 2006/09/24, 21:55:53 »
jep heb ik gedaan..staat standaard indd op ATI
heb echt geen idee hoe ik dit gefixt krijg :(

mn xorg.conf is niets mis mee volgens mij:

Section "Device"
        Identifier      "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Driver          "fglrx"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        HorizSync       28-49
        VertRefresh     43-72
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. R420 JI [Radeon X800PRO]"
        Monitor         "Generic Monitor"
        DefaultDepth    24
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #10 Gepost op: 2006/09/24, 22:27:39 »
nog eens de output van

fglrxinfo

glxinfo|grep direct

cat /etc/X11/xorg.conf|grep Module -A 20

?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #11 Gepost op: 2006/09/24, 22:37:00 »
fglrxinfo:

darell@bora:~$ fglrxinfo
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual!
glxinfo|grep direct:

darell@bora:~$ glxinfo|grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
cat /etc/X11/xorg.conf|grep Module -A 20:

darell@bora:~$ cat /etc/X11/xorg.conf|grep Module -A 20
Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc11"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
Ook heb ik de drivers nog eens verwijdert en toen de kernel k7 (waar eerst alles goed op draaide) ook verwijdert. Daarna heb ik die kernel weer geinstalleerd samen met de drivers, maarja het blijft hetzelfde zo te zien
Open Source = Freedom = Power !!

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #12 Gepost op: 2006/09/24, 22:46:18 »
wow ik was vergeten om "load glx" te plaatsen in "module" na de herinstallatie van de kernel.
Nu doet ie het wel weer helemaal goed :D ik weet dus ook hoe ik het moet oplossen nu als het nog eens zou gebeuren, gewoon drivers verwijderen, kernel verwijderen, dan de boel opnieuw installeren en dat in "module" plaatsen en dan doet ie het weer!
Echt superbedankt ProfoX!
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #13 Gepost op: 2006/09/24, 23:53:55 »
als het nog eens voorkomt: eerst proberen dat in de module sectie toe te voegen (dat load glx ding) en X herstarten met bv. CTRL+ALT+BackSpace of met "sudo /etc/init.d/gdm restart"

heb je trouwens linux-k7 ge
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #14 Gepost op: 2006/09/25, 00:12:55 »
ok bedankt! alhoewel ik niet hoop dat er een volgende keer is ;)

Heb indd k7 geinstalleerd:

darell@bora:~$ apt-cache policy linux-k7
linux-k7:
  Installed: 2.6.15.25
  Candidate: 2.6.15.25
  Version table:
 *** 2.6.15.25 0
        500 http://security.ubuntu.com dapper-security/restricted Packages
        100 /var/lib/dpkg/status
     2.6.15.22 0
        500 http://nl.archive.ubuntu.com dapper/restricted Packages
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #15 Gepost op: 2006/09/25, 00:15:01 »
Ok
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #16 Gepost op: 2006/09/25, 00:33:30 »
Ik hoop het ook! :)
nogmaals superbedankt voor je hulp! :D
Open Source = Freedom = Power !!

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #17 Gepost op: 2006/09/29, 00:42:18 »
hm na een update krijg ik opeens deze melding als ik glxgears doe:

Xlib:  extension "XFree86-DRI" missing on display ":1.0".glxgears start wel gewoon op en ik haal deze snelheid:
55599 frames in 5.0 seconds = 11098.927 FPSglxinfo|grep direct zegt:
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No
fglrxinfo:
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 PRO Generic
OpenGL version string: 2.0.5814 (8.25.18)
apt-cache policy xorg-driver-fglrx:
xorg-driver-fglrx:
  Installed: 7.0.0-8.25.18+2.6.15.11-5
  Candidate: 7.0.0-8.25.18+2.6.15.11-5
  Version table:
 *** 7.0.0-8.25.18+2.6.15.11-5 0
        500 http://security.ubuntu.com dapper-security/restricted Packages
        100 /var/lib/dpkg/status
     7.0.0-8.25.18+2.6.15.11-1 0
        500 http://nl.archive.ubuntu.com dapper/restricted Packages
is nu iets mis ofniet? en hoe krijg kom ik aan die extension "XFree86-DRI"?
Open Source = Freedom = Power !!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #18 Gepost op: 2006/09/29, 00:48:41 »
Jij draait waarschijnlijk Xgl. Just ignore it ;) En Direct rendering: no is ook normaal wanneer je Xgl draait

edit: ik moet toegeven dat ik niet precies weet waar die Xlib:  extension "XFree86-DRI" missing on display ":1.0".
melding vandaan komt, maar ik heb ze ook, en bij mij werkt alles prima.
Misschien eens een keer onderzoeken met Google? :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #19 Gepost op: 2006/09/29, 01:03:49 »
Hey ja indd, onder een Gnome sessie heb ik het niet! :)
ff kijken of ik kan vinden wat die extension "XFree86-DRI" is op het engelse ubuntu forum ofzo, maarja voor de rest merk ik niks dus het zal wel goed zijn het viel me alleen opeens op
Open Source = Freedom = Power !!

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #20 Gepost op: 2006/09/29, 11:10:49 »
Hey daar,

Ik heb nu eindelijk 6.06 draaien en m'n videokaart ook goed kunnen instellen.
Kwas bezig met compiz via deze site: http://wiki.ubuntu.com/NIXglCompiz
Alleen bij de onderstaande regel loop ik vast...:

sudo apt-get install xserver-xgl compiz compiz-core compiz-gnome csm compiz-plugins cgwd cgwd-themes cgwd-themes-extra xwinwrap

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
Pakket csm is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket csm heeft geen installeerbare kandidaat


Kwestie van afwachten begrijp ik? Dit is de eerste keer dat ik Compiz probeer te installeren, misschien is er nog een andere mogelijkheid?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #21 Gepost op: 2006/09/29, 11:58:51 »
Repositories liggen ff door elkaar; had je dit niet gelezen?

Citaat
DEZE HOWTO IS OUT OF DATE !!!! Voorlopig moet je gewoon even wachten met het installeren van compiz/beryl :) De repositories zijn helemaal overhoop gehaald (22/09/2006)
Er is wel een andere mogelijkheid; ik beschrijf ze vanavond.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #22 Gepost op: 2006/09/29, 12:55:13 »
Citaat van: profoX
Repositories liggen ff door elkaar; had je dit niet gelezen?

Citaat
DEZE HOWTO IS OUT OF DATE !!!! Voorlopig moet je gewoon even wachten met het installeren van compiz/beryl :) De repositories zijn helemaal overhoop gehaald (22/09/2006)
Er is wel een andere mogelijkheid; ik beschrijf ze vanavond.
Nee, ik had dat er al een beetje uit op kunnen maken.
Ik wacht het wel ffies af. :)

Ow, de howto is out of date, ja zag 't al staan. ;)

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Math.

  • Lid
    • http://www.open-design.nl/
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #23 Gepost op: 2006/09/29, 16:18:54 »
Profox, welke site moet ik in de gaten houden om Compiz straks goed te kunnen installeren?

www.Open-design.nl - Open your mind. B creative with OSS.

Offline Darell

  • Lid
    • http://launchpad.net/~darell
  • Steunpunt: Nee
foutmelding glxgears
« Reactie #24 Gepost op: 2006/09/29, 16:41:52 »
Compiz krijgt een nieuwe naam: Beryl
hier is hun site: http://forum.beryl-project.org/
Open Source = Freedom = Power !!