Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: PC start alleen met WOL als er vanuit Windows afgesloten wordt  (gelezen 8917 keer)

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Mijn PC start alleen met WOL (Wake On LAN) als er vanuit Windows afgesloten wordt.

In Windows kreeg ik WOL pas werkend niet alleen nadat ik in de eigenschappen van de netwerkkaart WOL had aangezet. Maar ik moest ook in de powermanagement tab van de netwerkkaart aangeven dat de PC uit standby gehaald mag worden. In Linux heb ik geen powermanagement kunnen vinden, alleen ethtool.

Dit is de output van ethtool:

jjr@jjr-desktop:~$ sudo ethtool eth0
[sudo] password for jjr:
Settings for eth0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pg
Wake-on: g
Current message level: 0x00000037 (55)
Link detected: yes

Hoe kan ik de PC met WOL aanzetten nadat deze vanuit Ubuntu Intrepid Ibex is afgesloten?

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #1 Gepost op: 2009/01/23, 23:11:39 »
 synaptic het pakket etherwake kan je daar iets mee

[verwijderd door de beheerder]
Gestopt als aktief Forumlid 17/10/2011

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #2 Gepost op: 2009/01/23, 23:22:13 »
synaptic het pakket etherwake kan je daar iets mee
Bedankt voor je antwoord. Ik heb etherwake nooit geïnstalleerd, maar het is volgens mij alleen bedoeld om andere computers een 'magic packet' te sturen waardoor ze 'wakker worden'. Het sturen van magic packets werkt goed, anders had ik de PC ook niet kunnen opstarten na afsluiten vanuit Windows.

Het probleem zit (misschien?) in dat Linux niet naar de netwerkkaart communiceert dat deze de PC uit standby mag halen. Of de PC verliest misschien door Ubuntu het statisch IP adres tijdens het afsluiten? Vreemd genoeg gaat alles goed als ik vanuit Windows de PC afsluit.

Heeft iemand misschien een idee hoe ik dit kan oplossen?
« Laatst bewerkt op: 2009/01/23, 23:30:16 door JJRabbit »

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #3 Gepost op: 2009/01/23, 23:52:30 »
onderstaand topic geeft info over wake-on-lan,wellicht kan je er iets mee

topic wake on lan
Gestopt als aktief Forumlid 17/10/2011

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #4 Gepost op: 2009/01/24, 03:26:38 »
Heb je WOL ook aangezet in je Bios ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #5 Gepost op: 2009/01/24, 09:50:28 »
Heb je WOL ook aangezet in je Bios ??
Biedt het Bios een optie om WOL alleen te laten werken met Windows en niet met Ubuntu?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #6 Gepost op: 2009/01/24, 12:26:02 »
uuuuh nee?
Het heeft nix te maken met het OS wat op de pc staat.
Bij power management in de bios kan je instellen waarmee de pc aangezet kan worden.
En indien je NIC kaart dit ondersteund kan je instellen dat de pc via een magic pakket over het netwerk aangezet mag worden.

Indien dit ingesteld is zal de pc dus opstarten en maar net wat jij als 1e in Grub hebt staan zal dan booten.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #7 Gepost op: 2009/01/24, 12:55:17 »
Hall JJRabbit, wat voor netwerkkaart zit er in? Wat is de uitkomst van lspci | grep -i -e ethernet -e network ?

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #8 Gepost op: 2009/01/24, 13:34:06 »
uuuuh nee?
WOL (Wake On LAN) werkt namelijk perfect als ik de computer afsluit in Windows. Maar als ik de PC afsluit in Ubuntu, werkt WOL niet.

Hall JJRabbit, wat voor netwerkkaart zit er in? Wat is de uitkomst van lspci | grep -i -e ethernet -e network ?
jjr@jjr-desktop:~$ lspci | grep -i -e ethernet -e network
02:15.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
jjr@jjr-desktop:~$

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #9 Gepost op: 2009/01/24, 14:29:27 »
JJRabbit

 onderstaande link vooral het item support pg en het gedeelte make it executable, zie de output van ethtool in een van je vorige post,geeft aan dat pg ondersteunt wordt

Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pg
Wake-on: g

Wake on Lan with Linux and Windows
Gestopt als aktief Forumlid 17/10/2011

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #10 Gepost op: 2009/01/24, 17:11:06 »
onderstaande link...
Wake on Lan with Linux and Windows
Het probleem zit waarschijnlijk in de afsluitprocedure van Ubuntu. Ik denk aan het volgende probleem:

  • Powermanagement instellingen van de netwerkkaart worden in Ubuntu niet op een juiste manier doorgegeven

In de afbeelding is te zien welke instelling in MS Windows nodig was om WOL werkend te krijgen. Het gaat om de instelling: 'Dit apparaat mag de computer uit stand-by halen'.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #11 Gepost op: 2009/01/24, 17:16:34 »
Als je WOL hebt aangezet in je bios kan je daarna deze How To volgen.
http://ubuntuforums.org/showthread.php?t=234588

Je kan ook nog alleen deze opdracht proberen:
ethtool -s eth0 wol g
en of de man lezen ervoor
man ethtool
« Laatst bewerkt op: 2009/01/24, 17:18:43 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #12 Gepost op: 2009/01/24, 18:12:17 »
Als je WOL hebt aangezet in je bios kan je daarna deze How To volgen.
http://ubuntuforums.org/showthread.php?t=234588

Je kan ook nog alleen deze opdracht proberen:
ethtool -s eth0 wol g
en of de man lezen ervoor
man ethtool
Gandyman, hoewel ik je hulp op prijs stel vermoed ik dat je het probleem niet begrijpt. Als WOL uit zou staan in het bios, dan start de computer ook niet op met WOL na afsluiten met Windows.

In mijn eerste bericht in deze thread heb ik de uitslag van ethtool gegeven, hieruit blijkt dat WOL ondersteund is door mijn netwerkkaart en zelfs aan staat.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #13 Gepost op: 2009/01/24, 21:54:36 »
JJRabit, je moet de regel ethtool -s eth0 wol g wel degelijk gebruiken, het beste is om deze in /etc/init.d/networking te zetten of om zoals in de handleiding die Gandyman linkt zelf een init.d scriptje te maken met deze regel erin.
Wat er waarschijnlijk gebeurt is dat het laden van de netwerk kernel module resulteert in het niet meer kunnen wollen van de machine als deze uitgezet is onder Linux. Dit zet je weer aan door na het laden van de netwerk kernel module even dat ethtool commando uit te laten voeren. Op m'n werk hebben we thinclients met Realtek 8139 chipsets die hetzelfde probleem vertonen. Na het toevoegen van het ethtool commando in het netwerk opstartscript konden de thinclients weer gewoon gewold worden.

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #14 Gepost op: 2009/01/24, 23:25:10 »
JJRabit, je moet de regel ethtool -s eth0 wol g wel degelijk gebruiken, het beste is om deze in /etc/init.d/networking te zetten of om zoals in de handleiding die Gandyman linkt zelf een init.d scriptje te maken met deze regel erin.
Wat er waarschijnlijk gebeurt is dat het laden van de netwerk kernel module resulteert in het niet meer kunnen wollen van de machine als deze uitgezet is onder Linux. Dit zet je weer aan door na het laden van de netwerk kernel module even dat ethtool commando uit te laten voeren. Op m'n werk hebben we thinclients met Realtek 8139 chipsets die hetzelfde probleem vertonen. Na het toevoegen van het ethtool commando in het netwerk opstartscript konden de thinclients weer gewoon gewold worden.
Stap 2b van de handleiding heb ik zojuist uitgevoerd, helaas werkt het nog niet. Ergens heb ik gelezen dat voor de Realtek idd elke sessie WOL weer opnieuw aangezet moet worden. Hiervan is bij mijn netwerkkaart geen sprake, ethtool geeft altijd weer dat WOL aan staat, ook na een reboot.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #15 Gepost op: 2009/01/25, 02:02:41 »
Gandyman, hoewel ik je hulp op prijs stel vermoed ik dat je het probleem niet begrijpt. Als WOL uit zou staan in het bios, dan start de computer ook niet op met WOL na afsluiten met Windows.

Ik snap jouw wel jij snapt mij niet !

Citaat
In mijn eerste bericht in deze thread heb ik de uitslag van ethtool gegeven, hieruit blijkt dat WOL ondersteund is door mijn netwerkkaart en zelfs aan staat.
Dat ik er nogmaals op hamer dat het zowel in de bios of in de NIC moet aanstaan wil zoveel zeggen dat we niet er achteraf achter moeten komen dat dit niet het geval is en we hier eindeloos dingen zitten uit te vogelen.

enyway.....

Vroeg of opperde ik al eerder ?
Betreft het hier een dualboot ?
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #16 Gepost op: 2009/01/25, 10:11:12 »
Citaat
Betreft het hier een dualboot ?
Ja, het is dualboot (Ubuntu Intrepid Ibex en Windows XP).

De bios instellingen:

[Integrated Peripherals]
 onboard lan boot rom= enabled
[Power Management Setup]
 ACPI function = enabled
 ACPI Suspend Type = S3(STR)
 Power On by Ring = enabled
 Wake-Up by PCI Card = enabled
 Resume by Alarm = disabled

Het kan natuurlijk niet aan het bios liggen, immers dan zou WOL ook in Windows niet moeten werken.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #17 Gepost op: 2009/01/25, 10:48:03 »
Ergens heb ik gelezen dat voor de Realtek idd elke sessie WOL weer opnieuw aangezet moet worden. Hiervan is bij mijn netwerkkaart geen sprake, ethtool geeft altijd weer dat WOL aan staat, ook na een reboot.
Bij die realtek 8139 kaartjes gaf ethtool ook gewoon aan dat wol aanstond, toch moest er na het laden van de kernel module nog een keer het ethtool commando uitgevoerd worden anders werkte wol niet nadat je ze weer had uitgezet.

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #18 Gepost op: 2009/01/25, 15:03:42 »
Ik heb naast het installeren van het script ook een keer los dit ingevuld:
sudo ethtool -s eth0 wol g
Nu kan de PC helemaal niet meer afsluiten. De PC loopt vast en geeft de output:

*Stopping NTP server ntpd
nm-dispatcher,action: Caught signal 15, shutting down...
acpid: exiting

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #19 Gepost op: 2009/01/25, 15:25:05 »
De pc loopt denkelijk niet vast maar gaat in hibernate en gaat wachten op dat magic pakket.

Maagoe, je hebt dus een dualboot !
En welk OS start het eerste op wanneer je de pc normaal boot?

Dit is vrij belangrijk namelijk.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #20 Gepost op: 2009/01/25, 16:26:04 »
De pc loopt denkelijk niet vast

Als ik normaal gesproken de PC in hybernate breng, dan gaat deze uit en staan er geen letters meer op de monitor. In de situatie zoals deze nu is, staan de letters 'acpid: exiting' na een kwartier nog steeds op het scherm.

Citaat
De PC gaat in hibernate en wacht op dat magic pakket.

Dat lijkt me onwaarschijnlijk, ik zie namelijk geen lichtjes branden op de netwerkkaart. Ik heb je theorie uitgetest, maar de PC gaat niet aan na het sturen van een magic packet.

Citaat
Welk OS start het eerste op wanneer je de pc normaal boot?

Ubuntu start als eerste op.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #21 Gepost op: 2009/01/25, 16:38:22 »
Hmz, waarom ik dit vroeg was omdat ik het vreemd vind dat je windows wel via het netwerk met een magic pakket kan opstarten en Ubuntu niet.

Mijn Probleem zit hem in het feit dat je via een magic pakket de pc aanzet.
Vervolgens gaat hij booten, de bios pakt het eerste boot-device, en Grub zal opstarten.
Nu staat in grub als 1e Ubuntu, dus zou normale wijze Ubuntu moeten starten.

Staat daar echter windows dan zou windows moeten starten.

Ik snap dus echt niet hoe een magic pakket hieromheen werkt en direct een OS opstart.
Zonder dat eerst op de MBR word gekeken door de bios.

Enigste wat ik kan bedenken is dat je de NIC geconfigureerd hebt vanuit windows.
Ik heb Intell NIC's en dan kan je veel zaken instellen, klopt helemaal.

Dus er word vanaf dat moment geboot vanuit de NIC en de bios word genegeerd.

nu dit zo ingesteld is zal de NIC dus niet naar Ubuntu gaan.
wil je dit wel dan zal je dit in de NIC moeten instellen.

Kijk een WOL voor een pc waar maar 1 OS opstaat is makkelijker, maar een pc met 2 OSen ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #22 Gepost op: 2009/01/25, 17:28:16 »
Hmz, waarom ik dit vroeg was omdat ik het vreemd vind dat je windows wel via het netwerk met een magic pakket kan opstarten en Ubuntu niet.

Dat heb ik nooit beweerd. Als de PC opstart, dan start altijd Ubuntu.
Maar de PC start überhaupt alleen met een magic packet als deze afgesloten/uitgezet is in Windows. Heb ik de PC afgesloten met Ubuntu, dan zet Ubuntu de netwerkkaart uit, maar de PC zelf niet (die loopt vast). Als de netwerkkaart uit staat kan deze geen magic packets ontvangen.

Een plaatje geeft misschien meer duidelijkheid, ik heb de situatie in een soort van conceptmap weergegeven:
(zie bijlage)

[verwijderd door de beheerder]
« Laatst bewerkt op: 2009/01/25, 17:42:50 door JJRabbit »

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #23 Gepost op: 2009/01/25, 17:50:16 »
Geloof me, ik heb geen plaatje nodig om het te snappen  XD XD XD XD

Dat Ubuntu vastloopt na die opdracht is heel vreemd...

Geef deze opdracht eens in Terminal
sudo apt-get install ethtoolen kijk wat de output is.

Daarna doe je:
sudo /etc/init.d/wakeonlanconfig
hierin plaats je de volgende tekst:
#!/bin/bash
ethtool -s eth0 wol g

Nu sla je dit op.

vervolgens voeg je hem toe met
sudo update-rc.d -f wakeonlanconfig defaults
Nu voer je hem uit:
sudo /etc/init.d/wakeonlanconfig
ff checkuh of het werkt
sudo ethtool eth0
Naast andere info moet je dit ertussen zien staan
Supports Wake-on: pg
Wake-on: g

Om nu je NIC aan te houden na het afsluiten van Ubuntu.
sudo gedit /etc/init.d/halt
Als het goed is staat er een regel zoals: "halt -d -f -i $poweroff $hddown"

Verander dit naar: "halt -d -f $poweroff $hddown"

Last but not least je MAC adres oppikken met:
ifconfig |grep HW
Zet je pc uit met
sudo shutdown -h nowwaarom ?
Omdat je nu toch terminal open hebt staan  =D

Nu bij een andere pc dat magic pakket versturen.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline JJRabbit

  • Lid
  • Steunpunt: Nee
Re: PC start alleen met WOL als er vanuit Windows afgesloten wordt
« Reactie #24 Gepost op: 2009/01/25, 18:34:50 »
Ok, dit is wat ik heb gedaan:

jjr@jjr-desktop:~$ sudo apt-get install ethtool
[sudo] password for jjr:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
ethtool is reeds de nieuwste versie.
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  snort-rules-default libglib1.2ldbl libgtk1.2 libgtk1.2-common oinkmaster
  libprelude2 libnet1 ettercap-common
U kunt deze verwijderen via 'apt-get autoremove'.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
jjr@jjr-desktop:~$ sudo gedit /etc/init.d/wakeonlanconfig
jjr@jjr-desktop:~$ sudo update-rc.d -f wakeonlanconfig defaults
update-rc.d: warning: /etc/init.d/wakeonlanconfig missing LSB style header
 Adding system startup for /etc/init.d/wakeonlanconfig ...
   /etc/rc0.d/K20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc1.d/K20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc6.d/K20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc2.d/S20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc3.d/S20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc4.d/S20wakeonlanconfig -> ../init.d/wakeonlanconfig
   /etc/rc5.d/S20wakeonlanconfig -> ../init.d/wakeonlanconfig
jjr@jjr-desktop:~$ sudo /etc/init.d/wakeonlanconfig
jjr@jjr-desktop:~$ sudo ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pg
Wake-on: g
Current message level: 0x00000037 (55)
Link detected: yes
jjr@jjr-desktop:~$ sudo gedit /etc/init.d/halt

De code die ik zag in halt kwam niet helemaal overeen met die van jou, dit is wat ik zag:

   # Make it possible to not shut down network interfaces,
   # needed to use wake-on-lan
   netdown="-i"
   if [ "$NETDOWN" = "no" ]; then
      netdown=""
   fi

   log_action_msg "Will now halt"
   halt -d -f $netdown $poweroff $hddown


Daarom heb ik de $netdown verwijderd, er staat nu: halt -d -f $poweroff $hddown.

De PC sluit nog steeds niet af, het systeem loopt vast en de tekst "acpid: exiting" blijft in beeld.