Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Flash pakt verkeerde geluidskaart (OSS4) [opgelost]  (gelezen 709 keer)

Offline Remuzzz

  • Lid
  • Steunpunt: Nee
Flash pakt verkeerde geluidskaart (OSS4) [opgelost]
« Gepost op: 2009/01/15, 21:00:48 »
Hoi!

Ik heb na een tussenpauze van een halfjaartje Windows toch maar voor Ubuntu gekozen. Mijn laptop, Dell XPS M1330, heb ik aan een apart beeldscherm en toetsenbord gehangen. Zodoende heb ik een externe geluidskaart, een Creative Soundblaster USB connect.

Na de installatie van Ubuntu 8.10 werkte de geluidskaart meteen. Maar in Firefox pakt de flashspeler toch de boxen van mijn laptop, en niet die van mijn externe geluidskaart. Alle instellingen geprobeerd, Alsa, oss, pulseaudio. Geen resultaat. Ook heb ik libflashsupport geinstalleerd.

Na lang zoeken kwam ik de tip tegen om Alsa te blokkeren en OSS4 op mijn computer te zetten. Dit is ook gelukt. Alles werkt..... op Flash na.

Gek genoeg kan ook VLC niet omgaan met mijn geluid. Maar bijvoorbeeld Movie Player weer wel. Ik ben ten einde raad. Is het mogelijk om ergens centraal aan te geven dat alle programma's dezelfde centrale soundserver moeten gebruiken?

Hopelijk kunnen jullie me helpen!

Groetjes,
Remy


Edit: ik heb het opgelost. Wat ik gedaan heb is het volgende.


Zoek eerst op via ossinfo wat het pad is van je oss geluidskaart.

Run daarna dit commando in terminal:

sudo ln -sf *hierjepad* /dev/dsp

Hiermee verander je de link van je geluidskaart naar die van je tweede geluidskaart. Dat ik hier niet eerder opgekomen ben!
« Laatst bewerkt op: 2009/01/16, 19:30:12 door Remuzzz »