Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: /Home wordt niet meer herkent  (gelezen 4370 keer)

Offline John K

  • Lid
  • Steunpunt: Nee
/Home wordt niet meer herkent
« Gepost op: 2009/01/13, 18:16:33 »
Ik heb met Gparted live cd mijn aparte /Home partitie vergroot van 2.27 gig naar 7.27 gig d.m.v vrije ruimte. Wanneer ik Ubuntu 7.10 nu opnieuw opstart herkent deze /Home niet meer. Hoe kan ik het /Home label teruggeven aan de /Home partitie? Ik dacht zelf aan een 5.10 cd te draaien en dan handmatig de betreffende partitie instellen als /Home, dan partitieverandering wegschrijven en setup afsluiten zonder opnieuw te installeren.

Heeft iemand een idee?

Groeten John

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #1 Gepost op: 2009/01/13, 18:38:05 »
Probleem is dat wanneer je partities gaat veranderen het UUID nummer verandert.

Als je nu in de fstab kijkt zie je bijv. dit staan
# /dev/hda6
UUID=01C3C9F85BBA1520 /media/hda6     ntfs    defaults,umask=007,gid=46 0       1


Je ziet dat /dev/hda6 is geblokkeert met een #
Haal nu dit # weg en het UUID nummer.
Dan ziet het er ongeveer zo uit

/dev/hda6 /media/hda6     ntfs    defaults,umask=007,gid=46 0       1

Je vind het in /etc/fstab

Nu zou je /home weer wel herkend worden een aangekoppeld zijn.

Hierboven staat een voorbeeld he ?
Jij moet even kijken welke voor je /home is.

en sja dit is een nadeel van een slimme uitvinding......
« Laatst bewerkt op: 2009/01/13, 18:39:45 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #2 Gepost op: 2009/01/13, 19:04:02 »
Hoe kom ik in /etc/fstab nu ik niet meer kan inloggen?

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #3 Gepost op: 2009/01/13, 19:14:30 »
In recovery mode inloggen, in het menu kiezen voor de command line en dan typt ge:
nano /etc/fstab

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #4 Gepost op: 2009/01/13, 20:13:30 »
Of je boot van de Ubuntu Live-cd, en doet het van daaruit.

Altijd handig zo'n live-cd..  O0
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #5 Gepost op: 2009/01/13, 20:15:13 »
Ik heb in de recovery mode op de  command line 'nano /etc/fstab' ingetypt, dan krijg ik een hele lijst met al mijn partities, maar voor alle, ook de /Root, staat een # met een ontzettend lang nummer erachter. Achter de betreffende partitie staat inderdaad /Home, maar ik zou niet weten hoe ik tekst moet aanpassen en opslaan in 'nano /etc/fstab'.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #6 Gepost op: 2009/01/13, 20:17:55 »
Of je boot van de Ubuntu Live-cd, en doet het van daaruit.

Altijd handig zo'n live-cd..  O0

Wanneer ik met de live-cd in de terminal nano /etc/fstab intyp krijg ik dit;

unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0

John K


Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #8 Gepost op: 2009/01/13, 20:27:39 »
~$ cat /etc/fstab
unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0


Ik kan natuurlijk wel, met gebruik van de live-cd, in 'Places' naar de partitie waar de /Root staat, dan naar etc/fstab en daar het # en het nummer weghalen en opslaan. Zou dit de oplossing zijn? Ik vind het alleen vreemd dat voor alle partities dit # met een lang nummer staat.

John K

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #9 Gepost op: 2009/01/13, 20:28:55 »
Dat is inderdaad de oplossing, want als ge op de live-cd dat commando ingeeft, zal hij de fstab aanpassen van de live-sessie, en dat is dus niet de bedoeling.

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #10 Gepost op: 2009/01/13, 20:35:09 »
Wanner ik, met gebruik van de live-cd, in 'Places' naar de partitie waar de /Root staat, dan naar etc/fstab en daar het # en het nummer weghaal en opsla, krijg ik de volgende melding;

Could not save the file /media/disk/etc/fstab.

You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again.

Wat nu?

John K

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #11 Gepost op: 2009/01/13, 20:37:32 »
Natuurlijk ook als root werken, dus in de terminal:
gksudo gedit /media/disk/etc/fstab

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #12 Gepost op: 2009/01/13, 20:48:21 »
Doe het meteen goed en plaats de huidige UUID in plaats van de oude.

* je kan de UUID zien door in de terminal te typen

sudo blkid

Knip het gedeelte "UUID="###"" voor je /home partitie naar het klembord: selecteren met de muis en Ctrl+Shift+C

Start gedit en open de /etc/fstab waar je systeem geïnstalleerd is.

sudo gedit /media/disk/etc/fstab

Vervang het gedeelte UUID=... dat nu in je fstab staat door wat je in het klembord gekopieerd had.

Bewaren. Bij de volgende opstart zou het terug goed moeten gaan.
« Laatst bewerkt op: 2009/01/14, 12:19:55 door vanadium »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #13 Gepost op: 2009/01/13, 20:57:27 »
~$ cat /etc/fstab
unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0
raar dat je zo weinig info krijgt, hier mijn output:

gerolf@Ugly:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda6
UUID=b265a09b-b911-4190-9309-18fb33121ab8 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=9cf0e518-8ef9-46e2-a743-5a5da63d10b8 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
gerolf@Ugly:~$

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #14 Gepost op: 2009/01/13, 21:02:23 »
Doe het meteen goed en plaats de huidige UUID in plaats van de oude.

* je kan de UUID zien door in de terminal te typen

sudo blkid -l

Knip het gedeelte "UUID="###"" voor je /home partitie naar het klembord: selecteren met de muis en Ctrl+Shift+C

Start gedit en open de /etc/fstab waar je systeem geïnstalleerd is.

sudo gedit /media/disk/etc/fstab

Vervang het gedeelte UUID=... dat nu in je fstab staat door wat je in het klembord gekopieerd had.

Bewaren. Bij de volgende opstart zou het terug goed moeten gaan.



~$ sudo blkid -l
The lookup option requires a search type specified using -t
ubuntu@ubuntu:~$ sudo blkid -t
blkid: option requires an argument -- t
blkid 1.0.0 (12-Feb-2003)
usage:  blkid [-c <file>] [-ghl] [-o format] [-s <tag>] [-t <token>]
    [-v] [-w <file>] [dev ...]
        -c      cache file (default: /etc/blkid.tab, /dev/null = none)
        -h      print this usage message and exit
        -g      garbage collect the blkid cache
        -s      show specified tag(s) (default show all tags)
        -t      find device with a specific token (NAME=value pair)
        -l      lookup the the first device with arguments specified by -t
        -v      print version and exit
        -w      write cache to different file (/dev/null = no write)
        dev     specify device(s) to probe (default: all devices)

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #15 Gepost op: 2009/01/13, 21:10:03 »
tik enkel: sudo blkid
dan zie je de UUID wel.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #16 Gepost op: 2009/01/13, 21:11:05 »
Hebt ge gedaan hoe ik het zei?

Het is trouwens "sudo blkid -l", met een kleine "L".

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #17 Gepost op: 2009/01/13, 21:13:26 »
Hebt ge gedaan hoe ik het zei?

Het is trouwens "sudo blkid -l", met een kleine "L".
dan gaat het niet zie zijn vorige bericht (tenandere ook bij mij niet)

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #18 Gepost op: 2009/01/13, 21:15:37 »
Inderdaad, foutje. Dacht dat hij een "|" had getypt.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #19 Gepost op: 2009/01/13, 21:18:30 »
Alstublieft niet in iedere topic een disc opvoeren die niet ter zake is, sjonge jonge.

Zie dit nu in iedere post van mensen die hier komen, ze stellen 1 vraag en er duiken gelijk 10 man op, die onderling gaan discuseren.
En geloof me zo help je iemand Niet !!

Het word allemaal veel te moeilijk gemaakt.

Mijn idee was erg simpel.

Eerst ff het probleem oplossen door een simpele handeling , dwz de UUID weghalen en dan het # verwijderen.

Zodra zijn pc weer normaal opstart kan de zaak eventueel opgepoetst worden door de UUID terug te plaatsen, in grafische mode, indien dit zo noodzakelijk is, wat ik echter betwijfel ......

Nogmaals, houd het zo simpel mogelijk voor de mensen.

Jullie razen maar door en de mensen krijgen niet eens tijd om op adem te komen.

Rustig aan en stap voor stap werken, dan help je de mensen het beste.
« Laatst bewerkt op: 2009/01/13, 21:21:21 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #20 Gepost op: 2009/01/13, 21:35:05 »
Ik heb alles gedaan wat jullie aanraden, maar wat ik ook probeer, bij het opstarten krijg ik de tekst;

File system check fail.

En dan een lijst met;

Bash; no job control in this shell
bash; groups; command not found
bash; lesspipe command not found

etc, etc.

Wanneer ik hierna ctrl alt delete intyp, dan kom ik in het inlogscherm maar wanneer ik dan de gebruiker ingeef zegt Ubuntu de /Home niet te kunnen vinden.

Wanneer ik via de live-cd met 'sudo nautilus' naar de betreffende partitie met mijn /Home files ga kan ik verschillende mappen niet kopieren naar een ander lokatie omdat ik geen schrijfrechten zou hebben.

Wat gebeurt er? Hoe kan ik terug?

Johgn K

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #21 Gepost op: 2009/01/13, 22:03:19 »
boot van de live-cd

Nu kan je 2 dingen doen:
of met nautilus in root rechten die fstab bewerken.
of met de opdracht
gksudo gedit /media/disk/etc/fstab

eventueel dat #hekje# weghalen en 1 regel ervan maken.

Of wat al voorgesteld werd de nieuwe UUID ervoor zetten.
Hiermee zou ik zelf ff wachten, het moet zo simpel mogelijk zijn voor Ubuntu om nu eerst normaal te booten en je /home te koppelen.

opslaan en dan de pc rebooten vanaf de HD.
« Laatst bewerkt op: 2009/01/13, 22:06:23 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #22 Gepost op: 2009/01/13, 22:36:39 »
~$ sudo blkid
/dev/sda1: UUID="6F0E853F0E84A8F" LABEL="WinRE" TYPE="ntfs"
/dev/sda2: UUID="C6C0EB28C0EB1E05" LABEL="Vista" TYPE="ntfs"
/dev/sda3: UUID="c0b00aac-31ff-4749-8dd3-2585a0c025c3" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: TYPE="swap"
/dev/sda6: UUID="67eb3b2c-407d-4456-9bef-e24738d2fcc0" SEC_TYPE="ext2" TYPE="ext3"


Dit is wat ik krijg. Het gaat om de laatste, sda6. Sinds ik deze /Home heb vergroot met de gparted-live cd is dit UUID nummer niet meer verandert. Ik zou dus niet weten wat ik moet vervangen.

Als ik met

moet ik dan de hele UUID=67eb3b2c-407d-4456-9bef-e24738d2fcc0 weghalen zodat het

/dev/sda6 /home           ext3    defaults        0       2

wordt? Ik heb dit al gedaan, maar er verandert niet bij het opstarten, de opstart blijft zeggen 'file sytem check failed, en gaat dan naar root$

John K

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #23 Gepost op: 2009/01/13, 22:46:14 »
Dit bedoel ik nou met verwarring....

Die opdracht is om erachter te komen wat op dit moment je UUID is.
Dit onthoud je ( DUH  =D )  of kopieer je ff naar een tekst editor of zoiets....

Volgende stap is je fstab file te openen die je vind in /etc/fstab
Want hierin word gekeken en bepaald wat de HD of partitie is.

dus nu de fstab openen met sudo rechten en dan bewerken.

wederom de opties hierboven, of de UUID veranderen naar wat je net gevonden hebt.

Of het simpel houden dat # weghalen zodat het  hda6 blablabla word.

Dan opslaan en rebooten.

I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline John K

  • Lid
  • Steunpunt: Nee
Re: /Home wordt niet meer herkent
« Reactie #24 Gepost op: 2009/01/13, 23:06:05 »
In etc/fstab staat, doordat ik dit heb verandert, /dev/sda6       /home           ext3    defaults        0       2

Intussen ka ik wel weer inloggen.

John K