Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [ Opgelost ] Traag ladende webpagina's  (gelezen 1822 keer)

PeterNoot

  • Gast
[ Opgelost ] Traag ladende webpagina's
« Gepost op: 2008/12/30, 16:27:05 »
Afgelopen dagen heb ik gebruikt om Ubuntu 8.10 (Itrepid Ibex) te installeren op een computer. Ik vind het erg leuk om met Ubuntu te spelen.

Wat mij echter opvalt is dat de internet pagina's zo traag laden. Niet dat internet langzaam is (zegt speednet tenminste), maar de betreffende servers worden laat gevonden. Steeds staat onderin de status balk van Firefox de tekst Server xxx opzoeken.... En daar doet hij dan even over, zeker als de pagina gebruik maakt van een heleboel verschillende servers.
Op mijn andere computer met MS Windows  ;) treed dat probleem niet op.

Nu heb ik al e.e.a. gevonden, maar ik vraag me af of dat de oplossingen zijn:
  • Draadloos internet schijnt bij Intrepid lastig te zijn, maar ik gebruik een draadje.
  • Toen las ik op dit forum over het uitzetten van "Pango" in Firefox, maar dat gaat volgens mij over Firefox versie 1.5. http://forum.ubuntu-nl.org/index.php/topic,10185.0.html.
  • Ook las ik wat over ipv6 in relatie tot ipv4, dat heb ik uitgevoerd. Oftewel 'alias net-pf-10 ipv6' in 'alias net-pf-10 off' verandert. http://forum.ubuntu-nl.org/index.php/topic,16897.0.html
  • Tevens dacht ik aan het instellen van DNS servers maar dat wordt in mijn router al geregeld (via OpenDNS), dat zou toch voldoende moeten zijn?

Weten jullie wellicht nog iets? Moet ik toch iets met de DNS doen? Of met Pango?
« Laatst bewerkt op: 2009/01/06, 21:40:24 door PeterNoot »

Offline peter10

  • Lid
    • Mijn Hyve
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #1 Gepost op: 2008/12/30, 16:31:16 »
Hallo naamgenoot.

Helaas heb ik geen idee.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #2 Gepost op: 2008/12/30, 16:33:31 »
Het lijkt toch een DNS probleem te zijn.
Weet je zeker dat je router goed ingesteld is, en dat je computer bij je router de DNS aanvragen doet?

PeterNoot

  • Gast
Re: Traag ladende webpagina's
« Reactie #3 Gepost op: 2008/12/30, 16:53:22 »
Het lijkt toch een DNS probleem te zijn.
Weet je zeker dat je router goed ingesteld is, en dat je computer bij je router de DNS aanvragen doet?

Hoe weet ik zeker dat Ubuntu direct bij mijn router de DNS aanvragen doet? Is er een manier om dat te controleren?
Of moet de router ergens als gateway worden opgeven?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #4 Gepost op: 2008/12/30, 16:56:46 »
Rechtsklikken op het netwerkicoontje op je paneel en kiezen voor "connection information".
Plaats die gegevens hier.

PeterNoot

  • Gast
Re: Traag ladende webpagina's
« Reactie #5 Gepost op: 2008/12/30, 17:15:30 »

Apparaat: Ethernet (eth0)
Stuurprogramma: forcdeth
Snelheid: 100 Mb/s
Beveiliging: geen

IP-adres: 192.168.xxx.xxx
Broadcastadres: 192.168.xxx.xxx
Subnetmasker: 255.255.255.0
Standaardroute: 192.168.yyy.yyy
Primaire DNS: 192.168.yyy.yyy
Secondaire DNS: 208.67.222.222


In de regels hierboven wordt volgens mij aangegeven dat eerst naar de router (192.168.yyy.yyy) gekeken wordt voor de DNS-servers, daarna rechtstreeks bij OpenDNS (208.67.222.222).
Dat is toch goed? In mijn router staan namelijk beide adressen vermeld van OpenDNS. Voordeel daarvan is dat ik op één plek bepaal waar de DNS-informatie vandaan gehaald moet worden.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #6 Gepost op: 2008/12/30, 17:24:00 »
Met dig kan je kijken hoelang het duurt voordat je antwoord hebt van je DNS server.
Bijvoorbeeld:
dig @208.67.222.222 ubuntu.com
dig @ip-van-je-router ubuntu.com

Hier zitten ze beide zo rond de 30 msec.

PeterNoot

  • Gast
Re: Traag ladende webpagina's
« Reactie #7 Gepost op: 2008/12/30, 17:29:54 »
En dit is de reactie van dig (waar staat dat commando trouwens voor?):

peter@CSA-Ubuntu:~$ dig @208.67.222.222 ubuntu.com

; <<>> DiG 9.5.0-P2 <<>> @208.67.222.222 ubuntu.com
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25056
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ubuntu.com.         IN   A

;; ANSWER SECTION:
ubuntu.com.      190   IN   A   91.189.94.156

;; Query time: 36 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Tue Dec 30 17:24:58 2008
;; MSG SIZE  rcvd: 44

peter@CSA-Ubuntu:~$ dig @192.168.yyy.yyy ubuntu.com

; <<>> DiG 9.5.0-P2 <<>> @192.168.yyy.yyy ubuntu.com
; (1 server found)
;; global options:  printcmd
;; connection timed out; no servers could be reached


Via de router lijkt het dus niet te werken, toch? Overigens heb ik de "yyy" in het adres voor de getallen vervangen, natuurlijk.
Betekend dit nu dat ik toch in Ubuntu de DNS-servers moet opgeven?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #8 Gepost op: 2008/12/30, 18:01:58 »
Heb je het verkeerde ip adres van je router ingevuld?
Anders is of je router, of Ubuntu niet goed ingesteld.

De traagheid komt nu waarschijnlijk doordat Ubuntu eerst gaat wachten op een antwoord van de router. Als dat na een tijdje niet komt, gaat hij het zelf proberen bij OpenDNS.

Wat zegt het commando dig ubuntu.com ?
Dan pakt hij als het goed is dezelfde instellingen als Firefox zou doen.

PeterNoot

  • Gast
Re: Traag ladende webpagina's
« Reactie #9 Gepost op: 2008/12/31, 16:40:30 »
Hoi Johan,

Bedankt dat je me blijft helpen.
Momenteel zit ik echter niet achter de Ubuntu-computer en kan jou suggesties niet uitproberen. Ik zal (hopelijk) morgen eens verder gaan met uitzoeken.

Het adres van de router heb ik bij het dig commando tweemaal gecontroleerd, de laatste maal door te browsen naar de webpagina van de router en het adres daarvan kopiëren. Dat moet ik goed ingevuld hebben. Ubuntu heeft zelf de locatie van de router gevonden, tijdens het installeren. Tevens geeft hij ook de goede locatie aan bij connection information.
De instellingen van de router (ten aanzien van de DNS-servers) moet wel goed zijn omdat meerdere computers gebruik maken van deze router. Die kennen niet het probleem van het traag vinden van de website-servers. Toch heb ik die nog even vergeleken met OpenDNS en ze kloppen.

De ideeën die ik nog heb zijn:
  • Het dig commando ubuntu.com uitproberen en dit hier terug rapporteren;
  • Met een andere webbrowser (welke?) kijken of het probleem ook optreed;
  • De DNS-servers in Ubuntu vastleggen, ik neem aan dat het mogelijk is dat ergens 'hard' vast te leggen?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Traag ladende webpagina's
« Reactie #10 Gepost op: 2008/12/31, 22:39:26 »

PeterNoot

  • Gast
Re: Traag ladende webpagina's
« Reactie #11 Gepost op: 2009/01/01, 13:55:19 »
Het probleem is inderdaad de DNS-servers.
Na de aanpassing in de /etc/dhcp3/dhclient.conf van met de regel prepend domain-name-servers 208.67.222.222,208.67.220.220; zoals aangegeven door Vistaus laden de internetpagina's op normale snelheid.

Toch vreemd dat in Windows een verwijzing naar de router voldoende is, terwijl in Ubuntu de DNS-servers direct toegewezen moeten worden.
Ik zou het gemakkelijker vinden dat de router bepaalt welke DNS-servers de aangesloten computers dienen te gebruiken.

In ieder geval bedankt voor jullie hulp en GOED NIEUWJAAR!
« Laatst bewerkt op: 2009/01/01, 13:57:33 door PeterNoot »