Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem netwwerk adapter Asus moederbord  (gelezen 4307 keer)

Offline L.P.

  • Lid
  • Steunpunt: Nee
Probleem netwwerk adapter Asus moederbord
« Gepost op: 2008/12/29, 22:13:55 »
Ik heb net een nieuw Asus p5q se plus moederbord in mijn computer alleen als ik een tijdje internet heb aanstaan dan kan ik mijn computer opnieuw opstarten anders doet internet het helemaal niet

Wie kan mij hiermee helpen er zit een Realtec Gigabit lan controller in


Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #1 Gepost op: 2009/01/02, 09:28:19 »
Geen Linux probleem, want zoals je zelf zegt werkt het gewoon.
Ik zou maar terug gaan naar de leverancier van je bord.
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #2 Gepost op: 2009/01/02, 12:01:24 »
Hallo L.P., graag uitkomst posten van lspci | grep -e Ethernet -e Network in een terminal. Kopiëren in de terminal gaat met ctrl+shift+c. Ik vermoed dat je zelf een kernel module moet compileren voor je netwerkkaart omdat de module die nu geladen wordt kennelijk niet helemaal goed werkt.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #3 Gepost op: 2009/01/02, 12:07:39 »
Dan krijg ik dit

luite@luite-desktop:~$ lspci | grep -e Ethernet -e Network
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
luite@luite-desktop:~$

Heb een tweede er in geplaatst om te kijken of het daar aan ligt maar deze had dezelfde probleem bij mijn vorige moederbord waren er geen problemen

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #4 Gepost op: 2009/01/02, 12:31:04 »
Hallo L.P., ik heb exact dezelfde nic in mijn notebook zitten en Ubuntu laadt daarvoor de r8169 module en dat werkt gewoon niet goed.
Je zult dus zelf een module moeten compileren, de broncode kun je hier downloaden: ftp://210.51.181.211/cn/nic/r8168-8.010.00.tar.bz2
Als je deze hebt gedownload (onthou wel het mapje waarin je de boel hebt gedownload) moet je een terminal openen en naar het mapje gaan waar de download in staat, dit kan mbv het commando cd. Met het commando pwd kun je opvragen in welk mapje je zit.
Als je in het mapje bent waar de download staat kun je deze uitpakken met tar jxvf r8168-8.010.00.tar.bz2
Vervolgends cd je in het mapje dat nieuw is aangemaakt met cd r8168-8.010.00
Vervolgens moet je de kernel module compileren:
sudo apt-get install build-essential linux-headers-`uname -r` <Enter>
sudo make clean modules <Enter>
sudo make install <Enter>
sudo depmod -a <Enter>

En vervolgens opnieuw opstarten en lsmod | grep r81 draaien en graag de uitkomst posten daarvan.
Kan zijn dat er tijdens het compileren iets fout gaat, waarschijnlijk omdat je nog een pakketje mist. Graag foutmeldingen ook posten.

En ik zie nu ook dat je er twee nics in heb zitten, je zou dus ook die andere kunnen gebruiken. Of is die al in gebruik?
« Laatst bewerkt op: 2009/01/02, 12:35:27 door AutoStatic »

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #5 Gepost op: 2009/01/02, 13:10:33 »
Dit is wat tot nu toe de uitkomst is

luite@luite-desktop:~$ cd Bureaublad
luite@luite-desktop:~/Bureaublad$ dir
r8168-8.010.00.tar.bz2
luite@luite-desktop:~/Bureaublad$ tar jxvf r8168-8.010.00.tar.bz2
r8168-8.010.00/
r8168-8.010.00/readme
r8168-8.010.00/src/
r8168-8.010.00/src/r8168_n.c
r8168-8.010.00/src/Makefile_linux24x
r8168-8.010.00/src/r8168.h
r8168-8.010.00/src/Makefile
r8168-8.010.00/Makefile
luite@luite-desktop:~/Bureaublad$ cd r8168-8.010.00
luite@luite-desktop:~/Bureaublad/r8168-8.010.00$ sudo apt-get install build-essential linux-headers-`uname -r`
[sudo] password for luite:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
linux-headers-2.6.27-9-generic is reeds de nieuwste versie.
De volgende extra pakketten zullen geïnstalleerd worden:
  dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev
Voorgestelde pakketten:
  debian-keyring g++-multilib g++-4.3-multilib gcc-4.3-doc libstdc++6-4.3-dbg
  libstdc++6-4.3-doc
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  build-essential dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev
0 pakketten opgewaardeerd, 5 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Er moeten 6103kB aan archieven opgehaald worden.
Door deze operatie zal er 21,1MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? j
Ophalen:1 http://nl.archive.ubuntu.com intrepid/main libstdc++6-4.3-dev 4.3.2-1ubuntu11 [1354kB]
Ophalen:2 http://nl.archive.ubuntu.com intrepid/main g++-4.3 4.3.2-1ubuntu11 [4128kB]
Ophalen:3 http://nl.archive.ubuntu.com intrepid/main g++ 4:4.3.1-1ubuntu2 [1444B]
Ophalen:4 http://nl.archive.ubuntu.com intrepid/main dpkg-dev 1.14.20ubuntu6 [612kB]
Ophalen:5 http://nl.archive.ubuntu.com intrepid/main build-essential 11.4 [7172B]
6103kB opgehaald in 6s (892kB/s)                                               
Selecteren van voorheen niet geselecteerd pakket libstdc++6-4.3-dev.
(Database inlezen ... 136643 bestanden en mappen geïnstalleerd.)
Uitpakken van libstdc++6-4.3-dev (uit .../libstdc++6-4.3-dev_4.3.2-1ubuntu11_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket g++-4.3.
Uitpakken van g++-4.3 (uit .../g++-4.3_4.3.2-1ubuntu11_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket g++.
Uitpakken van g++ (uit .../g++_4%3a4.3.1-1ubuntu2_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket dpkg-dev.
Uitpakken van dpkg-dev (uit .../dpkg-dev_1.14.20ubuntu6_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket build-essential.
Uitpakken van build-essential (uit .../build-essential_11.4_i386.deb) ...
Processing triggers for man-db ...
Instellen van dpkg-dev (1.14.20ubuntu6) ...
Instellen van libstdc++6-4.3-dev (4.3.2-1ubuntu11) ...
Instellen van g++-4.3 (4.3.2-1ubuntu11) ...
Instellen van g++ (4:4.3.1-1ubuntu2) ...

Instellen van build-essential (11.4) ...
luite@luite-desktop:~/Bureaublad/r8168-8.010.00$ sudo make clean modules
make -C src/ clean
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt binnengegaan
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers *.order
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt verlaten
make -C src/ modules
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt binnengegaan
make -C /lib/modules/2.6.27-9-generic/build SUBDIRS=/src modules
make[2]: Map '/usr/src/linux-headers-2.6.27-9-generic' wordt binnengegaan
scripts/Makefile.build:41: /src/Makefile: Bestand of map bestaat niet
make[3]: *** Er is geen regel om doel '/src/Makefile' te maken.  Gestopt.
make[2]: *** [_module_/src] Fout 2
make[2]: Map '/usr/src/linux-headers-2.6.27-9-generic' wordt verlaten
make[1]: *** [modules] Fout 2
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt verlaten
make: *** [modules] Fout 2
luite@luite-desktop:~/Bureaublad/r8168-8.010.00$ sudo make install
make -C src/ install
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt binnengegaan
install -m 744 -c r8168.ko /lib/modules/2.6.27-9-generic/kernel/drivers/net/
install: kan status van `r8168.ko' niet opvragen: Bestand of map bestaat niet
make[1]: *** [install] Fout 1
make[1]: Map '/home/luite/Bureaublad/r8168-8.010.00/src' wordt verlaten
make: *** [install] Fout 2
luite@luite-desktop:~/Bureaublad/r8168-8.010.00$ sudo depmod -a
luite@luite-desktop:~/Bureaublad/r8168-8.010.00$

Zal hem nu herstarten

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #6 Gepost op: 2009/01/02, 13:14:03 »
Heb hem herstart krijg deze uitkomst

luite@luite-desktop:~$ lsmod | grep r81
r8169                  35972  0
luite@luite-desktop:~$

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #7 Gepost op: 2009/01/02, 16:10:08 »
Oeps, er gaat iets fout:make[2]: Map '/usr/src/linux-headers-2.6.27-9-generic' wordt binnengegaan
scripts/Makefile.build:41: /src/Makefile: Bestand of map bestaat niet
make[3]: *** Er is geen regel om doel '/src/Makefile' te maken.  Gestopt.
make[2]: *** [_module_/src] Fout 2
En je hebt 8.10, moet ik die even booten om te kijken welke pakketjes je nog nodig hebt. Anders kan ik met checkinstall ook een pakketje voor je maken, hoef je alleen maar te dubbelklikken.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #8 Gepost op: 2009/01/02, 19:08:13 »
Oke hoor het wel

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #9 Gepost op: 2009/01/03, 12:24:59 »
Heb je een 32-bits of 64-bits Ubuntu geïnstalleerd?

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #10 Gepost op: 2009/01/03, 12:29:44 »
32 bits ubuntu heb ik versie 8.10

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #11 Gepost op: 2009/01/03, 12:35:46 »
Ah jammer, heb alleen 64-bits draaien dus heb wel een pakketje voor je maar daar heb je dan niks aan...
Ik zou proberen het pakket linux-headers-2.6.27-9-generic opnieuw te installeren, daar heb ik ook problemen mee gehad onder 8.10.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #12 Gepost op: 2009/01/03, 13:04:00 »
Kunt u mij ook precieser zijn welk bestand ik moet hebben misschien even de uitkomst in synaptic copieren want heb wel wat gevonden maar krijg nog steeds deze uitkomst

luite@luite-desktop:~$ lsmod | grep r81
r8169                  35972  0
luite@luite-desktop:~$


Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #13 Gepost op: 2009/01/03, 13:08:06 »
Hallo L.P., het gaat om het pakket linux-headers-2.6.27-9-generic
En de module is nog helemaal niet gecompileerd, vandaar dat deze ook nog niet geladen wordt.

Offline panzervos

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #14 Gepost op: 2009/01/03, 16:57:44 »
Hallo L.P., ik heb exact dezelfde nic in mijn notebook zitten en Ubuntu laadt daarvoor de r8169 module en dat werkt gewoon niet goed...

AutoStatic, hoezo werkt dit niet goed?
Ik heb rev 01 van dezelfde nic en dezelfde module r8169 geladen.
Tot nu toe heeft dit altijd perfect gewerkt met Ubuntu 7.04, 7.10 en 8.10.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #15 Gepost op: 2009/01/03, 18:58:50 »
Bij mij werkt het dus niet na een tijdje is de verbinding gewoon weg

Offline panzervos

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #16 Gepost op: 2009/01/03, 19:09:49 »
De enige keer dat ik zoiets heb meegemaakt was toen ik onder Ubuntu 8.04 met Deluge torrents aan het binnenhalen was.
Na het sluiten van Deluge had ik na ongeveer 2 minuten weer internetverbinding.
Misschien is dit bij jou ook het geval, maar misschien ook niet.
Het is alleen een tip.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #17 Gepost op: 2009/01/03, 19:19:09 »
AutoStatic, hoezo werkt dit niet goed?
Ik heb rev 01 van dezelfde nic en dezelfde module r8169 geladen.
Tot nu toe heeft dit altijd perfect gewerkt met Ubuntu 7.04, 7.10 en 8.10.
Hier gaat het om rev 02. Die doet het kennelijk niet goed: http://www.google.nl/search?q=Realtek+Semiconductor+Co.%2C+Ltd.+RTL8111%2F8168B+PCI+Express+Gigabit+Ethernet+controller+(rev+02)+ubuntu

Offline panzervos

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #18 Gepost op: 2009/01/03, 20:15:56 »
Sorry, ik had er verder niet naar gezocht.
Bedankt voor je antwoord.

@L.P.:Succes met je NIC!

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #19 Gepost op: 2009/01/03, 20:50:55 »
L.P., het pakket linux-headers-2.6.27-9 moet ook geïnstalleerd zijn, dus met een sudo apt-get install linux-headers-2.6.27-9-generic linux-headers-2.6.27-9 zou je alle pakketten moeten hebben om de realtek module te kunnen compileren.

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #20 Gepost op: 2009/01/04, 12:11:25 »
Ik heb me even op het internet ingelezen daar kwam naar voren dat het gewoon aan het hele realtec gebeuren ligt dat linux daar niet helemaal mee overweg kan door waarschijnlijk gebrekkige drivers
Ik heb nu een 3com netwerk kaart in mijn pc geplugt en zal even zien of dit wel goed gaat werken als het niet werkt dan horen jullie het snel denk ik op dit forum

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #21 Gepost op: 2009/01/04, 12:37:18 »
Ok, kan ook. Bij mij werkt die Realtek nic prima. Succes verder!

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #22 Gepost op: 2009/01/04, 16:28:31 »
Ja om verdere problemen te voorkomen als ik later een keer een clean installd oe dan wil ik niet tegen dezelfde problemen aanlopen tot nu toe draait het als een trein

Offline Johan Velthuizen

  • Lid
    • http://www.velthuizen.nl
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #23 Gepost op: 2009/01/04, 19:30:52 »
Hier sinds een week hetzelfde probleem na enige tijd geen internet meer.

Voordien nooit een probleem gehad ik werk met Kubuntu 8.04 maar ook als ik nu s'morgens de PC start heb ik geen internet omdat er geen IP adres wordt opgehaald, na eindeloos opnieuw starten wordt eindelijk een IP adres opgepikt maar is het internet tergend langzaam.
« Laatst bewerkt op: 2009/01/04, 19:32:50 door Johan Velthuizen »

Offline L.P.

  • Lid
  • Steunpunt: Nee
Re: Probleem netwwerk adapter Asus moederbord
« Reactie #24 Gepost op: 2009/01/04, 21:05:25 »
Bij mij was het de oplossing om een andere netwerk adapter in de pc te zetten en dan van een gerenomeerd merk dus geen sweex of realtec of een realtec chipset heb zelf een 3com adapter er in en deze loopt als een zonnetje onboard moet nog even uitgezet worden