Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: GNome werkt niet meer na inloggen op KDE.  (gelezen 862 keer)

Phaldmmor

  • Gast
GNome werkt niet meer na inloggen op KDE.
« Gepost op: 2006/09/19, 22:10:25 »
Hallo,

Ik heb een beetje vreemd probleem. Nadat ik een keer op KDE ben ingelogt kan ik Gnome niet meer gebruiken.
Na het inloggen op Gnome verschijnt wel de balk dat de applicaties van gnome worden geladen, vervolgens zie ik een aantal malen mijn werkbalken knipperen en slaat het scherm op zwart, even daarna kom ik in een terminal sessie terecht.

Het uitschakelen en opnieuw opstarten van de computer lost dit probleem niet op.
De laatste keer heb ik mijn hele systeem opnieuw geinstalleerd, maar heb geen zin omdat nou weer te doen.

Ik weet nog niet zoveel van Ubuntu en ik weet niet zo goed waar te beginnen met troubleshooten. Is er ergens een logfile ofzo die ik kan nakijken?

KDE werkt verder gewoon goed zonder problemen,

Alvast bedankt!

Gr. Phaldmmor

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
GNome werkt niet meer na inloggen op KDE.
« Reactie #1 Gepost op: 2006/09/20, 06:39:05 »
Als je in de terminal komt doe dan eens:
gdm start
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
GNome werkt niet meer na inloggen op KDE.
« Reactie #2 Gepost op: 2006/09/20, 11:53:57 »
Phaldmmor: heb je toevallig gebruik gemaakt van die gtk-qt engine om GTK apps een Qt stijl toe te wijzen?

Probeer dit bestand eens te verwijderen: ~/.gtkrc-2.0
voordat je inlogt op GNOME

als je op de terminal terechtkomt:
rm ~/.gtkrc-2.0

en daarna gdm weer herstarten zodat je kan inloggen:
sudo /etc/init.d/gdm restart
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Phaldmmor

  • Gast
GNome werkt niet meer na inloggen op KDE.
« Reactie #3 Gepost op: 2006/09/20, 12:42:14 »
Citaat van: profoX
Phaldmmor: heb je toevallig gebruik gemaakt van die gtk-qt engine om GTK apps een Qt stijl toe te wijzen?

Probeer dit bestand eens te verwijderen: ~/.gtkrc-2.0
voordat je inlogt op GNOME

als je op de terminal terechtkomt:
rm ~/.gtkrc-2.0

en daarna gdm weer herstarten zodat je kan inloggen:
sudo /etc/init.d/gdm restart
In KDE heb ik bij systeeminstellingen ergens iets aangegeven dat GNOME apps in KDE stijl moeten worden weergegeven, denk dat dat is wat jij bedoeld. Heb hier even mee zitten spelen omdat anders Firefox heel erg raar werd weergegeven. Zal vanavond de oplossing proberen, zit nu op mijn werk.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
GNome werkt niet meer na inloggen op KDE.
« Reactie #4 Gepost op: 2006/09/20, 13:11:59 »
Ja, dat bedoel ik. Dat kan achteraf wel problemen geven :) deze bug werd zogezegd reeds gefixt, maar dat is niet waar. Hij is er nog steeds.

Kan je hier een comment aan toevoegen om te zeggen dat die bug inderdaad nog niet is opgelost?
https://launchpad.net/distros/ubuntu/+source/gtk-qt-engine/+bug/36256

Ik heb hem net ge-heropend.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Phaldmmor

  • Gast
GNome werkt niet meer na inloggen op KDE.
« Reactie #5 Gepost op: 2006/09/20, 21:17:11 »
Thanx profox, probleem is nu idd opgelost! Heb mijn comment toegevoegd op launchpad, hopelijk fixt iemand deze bug, want is wel een vervelende bug!

Alleen nu heb ik weer allemaal dikke lelijke letters in Firefox!!! :(
Kan ik dat probleem oplossen zonder gnome te vernagellen

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
GNome werkt niet meer na inloggen op KDE.
« Reactie #6 Gepost op: 2006/09/20, 21:32:40 »
Phaldmmor: screenshotje ofzo? ik weet niet goed wat je bedoelt.

Misschien eens kijken bij Systeem -> Voorkeuren -> Lettertype
of bij Firefox in Bewerken -> Voorkeuren -> Inhoud -> Lettertypen en kleuren
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Phaldmmor

  • Gast
GNome werkt niet meer na inloggen op KDE.
« Reactie #7 Gepost op: 2006/09/20, 22:04:55 »
mmmz lukt me even niet op screenshot mee te sturen. Probleem is dat de letters in het menu en de werkbalken van firefox dik vet gedrukt en groot zijn als ik KDE gebruik. Ik kan dit probleem oplossen door in KDE naar Systeem Settings > Uiterlijk > GKT Styles and Fonts te gaan en daar bij GKT Fonts eerst Use other fonts te selecteren dan toepassen en dan weer terug naar de orginele setting, Use my KDE fonts in GTK applications te selecteren. Als ik doe krijg ik echter weer spontaan last van het probleem dat ik GNOME niet meer kan starten. Als ik echter de file ~/.gtkrc-2.0 verwijder heb ik het probleem met firefox weer terug :(

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
GNome werkt niet meer na inloggen op KDE.
« Reactie #8 Gepost op: 2006/09/20, 22:35:27 »
Aah.. Tjah.. Firefox is een GTK programma he :( waarschijnlijk zien al je GTK programma's er zo lelijk uit in KDE, maar kan je die stijl niet gewoon aanpassen zonder die gtk-qt-engine ? hmmz.. moet ik ook maar eens een keertje gaan bekijken...

PS: Konqueror is meer dan een waardig alternatief voor Firefox onder KDE ;)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

stilst

  • Gast
GNome werkt niet meer na inloggen op KDE.
« Reactie #9 Gepost op: 2006/11/04, 00:54:38 »
Ik had hetzelfde probleem.
Het hidden bestand ~/.gtkrc-2.0 kon ik niet vinden op mijn systeem
Ik heb dan maar de toepassing gtk2engines-gtk-qt verwijderd met synaptic.
Daarmee is het bij mij opgelost geraakt, ik kan nu terug GNome en KDE gebruiken.