Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Pakket blokkeren van updaten  (gelezen 518 keer)

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
Pakket blokkeren van updaten
« Gepost op: 2008/12/23, 17:01:11 »
Hallo beste mensen,

Ik zit met een heel rare vraag. Is het ook mogelijk (en niet al te dom) om een pakket te blokkeren van updaten?
Het probleem is namelijk dat om de een of andere rede de zsnes pakket in de repo's verkeerd is gecompiled, en daardoor dus crashed bij het opstarten. Op launchpad vond ik een deb die goed was gecompiled waardoor hij dus werkt. Alleen dit is een oude versie, en dus wil update manager steeds de nieuwe versie installeren. Dit wil ik niet, want dan werkt hij niet meer, en kan ik de oudere deb weer installeren.

1) Is het mogelijk?
2) Beschadig ik het update systeem hier niet mee indien mogelijk?

Groet, vlerk

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Pakket blokkeren van updaten
« Reactie #1 Gepost op: 2008/12/23, 17:06:16 »
Volgens mij kan je, wanneer de updater dit aangeeft, een pakket de-selecteren.
Maar voor de goede orde, welk pakket voor welke versie ?
Dit is dan mogelijk belangrijk voor anderen op dit forum.........
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: Pakket blokkeren van updaten
« Reactie #2 Gepost op: 2008/12/23, 17:06:57 »
Dat gaat. In Synaptic uw pakket selecteren, dan boven klikken op "pakket" en "versie vastzetten".

Volgens mij gaat dat met dit pakket helemaal geen problemen opleveren. Het zou misschien kunnen mislopen met belangrijke systeempakketten. Hoewel het dependency systeem problemen zou moeten voorkomen dan.

Offline Koen Bokern

  • Lid
  • Steunpunt: Nee
Re: Pakket blokkeren van updaten
« Reactie #3 Gepost op: 2008/12/23, 19:52:40 »
Dank voor jullie reacties, het is gelukt :)

Het gaat om het pakket zsnes.

Versies:
1.510-2.1ubuntu1 (intrepid) >> https://bugs.launchpad.net/ubuntu/+source/zsnes/+bug/250425
1.510-0ubuntu1 (now)
zie ook mijn topic over dit probleem.
http://forum.ubuntu-nl.org/index.php/topic,35177.0.html