Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Raar muis scroll-gedrag na upgrade Intrepid  (gelezen 1539 keer)

halebopp

  • Gast
Raar muis scroll-gedrag na upgrade Intrepid
« Gepost op: 2008/12/22, 22:13:44 »
Sinds de upgrade naar Intrepid scrollt mijn muis niet meer goed. Ik heb een Logitech MX700 (of MX-700). Als ik het scroll wieltje gebruik dan is het de bedoeling dat er verticaal gescrolld wordt. In plaats daarvan scroll ik niet alleen verticaal maar tegelijkertijd ook horizontaal. Ik ga dus na de upgrade diagonaal scrollend door het leven. Zeer irritant!  :(

Herkent iemand dit?

Ik had geen aparte fdi voor HAL. Sinds een paar dagen wel, maar het heeft niet geholpen. Dit is mijn huidige fdi:

<match key="info.capabilities" contains="input.mouse">
     <merge key="input.x11_options.ButtonMapping" type="string">1 2 3 4 5 6 7 8 9 10</merge>
     <merge key="input.x11_options.YAxisMapping" type="string">4 5</merge>
     <merge key="input.x11_options.EmulateWheel" type="string">true</merge>
     <merge key="input.x11_options.Buttons" type="string">10</merge>
     <merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
   </match>

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #1 Gepost op: 2008/12/22, 23:45:00 »
Misschien het probleem wat ik ook had. Systeem>Voorkeuren>Toetsenbord >Tabblad Muistoetsen> Per ongeluk "De muisaanwijzer is bestuurbaar met het nummerblok" aangevinkt?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

halebopp

  • Gast
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #2 Gepost op: 2008/12/23, 09:15:48 »
Helaas, die staat bij mij netjes uitgevinkt....

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #3 Gepost op: 2008/12/23, 14:37:42 »
Wat is het pad naar dat fdi bestand? Kan ik kijken hoe het er bij mij uitziet.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

halebopp

  • Gast
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #4 Gepost op: 2008/12/23, 14:41:42 »
Alvast bedankt!
Het pad is
/etc/hal/fdi/policy/

Maar als je zelf geen fdi hebt gemaakt voor je muis dan zal er hier ook geen fdi bestand staan. HAL pakt normaal gesproken prima settings voor de Logitech MX700 heb ik gemerkt, op het scrollen na dan.....  :-X

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #5 Gepost op: 2008/12/23, 19:36:11 »
Klopt helemaal geen fdi bestand. Zou verder het een twee drie niet weten, een van de andere forum leden?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline jw

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #6 Gepost op: 2008/12/30, 10:20:11 »
Ik heb een marble mouse en wil de hal/fdi veranderen. In 8.04 gaat dat nog met xorg.conf maar 8.10 met fdi. Weet iemand hoe ik de hal/fdi files moet editten?

Ik wil dit regeltje erin zetten van deze site: https://help.ubuntu.com/community/Logitech_Marblemouse_USB

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #7 Gepost op: 2008/12/30, 15:35:11 »
Ik heb een marble mouse en wil de hal/fdi veranderen. In 8.04 gaat dat nog met xorg.conf maar 8.10 met fdi. Weet iemand hoe ik de hal/fdi files moet editten?

Ik wil dit regeltje erin zetten van deze site: https://help.ubuntu.com/community/Logitech_Marblemouse_USB
Normaal gezien kan je een bestand editten via terminal: sudo gedit bestandsnaam (volledig adres dus)
Wat je eerst zeker moet doen is je bestand veilig stellen:
sudo cp /etc/hal/fdi/policy/preferences.fdi /etc/hal/fdi/policy/preferences.fdi.originalDaarna:
sudo gedit  /etc/hal/fdi/policy/preferences.fdi Nu selekteer je alles in het bestand en delete het.
Selecteer en Kopiëer het bestandje van de webpagina en je Plakt het in je fdi bestand.
Dan opslaan en computer herstarten.
Bovenaan in het bestandje staat wel iets over encoding, kijk dit even na of dat hetzelfde is als in je originele bestand, dat zal waarschijnlijk dezelfde moeten zijn maar dat weet ik niet zeker.
Als het niet moest werken kan je altijd je originele terugzetten door de twee bestanden te hernoemen. Bij /etc/hal/fdi/policy/preferences.fdi.original haal je .original weg en bij het andere zet je bijv.:   .test    erbij. (Altijd zien dat de puntjes erbij staan of mee verwijderd worden. Je ziet in de oorspronkelijke naam geen puntje op het einde, staat dat er wel dan word het bestand niet herkend. Opletten dus.

Alternatief voor het veranderen van het bestand inplaats van te hernoemen:
Maak een nieuw bestand aan. Je kan dat op de Desktop doen via je rechtermuisknop maar de adressering ervan hangt af van je taal. In nederlands is dat dus Bureaublad. Dat geeft verschil.
Als je nu dat bestandje via de webpagina Selekteert en Kopiëert, Plak je dit in dat bestandje, Opslaan als... En geef het een korte naam, bijv. 'pref'
Open een terminal:
sudo cp /home/jouwgebruikersnaam/Desktop/pref /etc/hal/fdi/policy/preferences.fdiDus hierboven opletten als je in de nederlandse versie werkt:
sudo cp /home/jouwgebruikersnaam/Bureaublad/pref /etc/hal/fdi/policy/preferences.fdiLet op de hoofdletter in Desktop en Bureaublad (is ook met een hoofdletter geloof ik) anders krijg je een error: cp: cannot stat `/desktop/pref': No such file or directory
Je kan het natuurlijk ergens anders opslaan maar dan veranderd logischerwijze het adres ernaartoe.


Opmerkingen en aanpassingen zijn altijd welkom.

Offline jw

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #8 Gepost op: 2008/12/31, 09:56:18 »
 :)  Bedankt Heir4c, scrollen doet het weer in 8.10  8) Ik heb je eerste tips opgevolgd, en gewoon die tekst vd site in FDI gezet. Xorg opstarten is niet genoeg, pc moet helemaal nieuw opgestart.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #9 Gepost op: 2008/12/31, 11:50:07 »
Ben ik blij,ik ben tenslotte maar een groentje. Heb intussen het bericht aan gepast en er 'computer herstarten' bijgezet.
thx om het te melden dat het gelukt is.

Offline jw

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #10 Gepost op: 2008/12/31, 12:23:25 »
Ik ben niet helemaal een groentje maar die FDI gaat me behoorlijk ver. ;)

halebopp

  • Gast
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #11 Gepost op: 2008/12/31, 13:39:24 »
In plaats van preferences.fdi aan te passen kan je ook een nieuw bestand toevoegen aan /etc/hal/fdi/policy/

Bijvoorbeeld logitech.fdi voor je muis. Alle fdi bestanden in deze map worden meegenomen door HAL.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Raar muis scroll-gedrag na upgrade Intrepid
« Reactie #12 Gepost op: 2008/12/31, 16:42:07 »
thx voor de info, elke dag leren we wat bij. Mooi.