Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Mediaserver en PS3  (gelezen 2290 keer)

Zarkuno

  • Gast
Mediaserver en PS3
« Gepost op: 2008/12/22, 17:53:23 »
Hey daar!

Op één of andere manier lukt het niet om welke mediaserver dan ook goed draaiende te krijgen voor m'n PS3...
Ik heb Mediatomb, Fuppes en PS3 Media Server geprobeerd. Met alle programma's zie ik de bestanden en bij foto en film zelfs de thumbnails. Ze worden alleen niet gedraaid. Alle geprobeerde bestanden geven "incompatible data".

Ik heb met en zonder firewall op de router geprobeerd, maar zonder resultaat.

 ???

Offline bas.

  • Lid
    • Wat mij bezig houdt
  • Steunpunt: Nee
Re: Mediaserver en PS3
« Reactie #1 Gepost op: 2008/12/22, 23:26:43 »
Ik heb hem werkend gehad met mediatomb na veel zoeken met google had ik een config file gevonden die foutloos werkte.
Ik wil morgen wel even zoeken of ik deze nog kan vinden voor je.
Ik zelf gebruik inmiddels freenas voor mijn media server en ftp server en ben daar zeer tevreden over.
=SOG= 4 life

laptop DELL Inspiron 1525 ubuntu 9.10

Ubuntu user # 27873

Wat mij bezig houdt

Zarkuno

  • Gast
Re: Mediaserver en PS3
« Reactie #2 Gepost op: 2008/12/23, 12:57:08 »
Ok, thanks! Het rare is alleen wel dat hetzelfde probleem zich voordoet bij al die mediaserver-oplossingen...
En ik kan me bijv. niet voorstellen dat het een codec-probleem is, dan zouden jpg en mp3 toch evengoed moeten werken?

Offline bas.

  • Lid
    • Wat mij bezig houdt
  • Steunpunt: Nee
Re: Mediaserver en PS3
« Reactie #3 Gepost op: 2008/12/23, 20:04:11 »
Dit is de config file die ik gebruikt heb:

<?xml version="1.0" encoding="UTF-8"?>
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlnssi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
<server>
<ui enabled="yes">
<accounts enabled="no" session-timeout="30">
<account user="mediatomb" password="mediatomb"/>
</accounts>
</ui>
<name>MediaTomb</name>
<udn>uuid:c4425c07-a131-403b-88a6-e1e2dc163b7f</udn>
<home>/var/lib/mediatomb</home>
<webroot>/usr/share/mediatomb/web</webroot>
<storage>
<sqlite3 enabled="yes">
<database-file>sqlite3.db</database-file>
</sqlite3>
<mysql enabled="no">
<host>localhost</host>
<username>mediatomb</username>
<database>mediatomb</database>
</mysql>
</storage>
<protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
<!--
Uncomment the lines below to get rid of jerky avi playback on the
DSM320 or to enable subtitles support on the DSM units
-->
<!--
<custom-http-headers>
<add header="X-User-Agent: redsonic"/>
</custom-http-headers>

<manufacturerURL>redsonic.com</manufacturerURL>
<modelNumber>105</modelNumber>
-->
<!-- Uncomment the line below if you have a Telegent TG100 -->
<!--
<upnp-string-limit>101</upnp-string-limit>
-->
</server>
<import hidden-files="no">
<scripting script-charset="UTF-8">
<common-script>/usr/share/mediatomb/js/common.js</common-script>
<playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
<virtual-layout type="builtin">
<import-script>/usr/share/mediatomb/js/import.js</import-script>
</virtual-layout>
</scripting>
<mappings>
<extension-mimetype ignore-unknown="no">
<map from="mp3" to="audio/mpeg"/>
<map from="ogg" to="application/ogg"/>
<map from="asf" to="video/x-ms-asf"/>
<map from="asx" to="video/x-ms-asf"/>
<map from="wma" to="audio/x-ms-wma"/>
<map from="wax" to="audio/x-ms-wax"/>
<map from="wmv" to="video/x-ms-wmv"/>
<map from="wvx" to="video/x-ms-wvx"/>
<map from="wm" to="video/x-ms-wm"/>
<map from="wmx" to="video/x-ms-wmx"/>
<map from="m3u" to="audio/x-mpegurl"/>
<map from="pls" to="audio/x-scpls"/>
<map from="flv" to="video/x-flv"/>
<!-- Uncomment the line below for PS3 divx support -->
<map from="avi" to="video/divx"/>
<map from="divx" to="video/divx"/>
<!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
<!-- <map from="avi" to="video/avi"/> -->
</extension-mimetype>
<mimetype-upnpclass>
<map from="audio/*" to="object.item.audioItem.musicTrack"/>
<map from="video/*" to="object.item.videoItem"/>
<map from="image/*" to="object.item.imageItem"/>
</mimetype-upnpclass>
<mimetype-contenttype>
<treat mimetype="audio/mpeg" as="mp3"/>
<treat mimetype="application/ogg" as="ogg"/>
<treat mimetype="audio/x-flac" as="flac"/>
<treat mimetype="image/jpeg" as="jpg"/>
<treat mimetype="audio/x-mpegurl" as="playlist"/>
<treat mimetype="audio/x-scpls" as="playlist"/>
<treat mimetype="audio/x-wav" as="pcm"/>
<treat mimetype="video/x-msvideo" as="avi"/>
</mimetype-contenttype>
</mappings>
</import>
<transcoding enabled="no">
<mimetype-profile-mappings>
<transcode mimetype="video/x-flv" using="vlcmpeg"/>
<transcode mimetype="application/ogg" using="vlcmpeg"/>
<transcode mimetype="application/ogg" using="oggflac2raw"/>
<transcode mimetype="audio/x-flac" using="oggflac2raw"/>
</mimetype-profile-mappings>
<profiles>
<profile name="oggflac2raw" enabled="no" type="external">
<mimetype>audio/L16</mimetype>
<accept-url>no</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>no</accept-ogg-theora>
<agent command="ogg123" arguments="-d raw -f %out %in"/>
<buffer size="1048576" chunk-size="131072" fill-size="262144"/>
</profile>
<profile name="vlcmpeg" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25, aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,ch annels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
</profiles>
</transcoding>
</config>

succes.
=SOG= 4 life

laptop DELL Inspiron 1525 ubuntu 9.10

Ubuntu user # 27873

Wat mij bezig houdt

Offline bas.

  • Lid
    • Wat mij bezig houdt
  • Steunpunt: Nee
Re: Mediaserver en PS3
« Reactie #4 Gepost op: 2008/12/23, 20:05:52 »
Een codec probleem zou het denk ik niet zijn aan gezien de ps3 het alleen maar afspeelt en de pc de codecs heeft die gebruikt worden.
=SOG= 4 life

laptop DELL Inspiron 1525 ubuntu 9.10

Ubuntu user # 27873

Wat mij bezig houdt

Zarkuno

  • Gast
Re: Mediaserver en PS3
« Reactie #5 Gepost op: 2008/12/25, 09:42:49 »
Ik ben eruit!

Het bleek (na een paar uur proberen) achteraf een instelling op de PS3. UPNP stond uit. Wel raar want de upnp-server op m'n laptop (mediaplayer) deed het gewoon wel.

Evengoed bedankt voor de config-file!

Ik heb nu ipv. Mediatomb de PS3 Media Server (op basis van java) draaien, hij speelt zelfs m2ts-bestanden moeiteloos af.

 =D

Offline bas.

  • Lid
    • Wat mij bezig houdt
  • Steunpunt: Nee
Re: Mediaserver en PS3
« Reactie #6 Gepost op: 2008/12/25, 10:43:27 »
UPNP moet idd wel aan staan ja anders gebeurt echt helemaal niks.
Alleen heb ik geen idee wat m2ts bestanden zijn  ???
=SOG= 4 life

laptop DELL Inspiron 1525 ubuntu 9.10

Ubuntu user # 27873

Wat mij bezig houdt