Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Virtualbox clone van .vdi start niet door...  (gelezen 1204 keer)

Offline nicolaasjan

  • Lid
  • Steunpunt: Nee
Virtualbox clone van .vdi start niet door...
« Gepost op: 2008/12/22, 17:29:44 »
Hallo allemaal!

Omdat ik overweeg een Mandriva partitie, met daarop een te behouden virtuele Ubuntu installatie, te wissen heb ik betreffende vdi gecloned naar m'n usb-schijf met het commando:
VBoxManage clonevdi /home/nico/.VirtualBox/VDI/Ubuntu-8.04.vdi /media/LACIE/Ubuntu-8.04.clone.vdiDit is succesvol voltooid met de volgende output:
Clone hard disk created in format 'VDI'. UUID: 4313de92-e421-4456-bf1c-e93d1314ba89Wanneer ik vervolgens in m'n Ubuntu host met behulp van Virtualbox een nieuwe machine hiervan maak, wordt deze wel geopend, maar blijft steken in "GRUB loading, please wait..."
Nou ik kan wachten tot ik een ons weeg, maar verder gaat ie niet. ???
Hetzelfde verhaal onder WindowsXP als host.
Via Google heb ik helaas niets zinnigs kunnen vinden.

Weet iemand wellicht een manier om die virtuele schijf alsnog aan de praat te krijgen?

M.v.g., Nico. :)

Offline nicolaasjan

  • Lid
  • Steunpunt: Nee
Re: Virtualbox clone van .vdi start niet door...
« Reactie #1 Gepost op: 2009/01/18, 19:18:22 »
[bump]

niemand een idee?

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Virtualbox clone van .vdi start niet door...
« Reactie #2 Gepost op: 2009/01/19, 11:02:14 »
Hallo, ik vermoed dat die UUID door de virtuele grub niet herkend/begrepen wordt. Maar hoe dat op te lossen? In een VBox.log van een van m'n VM's vind ik wel twee keer een string "uuid", maar de waarden daar zijn hexadecimaal...

EDIT. Misschien kun je iets met de opdracht
$ VBoxManage list       # geeft uuid's van al je vm's
« Laatst bewerkt op: 2009/01/19, 11:16:51 door Paul Matthijsse »
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline nicolaasjan

  • Lid
  • Steunpunt: Nee
Re: Virtualbox clone van .vdi start niet door...
« Reactie #3 Gepost op: 2009/01/19, 15:28:57 »
Hallo, ik vermoed dat die UUID door de virtuele grub niet herkend/begrepen wordt. Maar hoe dat op te lossen? In een VBox.log van een van m'n VM's vind ik wel twee keer een string "uuid", maar de waarden daar zijn hexadecimaal...

EDIT. Misschien kun je iets met de opdracht
$ VBoxManage list       # geeft uuid's van al je vm's
Paul, bedankt voor het meedenken, maar ik had van kwaaigheid die gekloonde .vdi al versnipperd... :-[
Wel had ik een "gewone" kopie gemaakt en jawel hoor, die doet 't wel!
Zowel in Linux als Windows hosts.
Die Mandriva partitie heb ik toch nog maar niet verwijderd; kon het niet over m'n hart verkrijgen.
Wel heb ik 'm ge├╝pgrade van 2008.0 naar 2008.1; dat ging zowaar nog goed ook!

M.v.g., Nico. :)

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Virtualbox clone van .vdi start niet door...
« Reactie #4 Gepost op: 2009/01/19, 17:11:34 »
Dat van die kwaaiigheid ken ik wel ("WAT? Jij het niet meer doen? Opzouten, wegwezen, prullenbak!")  :)
Gelukkig dat die 'gewone' het nog wel goed doet!

Groet, Paul.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...