Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Webcam Sweex WC040 werkt niet  (gelezen 4053 keer)

Tijssie

  • Gast
Webcam Sweex WC040 werkt niet
« Gepost op: 2008/12/12, 18:14:13 »
Hallo mensen,
Ik krijg mijn Sweex webcam niet aan de praat... Ik heb easycam 2 van een franse site geinstalleerd en het leek goed te gaan maar de cam wordt niet herkend in apps als cheese, camorama. Bij lsusb krijg ik:
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 2770:930b NHJ, Ltd CCD Webcam(PC370R)
Bus 001 Device 004: ID 15a9:0004 
Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Iemand opties?? Ik draai Ubuntu 8.10 en heb niet zo veel ervaring behalve dat ik het een mooi besturingssyteem vind!
Groeten Tijs

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam Sweex WC040 werkt niet
« Reactie #1 Gepost op: 2008/12/12, 20:28:44 »
Is er wel een driver geïnstalleerd met Easycam2? De gscpa?
Naar wat ik begrijp is je Webcam er een met "Motion" misschien heb je wel de UVC driver nodig
http://forum.nedlinux.nl/viewtopic.php?pid=255798#p255798
http://linux-uvc.berlios.de/
http://www.lavrsen.dk/twiki/bin/view/Motion/LinuxUvcTrackingPatch

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #2 Gepost op: 2008/12/13, 12:46:14 »
Goeie vraag, de Franse tool zegt van wel en er staat zelfs mijn webcam als ik 'm nog een keer installeer via de tool. Die link naar de download voor de UVC is uit de lucht maar op het eerste forum staat ook iemand met mijn probleem zonder antwoord dus ik vrees dat ik een andere nodig heb, ik ben nl niet zo handig met allerlei zaken programmeren... Bedankt voor je reactie!

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Webcam Sweex WC040 werkt niet
« Reactie #3 Gepost op: 2008/12/13, 15:21:01 »

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #4 Gepost op: 2008/12/14, 15:26:21 »
Hallo Vistaus,
Als ik de eerste regel intik:
sudo modprobe -r gspca
krijg ik als antwoord:
FATAL: Module gspca not found.
Ik dacht dat dat gspca standaard in ubuntu 8.10 zat en ik heb ook nog easycam geinstalleerd...
Kan ik dit ook los installeren en zo ja hoe??
Gr. Tijs

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Webcam Sweex WC040 werkt niet
« Reactie #5 Gepost op: 2008/12/14, 17:38:03 »
Hallo Vistaus,
Als ik de eerste regel intik:
sudo modprobe -r gspca
krijg ik als antwoord:
FATAL: Module gspca not found.
Ik dacht dat dat gspca standaard in ubuntu 8.10 zat en ik heb ook nog easycam geinstalleerd...
Kan ik dit ook los installeren en zo ja hoe??
Gr. Tijs


Er kunnen 2 dingen zijn:

1 De tutorial werkt niet voor jou webcam
2 De tutorial werkt niet voor 8.10 (maar dat lijkt me behoorlijk sterk)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam Sweex WC040 werkt niet
« Reactie #6 Gepost op: 2008/12/14, 19:05:56 »
Hallo Vistaus,
Als ik de eerste regel intik:
sudo modprobe -r gspca
krijg ik als antwoord:
FATAL: Module gspca not found.
Ik dacht dat dat gspca standaard in ubuntu 8.10 zat en ik heb ook nog easycam geinstalleerd...
Kan ik dit ook los installeren en zo ja hoe??
Gr. Tijs

Heb je gspca-source geinstalleerd in Synaptic? Nee, doe dit alsnog.
source for the gspca v4l kernel module
The gpsca video for linux (v4l) driver, provides support for
webcams and digital cameras based on the spca5xx range of chips
manufactured by SunPlus, Sonix, Z-star, Vimicro, Conexant, Etoms,
Mars-semi, Pixart and Transvision.
Hierna nog eens proberen met Easycam2.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #7 Gepost op: 2008/12/14, 19:45:26 »
Hallo Gijs,
Hoe moet ik dat installeren?
Groeten Tijs

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Webcam Sweex WC040 werkt niet
« Reactie #8 Gepost op: 2008/12/14, 20:21:01 »
Dat lijkt me niet Gijs, althans op 8.04 hoeft dat niet, dus op 8.10 dan ook niet neem ik aan.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam Sweex WC040 werkt niet
« Reactie #9 Gepost op: 2008/12/14, 21:57:49 »
Dat lijkt me niet Gijs, althans op 8.04 hoeft dat niet, dus op 8.10 dan ook niet neem ik aan.
Ik heb deze in ieder geval wel geïnstalleerd op 8.10. Baat het niet,schaadt het niet.
@Thijssie, zit in Synaptic, zoeken op gspca-source en kijken of dit voor jou ook voldoet, verwijderen kan altijd nog.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #10 Gepost op: 2008/12/15, 20:53:05 »
Hallo Gijs,
Merci voor je reactie, ik geloof dat ik langzaam verder kom.
ik heb die gspca module geinstalleerd via Synaptic, opnieuw opgestart en de volgende regel geprobeerd:
sudo modprobe -r gspca
Dan krijg ik weer als antwoord:
FATAL: Module gspca not found.
Vreemd toch, de installatie is goed gegaan, hij staat ook in de lijst nu bij synaptic en toch zegt ie dat ie ḿ niet kan vinden...
Ook een herinstallatie via easycam2 mocht niet baten.
Zijn er nog mogelijkheden of moet ik een ubuntu-proof webcammetje halen?
Groeten tijs

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam Sweex WC040 werkt niet
« Reactie #11 Gepost op: 2008/12/15, 22:59:50 »
Download het orgineel hier eens http://mxhaard.free.fr/download.html
Rechts op klikken en dan Hier uitpakken kiezen. Dan naar de map gaan waar het bestand is uitgepakt, hierin zit een read en install tekstbestand hierin staat hoe je het moet installeren.
Als het niet lukt post je maar weer.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #12 Gepost op: 2008/12/17, 10:30:43 »
Hallo Gijs,
Wow, een hele rits foutmeldingen na de ./gspca_build....
In het installatie bestand staat dat ik ḿ eerst moet compilen, alleen niet hoe te installeren. Nog een tipje misschien?
Alvast bedankt!
Groeten Tijs

 REMOVE the old module if present
ERROR: Module gspca does not exist in /proc/modules

 CLEAN gspca source tree
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
   .gspca.o.cmd  *.o *.ko *.mod.* .[a-z]* core *.i \
   *.symvers *.err

 COMPILE gspca Please Wait ....!!

 INSTALL gspca in the kernel binary tree
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: cannot stat `gspca.ko': No such file or directory
make: *** [install] Error 1

 LOAD gspca in memory
FATAL: Module gspca not found.

 PRINT COMPILATION MESSAGES if ERRORS look kgspca.err
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/tijs/Bureaublad/gspcav1-20071224 CC=cc modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-10-generic'
  CC [M]  /home/tijs/Bureaublad/gspcav1-20071224/gspca_core.o
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c: At top level:
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
make[2]: *** [/home/tijs/Bureaublad/gspcav1-20071224/gspca_core.o] Error 1
make[1]: *** [_module_/home/tijs/Bureaublad/gspcav1-20071224] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-10-generic'
make: *** [default] Error 2

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Webcam Sweex WC040 werkt niet
« Reactie #13 Gepost op: 2008/12/18, 16:52:55 »
Eerst compilen, en dan sudo make install. Maar dat kan niet als je bij make al errors krijgt. Het lijkt erop dat de gspca module niet aanwezig is in de kernel... zeer vreemd.

Tijssie

  • Gast
Re: Webcam Sweex WC040 werkt niet
« Reactie #14 Gepost op: 2008/12/29, 19:03:07 »
Nog iemand een optie, anders sluit ik 'm maar af?
Iedereen die gereageerd heeft: hartelijk bedankt!
Groeten Tijs

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Webcam Sweex WC040 werkt niet
« Reactie #15 Gepost op: 2008/12/29, 20:29:02 »
Thijs nog even dit Bus 001 Device 005: ID 2770:930b NHJ, Ltd CCD Webcam(PC370R), ik heb gezocht op deze chip en dit zou een philips chip zijn http://www.linuxquestions.org/questions/linux-hardware-18/philips-spc900nc-webcam-and-pwc-issues-683808/ in de laatste post verwijzing naar deze site http://www.qbik.ch/usb/devices/showdev.php?id=4388
en de download http://www.saillard.org/linux/pwc/ er staat boven een tabje met debian packages,
geen idee of je die kan gebruiken, in eerste instantie toch de tarrball gebruiken. In Synaptic staat nog het programma setpwc. Hopelijk heb je hier wat aan.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.