Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Apache start niet meer.  (gelezen 6336 keer)

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Apache start niet meer.
« Gepost op: 2008/12/10, 23:49:47 »
Hallo allemaal ik heb op mijn ubuntu systeem een apache server draaien.
Maar sinds kort wil hij niet meer opstarten.

bij het uitvoeren van sudo apache2ctl restart krijg ik de volgende error.
Kan iemand mij op weg helpen?

Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #1 Gepost op: 2008/12/10, 23:56:44 »
probeer dit eens:
sudo /etc/init.d/apache2 restart
 stop
 start
 restart

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #2 Gepost op: 2008/12/10, 23:58:46 »
sudo /etc/init.d/apache2 restart
 * Restarting web server apache2                                                apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName
httpd (no pid file) not running
apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #3 Gepost op: 2008/12/11, 02:11:03 »
Je moet hem even een "qualified domain name" geldige domein naam geven.
Dat woordje geldig kan je met een korrel zout nemen, maar het moet wel een domein naam zijn.

omdat hij die niet heeft pakt hij automatisch het server ipadres.
echter dit is om reden al ingebruik en dus eindigt hij met "adres 0.0.0.0:443"
dit ipadres met poort kan niet dus stop hij weer.

ea kan je hierin regelen.
/etc/httpd/conf/httpd.conf
/etc/httpd/conf.d/system-config-httpd.conf

Normaal gesproken komt dit ook wanneer er 2 webserver tegelijk werken die dezelfde poorten willen gebruiken (80/443)

Wanneer je httpd stopt heb je er ook geen last meer van.
Starten & stoppen
service httpd start
service httpd stop


Indien je toch httpd wilt gebruiken moet je even een # plaatssen voor "Listen 443" in de ssl.conf
/etc/httpd/conf.d/ssl.conf

voorbeeld:
#
# When we also provide SSL we have to listen to the
# the HTTPS port in addition.
#
#Listen 443
« Laatst bewerkt op: 2008/12/11, 11:48:38 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #4 Gepost op: 2008/12/11, 10:41:38 »
Als ik httpd probeer te stoppen krijg ik:

sudo: service: command not found


Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #5 Gepost op: 2008/12/11, 11:51:08 »
Doe je wel
sudo service httpd stop

en of doe dan eens
sudo httpd stopkan het nu niet testen....

en vergeet niet een hekje te plaaten voor "Listen 443" in de ssl.conf
als je httpd niet gebruikt heb je die toch niet nodig.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #6 Gepost op: 2008/12/11, 11:58:15 »
sudo service httpd stop werkt niet
en die andere ook niet.


mijn ssl.conf geeft geen Listen.

locate ssl.conf geeft:

Citaat
/etc/apache2/mods-available/ssl.conf
/etc/apache2/mods-enabled/ssl.conf
/usr/share/doc/apache2.2-common/examples/apache2/extra/httpd-ssl.conf.gz
/var/lib/dpkg/info/openssl.conffiles

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #7 Gepost op: 2008/12/11, 12:05:00 »
Ok, volgens mij heb je dan ook helemaal geen httpd die actief of zelfs geïnstalleerd is.

Kan je ons de inhoud van de file /etc/hostname eens geven aub? In die file staat namelijk je huidige FQDN (Fully qualified domain name).

° Bezoek mijn blog Digital (in)Sanity °

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #8 Gepost op: 2008/12/11, 12:10:01 »
Die is helemaal leeg!

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #9 Gepost op: 2008/12/11, 12:11:10 »
Ok, geef eens dit commando in in de terminal:

hostname -f
Wat is hiervan de output?

° Bezoek mijn blog Digital (in)Sanity °

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #10 Gepost op: 2008/12/11, 12:12:42 »
sudo service httpd stop werkt niet
en die andere ook niet.


mijn ssl.conf geeft geen Listen.

locate ssl.conf geeft:

Citaat
/etc/apache2/mods-available/ssl.conf
/etc/apache2/mods-enabled/ssl.conf
/usr/share/doc/apache2.2-common/examples/apache2/extra/httpd-ssl.conf.gz
/var/lib/dpkg/info/openssl.conffiles

Grumpf  ???

Kijk in /etc/apache2/  
staat daar een file met de naam "ports.conf"  ??
dus /etc/apache2/ports.conf
Dan staat hierin naar welke poorten geluisterd moet worden.
en kan je hier dat # voor die listen 443 zetten.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #11 Gepost op: 2008/12/11, 12:23:41 »
File ziet er zo uit
Listen 80

<IfModule mod_ssl.c>
    Listen 443
</IfModule>
listen 443


Heb het veranderd in

Listen 80
<IfModule mod_ssl.c>
    Listen 443
</IfModule>
#listen 443

en nu?


ps: bedankt voor de hulp tot zo ver ;-)




Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #12 Gepost op: 2008/12/11, 12:47:36 »
En nu ff opnieuw starten.
of apache alleen opnieuw starten.

misschien is het beter de hele server ff opnieuw te starten met een reboot.
alles fris en dan maar duimen  ;)
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #13 Gepost op: 2008/12/11, 13:00:13 »
Ik kan nu niet de server restarten om dat ik er via vnc in zit. Server staat thuis en als ik hem hier opnieuw wil starten dan logt ie niet in en kan ik er ook niet in via vnc.

Ik heb iig geprobeerd om apache op te starten en dan krijg ik:

apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName


Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #14 Gepost op: 2008/12/11, 13:04:37 »
Ok, geef eens dit commando in in de terminal:

hostname -f
Wat is hiervan de output?

Kan je dit aub eens doen? Volgens mij gaat dit probleem opgelost zijn als we in de file /etc/hostname een FQDN gaan ingeven. Maar dan moeten we eerst wel weten wat we gaan ingeven natuurlijk. Ken je zo vanbuiten de naam die je aan de server gegeven hebt. Je kan anders eens proberen om in de file /etc/hostname dit in te geven:

<naam_van_je_server>.local

° Bezoek mijn blog Digital (in)Sanity °

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #15 Gepost op: 2008/12/11, 13:11:44 »
in mijn hostname heb ik nu  gezet

pc-ds3.local
Vervolgens heb ik gedaan
sudo apache2ctl start
Dan krijg ik de melding:

Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName


Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #16 Gepost op: 2008/12/11, 15:10:30 »
Deze melding:
Citaat
apache2: Could not reliably determine the server's fully qualified domain name, using 192.168.1.12 for ServerName
Is niet perse een foutmelding.
Hier kan je gewoon mee leven hoor ?
En hier kan je gewoon mee werken en oud worden.  ;)
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #17 Gepost op: 2008/12/11, 15:30:18 »
Lokaal doet hij het inderdaad weer.
Maar van buitenaf kan ik er nog niet bij.

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #18 Gepost op: 2008/12/11, 15:32:26 »
Dat gaat dan weer een ander probleem zijn. Moet je door een router/firewall heen? Indien ja, dan moet je de port-forwarding eens gaan nakijken of je http poort wel geforward wordt naar het interne IP adres van je server!

° Bezoek mijn blog Digital (in)Sanity °

Offline sandersjj

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #19 Gepost op: 2008/12/11, 16:19:24 »
Daar zit wat in. Dat ga ik dan vanvond wel weer recht zetten.

Maar wat ik eigenlijk wilde is SVN installeren. Daar begon het voor mij allemaal mee.

Hiervoor gebruik ik  deze http://www.sellersrank.com/ubuntu/setup-apache-subversion-ssl-https-with-virtual-hosts-on-ubuntu/ handleiding

Bij het uitvoeren van:

sudo apt-get install libapache2-svnKreeg ik de volgende melding:


Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libc-client2002edebian linux-headers-2.6.24-16-generic
  linux-headers-2.6.24-16
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libsvn1
Suggested packages:
  db4.6-util patch libsvn-ruby1.8
Recommended packages:
  exim4 mail-transport-agent libconfig-inifiles-perl libsvn-perl
  python-subversion
The following NEW packages will be installed:
  libsvn1 subversion subversion-tools
0 upgraded, 3 newly installed, 0 to remove and 179 not upgraded.
Need to get 1009kB of archives.
After this operation, 5427kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://nl.archive.ubuntu.com hardy/main libsvn1 1.4.6dfsg1-2ubuntu1 [594kB]
Get:2 http://nl.archive.ubuntu.com hardy/main subversion 1.4.6dfsg1-2ubuntu1 [243kB]
Get:3 http://nl.archive.ubuntu.com hardy/main subversion-tools 1.4.6dfsg1-2ubuntu1 [172kB]
Fetched 1009kB in 1s (763kB/s)     
Selecting previously deselected package libsvn1.
(Reading database ... dpkg: error processing /var/cache/apt/archives/libsvn1_1.4.6dfsg1-2ubuntu1_i386.deb (--unpack):
 failed in buffer_read(fd): files list for package `ubuntu-standard': Input/output error
Errors were encountered while processing:
 /var/cache/apt/archives/libsvn1_1.4.6dfsg1-2ubuntu1_i386.deb
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Wat moet ik hiermee. Kan ik mijn installatie process gewoon volgen of moet ik iets anders doen?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: Apache start niet meer.
« Reactie #20 Gepost op: 2008/12/11, 17:43:22 »
Geen idee wat je precies wilt met SVN ??

Maagoe

hier vind je een How To die goed is en waar je wel het nodige uit kan halen.
http://www.howtoforge.com/debian_subversion_websvn
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D