Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Bestand is in gebruik bij 'netwerkschijf'  (gelezen 618 keer)

Offline sjampoo

  • Lid
  • Steunpunt: Nee
Bestand is in gebruik bij 'netwerkschijf'
« Gepost op: 2008/12/10, 21:55:09 »

2 rariteiten op 1 avond, waar ik niet uitkom:

Zoals wellicht bekend; ik ben mijn cd collectie aan het digitaliseren/ordenen/catalogiseren.

Zolang data lokaal staat ( /home/ikke/muziek ) gaat alles goed: Ik kan playlistjes maken, opslaan, openen etc.

Maar; zodra ze op een netwerkshare staan ( w2k server, via fstab automatisch gemount, mét schrijfrechten ) gaat het mis:

playlistje, geopend via 'rechtsklik -> openen met texteditor' wil ik opslaan:



Lokaal slaat ie gewoon op, maar 'gemount' op een netwerk share geeft ie bovenstaande foutmelding. Opslaan als werkt wél maar dan moet ik handmatig de oude tekst file weggooien, en de nieuwe weer hernoemen naar de oude naam. ( weggooien van de 'busy tekst file' gaat wel zonder problemen ).

De schijf is gemount via de volgende regel:
Citaat
//10.0.0.155/data /media/data_home-server cifs credentials=/root/.smbcredentials,iocharset=utf8,_netdev 0 0

Wat gaat er mis?  ???

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Bestand is in gebruik bij 'netwerkschijf'
« Reactie #1 Gepost op: 2008/12/11, 10:03:12 »
Niks :)
Ik zou de optie nobrl toevoegen aan je mount opties://10.0.0.155/data /media/data_home-server cifs credentials=/root/.smbcredentials,iocharset=utf8,_netdev,nobrl 0 0
« Laatst bewerkt op: 2008/12/12, 09:52:32 door AutoStatic »

Offline sjampoo

  • Lid
  • Steunpunt: Nee
Re: Bestand is in gebruik bij 'netwerkschijf'
« Reactie #2 Gepost op: 2008/12/14, 19:03:56 »
Hmm,. 

//10.0.0.155/data /media/data_home-server cifs credentials=/root/.smbcredentials,iocharset=utf8,nobrl,_netdev 0 0
En nog steeds zelfde probleem:
-voorkeur speler voor mp3's wordt niet herkend
-file editen met gedit levert 'text file busy' bij opslaan.

Waar kan het nog meer aan liggen?

- edit -

//10.0.0.155/data /media/data_home-server cifs credentials=/root/.smbcredentials,iocharset=utf8,_netdev,nobrl 0 0werkt ook niet ( volgorde nobrl & _netdev stond bij mij nog anders dan in voorstel AutoStatic. ) Maar helaas: ook nu nog immer

Begint nu echt vervelend te worden.

« Laatst bewerkt op: 2008/12/14, 19:10:14 door sjampoo »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Bestand is in gebruik bij 'netwerkschijf'
« Reactie #3 Gepost op: 2008/12/14, 20:08:48 »
Het ligt aan CIFS. Gedit maakt een backup van het origineel (met een ~ erachter) en maakt iets van een tijdelijk bestand aan waarin je gaat editten. CIFS begrijpt dit niet. Is geen tekortkoming van Ubuntu maar van CIFS. De nobrl optie is daar een workaround voor als ik het goed heb:
       nobrl
          Do  not  send byte range lock requests to the server. This is neces‐
          sary for certain applications that break with cifs  style  mandatory
          byte  range locks (and most cifs servers do not yet support request‐
          ing advisory byte range locks).

Volgorde maakt niet uit. Ik kan op mijn via CIFS gemounte share wel gewoon dingen editten met gedit. Mijn fstab ziet er zo uit://192.168.1.1/public  /opt/public  cifs  noperms,guest,nobrl  0       0

Offline WLSRL2

  • Lid
  • Steunpunt: Nee
Re: Bestand is in gebruik bij 'netwerkschijf'
« Reactie #4 Gepost op: 2009/01/25, 15:11:58 »
Ik heb ook dezelfde problemen na de installatie van Ubuntu 8.10.  Met dezelfde parameters in de fstab file als voorheen, lukt het dus niet meer om een gewijzigd bestand terug te saven.  Een nieuw bestand aanmaken is geen probleem, ook het kopieren via nautilus is geen probleem.
Dit zijn mijn regels in mijn FSTAB file:

//xxx.xxx.xxx.xxx/docuron /home/ronny/Documents cifs setuids,credentials=/mnt/lacie.txt,uid=ronny,gid=ronny,noperm,dir_mode=0777,nobrl,rw 0 0

Volgens verschillende artikels die ik gevonden heb zou het toevoegen van de parameter nounix hier moeten helpen.  Echter is dit niet het geval.  Ook nodfs is geen oplossing.
Gezien ik 2 verschillende types van nas schijven heb (Iomega en Lacie) stel ik vast dat bovenstaande parameters werken voor een oudere Lacie schijf maar niet voor een nieuwe Iomega.  Deze laatste heeft een firmware versie 20.20 en is een nas met 1 Tb harde schijf.
Op mijn werk gebruiken we Windows XP en Windows Server 2003.  Zelfde probleem bij deze toestellen.  Een bestand kan je niet meer wijzigen.

Om thuis verder te kunnen heb ik NFS geactiveerd op de nas (gewoon optie aanvinken bij de share).
Op mijn werkstation heb ik eerst de volgende zaken geïnstalleerd:

sudo apt-get install portmap nfs-common

Daarna op mijn Nas alle ipadressen in mijn range full control gegeven.

Het mounten van de shares gebeurt nu via volgende regel in de FSTAB file:

XXX.XXX.XXX.XXX:/nethdd//Data/docuron /home/ronny/Documents nfs rsize=8192,wsize=8192,timeo=14,intr

Via een prompt kan je dit als volgt testen:

sudo mount xxx.xxx.xxx.xxx:/nethdd//Data/docuron /mnt/ronny

Hopelijk kan je ook gebruik maken van deze oplossing.