Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]Probleem met installeren Driver VIA/S3G KM400  (gelezen 1886 keer)

frontmill

  • Gast
[OPGELOST]Probleem met installeren Driver VIA/S3G KM400
« Gepost op: 2008/12/08, 14:52:09 »
Omdat mijn laptop het pas heeft begeven ben ik even een wat ouder pctje aan het installeren. Echter, na installatie van ubuntu bleek dat ik m'n resolutie niet hoger kon zetten dan 800x600. Dus besloot ik naar drivers op zoek te gaan. Op de site van de moederbord fabrikant heb ik de juiste driver gevonden voor mijn onboard kaart (VIA/S3G KM400 Graphics Driver).

Echter bij installatie krijg ik allerlei foutmeldingen, kan iemand mij vertellen hoe dit komt en wat een mogelijke oplossing zou zijn?

Citaat
-------- install start --------
install S3G CLE266 driver
Which CPU do you use ?
1. VIA C3-2(Nehemiah) or INTEL Pentium 2/3/4
2. VIA C3
3. AMD K 7/8
3
cp: cannot stat `//k7/via_v4l_drv.o': No such file or directory
cp: cannot stat `/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/videodev.o': No such file or directory
cp: cannot stat `//k7/videodev.o': No such file or directory
cp: cannot stat `//k7/via_drv.o': No such file or directory
mkdir: cannot create directory `/lib/modules/2.6.27-9-generic/kernel/drivers/char/drm': File exists
cp: cannot stat `//k7/via.o': No such file or directory
cp: cannot stat `//k7/via_dri.so': No such file or directory
cp: cannot stat `//k7/libddmpeg.so': No such file or directory
sed: can't read /etc/rc.d/rc.local: No such file or directory
cp: cannot create regular file `/etc/rc.d/rc.local': No such file or directory
sed: can't read /etc/rc.d/rc.local: No such file or directory
cp: cannot create regular file `/etc/rc.d/rc.local': No such file or directory
sed: can't read /etc/rc.d/rc.local: No such file or directory
cp: cannot create regular file `/etc/rc.d/rc.local': No such file or directory
insmod: can't read '/lib/modules/2.6.27-9-generic/kernel/drivers/char/agp/agpgart.o': No such file or directory
FATAL: Module via_v4l_drv not found.
insmod: can't read '/lib/modules/2.6.27-9-generic/kernel/drivers/char/drm/via.o': No such file or directory
Now start to install VIA(S3) display utility...
Put the main program(s3utility) into the bin directory: /usr/local/bin
Utility installation is finished!
 -------- vinstall end --------
« Laatst bewerkt op: 2008/12/08, 18:25:34 door frontmill »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #1 Gepost op: 2008/12/08, 15:02:55 »
Hallo frontmill, je kan het beste de OpenChrome driver gebruiken: sudo apt-get install xserver-xorg-video-openchrome
Vervolgens zou je na opnieuw uit- en ingelogd te hebben de boel in moeten kunnen stellen op een hogere resolutie.
« Laatst bewerkt op: 2008/12/08, 15:04:33 door AutoStatic »

frontmill

  • Gast
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #2 Gepost op: 2008/12/08, 15:22:52 »
Bedankt voor je antwoord!

Maar helaas, het was al geinstalleerd:
Citaat
xserver-xorg-video-openchrome is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.27-7 linux-headers-2.6.27-7-generic

En ik kan de resolutie helaas nog niet hoger instellen (in ieder geval niet via GUI, heb geen ervaring met het bewerken van xorg.conf, misschien kan dat uitkomst bieden?)

Even terzijde, ik vind dat mijn xorg.conf er ook erg leeg uitziet, of hoort dat zo?

Citaat
Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #3 Gepost op: 2008/12/08, 15:44:35 »
Ja dat hoort zo, je hebt 8.10 neem ik aan. 8.10 heeft Xorg 1.5 en daar zou het allemaal automatisch ingesteld moeten worden. Hier staat wel wat info: https://help.ubuntu.com/community/OpenChrome
Maar of je er iets aan hebt betwijfel ik.
En zou je de uitkomst kunnen posten van lspci | grep -i vga?
« Laatst bewerkt op: 2008/12/08, 15:46:29 door AutoStatic »

frontmill

  • Gast
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #4 Gepost op: 2008/12/08, 15:50:18 »
Dit is de uitkomst:

(en ja, ik heb inderdaad 8.10, excuses, had ik er wel even bij kunnen vermelden)

Citaat
01:00.0 VGA compatible controller: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #5 Gepost op: 2008/12/08, 17:28:17 »
Kwam dit tegen bij onze Franse collegae: http://forum.ubuntu-fr.org/viewtopic.php?id=264106

Je zou dus onderstaande instellingen in xorg.conf eens kunnen proberen.
Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "vbe"
EndSection

Section "Device"
    Identifier    "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    28-51
    VertRefresh    43-60
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
EndSection

Section "DRI"
    Mode    0666
EndSection

frontmill

  • Gast
Re: Probleem met installeren Driver VIA/S3G KM400
« Reactie #6 Gepost op: 2008/12/08, 18:24:44 »
Kwam dit tegen bij onze Franse collegae: http://forum.ubuntu-fr.org/viewtopic.php?id=264106

Je zou dus onderstaande instellingen in xorg.conf eens kunnen proberen.

Je bent een held! Een simpele copy-paste did the trick!

Bedankt!

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: [OPGELOST]Probleem met installeren Driver VIA/S3G KM400
« Reactie #7 Gepost op: 2008/12/08, 19:17:02 »
Graag gedaan, had de xorg.conf al aangepast voor je, stond een hoop nutteloos spul in. Maar mooi dat het werkt!

frontmill

  • Gast
Re: [OPGELOST]Probleem met installeren Driver VIA/S3G KM400
« Reactie #8 Gepost op: 2008/12/08, 22:43:19 »
Graag gedaan, had de xorg.conf al aangepast voor je, stond een hoop nutteloos spul in. Maar mooi dat het werkt!

Mijn dank is groot! (Dat een simpele copy-paste did the trick zei ik vooral voor mensen die de zoekfunctie gebruiken met een soortgelijk probleem, ik doelde er niet op dat jij had ge-copy-paste  ;))