Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Advanced mode Edirol ua-1ex  (gelezen 4987 keer)

Offline Floyo

  • Lid
  • Steunpunt: Nee
Advanced mode Edirol ua-1ex
« Gepost op: 2008/12/07, 13:03:00 »
Ik heb sinds gisteren een edirol ua-1ex usb geluidskaart. Nu werkt deze prima Het enige wat ik niet snap is dat ik met deze geluidskaart heel snel Xruns krijg met jack. Alleen met een buffer van 9 krijg ik geen Xruns maar heb ik wel een latency van 12mS, dit is met mijn onboard kaart nog beter. Nu dacht ik dat dit kon komen doordat de kaart niet in de advanced mode werkt. Volgens de alsa wiki zou de kaart het wel moeten werken in de advanced mode.

Ik ben niet de enige die dit probleem heeft, maar iedereen heeft het over een patch (quirk) die in in alsa zou moeten zitten. Dit gaat om versie 1.0.14 Nu heb ik volgens cat /proc/asound/version versie 1.0.16., volgensmij zou die patch er dan ook in moeten zitten?

Dus wat ik vragen wil is of iemand weet hoe ik de kaart op zijn volle kracht kan laten werken. Doe ik iets fout of moet ik alsa patchen/ upgraden?

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #1 Gepost op: 2008/12/07, 18:55:33 »
Hallo Floyo, zelf heb ik een Edirol UA-25 en die werkt prima in advanced mode. Maar als ik Compiz heb draaien onder Gnome dan krijg ik met jack ook geheid xruns. Als ik het draai onder bijv. fluxbox dan werkt het prima. Het kan ook aan je andere hardware liggen, wat voor PC/notebook gaat het om? Ik heb hier bijv een oude Asus A2500 liggen en no way dat jack daar lekker op wil draaien. Waar het aan ligt, echt geen idee.

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #2 Gepost op: 2008/12/07, 19:45:28 »
Ik heb een acer aspire 5050. Met de onboard geluidskaart kan ik een latency van 5 ms krijgen en geen Xruns. Maar volgensmij ligt het probleem bij alsa, want als ik de kaart in advanced mode zet en hem weer inplug (moet volgens ubuntu hardware list) en ik ga naar de geluidsvoorkeuren en druk vervolgens op test, dan hoor ik even een pieptoon (zoals het hoort) en dan verdwijnt het scherm. Als ik dan in bv amarok wat probeer af te spelen freezed deze ook.

Dus wat er aan de hand is weet ik niet, volgens de alsa wiki moet hij werken. Ik draai trouwens normaal Metacity met een RT kernel.

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #3 Gepost op: 2008/12/07, 22:13:27 »
En als je opstart met de Edirol aangesloten? En welke versie van Ubuntu?

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #4 Gepost op: 2008/12/08, 07:24:32 »
Ik zal eens kijken wat er gebeurt als ik opstart met het ding al in advanced mode (ik heb al wel alsa reload gedaan dus ik weet niet of het vel uit gaat maken). Ik gebruik 8.04

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #5 Gepost op: 2008/12/08, 09:06:20 »
8.04 met de RT kernel zou goed moeten werken. Had je /etc/security/limits.conf al aangepast? Misschien helpt dat nog.

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #6 Gepost op: 2008/12/08, 18:10:43 »
Ik heb de kaart nu al wel werkend met de advanced mode :), ik heb de nieuwste versie van alsa gecompileerd. Alleen de Xruns zijn er nog steeds.
er staat 3(1024) ofzo en dat loopt op naarmate de tijd vordert.

Limits.conf heb ik al aangepast memlock staat op 250Mb.

Aha het werkt al, alleen heb ik een latency van 10.7mS :(. ik moet de frames/period op 256 zetten en de periods/buffer op 4. Kan ik dit mischien nog tweaken?
« Laatst bewerkt op: 2008/12/08, 18:17:13 door Floyo »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #7 Gepost op: 2008/12/08, 19:19:16 »
Die Edirol kaarten kunnen een frames/period aan van 64 dus je kan de boel nog wat tweaken. En op wat voor Sample Rate staat jack nu?

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #8 Gepost op: 2008/12/08, 19:21:18 »
op 96KHZ. het maximale wat de kaart aan kan, knopje voor 96 KHZ staat ook op afspelen.

Hm, als ik de frames/period op 64 zet start ie (geen foutmeldingen) en stopt 'ie meteen weer
« Laatst bewerkt op: 2008/12/08, 19:26:46 door Floyo »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #9 Gepost op: 2008/12/08, 19:32:31 »
Er zit een venstertje Messages bij qjackctl zodat je kan debuggen. Gebruik mijn kaart altijd op 48000Khz, eigenlijk nog nooit hoger geprobeerd, ook niet onder Windows. Dus dat zou het ook kunnen zijn. Je onboard kaartje komt waarschijnlijk ook niet hoger dan die sample rate en vandaar misschien dan ook de lage latency die je kan halen.

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #10 Gepost op: 2008/12/08, 19:38:25 »
ik krijg dit op 48KHZ met 64 frames/period, heb de kaart anders gezet en opnieuw ingeplugd.


9:36:25.346 Patchbay deactivated.
19:36:25.491 Statistics reset.
19:36:25.556 ALSA connection graph change.
19:36:25.734 ALSA connection change.
19:36:30.053 Startup script...
19:36:30.054 artsshell -q terminate
19:36:30.477 Startup script terminated with exit status=256.
19:36:30.478 JACK is starting...
19:36:30.478 /usr/bin/jackd -R -P10 -p1024 -t5000 -dalsa -r48000 -p64 -n4 -D -Chw:1 -Phw:1 -m -i2 -o2 -Xraw -O1
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
19:36:30.497 JACK was started with PID=11588.
19:36:30.518 Server configuration saved to "/home/floyo/.jackdrc".
19:36:30.520 Statistics reset.
19:36:30.570 Client activated.
19:36:30.572 JACK connection change.
19:36:30.579 JACK connection graph change.
19:36:30.580 Buffer size change (64).
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:1|hw:1|64|4|48000|2|2|nomon|swmeter|-|32bit
control device hw:1
configuring for 48000Hz, period = 64 frames (1.3 ms), buffer = 4 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 4 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 4 periods for playback
19:36:30.608 XRUN callback (1).
19:36:32.579 XRUN callback (130 skipped).
19:36:32.683 XRUN callback (132).

Hierachteraan stonden lappen text over die Xruns. (het gebeurt vreemd genoeg alleen maar met zynaddsubfx en niet met hydrogen ??!!)
« Laatst bewerkt op: 2008/12/08, 19:57:17 door Floyo »

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #11 Gepost op: 2008/12/10, 17:21:02 »
Jack kan een blaag zijn af en toe. Het is gewoon tweaken totdat je een setting hebt gevonden waarmee je weinig xruns hebt. En gebruikerservaringen van jouw edirol onder Linux erop naslaan via Google, misschien vind je dan nog interessante info.

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #12 Gepost op: 2008/12/10, 17:25:05 »
Ik heb zo'n idee dat al die rolands dezelfde dac en adc's hebben, zou jij mischien de settings van jouw jack kunnen posten, mischien helpt het :).

Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #13 Gepost op: 2008/12/11, 10:11:38 »
Zal ik doen. Zal ik het gelijk even testen met zynaddsubfx en wat andere progjes.

Offline .zamorano

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #14 Gepost op: 2008/12/11, 12:08:20 »
Zorg dat je de handleiding qjackctl ff goed doorneemt...

edit: en kijk hier eens rond, daar vind je allerlei tips: http://www.homerecording.be/forum/f43/
« Laatst bewerkt op: 2008/12/11, 12:24:10 door .zamorano »

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #15 Gepost op: 2008/12/12, 21:34:05 »
Ik ben intussen ook al wat verder, het probleem is nu grotendeels opgelost, in Zynaddsubfx stond de sample size op 512 toen ik die op 64had gezet waren de Xruns grotendeels weg. Alleen verschijnen er soms bergen Xruns zomaar uit het niets, soms na 10min soms na een half uur.
dan krijg ik iets van 1(127) Xruns. Wat betekent dat nou dat er 127 Xruns zijn of 1?


Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #16 Gepost op: 2008/12/13, 18:19:05 »
Geen idee, kan een cronjob zijn of een ander proces wat in de weg gaat zitten. Herken het probleem hoor, tot nu toe heeft jack daardoor nog niet echt indruk op me gemaakt. Vind het eerlijk gezegd een buggy rotding :rolleyes:

Offline .zamorano

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #17 Gepost op: 2008/12/16, 10:42:25 »
Geen idee, kan een cronjob zijn of een ander proces wat in de weg gaat zitten. Herken het probleem hoor, tot nu toe heeft jack daardoor nog niet echt indruk op me gemaakt. Vind het eerlijk gezegd een buggy rotding :rolleyes:
Ja je moet wel weten hoe je ermee werkt heh. Als je Firefox open hebt staan met bijv youtube, dan accepteert JACK dat niet bijv. Lees aub de handleiding Qjack en dit draadje:

http://www.homerecording.be/forum/t9556.htm





Offline AutoStatic

  • Lid
    • autostatic
    • linux.autostatic.com - Audio Productie & Linux
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #18 Gepost op: 2008/12/16, 16:56:27 »
Ik had dus gelijk: het is gewoon een buggy rotding.
Ik zal 'm updaten naar 1.115.
Maar .zamorano, onderschat me niet, ik weet dondersgoed hoe dat spul werkt ;)

Offline .zamorano

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #19 Gepost op: 2008/12/16, 17:23:11 »
Ik had dus gelijk: het is gewoon een buggy rotding.
Ik zal 'm updaten naar 1.115.
Maar .zamorano, onderschat me niet, ik weet dondersgoed hoe dat spul werkt ;)

Ik nodig je graag uit om me hier http://www.homerecording.be/forum/f43/ af en toe te assisteren en mij en anderen van je kennis gebruik te maken ;)

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #20 Gepost op: 2008/12/19, 06:41:14 »
oke hier staat dus dat de versie die ik heb buggy is (leuk :() dus ik zal ook eens gaan upgraden, heeft met alsa tenslotte ook gewerkt :).

http://www.homerecording.be/forum/t9551.htm

dit vindt ik nou weer niet leuk :(, is dit nodig of is dit al gedaan, anders moet ik weer diep in mijn goedwerkende systeem gaan poeren.

Welcome to JACK, the Jack Audio Connection Kit.

Please see the website (http://jackit.sf.net/) for more information.

NOTE: If you are using reiserfs or ext3fs or anything except ext2fs
for the directory where JACK puts its temporary files (/tmp by
default), then the JACK team recommends that you do *one* of the
following:

----------------------------

Mount a tmpfs on /tmp.  You should have a lot of swap space available
in case some programs try to write very large files there.
In your /etc/fstab add a line:

   none        /tmp    tmpfs   defaults        0       0

 You'll probably want to reboot here, or kill X then 'mount /tmp'.

---- OR ----

Alternatively, you can do this without affecting your /tmp:

# mkdir /mnt/ramfs

[edit /etc/fstab and add the following line]
 none       /mnt/ramfs      tmpfs      defaults  0 0

Then add --with-default-tmpdir=/mnt/ramfs to the JACK configure
line when you build it.  No clients need to be recompiled.

------------------------------

Failure to do one of these could lead to extremely poor performance from JACK,
since its normal operation will cause bursts of disk I/O that are
completely unnecessary. This suggestion can also be used by ext2fs
users if they wish.
« Laatst bewerkt op: 2008/12/19, 06:48:14 door Floyo »

Offline .zamorano

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #21 Gepost op: 2008/12/19, 09:52:54 »
Dit zin in je fstab zetten lijkt me niet echt een probleem...

sudo pico /etc/fstab
Even backup maken!

Deze zin onderaan het bestand plakken:
  none        /tmp    tmpfs   defaults        0       0
Over de swap zou ik me nog niet heel druk maken...
Verder kun je het beste ext3 gebruiken voor je bestandsysteem en home map

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #22 Gepost op: 2008/12/19, 16:03:46 »
Leuk, heb ik al dat gedoe gedaan met mijn Fstab, moest volgens de jack site ook nog een ander regeltje in en dan krijg ik van jack de melding dat ik de libjack.so.0 niet heb?? volgensmij zou deze meegecomileerd moeten worden. Ik heb trouwens geprobeerd versie 0.116.1 geprobeerd te compilen, mij vielen verder geen errors op.

Doe ik iets fout :(?

Oja, ik heb sinds de veranderingen soms ook ineens kleine knippers over mijn scherm lopen :( :(
« Laatst bewerkt op: 2008/12/19, 16:06:11 door Floyo »

Offline .zamorano

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #23 Gepost op: 2008/12/20, 23:22:30 »
Kijk anders hier eens en installeer jackd daarna eens...

http://www.homerecording.be/forum/t9008.htm#post58664

Offline Floyo

  • Lid
  • Steunpunt: Nee
Re: Advanced mode Edirol ua-1ex
« Reactie #24 Gepost op: 2008/12/22, 10:07:35 »
volgens mij is het grootste probleem dat jack die lib mist. alleen wanneer ik die oude probeer te verwijderen in synaptic stelt hij voor zo'n beetje mijn halve systeem te verwijderen :(. dus ik moet volgens mij van die oude libs af en ik moet de nieuwe installeren. maar hoe doe ik dit zonder dat synaptic alle pakketten wil verwijderen?

ha vordering:

ik heb hier een vrij ranzig debje gevonden dat jack instaleert naast de oud in een ander path.
net even getest en het werkt voorlopig zelfs met maar 2 Xruns in de generic kernel! :), nu even rebooten naar de realtime kernel.
« Laatst bewerkt op: 2008/12/22, 10:24:40 door Floyo »