Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Help, geen geluid!  (gelezen 3584 keer)

Lai

  • Gast
Help, geen geluid!
« Gepost op: 2005/12/11, 13:00:33 »
Ik heb hier thuis 3 pc's staan; een op mijn kamer. Aangezien ik de pc op mijn  kamer toch alleen gebruik voor mahjong en als vervanging van mijn stereo, leek het mij wel leuk om eens met linux te beginnen. Aangezien ik geen zin had in het branden van 80 cd's kwam ik al snel bij ubuntu uit.  Alles werkt prima behalve mijn als100 ISA geluidskaart. Ik heb de OSS drivers van realtek gedownload en geprobeerd deze te instaleren via de commandline in Xterm-safemode als "root". Echter hij wil het geluid maar niet configureren: "vermoedelijk ontbreken er enkele belangrijke linux packages". Dit zouden dan GCC, MAKE, BINUTILS en/of KERNEL-SOURCE zijn. Met synaptic heb ik de eerste drie ge

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #1 Gepost op: 2005/12/11, 13:34:50 »
Zoek in system -> admin -> synaptic naar de build-essentials. (Dan installeert hij alles wat je nodig hebt om te compileren)

Probeer het ook eens met ALSA ipv OSS.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #2 Gepost op: 2005/12/11, 14:23:14 »
modprobe isapnp
Als dat niet helpt:
apt-get install linux-headers-$(uname -r) gcc-3.4 build-essential (deze staan op de CD)

Lai

  • Gast
Help, geen geluid!
« Reactie #3 Gepost op: 2005/12/11, 17:16:00 »
sudo -s -H
password: ********
cd etc/modprobe.d
./isapnp
geen toegang

Ik heb dit ook gehad met OSS toen ik de logfiles wilde bekijken. Doe ik iets verkeerd? Ik ben echt een leek als het aankomt op linux command lines. Misschien niet zo handig, maar je moet eens beginnen. Wat betreft gcc 3.4, dat heb ik volgens mij al ge

Offline bwog

  • Lid
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #4 Gepost op: 2005/12/11, 21:32:27 »
Volgens mij  bedoeld Dennis dat je in een terminal

modprobe isapnp

moet schrijven.


Om een file te lezen moet je

gedit fliename

doen, of zelfs sudo gedit filename als je iets wil veranderen.

Ik vind dit een goed geschreven introductie: http://www.tuxfiles.org/

Lai

  • Gast
Help, geen geluid!
« Reactie #5 Gepost op: 2005/12/14, 23:15:09 »
De commands lukken nu wel aardig, alleen de modules zijn niet te vinden, die zal ik dan moeten activeren of zelf moeten maken. Van Alsa weet ik dat de geluidskaart ondersteunt wordt, ik weet echter niet welke files of programma's ik moet gebruiken.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #6 Gepost op: 2005/12/15, 20:09:55 »
installeer alsa via systeem->admin->synaptic?

Lai

  • Gast
Help, geen geluid!
« Reactie #7 Gepost op: 2005/12/15, 20:33:15 »
Niet nodig, is standaard. Hij zegt modules in de kernel te hebben voor elke door ALSA ondersteunde geluidskaart, dus ook voor de mijne.

modprobe snd-als100

o.i.d. werkt echter niet.

Lai

  • Gast
Help, geen geluid!
« Reactie #8 Gepost op: 2005/12/24, 10:26:03 »
Probleem opgelost! Tentamens voorbij, moederbord en processor eruit gehaald en ergens van zolder een PIII 500Mhz vandaan gehaald met onboard geluid en video. Dat is overigens meer dan twee keer zo snel dan mijn PIIMMX 233Mhz. Het geluid doet het nu goed al gaat het afpelen van CD's wat traag. Had ik er misschien geen oude IBM 8x cd rom in moeten zetten :P. Het moederbord wat er nu inzit is mij verder vrij onbekend, het is van compaq met een hele apparte bios, waar overigens ook nog een wachtwoord op zit dat ik niet ken. Dat is echter niet zo'n probleem, maar weet iemand misschien waar ik kan zien hoeveel video geheugen ik heb?

Offline bwog

  • Lid
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #9 Gepost op: 2005/12/24, 12:24:17 »
De hoeveelheid video geheugen zie ik als eerste bovenin het scherm tijdens opstarten. Daarna verschijnt de totale hoeveelheid geheugen.

Lai

  • Gast
Help, geen geluid!
« Reactie #10 Gepost op: 2005/12/24, 13:03:01 »
meestal wel, maar ik krijg een dik vet compaq scherm :(

koosie

  • Gast
Help, geen geluid!
« Reactie #11 Gepost op: 2006/01/21, 16:17:01 »
Citaat van: Dennis
modprobe isapnp
Als dat niet helpt:
apt-get install linux-headers-$(uname -r) gcc-3.4 build-essential (deze staan op de CD)
Hetzelfde probleem doet zich bij mij voor (ook ISA als 100+ geluidskaart). Reactie op modprobe isapnp: FATAL: Module isapnp not found.
Verder: gccc-4.0 base is geinstalleerd. Dan nog gcc-3.4 base installeren?

Het lijkt alsof ubuntu aan ISA-sloten  voorbij gaat? Dank, alvast.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Help, geen geluid!
« Reactie #12 Gepost op: 2006/01/21, 18:14:19 »
Neem gcc-3.4 installeren, niet gcc-3.4-base (die wordt door de dependencies wel meegetrokken).